18:01:08 <amrith> #startmeeting trove
18:01:09 <openstack> Meeting started Wed May 11 18:01:08 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:12 <openstack> The meeting name has been set to 'trove'
18:01:16 <flaper87> o/
18:01:21 <amrith> ./
18:01:22 <twm2016> o/
18:01:59 <amrith> let's give folks a couple of minutes to trickle in
18:02:05 <tellesnobrega> o/
18:02:13 <dloi> o/
18:02:16 <vkmc> o/
18:02:21 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:35 <peterstac> `o/o/
18:02:41 <amrith> that's new
18:02:48 <johnma> o/
18:02:50 <pmalik> *\o/*
18:02:54 <mvandijk> ./
18:03:20 <amrith> ok, sounds like a quorum to me, let's get started.
18:03:31 <amrith> #topic Action items from last week's meeting
18:03:39 <amrith> This would have been the meeting a couple of weeks ago
18:03:49 <amrith> I didn't find any. does anyone remember anything as action items?
18:04:13 <amrith> this was the meeting notes from April 20th
18:04:15 <amrith> #link http://eavesdrop.openstack.org/meetings/trove/2016/trove.2016-04-20-18.01.txt
18:05:09 <amrith> I guess not, so if no one has anything from the old meeting, we'll move along.
18:05:28 <amrith> #topic Trove pulse update
18:05:36 <amrith> #link http://bit.ly/1VQyg00
18:06:36 <amrith> the backlog of reviews (queue growht) is certainly related to the summit
18:06:49 <amrith> but we do have a number of outstanding reviews, some for over a couple of weeks.
18:07:22 <amrith> like https://review.openstack.org/#/c/306430/
18:07:31 <amrith> which I'm sure pmackinn would like to see merged
18:07:47 <amrith> and https://review.openstack.org/#/c/300009/
18:07:56 <cp16net> howdy
18:08:00 <amrith> both of which would be good to backport to mitaka quickly
18:08:18 <flaper87> These 2 reviews seem ready to go
18:08:18 <amrith> so any available cores who can review and approve these (and the dozen or so other changes that need a +1)
18:08:38 <flaper87> amrith: quick question re 300009. Any reason why it was not approved after 2 +2s ?
18:09:01 <amrith> flaper87, the general rule we've followed in trove is that we won't +1 a change with two +2's from the same company
18:09:01 <peterstac> I count almost 20 review that are looking for a second +2/WF+1
18:09:04 <amrith> rax respected that
18:09:07 <amrith> hp respects that
18:09:11 <amrith> we (tesora) do the same
18:09:18 <amrith> in only very specific cases
18:09:18 <flaper87> amrith: gotcha, ok! Makes sense
18:09:21 <amrith> like a broken build
18:09:38 <amrith> or something (like peterstac did yesterday) to fix the tests and reduce the mock recursion depth
18:09:41 <amrith> do we break that rule.
18:09:53 <amrith> by agreement, we decided to waive that rule for some changes
18:09:59 <amrith> those proposed by the proposal bot
18:10:06 <flaper87> yeah, I failed to notice the pattern. We used to have that in Glance too.
18:10:15 <amrith> otherwise, it is a good practice to have a wider review audience
18:10:38 <amrith> I assume that there will be situations where the build is broken or something expeditious needs to be done, and a single core can do that.
18:10:44 <cp16net> +1
18:10:45 <amrith> but these changes require some review.
18:10:49 <flaper87> +1
18:10:58 <amrith> hence you'll see many where peter and I have +2'ed but someone else must +1
18:11:11 <amrith> which is what peterstac was alluding to
18:11:14 <amrith> as 20+
18:11:16 <amrith> #link https://review.openstack.org/#/q/NOT+label:Workflow%253E%253D1+NOT+label:Workflow%253C%253D-1+label:Verified%253E%253D1%252Cjenkins+NOT+owner:self+label:Code-Review%253E%253D2+NOT+label:Code-Review-1+is:mergeable+status:open++%28project:openstack/trove+OR+project:openstack/trove-integration+OR+project:openstack/trove-specs+OR+project:openstack/python-troveclient+OR+project:openstack/trove-dashboard%29
18:11:39 <amrith> for example, I think https://review.openstack.org/#/c/313648/ should be quick :)
18:12:08 <amrith> anyway, this is back to the same issue we've dealt with for some time
18:12:22 <amrith> #link https://gist.github.com/amrith/70b8913df8109c2ef40b0d08338f6206
18:12:28 <amrith> that's the review counts
18:12:39 <amrith> and we should try and pick up the pace ...
18:12:48 <amrith> I have nothing further to add on this
18:12:57 <amrith> hi cp16net, sorry didn't see you come in
18:13:22 <cp16net> howdy
18:13:32 <flaper87> yup, noticed the review rate! Happy to help there as much as possible
18:13:37 <amrith> anything further to add re: trove pulse ...
18:13:42 * flaper87 has nothing
18:14:12 <amrith> #topic Announcements
18:14:23 <amrith> we've discussed these things already
18:14:29 <amrith> I've updated the newton release calendar
18:14:36 <amrith> #link http://releases.openstack.org/newton/schedule.html
18:14:40 <amrith> with trove specific dates
18:15:12 <amrith> The next deadline we have is:  Deadline for proposing specs for Newton is R-17 (Week of June 13 to 17)
18:15:25 * flaper87 writes that down in his calendar
18:15:30 <amrith> and the spec freeze comes after that  Deadline for specs for Newton to be merged is R-12 (Week of July 11 to 15)
18:16:06 <amrith> any questions or comments on this ...
18:16:30 <flaper87> none from me  other that I think having a spec freeze is a good thing
18:16:36 * flaper87 shuts up
18:17:09 <amrith> anyone have any other announcements
18:17:56 <amrith> ok, moving along then ...
18:17:59 <amrith> #topic      Specs that are up for review
18:18:19 <amrith> So I made a list of specs that are up for review sometime this morning
18:18:26 <amrith> I believe that some specs came in after that
18:18:48 <amrith> #link https://review.openstack.org/315141
18:19:10 <amrith> #link https://review.openstack.org/#/c/315079/
18:20:01 <amrith> vkmc, your spec is verified failed and is tehrefore not showing up on the dashboard. I believe johnma has the reason for it in her comments.
18:20:12 <amrith> if you'd update it, it'll pop-up on people's dashbaords
18:20:15 <vkmc> amrith, yeah, amending soon
18:20:16 <amrith> (if they use the dashboard)
18:20:22 * flaper87 hasn't reviewed these last 2 specs
18:20:30 <amrith> any discussion of the specs that are up for review
18:20:45 <amrith> pmackinn, yt?
18:20:55 <pmackinn> no
18:21:05 <pmackinn> 'sup?
18:21:10 <amrith> or maybe vkmc (since pmackinn isn't here, he says), would you respond to my comments in https://review.openstack.org/#/c/315141/
18:21:14 <tellesnobrega> im sending a new patch for review on the cinder backups this week hopefully, so that will something to review
18:21:20 <amrith> the BP is in trove-integration
18:21:30 <amrith> which I'm hoping we can kill soon(ish)
18:21:39 <amrith> do you want to register the BP in some other project?
18:22:09 <pmackinn> amrith, re-targeting to the new T-I-B
18:22:20 <pmackinn> amrith, do we have a repo?
18:22:20 <amrith> pmackinn, are you able to enter bp's there?
18:22:29 <amrith> if not I may have to fix lp permissions
18:22:32 <amrith> pl lmk
18:22:40 <amrith> lp project is trove-image-builder
18:22:48 <amrith> re: repo, there was this whole flap about the name
18:22:49 <pmackinn> https://blueprints.launchpad.net/trove-image-builder/+spec/trove-image-builder
18:22:52 <vkmc> amrith, I'll review last update on 315141 soon
18:22:58 <vkmc> and reply to your comments
18:23:12 <amrith> if you are fine with the name I'll add the bp link to my infra changes and WF+0 them
18:23:42 <amrith> https://review.openstack.org/#/c/312805/ and https://review.openstack.org/#/c/312806/
18:23:46 <amrith> vkmc, thx
18:23:52 <vkmc> np
18:23:54 <pmackinn> amrith, re: comments we still have agreement in principle right? no need to get on the merry-go-round more at this point i would hope
18:24:29 <amrith> yes we have agreement in principle re: new repo, trove-integration dib elements find a new home, a wrapper to make it easier to use them, a new element to install the guest agent, ...
18:24:34 <amrith> I don't think I've missed anything
18:24:56 <amrith> I think the broader community will want to get involved when we start thinking about other tool chains.
18:25:10 <pmackinn> \o/
18:25:37 <amrith> I think that is still a point of some concern in the community at large, and I would like to make sure we are congisent of that.
18:25:59 <amrith> I see your new BP
18:26:06 <amrith> I will tag that and move forward for the repo
18:26:11 <pmackinn> not sure what concerns there would be at this point in the discussion
18:26:20 <pmackinn> and, hey community now
18:26:58 <amrith> one caution re: redstack build-image which I put in the review
18:27:08 <amrith> we can talk about that offline (#openstack-trove)
18:27:15 <amrith> any other discussion re: specs
18:27:16 <pmackinn> noted
18:27:18 <amrith> thanks tellesnobrega
18:27:21 <amrith> will look for that
18:27:24 <tellesnobrega> np
18:27:42 <amrith> tellesnobrega, you also had a q: re the old spec, I'd say abandon it for now. we can restore when appropriate
18:28:00 <tellesnobrega> amrith, sounds good, will do that
18:28:11 <flaper87> +1 for abandoning it
18:28:19 <amrith> #action [amrith] update infra specs to point to new BP and WF +0
18:28:26 <amrith> any other action items here?
18:28:58 <amrith> #action [tellesnobrega] abandon spec on CEPH (don't have a number handy)
18:29:17 <amrith> anything else?
18:29:29 <tellesnobrega> https://review.openstack.org/#/c/256057/
18:30:00 <amrith> #action [tellesnobrega] abandon spec on CEPH (https://review.openstack.org/#/c/256057/)
18:30:44 <amrith> if everyone would take a look at the specs that are up for review and post feedback that'd help us hit our deadline.
18:30:53 <amrith> anything else ...
18:31:24 <amrith> I'm going to skip the next two sections in the agenda since no one added anything in the agenda.
18:31:25 <amrith> but ...
18:31:43 <amrith> if you want to talk about proposals for review or projects for newton ... now's the chance
18:32:40 <amrith> ok, let's move along
18:32:43 <amrith> #topic Updating the API documentation
18:33:33 <amrith> I added this to the agenda after stubbing my toe on http://developer.openstack.org/api-ref-database-v1.html
18:33:47 <amrith> actually someone else did and pointed me at it.
18:33:54 <amrith> This is rather old
18:34:04 <amrith> not updated in a while
18:34:08 <amrith> inaccurate in some places
18:34:19 <amrith> so I asked other projects how they handled their API documentation
18:34:30 <amrith> and the answer is that they have it as part of the source tree
18:34:43 <amrith> and whenever a change updates the API, the document must be updated in the same commit
18:35:01 <amrith> does anyone have experience with this in another project?
18:35:10 <amrith> I'm thinking first of zaqar, glance, ...
18:35:24 <amrith> but others too ...
18:35:35 <flaper87> Yeah, we do that in both Zaqar and Glance. We're just moving Glance's WADL support to RST: https://review.openstack.org/#/c/312259/
18:35:46 <flaper87> so, if we do this in Trove, we should probably start off with RST directly
18:36:01 <amrith> Yes, that was the recommendation from a couple of other teams
18:36:18 <amrith> how did it work out to have to update the spec as part of the same commit
18:36:22 <flaper87> As a reviewer/contributor, I appreciate having these docs in-tree since it makes it easier to keep things updated
18:36:25 <amrith> was there a lot of conflict on merges?
18:36:32 <flaper87> Not really
18:36:42 <amrith> should we structure it as a single file or multiple files for the API?
18:36:47 <amrith> (to reduce conflict)
18:36:51 <flaper87> I can't think of any blocking/annoying issue related to this
18:37:00 <flaper87> multiple files is better, IMHO
18:37:01 <amrith> cp16net, how does this tie in with the example generator?
18:37:26 <cp16net> it should reference the output examples and inject them into the doc
18:37:31 * amrith rubs the magic lamp three times and says grapex grapex grapex
18:38:04 <cp16net> since the examples are statically named they should be able to be referenced by their file name
18:38:06 <amrith> cp16net, my concern was always whether these samples were complete
18:38:32 <cp16net> yeah they probably are not complete with the new api features that were added
18:38:46 <cp16net> the existing ones should be valid tho because they are run as part of the tests
18:38:57 <cp16net> unless that was sneakily removed
18:39:09 <amrith> well, they are complete insofar as the tests exercise the API, no?
18:39:28 <amrith> i.e. it is based on test coverage not on actually parsing the code, right?
18:39:30 <cp16net> i know they were used in the wadl doc generation that was there when you built with mvn or something
18:39:37 <cp16net> but its been a long time since i saw that
18:40:11 <cp16net> right they are bascially another set of tests that run to verify the example output
18:40:36 <cp16net> and that would need to be updated for the new api calls i.e. logs, etc...
18:40:48 <peterstac> cp16net, but they're run in the same vein as the fake tests, right?
18:40:54 <cp16net> possibly even clusterings
18:40:59 <amrith> cp16net, you refer to #link http://git.openstack.org/cgit/openstack/trove/tree/generate_examples.py
18:40:59 <cp16net> yeah
18:41:13 <cp16net> they are all run with fakemode so they are faster and verify api output
18:41:21 <peterstac> so those are getting pretty stale since everything new is done in the scenario realm now
18:41:51 <cp16net> yeah and fake mode is being ignored
18:42:02 <cp16net> and not run with the scenario tests
18:42:14 <cp16net> fakemode was using the int-tests suite
18:42:18 <amrith> so, now that the API doc's are (along with other docs) coming back to projects, how do we handle this?
18:42:21 <cp16net> or rather based on it
18:42:31 <peterstac> well, the scenario tests also use the int-tests suite
18:42:57 <peterstac> do you need to do something special to get the fakes to run?
18:43:16 <peterstac> (i.e. are they hard-coded to the api ones ...)
18:43:17 <cp16net> you would need to make sure ot import the scenarios when runnign fake mode
18:43:18 <amrith> peterstac, not that I know of
18:43:28 <cp16net> and i suspect that it will take a bit of work
18:44:02 <amrith> so, one thing I will point out is that other projects don't generate examples in an automated way.
18:44:08 <amrith> they do it the 'old way'
18:44:12 <amrith> I did it once
18:44:16 <amrith> go look at schema.py
18:44:23 <amrith> then look at each entry point (mapping)
18:44:31 <amrith> and see what other undeclared parameters it uses
18:44:35 <amrith> and write them all down.
18:44:54 <amrith> once we get that in place, we'll be in a better place to require updates on commit
18:44:55 <cp16net> https://github.com/openstack/trove/blob/master/run_tests.py#L229
18:45:05 <cp16net> i believe this is where they get loaded
18:45:47 <amrith> given that the completeness of these automated samples is dependent on the test coverage, do we want to continue this path?
18:46:37 <flaper87> mmh, sounds like quite some work and based on the current planned specs/work, it might be a bit unrealistic to also add this item
18:47:49 <flaper87> it doesn't feel like a critical item to me but others may disagree
18:47:51 <amrith> so what's the priority of this activity?
18:48:27 <amrith> given that not having documentation is a problem, shouldn't it be a higher priority. maybe not critical but not ignoreable either
18:48:35 <amrith> what (if anything) do we want to commit to doing in Newton?
18:49:50 <flaper87> I agree with the sentiment it should probably be a higher priority. Not sure how much of it we would be able to do in Newton, though. I'd need to spend some extra time looking into what's required in Trove's case to get this done.
18:49:59 * flaper87 learned something from the above discussion
18:50:30 <amrith> cp16net, peterstac anything to add?
18:50:57 <amrith> I'm going to guess not. let's revisit in a couple of weeks.
18:51:01 <cp16net> nothing here
18:51:03 <amrith> #topic Open Discussion
18:51:12 <amrith> anybody have anything ...
18:51:14 <cp16net> i have one thing i'd like to bring up
18:51:15 <pmalik> This has been sitting in review with +2 from peterstac.
18:51:16 <pmalik> It does not change how and what the tests run, but it's a needed first step if we ever want
18:51:16 <pmalik> to see the new tests as voting jobs.
18:51:16 <pmalik> It only affects the test code and the tests pass... Thx.
18:51:16 <pmalik> https://review.openstack.org/#/c/309190/
18:51:31 <amrith> cp16net, please go ahead
18:51:37 <flaper87> Is there a Trove midcycle planned for Newton?
18:51:41 <cp16net> i put up for a bug patch for mariadb clustering https://review.openstack.org/#/c/306638/
18:51:55 <amrith> cp16net, saw that
18:52:00 <cp16net> What was eluded to in comments may be a larger issue across instance create as well for neutron networks. If someone with more knowledge of neutron would like to take a look that would be helpful.
18:52:34 <amrith> cp16net, we could start with this fix
18:52:43 <amrith> after all, there are many ways to specify a neutron nic
18:52:48 <amrith> and this would fix the common case
18:52:51 <amrith> but not all cases
18:53:05 <amrith> I'm more inclined to go ahead with this change and leave the bigger case for the future
18:53:18 <amrith> i.e. don't let the perfect be the enemy of the good
18:53:25 <cp16net> ok i'll work on fixing the unit failure
18:53:48 <amrith> dougshelley66 may not be here, I'll speak with him about this; he and I had talked when this happened originally.
18:53:48 <cp16net> just didnt want what was mentioned to fall through the cracks
18:54:11 <amrith> thx cp16net
18:54:14 <cp16net> np
18:54:18 <amrith> pmalik, will look at that review
18:54:41 <amrith> flaper87, the current plan is for August 24, 25, 26 or thereabouts
18:54:41 <cp16net> its small enough to fix the issue that was raised
18:54:42 <amrith> in NYC
18:54:57 <amrith> was in meeting minutes two weeks ago
18:55:02 <amrith> and for some weeks before that.
18:55:08 <amrith> flaper87 ^^
18:57:26 <amrith> pmackinn, I've updated https://review.openstack.org/#/c/312806/ and https://review.openstack.org/#/c/312805/
18:57:36 <amrith> please review. vkmc, pmackinn ^^
18:58:00 <dougshelley66> amrith i'm here now..just catching up
18:58:06 <dougshelley66> i certainly don't want to be the enemy of the good
18:58:13 <dougshelley66> i'll take my -1 off that review
18:58:19 <pmackinn> amrith, thx
18:59:05 <amrith> anything else ...
18:59:09 <amrith> 50s to go ...
18:59:30 <amrith> #endmeeting