18:01:06 <amrith> #startmeeting trove
18:01:07 <openstack> Meeting started Wed Mar 30 18:01:06 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:10 <openstack> The meeting name has been set to 'trove'
18:01:39 <amrith> anyone here for Trove meeting?
18:01:40 <cp16net> howdy everyone
18:01:43 <peterstac> o/
18:01:47 <amrith> howdy cp16net
18:01:50 <johnma> hi
18:02:17 <tosky> hi
18:02:25 <imandhan> hi
18:02:31 <amrith> I'll give folks a minute to come in, and then since we have a longish meeting, I'm going to be relying on pastebombs :)
18:03:05 <pmackinn> o/
18:03:09 <dloi> o/
18:03:22 <amrith> In the interest of everyone's time, let's
18:03:22 <amrith> get started.
18:03:27 <amrith> we have a quorum
18:03:49 <amrith> #topic follow-up on action items.
18:03:50 <mvandijk_> ./
18:03:53 <amrith> not in the order in which they appear, but ...
18:04:07 <amrith> flaper87 to WF+1 the patches https://review.openstack.org/#/c/262289/ and  https://review.openstack.org/#/c/262287/
18:04:07 <amrith> done but they are hung up in the gate, that'll clear shortly.
18:04:08 <tellesnobrega> o;
18:04:11 <tellesnobrega> o/
18:04:16 <amrith> cp16net reply to trove-dashboard ML question for RC2
18:04:20 <amrith> cp16net, that was done, yes?
18:04:52 <amrith> yes, I see his email. We also cut an RC2. good ...
18:05:00 <amrith> And this one is (had better be) done, it will merge as soon as we get the gate fixed, more about that later.
18:05:01 <amrith> [all] please review changes https://review.openstack.org/#/c/262289/, https://review.openstack.org/#/c/262287/, and
18:05:01 <amrith> link http://openstack.markmail.org/thread/jepcqu335mrb5c7l in agenda and update the reviews
18:05:26 <amrith> other action items were for the entire team, please follow through.
18:05:26 <amrith> #action [all] If you have a patch set that you intend to resume work on, please put an update in it to that effect
18:05:26 <amrith> so we don't go abandon it under you ...
18:05:26 <amrith> #action [all] if any of the abandoned patches looks like something you would like to pick up feel free
18:05:35 <amrith> #action [all] If you have a patch set that you intend to resume work on, please put an update in it to that effect
18:05:41 <amrith> #action [all] if any of the abandoned patches looks like something you would like to pick up feel free
18:05:45 <amrith> Those two remain ...
18:06:01 <amrith> Anyone else have anything to add on last week's action items?
18:07:07 <amrith> ok, I guess not. I'll just assume that my internet connection is working :)
18:07:13 <cp16net> amrith: yes it was released and i guess i forgot to press send on the email
18:07:33 <amrith> #action [cp16net] press "send" on the email
18:07:36 <SlickNik> o/
18:07:37 <cp16net> :-P
18:07:51 <amrith> hi nikhil.
18:08:04 <amrith> let's see, moving on to the next item
18:08:09 <amrith> #topic Trove pulse update
18:08:17 <amrith> #link http://bit.ly/1VQyg00
18:08:18 <amrith> We've seen a drop in the number of reviews and the queue continues to grow. Please take time to review the (long
18:08:18 <amrith> list) of outstanding patches. Some have been around for quite a while.
18:08:28 <nikhil> hi amrith
18:08:32 <cp16net> amrith: sent
18:08:52 <amrith> sorry, wrong nikhil ... I meant SlickNik :)
18:08:55 <nikhil> oh the other nikhil
18:08:56 <nikhil> :)
18:09:09 <amrith> you are always welcome to stay nikhil ...
18:09:16 <nikhil> :)
18:09:45 <amrith> as we're at the end of the release cycle and not yet going full steam ahead on Newton, I guess there is a slight lull in patches. This is a good time to get caught up on reviews though ...
18:09:55 <amrith> Nothing more from me re: pulse update. Anyone else have anything to add?
18:10:33 <amrith> awfully quiet crowd today
18:10:48 <amrith> #topic Announcements - Newton release schedule published
18:11:01 <amrith> Agenda item says it all. This also means that Mitaka is almost done. A couple of small things to tie up (thanks cp16net).
18:11:12 <amrith> We know the schedule for Newton a long time ahead of Newton and we should try and learn from the issues we faced in Mitaka.
18:11:21 <amrith> I've summarized some of the things I learned.
18:11:25 <cp16net> np
18:11:29 <amrith> Anything else others would like to add to the list?
18:11:44 <dougshelley66> o/
18:11:58 <amrith> go ahead dougshelley66
18:12:33 <amrith> or you were just saying hello, ok.
18:12:40 <dougshelley66> sorry i was just noting that i was here...late :)
18:13:05 <amrith> Here's the list of what I learned
18:13:06 <amrith> If we want to push any code into OSLO, R-6 is a hard deadline.
18:13:14 <amrith> R-5, is the hard freeze for the python-troveclient. We must get all new functionality we need in the client into a version by that date or it won't be available for the release.
18:13:31 <amrith> we got into trouble with this for module management, because we thought the FFE extended to the client.
18:13:38 <amrith> R-5 is the target date by which all new functionality should be in, you need to request FFE's for anything that does not merge by that date
18:13:47 <amrith> R-3 is the RC1 target date, not a hard date. In the Mitaka cycle, I mistakenly believed that R-3 is a hard RC1 date. My mistake.
18:14:25 <amrith> Then there's a bunch of procedural stuff that goes into cutting the branches and stuff, and that's something I intend to write up so everyone knows what it is.
18:14:29 <amrith> and where the bodies are buried.
18:14:46 <amrith> Anything else others would like to add to the list?
18:15:08 <SlickNik> amrith: This (the hard freeze with the client) puts us in a precarious situation, since our int-test model depends on the client binding being there.
18:15:14 <cp16net> also reminder to update blueprints and bugs before release is cut
18:15:38 <amrith> SlickNik, yes. We are certainly in an awkward position with that.
18:15:54 <amrith> our approach of testing with the tarball has gotten us into trouble, and has also been a boon
18:16:17 <cp16net> but bp/bug management can be done after i found out as well.
18:16:52 <amrith> yes, but I guess we're getting close to the window on that allowable period.
18:16:57 <cp16net> re: the client i think that means we just need features earlier
18:17:19 <SlickNik> cp16net: ++ Something that we'll have to keep in mind for FFEs in the next cycle.
18:17:24 <amrith> yes, and also that FFE's don't cover client :(
18:17:30 <cp16net> yup
18:18:01 <vkmc> o/
18:18:21 <amrith> hi vkmc, anything else others would like to add to the list?
18:18:44 <johnma> amrith: whatabout the trove-dashboard deadlines?
18:19:06 <amrith> johnma, I believe trove-dashboard is not a client library. therefore the deadlines are along with trove
18:19:18 <johnma> ok, sounds good
18:19:28 <amrith> I've pushed to update the tags on that (release:managed) which will mean that the release team will bug us about it
18:20:15 <amrith> in any event, if you have other questions abotu release schedule, let's be sure to talk early; maybe at summit.
18:20:33 <amrith> and with that, let's move on
18:20:40 <amrith> #topic Announcements -  Getting rid of eventlet and replacing it with something else
18:20:48 <amrith> This went across the ML some days ago, figured I'd share it with the team.
18:20:54 <amrith> #link https://review.openstack.org/#/c/164035/
18:21:00 <amrith> If you have opinions and thoughts please post comments on the review. If you feel that they could impact Trove,
18:21:00 <amrith> please share with the team.
18:21:21 <amrith> Just an FYI for everyone, didn't plan to discuss this at length today. but if someone has concerns about it we could bring it back up at a future meeting.
18:21:59 <amrith> moving along then ...
18:22:08 <amrith> #topic Ongoing review of projects
18:22:14 <amrith> Please take a look at the agenda
18:22:22 <amrith> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting#Trove_Meeting.2C_March_30.2C_2016
18:22:31 <amrith> At the mid-cycle in Raleigh, one of the action items that we took away was that we should start tracking and
18:22:32 <amrith> monitoring all projects under way to completion through the release cycle. I'm going to start this up with the
18:22:32 <amrith> projects that we know are under way, and begin to highlight them so that people can focus time on reviewing them.
18:22:45 <amrith> FOR TODAY: The intent here is NOT to have each of you describe the status, rather to confirm that this list is
18:22:46 <amrith> still correct for Newton.
18:22:58 <amrith> In coming weeks we'll keep the focus on these projects and their respective reviews.
18:23:25 <amrith> So please take a minute to look over the list and confirm whether it looks ok and if there are any omissions or corrections required.
18:23:32 <amrith> As and when BP's are ready, please let me know so we can stay on top of the reviews and get these projects moving
18:23:33 <amrith> for Newton.
18:23:49 <amrith> I'll wait a couple of minutes for y'all to look over the list
18:24:19 <amrith> [pmackinn] Separate trove image build project based on libguestfs tools
18:24:20 <amrith> [tellesnóbrega/vkmc] Implementing CEPH as a backend for backups
18:24:20 <amrith> [sonali/vkmc] Configuration Groups for Couchdb
18:24:20 <amrith> [johnma] Enable CouchDB replication in Trove
18:24:20 <amrith> [amrith] Add support for hbase in Trove
18:24:22 <amrith> [peterstac] Locality for cluster/replication sets
18:24:24 <amrith> [petmal] Couchbase clusters
18:24:26 <amrith> [vgnbkr] Guest instance upgrade - BP coming
18:24:28 <amrith> [petmal] PostgreSQL incremental backup/restore
18:24:30 <amrith> [petmal] PostgreSQL replication
18:24:32 <amrith> [mvandijk] Associate volume-type with datastore
18:24:34 <amrith> [vgnbkr] Multi-Region Support
18:24:48 <amrith> what are we missing? are there things here that should not be on the list?
18:26:06 <amrith> OK, since no one is saying anything, I'll assume that these projects are accurate and if there are new ones you'll add them.
18:26:08 <pmackinn> amrith, these are "live" blueprints, correct?
18:26:14 <vkmc> amrith, when is the deadline to propose bp/specs for Newton?
18:26:23 <amrith> pmackinn, what do you mean? trove-specs?
18:26:29 <pmackinn> yes
18:26:34 <amrith> good point
18:26:40 <amrith> please register a blueprint in LP
18:26:49 <amrith> and please put the spec in trove-specs for newton
18:27:06 <amrith> vkmc, looking that up
18:27:07 <amrith> one second
18:27:23 <vkmc> thx :)
18:27:23 <pmackinn> amrith, got your design summit topic etherpad handy?
18:27:30 <amrith> #link http://releases.openstack.org/newton/schedule.html
18:28:18 <johnma> https://etherpad.openstack.org/p/trove-newton-proposed-sessions
18:28:37 <amrith> The deadline for all BP's is milestone 1
18:28:43 <johnma> is that what you were looking for pmackinn
18:28:59 <amrith> the feature freeze date is, I believe milestone 2
18:29:04 <amrith> cp16net, SlickNik is that correct?
18:29:22 <amrith> All features are to be in by milestone 3
18:29:32 <amrith> if any feature is not in by milestone 3, you need an FFE
18:29:44 <amrith> so, the goal is that all BP's and specs should be ready by milestone-1
18:29:51 <amrith> vkmc, did that answer your question
18:29:56 <cp16net> amrith: i had an artifical deadline i set last time to push for them to be in before
18:30:07 <vkmc> amrith, it did, thanks
18:30:21 <amrith> pmackinn, was that the link you were looking for?
18:30:51 <amrith> other questions?
18:30:55 <amrith> comments
18:30:58 <SlickNik> amrith: Feature Proposal Freeze is something that is enforced by the program teams ourselves
18:31:05 <pmackinn> yup thanks
18:31:25 <amrith> SlickNik, yes. And in the Mitaka release, we'd pushed for that to be at or about milestone 1
18:31:28 <amrith> if I recall
18:31:33 <johnma> so, milestone 1  - does that mean all BP's for NEwton need to be approved by then.
18:31:45 <amrith> johnma, yes that would be the goal
18:31:52 <amrith> again, as SlickNik said, this is not mandated
18:32:00 <amrith> this is something we're going to have to police for ourselves
18:32:00 <johnma> is that our project specific deadline
18:32:08 <johnma> oh ok
18:32:12 <johnma> got it
18:32:23 <amrith> but as a practical matter, if the specs aren't in by then, it makes it a rush at the end of the release cycle.
18:32:33 <SlickNik> amrith: Yes, sounds right — it seemed to work pretty well to get bp reviews and such prioritized.
18:32:34 <amrith> to get specs and code reviewed, and done on time.
18:32:55 <SlickNik> bp and spec reviews.
18:32:59 <cp16net> i agree with that it helped last time
18:33:04 <amrith> so, as SlickNik points out, this helps us prioritize things and that was part of he motivation for the action item in the mid-cycle
18:33:18 <amrith> let's not get behind the 8-ball was, I believe, the thinking.
18:33:49 <amrith> other questions and comments ...
18:34:00 <pmackinn> so, should there be specs up for any design summit topics?
18:34:05 <pmackinn> for inclusion
18:34:34 <amrith> pmackinn, one of the things we found useful in the past is to have the team together and review/discuss some complicated reviews or specs
18:34:48 <amrith> so if there is a particular project (say the one for guest images) which is wide ranging in scope
18:35:04 <amrith> if there were a spec for review ahead of summit, it would be great to review there
18:35:30 <amrith> there may be projects (take the couchdb config group one) which may be merged by then
18:36:08 <amrith> but leaving those kinds of things aside, if you feel that having the team look at the project at summit is a benefit, having a spec out for review ahead of the summit would be awesome. you already have one so I think it'll be good to discuss there.
18:36:37 <amrith> did I answer the question, or were you asking whether a spec was a requirement for a summit session? Answer: NO
18:37:01 * pmackinn wonders if summit be organized as such
18:37:21 <pmackinn> blocks of time boxes specifically for specs; others for pie in the sky
18:37:33 * amrith thinks about pie
18:37:39 <pmackinn> mmmm pie
18:37:50 <pmackinn> any who
18:38:04 <amrith> which brings us to
18:38:06 <amrith> #topic Summit Planning
18:38:11 <amrith> sorry pmackinn, not pie
18:38:18 <amrith> Please review the proposed sessions
18:38:18 <amrith> #link https://etherpad.openstack.org/p/trove-newton-proposed-sessions
18:38:29 <amrith> Please update your calendar for the various Trove sessions
18:39:02 <amrith> (WR1) Wednesday 0950 to 1030
18:39:02 <amrith> (WR2) Wednesday 1350 to 1430
18:39:02 <amrith> (WR3) Wednesday 1530 to 1610
18:39:02 <amrith> (WR4) Thursday 1150 to 1230
18:39:02 <amrith> (WR5) Thursday 1330 to 1410
18:39:03 <amrith> (WR6) Thursday 1420 to 1500
18:39:05 <amrith> (FB1) Wednesday 1720 to 1800
18:39:07 <amrith> (FB2) Thursday 0950 to 1030
18:39:09 <amrith> (FB3) Thursday 1100 to 1140
18:39:11 <amrith> (CM) Friday 0900 to 1230.
18:39:13 <amrith> I'll work on putting sessions together from the etherpad
18:39:22 <amrith> and should have something for next weeks meeting.
18:39:32 <amrith> Nothing more from me on this, anyone else have anything to add?
18:39:42 <cp16net> re: the session that flaper87 added i think the guys at ebay were interested in it as well last cycle but have not heard from them in a while
18:39:58 <cp16net> that was re: containers
18:40:20 <amrith> cp16net, yes.
18:40:33 <amrith> I would like to attend that session as well.
18:40:58 <amrith> That is an example of a project for which a BP ahead of summit would be good.
18:41:16 <amrith> I've spent some time researching that and it is non-trivial. I have a working prototype (maybe a year old now)
18:41:41 <amrith> and as we discussed in Raleigh, superconductor has something good to bring to that problem as well.
18:41:41 <cp16net> amrith: you will be able to fill in the details of the sessions for each time slot
18:41:58 <amrith> cp16net, I'll do that (hopefully) by next week.
18:42:13 <amrith> There are a lot of sessions that I'd like to merge and in some cases move around.
18:43:03 <amrith> ok, unless someone has other things to add, lets move on.
18:43:09 <pmackinn> SlickNik, was think of putting up a collab gdoc on superconductor, starting with your ideas
18:43:26 <amrith> pmackinn, why not an etherpad or a review?
18:43:37 <pmackinn> PICTURES
18:43:39 <amrith> I hesitate to go near gdoc for something like this ...
18:43:44 <pmackinn> BOXES and LINES
18:43:44 <amrith> oh, pictures
18:43:46 <amrith> good point
18:43:55 <pmackinn> and emojis
18:43:56 <amrith> sure
18:44:03 <amrith> go for it
18:44:11 <cp16net> i think i figured out how to add pictures to a spec
18:44:29 <pmackinn> O-<-<
18:44:34 <pmackinn> uml actor ^^
18:44:37 <amrith> <just kidding>   #action cp16net to share how to add pictures to a spec :)
18:44:53 <cp16net> i mentioned in the spec for multiregion support that vgnbkr put up
18:45:09 <cp16net> i'll make a test spec to and see if it works.
18:45:20 <pmackinn> can one edit the diagrams in a spec?
18:45:20 <SlickNik> pmackinn: Sounds good — we can distill what we have in the collab doc and propose a BP once we're at that stage (and when cp16net shows us his magic).
18:45:21 <amrith> #link https://review.openstack.org/#/c/294213/
18:45:48 <cp16net> yeah... .. image:: myimage.jpg
18:45:51 <cp16net> and check in the image
18:45:54 <amrith> #action pmackinn to put up a google-doc for the superconductor session at summit
18:46:20 <amrith> let's move on, we have a couple of more things to cover today.
18:46:21 <amrith> #topic Planning for mid-cycle
18:46:32 <amrith> I've put out a proposal for R-7 week, in the NYC area. R-7 is based in part on feedback from earlier mid-cycles;
18:46:32 <amrith> too early, too late. Does this work for folks? I'm making it NYC area because there is an OpenStack East Days event
18:46:32 <amrith> in NYC that week and it'll be fun to go to that as well.
18:46:43 <amrith> This is informational at this point, I've tentatively got someone who'll host the mid-cycle in that location so
18:46:43 <amrith> fingers crossed. Once that is confirmed, I'll share with the team.
18:47:31 <pmackinn> Aug 22-26? sounds good
18:47:34 <amrith> R-7 week is Aug 22-26
18:47:48 <amrith> yes, pmackinn I just realized that I should get the dates too :)
18:48:18 <amrith> so, for now please pencil that date into your calendars ..
18:48:39 <amrith> if you have a hard conflict with that date, please email me or something
18:48:51 <amrith> and moving along.
18:48:52 <amrith> #topic Recent instability in the gate
18:49:02 <amrith> On March 28th, Routes 2.3 was released. This caused problems for Trove and Neutron.
18:49:02 <amrith> #link https://bugs.launchpad.net/trove/+bug/1563028
18:49:03 <openstack> Launchpad bug 1563028 in Trove "Routes version 2.3 broke the way we register routes" [Critical,Fix released] - Assigned to Amrith (amrith)
18:49:11 <amrith> The change that caused this (in Routes) is
18:49:11 <amrith> #link https://github.com/bbangert/routes/commit/0a417004be7e2d950bdcd629ccf24cf9f56ef817
18:49:21 <amrith> We now have fixes merged for master and the merge for stable/mitaka is ongoing.
18:49:21 <amrith> We also found that Trove's CI jobs don't respect upper-constraints.txt. This means that we are more susceptible to
18:49:21 <amrith> breaking changes caused by any of the modules we use from pypi. See the ML posting this AM for more about upper-
18:49:21 <amrith> constraints.txt
18:49:40 <amrith> (thanks to those of you who helped review these changes; sorry for the number of iterations)
18:49:45 <amrith> #link http://openstack.markmail.org/thread/m2vqrgrftr5cjuai
18:49:54 <amrith> We've now got changes going in for master, mitaka, and liberty to respect upper-constraints.txt which should make
18:49:54 <amrith> our gate jobs more stable.
18:50:13 <amrith> I figured I'd share this with the team in case y'all were wondering what was up with the gate.
18:50:39 <vkmc> +1 thanks for working on that amrith
18:51:13 <amrith> thx vkmc. anyone have questions about this
18:51:29 <johnma> so amrith, all these patches related to those changes need to be merged by when?
18:51:56 <johnma> there still a number of patches related to this still open for reviews. is it something that needs to be reviewed soon
18:51:59 <amrith> by today so we can surely get rc2 tagged by tomorrow
18:52:10 <johnma> ok
18:52:11 <amrith> at this point, all the patches we need are going into master
18:52:21 <amrith> after that they have to get cherry-picked and merged into mitaka
18:52:38 <amrith> and rc2 tagging deadline (this is a deadline not a guideline) is thursday
18:53:49 <amrith> cp16net, the u-c change is in gate for master now
18:54:00 <amrith> once that merges, I'll get the cherry-pick for mitaka and ping you
18:54:13 <amrith> Nothing more from me on this, just wanted to pass the word along on what's been going on. Once these changes merge,
18:54:13 <amrith> we'll have other failed jobs begin to pass and merge.
18:54:21 <amrith> That's it from me, anyone have anything to add?
18:54:34 <amrith> #topic Open Discussion
18:54:47 <amrith> anyone have anything else they'd like to discuss ...
18:54:55 <amrith> we have a couple of minutes
18:54:59 <cp16net> sounds good amrith
18:55:18 <cp16net> thanks amrith for running the meeting :)
18:55:51 <amrith> thx cp16net comes with the baton I understand. thanks for carrying the baton for the past six months, and for all the bugs over the past 4 years :)
18:56:22 <amrith> anyone have anything else?
18:56:39 <amrith> Before we go, please remember to do more reviews in the coming weeks. Let's pick up the pace. Thanks!
18:56:42 <amrith> #endmeeting