18:00:55 <cp16net> #startmeeting trove
18:00:55 <openstack> Meeting started Wed Mar 16 18:00:55 2016 UTC and is due to finish in 60 minutes.  The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:58 <openstack> The meeting name has been set to 'trove'
18:01:06 <SlickNik> o/
18:01:06 <cp16net> howdy everyone
18:01:14 <pmackinn> cp16net, welcome back
18:01:15 <SlickNik> howdy cp16net — welcome back!
18:01:20 <cp16net> thanks :)
18:01:28 <amrith> ./
18:01:37 <tosky> hi
18:01:38 <dalees`> o/
18:01:45 <johnma> o/
18:02:19 <cp16net> #topic action items from last week
18:02:32 <cp16net> #info [amrith] figure out who has to send FFE acceptances
18:03:33 <amrith> Yup, I did ...
18:03:39 <cp16net> #done
18:03:47 <amrith> but it appears that FFE's don't extend to client. we'll talk abotu taht later.
18:03:58 <cp16net> yeah ok
18:04:08 <cp16net> #topic Trove pulse update
18:04:19 <cp16net> #link http://bit.ly/1VQyg00
18:05:00 <amrith> queue growth is negative, not since 9/9/2015 ;)
18:05:14 <cp16net> thats amazing
18:05:19 <cp16net> :)
18:05:28 <cp16net> i'm sure it wont last...
18:05:46 <vgnbkr> o/
18:06:02 <cp16net> but over all we've merged many of the patches needed for mitaka
18:06:16 <cp16net> which it looks like attributed to this
18:07:33 <cp16net> anyone have other comments?
18:08:07 <cp16net> ok moving on
18:08:12 <cp16net> #topic Announcements
18:08:29 <cp16net> #info mitaka release schedule
18:08:31 <cp16net> #link http://releases.openstack.org/mitaka/schedule.html
18:08:47 <cp16net> this week is RC-1 cut
18:10:03 <cp16net> that means that newton will be opening up soon
18:11:39 <cp16net> PTL self nominations are happening now and i sent an email out saying that i've decided to not run again for the newton cycle.
18:11:50 <pmackinn> do newton specs have to wait or can they be pushed up in advance?
18:12:06 <cp16net> they can be pushed up with the trove-spec repo
18:12:15 <cp16net> just add the newton folder
18:12:24 <johnma> we need to create a directory for newton specs
18:12:28 <cp16net> yup
18:13:29 <SlickNik> cp16net / pmackinn: we should be able to allow folks to target specs to future releases even if they're not open for coding yet.
18:13:37 <cp16net> amrith: has announced his candiacy which i think will be great
18:13:47 <cp16net> SlickNik: i agree
18:13:49 <amrith> thx cp16net
18:13:57 <johnma> thanks alot cp16net for all the hard work and helping us with a  smooth release. Quite alot of work was done in the release
18:14:05 <SlickNik> cp16net / amrith: I saw the PTL candidacy emails!
18:14:19 <cp16net> since the trove-spec repo is not a release repo you can push specs to any of the future releases
18:14:26 <SlickNik> cp16net: Thanks for all the awesome work in the Mitaka cycle.
18:14:28 <cp16net> this will not affect anything
18:14:35 <pmackinn> +1 cp16net thx
18:15:02 <SlickNik> amrith: Looking forward to the direction the Newton PTL takes us!
18:15:08 <cp16net> On that note i'd like to thank everyone for their contributions and hard work over the mitaka cycle
18:15:09 <amrith> I thought there was already a newton spec, but I was mistaken.
18:15:17 <amrith> cp16net, thanks for all that you've done for trove
18:15:30 <amrith> thanks SlickNik
18:15:49 <cp16net> and also i'd like to thank everyone for helping me out while i was away taking care of my new born.
18:15:53 <johnma> +1 to having Amrith as our next PTL. SlickNik said it well
18:16:24 <amrith> thx johnma ...
18:16:30 <cp16net> speaking of amrith ....
18:16:37 * amrith runs for the hills
18:16:37 <cp16net> #info [amrith] Cross project Quotas library/project
18:16:48 <amrith> oh, thx
18:16:54 <amrith> I put these two as informational items
18:16:58 <amrith> this one and the next one.
18:17:05 <amrith> wanted to bring it to everyone's attention.
18:17:11 <amrith> I posted a response on the quote thing on the ML
18:17:25 <amrith> it appears like we may have a library to use for quotas in the future.
18:17:39 <amrith> I was hoping that there would be a quotas capability taht would give us more in the short term.
18:17:46 <amrith> but maybe we'll have to wait for that.
18:18:04 <amrith> in particular, I was interested in this because quotas (of other projects) become interesting to us when we muck with remote.py.
18:18:11 <amrith> it is informational.
18:18:22 <amrith> same with the next one
18:18:27 <amrith> #info "Take a look at https://review.openstack.org/#/c/292451/"
18:18:40 <amrith> it is something that flaper87 proposed.
18:18:52 <amrith> it took a while to figure out what the dashboard is all about.
18:19:17 <amrith> once I got it to work (and I left some comments for others who want to tryi it), I felt that the dashboard didn't address the things I'd thought we talked about at previous meetings.
18:19:23 <cp16net> oh yeah we created that a long time ago
18:19:25 <amrith> but wanted to bring the review to everyones attention.
18:19:35 <cp16net> and it generated the link i've used for a while
18:19:45 <amrith> In particular, one of the shortcomings of gerrit is that there is no way to tag a review.
18:19:55 <amrith> i.e. tag a bunch of reviews for Mitaka-RC1 or some such thing.
18:20:03 <amrith> and so we resorted to the tagged by someone.
18:20:13 <amrith> when the dashboard was made, it was 'tagged by SlickNik'
18:20:23 <cp16net> yeah
18:20:27 <amrith> for Mitaka I starred the reviews and shared a link.
18:20:36 <amrith> so I'm less than enamored of this commit.
18:20:50 <cp16net> it would be nice to be able to corrolate the release to reviews
18:20:52 <amrith> but figured I'd share and let others see what it was. and maybe we'll get more ideas on what the dashboard should contain.
18:21:01 <cp16net> but i think it would arequire query to launchpad as well
18:21:07 <amrith> yes, I've been meaning to ask sdague a bunch of questions about it.
18:21:27 <cp16net> all that dash does it creates a link
18:21:33 <amrith> one was about tagging reviews. the other was about picking a sort order in the dashboard, the third was to make the dashboard we create a part of the project
18:21:52 <cp16net> its easier to update that file than mucking with a 1000+ characters on the url
18:21:53 <amrith> if you go to https://review.openstack.org/#/admin/projects/openstack/trove
18:21:57 <amrith> there is a dashboards list
18:22:05 <amrith> and I want to add dashboards there.
18:22:08 <amrith> I wonder how to do that
18:22:15 <amrith> So ...
18:22:18 <cp16net> that was old
18:22:25 <amrith> #action [amrith] do the things he says above ...
18:22:28 <cp16net> they decided not to keep up with those
18:22:40 <amrith> oh well, that's sad.
18:22:44 <SlickNik> amrith: If I recall correctly, to be able to do that you'd have to modify the list of gerrit default dashboards.
18:22:44 <cp16net> at least the last time i asked about it
18:23:20 <amrith> SlickNik, that may be it. have to figure out what a good way would be to do something like that.
18:23:27 <cp16net> yeah it requires an update to gerrit backend and i think they frowned upon because it might require a bit of work each time
18:23:30 <amrith> especially tracking reviews for a milestone.
18:23:30 <SlickNik> amrith: Talking to the CI folks, there wasn't an easy way to do that per team (i.e. making a change would result in that dashboard being available to everyone).
18:23:37 <amrith> I think that'd make sense for a number of projects.
18:23:39 <cp16net> it was on the infra team i believe
18:23:56 <amrith> anyway, not to rathole on that; I'll go find otu and report back to the team.
18:23:59 <amrith> that's all I had cp16net
18:24:06 <SlickNik> But they have done a couple of gerrit upgrades since then, so I wonder if this has changed at all.
18:24:31 <cp16net> k side note on that you can now update your list of links in gerrit
18:24:41 <cp16net> https://review.openstack.org/#/settings/preferences
18:24:48 <cp16net> in the my menu
18:24:54 <cp16net> create a link and add it there
18:25:10 <amrith> cp16net, yes. but is there a way to make it project wide?
18:25:22 <cp16net> no
18:25:32 <cp16net> other than adding it to a wiki or something for reference
18:25:39 <cp16net> ok moving on
18:25:44 <cp16net> #topic Health check on outstanding blueprints and features for Mitaka
18:25:51 <cp16net> #link https://review.openstack.org/#/q/starredby:amrith+status:open
18:26:19 <amrith> are we all good with the two mongodb changes listed there?
18:26:30 <amrith> I'd like those merged into RC1 if at all possible.
18:27:21 <cp16net> i think they are good
18:27:39 <cp16net> i didnt run through another test on then
18:27:42 <amrith> and if we can get imandhan's couchdb change merged, I think we're in a position to finalize the release notes and get rc1 going.
18:27:43 <cp16net> them*
18:27:52 <cp16net> i've been testing the couchdb patches
18:28:04 <imandhan> thanks cp16net
18:28:07 <amrith> I've tried a couple of times to connect with vkmc and sonali but have not been able to.
18:28:17 <pmackinn> vkmc is pto this week
18:28:18 <amrith> so I fear that the two couchdb configuration group things will slip
18:28:32 <amrith> well, that'd explain it!
18:28:45 <amrith> And I can't reach sonali.
18:29:01 <amrith> so I think we are good to call RC1 as soon as we get imandhan's changes in.
18:29:05 <cp16net> yeah i think we can move them to the next cycle
18:29:08 <amrith> is that correct?
18:29:28 <amrith> johnma, peterstac ... did we get everything else? are we missing something that should be starred?
18:29:49 <cp16net> any final requirements
18:29:56 <cp16net> updates or translations
18:30:13 <peterstac> looks like the Redis one got dropped somehow
18:30:16 <peterstac> #link https://review.openstack.org/#/c/272844/
18:30:44 <peterstac> For production systems, the backup shouldn't lock out the connections ...
18:30:56 <amrith> starred now
18:31:08 <amrith> we need another reviewer
18:31:23 <SlickNik> I'll review the redis patch
18:31:50 <cp16net> i had a concern about it but i think peter won me over.
18:32:42 <peterstac> cp16net, yeah, it fails over to the 'blocked' save if the bg one fails for any reason
18:32:50 <peterstac> (for example, due to memory issues)
18:33:08 <cp16net> yea
18:33:38 <tosky> it's not on the list of reviews, but is the plan of enabling the new scenario tests still on track for Mitaka?
18:34:06 <peterstac> well, we're moving ahead with it, but my guess is it won't be ready until Newton
18:34:18 <peterstac> but should be early in the cycle
18:34:29 <tosky> peterstac: not even a gate for the non-experimental datastore?
18:34:52 <cp16net> #agree scenario tests should be turned on in newton.
18:35:14 <peterstac> we could probably set up the mysql one as non-voting soon (since I think they're fairly stable)
18:35:35 <peterstac> we might want to run the Redis ones a bit more in case they need tweaking
18:35:43 <cp16net> we setup the other experimental jobs to run the scenario tests
18:35:47 <peterstac> (no sense wasting gate resources if we don't need to)
18:35:58 <cp16net> but they dont run normally
18:36:15 <tosky> right, but it's the chicken and egg problem: tests are not stable because are not always executed, so they are not used for gates, so not executed
18:36:22 <peterstac> yes, and with all the mitaka push I haven't be running them manually much lately
18:36:38 <peterstac> but I should have a little more time now :)
18:36:42 <cp16net> there hasnt been anyone working to make sure they are stable in the gate tho
18:36:54 <cp16net> there is a job you can run but last i checked it failed
18:36:57 <tosky> I didn't know about the extra job
18:37:24 <peterstac> if you run 'check experimental' in trove, it'll kick off the scenario tests for mysql and redis
18:37:39 <cp16net> yeah ^^ thats what i was going to say but peterstac beat me to it
18:38:13 <tosky> maybe we can talk about it post-meeting, if the failure was not complex (or it was just for redis), it could be fixed easily
18:38:33 <amrith> I suggest we take this up after the meeting please.
18:38:34 <cp16net> so for the features in mitaka that amrith starred we have the ones we need
18:38:38 <amrith> there are other things on the agenda.
18:38:43 <peterstac> cp16net, if you like I can try and get those ready for a 'non-voting' switch by next week (maybe ...)
18:39:20 <cp16net> if we dont hear from sonali or vkmc soon on status then we will have to push that feature to newron
18:39:56 <amrith> cp16net, I suggest we decide that now.
18:39:59 <amrith> so we can move on
18:40:17 <amrith> and cut rc1 as soon as the two mongo things, the couchdb change (imandhan) and the redis change are merged.
18:40:36 <cp16net> i'm in favor of pushing it wihtout any work on them in over a week
18:41:26 <amrith> does anyone feel differently?
18:41:28 <cp16net> amrith: i know you've been talking with the release team
18:41:37 <amrith> cp16net, yes.
18:41:44 <cp16net> is there pressure for release be cut asap?
18:42:03 <cp16net> i've caught parts of the convs but not heard much on when yet
18:42:13 <amrith> I would like to mark rc1 so we can focus on bug fixing. yes, RC1 deadline is this week. they'll do it anyway ...
18:42:29 <amrith> I would rather do it when we're ready and then focus on fixing and testing.
18:42:41 <cp16net> right i agree
18:42:52 <amrith> that'll also mean that we can tag stable/mitaka and other things (for newton) can start to land.
18:43:02 <cp16net> yup
18:43:16 <amrith> which is the next thing I have on the agenda ...
18:43:32 <cp16net> lets push the couchdb config groups now.
18:43:40 <amrith> I've let peterstac know already. the client side changes for module management won't be a mitaka thing.
18:43:41 <cp16net> and you can un star it
18:43:58 <amrith> #agreed couchdb configuration groups moves to Newton
18:44:00 <SlickNik> Also — no one likes to release on Fridays, so realistically we have until tomorrow to merge what we want for RC1
18:44:12 <cp16net> true
18:44:17 <amrith> I have a personal reason for wanting to cut it today.
18:44:26 <amrith> tomorrow and day after, cp16net and I are pub hopping.
18:44:38 <SlickNik> Ah, you're going to be in Austin!
18:44:40 <cp16net> heh :-P
18:44:45 <amrith> Yup
18:44:54 <amrith> johnma, watch out ...
18:45:00 <cp16net> ok i think that finalizes the patches we need fixed up asap
18:45:11 <amrith> yes, there are now 4
18:45:14 <johnma> sorry had to step out for a bit, came back just on time :)
18:45:28 <amrith> three are verified. and need a +1
18:45:31 <SlickNik> Makes sense — at this point, I'd highly recommend pushing out stuff that won't be ready to Newton.
18:45:32 <amrith> one is waiting for gate
18:45:44 <cp16net> ok so next thing on the agenda?
18:45:53 <amrith> So, for newton, we should remember that FFE's don't extend to the client.
18:46:11 <amrith> if we need changes on the client, the freeze date for the client is a HARD date.
18:46:22 <cp16net> #topic Summit planning
18:46:23 <amrith> and even if you get an FFE for a feature, that's your server side
18:46:30 <amrith> ok, on to summit planning ...
18:46:36 <peterstac> Is this new? I don't remember hard freeze dates for the clients before ...
18:46:55 <peterstac> (In fact I thought we got to release the client whenever we saw fit ...)
18:47:02 <cp16net> peterstac: i think its enforced more now than it was before
18:47:03 <amrith> peterstac, I don't know. And I don't know that it really matters at this point.
18:47:12 <amrith> and in the interest of time, I'd suggest we look ahead.
18:47:14 <amrith> to summit planning.
18:47:23 <peterstac> sure, noted
18:47:27 <cp16net> #link https://etherpad.openstack.org/p/trove-newton-proposed-sessions
18:47:44 <amrith> we have 3 fishbowls, 6 working sessions and a half day contributor meetup.
18:47:54 <cp16net> amrith: outlined the propsed sessions here that we had talked about at the meetup last time
18:47:57 <amrith> I've requested that our contributor meetup be Friday morning.
18:48:08 <amrith> because I know that several people have afternoon travel plans.
18:48:14 <cp16net> if there are other suggestions please add to this as you see fit
18:48:42 <SlickNik> amrith: ++
18:48:44 <amrith> #action [amrith] contact Victor Stinner re: python3
18:49:04 <amrith> #action [pmackinn] I've tagged you on some topics based on mid-cycle, please confirm
18:49:38 <amrith> #action [amrith] get leaders for all sessions that we want to actually conduct ;)
18:50:00 <pmackinn> amrith, noted
18:50:19 <amrith> cp16net, ... I'd like a quick rollcall vote on who'll be at summit.
18:50:32 <cp16net> ./
18:50:44 <dalees`> o/
18:50:47 <amrith> ./
18:50:54 <johnma> ./
18:50:59 <vgnbkr> o/
18:51:03 <peterstac> o/
18:51:06 <pmackinn> ./
18:51:36 <pmackinn> vmkc, ./ (pretty sure)
18:51:43 * peterstac raises hand for dougshelley66
18:51:59 <dloi> ./
18:52:35 <cp16net> looking forward to seeing everyone there
18:52:54 <cp16net> #topic open discussion
18:53:16 <amrith> thx cp16net
18:53:46 <cp16net> anyone have anything else?
18:54:04 <cp16net> if not i'll end it
18:54:05 <amrith> since we have the time, tosky had some questions earlier.
18:54:11 <amrith> or we can go to #openstack-trove
18:54:13 <amrith> and continue there?
18:54:45 <cp16net> either way we have about 5 min
18:54:51 <tosky> I think peterstac and cp16net mentioned they will recheck the status of the current job
18:55:11 <tosky> which would be enough for now :)
18:55:17 <peterstac> tosky, I'll work on that this week
18:55:22 <tosky> peterstac: thanks
18:55:27 <cp16net> sounds good
18:55:28 <peterstac> np
18:55:50 <amrith> one question for pmackinn
18:56:00 <pmackinn> oh boy
18:56:01 <amrith> pmackinn, any idea whether tellesnobrega will be at summit?
18:56:06 <amrith> I didn't put the ceph thing on the agenda
18:56:15 <amrith> but we should, if he's looking to do it for newton
18:56:41 <pmackinn> amrith, will enquire and try to get you an answer tomorrow
18:56:51 <amrith> there are other projects for which I've file BP's and I'll list some of these in the contributor meetup section or maybe have a session for "projects in Newton"
18:56:55 <amrith> thx pmackinn
18:57:22 <cp16net> alright thanks everyone
18:57:26 <amrith> #action [amrith] add projects in newton to agenda
18:57:45 <cp16net> #endmeeting