18:00:20 <amrith> #startmeeting trove
18:00:20 <openstack> Meeting started Wed Feb 24 18:00:20 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:25 <openstack> The meeting name has been set to 'trove'
18:00:36 <pmackinn> o/
18:00:47 <amrith> hi pete!
18:01:30 <amrith> pmackinn, while folks trickle in, did you read dougshelley66's blog post http://www.tesora.com/trove-midcycle-raleigh/
18:01:36 <amrith> nice pic of the RedHat office
18:01:36 <vgnbkr> o/
18:02:03 <dougshelley66> o/
18:02:08 <imandhan> o/
18:02:20 <pmackinn> amrith, dougshelley66: hey! real nice
18:02:46 <amrith> and thanks much for hanging out with us while we were there.
18:02:51 <pmalik> \./
18:03:03 <amrith> will get started in a minute or two
18:03:57 <pmackinn> "I felt our trip to Raleigh was well worth the cost and time...but, frankly, could have been a lot warmer."
18:04:21 <amrith> Well, we didn't want to say what we really felt. Being sold a bill of goods, etc., etc.,
18:04:26 <amrith> but, let's get started
18:04:26 <dougshelley66> pmackinn hey you are paraphrasing...i never said that...
18:04:45 <amrith> #topic Trove pulse update
18:04:53 <amrith> So, cp16net is out
18:04:58 <atomic77> \\o
18:05:03 <amrith> and I haven't figure out how to update the chart that he uses.
18:05:05 * atomic77 pants
18:05:10 <amrith> he didn't get me write permission in time.
18:05:16 <amrith> so our stats are a week old.
18:05:17 <peterstac> o/
18:05:18 <dougshelley66> any cp16net jr news>
18:05:26 <amrith> #link      http://bit.ly/1VQyg00
18:05:33 <amrith> dougshelley66, no news
18:05:50 <amrith> but will be sure to share with the team as soon as I hear something.
18:06:04 <amrith> I've seen a lot of new changes and some reviews go by.
18:06:12 <amrith> but we have a bunch more to do before we can get to m3.
18:06:20 <amrith> which brings us to the next item
18:06:24 <amrith> #topic Announcements
18:06:33 <amrith> #link      http://lists.openstack.org/pipermail/openstack-dev/2016-February/086362.html
18:07:10 <amrith> Sorry, wrong link
18:07:12 <amrith> #link http://releases.openstack.org/mitaka/schedule.html
18:07:27 <amrith> We are almost at R-6
18:07:38 <amrith> On Feb 26, we have to cut the final version of all non-client libraries.
18:08:00 <amrith> In the last meeting, we discussed this briefly
18:08:09 <amrith> and determined that we had horizon libraries
18:08:29 <amrith> abramley, dloi, imandhan would some of you like to fill us in on where we are relative to this?
18:09:22 <amrith> anyone
18:09:48 <amrith> imandhan, yt?
18:09:56 <imandhan> typing
18:10:01 <amrith> k, thx
18:10:11 <imandhan> amrith I'm going to let my angular panel table display patch stay in WIP for this release
18:10:59 <imandhan> the rest of the patches seem like they are in good shape
18:11:07 <imandhan> from a quick glance at the list
18:11:19 <amrith> imandhan, ok. wrt dashboard libraries for the current horizon dashboard, are we in good shape relative to that? is there something that we need to package up?
18:12:03 <imandhan> I'm not entirely sure about that, I can ask around and see what other projects are doing
18:12:11 <imandhan> I'll get back to you on that after the meeting
18:12:20 <amrith> imandhan, thanks
18:12:32 <imandhan> np
18:12:47 <dloi> I think there are a couple of patches to go for the regular django stuff
18:13:16 <amrith> hi dloi, do you think they're in good shape/on track?
18:13:27 <amrith> how do we get this released and given to (whoever)
18:13:32 <dloi> one has some test failures on it
18:13:42 <amrith> this relates to abramley's question that is later in the agenda, so we may as well move to that.
18:14:13 <amrith> [abramley] Recently all of the trove horizon code was moved into a separate plugin - trove-dashboard. Who in the community is responsible for creating ubuntu, rhel etc packages for this trove-dashboard plugin and ensuring that it installs and plugs into horizon on the various platforms?
18:14:13 <abramley> Yes - you touched on it above - we are all using trove-dashboard code from github - but at some point this needs to get packaged
18:14:22 <abramley> as deb / rpm etc for redhat, ubuntu suse etc
18:14:44 <abramley> Sahara will have the same issue
18:14:56 <amrith> abramley, do we know what they are doing (Sahara)
18:15:10 <abramley> I would assume that trove and sahara would be packaged in the same way - so that they can co-exist in the same horizon install
18:15:26 <imandhan> *zaqar is in the same boat too
18:15:28 <abramley> So far I have found a single task on a backlog to add a package for sahara for RDO
18:15:40 <abramley> ... but I didn't see anything for trove
18:15:51 <abramley> On the ubuntu side I haven't seen anything for any of the horizon plugins
18:17:21 <amrith> ok, so the question is this.
18:17:26 <abramley> I think we need to reach out to the various communities that do the packaging for the distros - but first we should talk to sahara etc
18:17:31 <amrith> is there a library that trove needs to 'release' for the dashboard?
18:17:47 <amrith> and is that something we have to do by R-6
18:17:52 <amrith> Feb 26
18:18:15 <abramley> In the past the people packaging horizon would just grab code from github during the build of the packages
18:18:17 <amrith> is Horizon expecting that we give them this plugin or whatever by R-6?
18:18:49 <abramley> I don't believe 'horizon' is expecting anything from trove / sahara etc - we are now a plugin on top of horizon so they don't have to worry about us
18:19:02 <dloi> I don;t thing horizon is expecting a packaged plugin
18:19:03 <abramley> It is really more of a packaging issue for the distro maintainers
18:19:11 <amrith> ok, if that is the case, is the horizon plugin a "non-client library"?
18:19:11 <imandhan> I'm asking a Horizon core who is at their midcycle currently so will let you know when I hear back
18:19:18 <amrith> Sounds like no.
18:19:27 <amrith> thanks imandhan
18:19:42 <amrith> imandhan, may I assign the action item to you to get this answered?
18:19:49 <imandhan> sure
18:20:00 * pmackinn pmackinn to enquire about RDO trove-dashboard
18:20:16 <pmackinn> #action pmackinn to enquire about RDO trove-dashboard
18:20:17 <imandhan> I'll communicate whatever I learn on the trove channel
18:20:20 <amrith> #action imandhan to get an answer from horizon whether they consider the trove-dashboard plugin to be a "non-client library" and whether they need it by R-6
18:20:36 <amrith> imandhan, if you would, email it to me please. it may get lost in the irc shuffle
18:20:45 <imandhan> okay, will do
18:21:26 <amrith> thanks pmackinn
18:21:45 <amrith> ok, that takes us on to the next topic
18:21:47 <amrith> #topic  Health check on outstanding blueprints and features for Mitaka
18:21:54 <amrith> #link      https://launchpad.net/trove/+milestone/mitaka-3
18:22:26 <amrith> I'm not going to run down the list but rather ask if anyone has a set of reviews or changes that they feel is falling behind.
18:22:48 <amrith> the deadline for all features is R-5, March 4th.
18:22:56 <amrith> anyone?
18:23:16 <peterstac> I'll be cutting it close with the module stuff
18:23:34 <amrith> peterstac, ok
18:23:50 <peterstac> I think I'm going to break it down into two sets to make it easier for review (plus I'm almost done the first one)
18:24:14 <amrith> there are several bugs for m-3 that are currently not assigned.
18:24:19 <peterstac> module creation/deletion, etc. and then instance apply/remove, etc.
18:24:21 <amrith> many appear to relate to PXC
18:24:25 <amrith> but not all
18:24:39 <amrith> #1509615	(mysql) incremental backup keeps instance in BACKUP state if backup has no lsn
18:24:39 <amrith> #1541222	need a way to set the listening ip to user specified address on guest datastores
18:24:39 <amrith> #1542485	guest_log_long_query_time should be controlled via configuration groups
18:24:39 <amrith> #1543211	PXC guestagent secure method has hack to set the admin password
18:24:40 <amrith> #1546372	mysql root enable reports the user as 'root' instead of context.user
18:24:41 <amrith> #1549291	Error in taskmanager.test_pxc_clusters.PXCClusterTasksTest.test_shrink_cluster_does_not_exist
18:25:16 <dougshelley66> i assume the bugs aren't required to be done by FF?
18:25:21 <amrith> no
18:25:50 <amrith> but R-5 is the deadline for all client libraries
18:26:03 <amrith> so if there is something that is in the client, the deadline is R-5
18:26:24 <amrith> There is time through R-2 for bug fixes
18:26:50 <amrith> so I'm not hearing anyone express concerns about features for R-5, which is good.
18:27:08 <amrith> going once
18:27:17 <amrith> going twice
18:27:20 <imandhan> wait
18:27:25 <amrith> ok, imandhan go ahead
18:27:44 <imandhan> I'm having a little trouble with my couchdb work. I'll try to push it all done this week
18:27:57 <imandhan> just wanted to throw that out there since it currently isn't out for review
18:28:11 <imandhan> and also, might be pinging some people with questions :)
18:28:14 <amrith> ok, if you can start sending them up for review in parts, it may expedite.
18:28:18 <amrith> sure
18:28:33 <amrith> anyone else?
18:28:38 <imandhan> hmm okay I can do parts
18:28:53 <amrith> not required
18:28:55 <amrith> don't change it now
18:29:04 <amrith> if you are on track to push all of it up this week, just do that.
18:29:19 <imandhan> ok cool
18:29:21 <amrith> anyone else
18:29:22 <imandhan> thanks!
18:29:29 <amrith> going once
18:29:35 <amrith> going twice
18:29:42 <amrith> #topic Open Discussion
18:29:42 <pmackinn> wait!
18:29:48 <pmackinn> oh ok
18:29:50 <amrith> #topic pmackinn
18:30:00 <amrith> let's talk about pmackinn
18:30:02 <amrith> ;)
18:30:05 <amrith> go ahead pmackinn
18:30:11 <pmackinn> are we in open? good?
18:30:20 <amrith> #topic Open Discussion
18:30:22 <amrith> now we are
18:30:25 <amrith> go ahead pmackinn
18:30:29 <pmackinn> is there a trove-integration spec template?
18:30:39 <amrith> I don't believe so
18:31:00 <pmackinn> or just use the trove one for a trove-int spec (image create per meetup)?
18:31:08 <amrith> bug good luck trying to get the test jobs on the trove-specs repository to understand two templates ;)
18:31:21 <amrith> use the same one would be my recommendation.
18:31:32 * pmackinn probably has his answer :-)
18:31:33 <amrith> A lot of sections would fall by the wayside, likely.
18:31:34 <pmackinn> thx
18:31:46 <amrith> others for Open Discussion
18:31:52 <dloi> My guess is the trove-dashboard is not a client library but just in case it is can we get one more +2 and WF for https://review.openstack.org/#/c/269735/ and https://review.openstack.org/#/c/270483/
18:32:13 <pmalik> Yes, one thing.
18:32:14 <pmalik> I have recently updated the root scenario tests to make use of the
18:32:14 <pmalik> new stuff added by cp16net in the cluster-root patch set.
18:32:14 <pmalik> The tests now also ping the datastore to verify the root credentials
18:32:14 <pmalik> actually work - see review: https://review.openstack.org/#/c/283754/
18:32:15 <pmalik> I however noticed that when we restore a root-enabled MySQL instance
18:32:18 <pmalik> we also reset the root password to a new random value:
18:32:20 <pmalik> https://github.com/openstack/trove/blob/master/trove/guestagent/datastore/mysql_common/service.py#L714
18:32:23 <pmalik> I don't think this is consistent with other datastores (see Mongo for instance).
18:32:25 <pmalik> More importantly, is this what we (the user) want?
18:32:27 <pmalik> If they enable root with password 'foo' then backup and restore
18:32:29 <pmalik> the instance it should still have the root password 'foo'.
18:32:31 <pmalik> Any opinions?
18:32:33 <pmalik> Thx. :P
18:33:38 <amrith> Sounds reasonable to me.
18:33:47 <amrith> I'm not sure why we reset it to a random value though.
18:33:54 <amrith> does anyone remember a good reason for this?
18:34:02 <dougshelley66> yes
18:34:27 <dougshelley66> isn't the point that the new instance isn't root enabled? or is ok that it is root-enabled as long as it shows root enabled?
18:34:53 <pmalik> Well the restored instance will always be marked as root-enabled.
18:35:02 <amrith> I believe that the important thing is that we should show it as root enabled.
18:35:13 <peterstac> (unless you exploit the defect ;P )
18:35:18 <amrith> whether the root is actually accessible or not, I think is less interesting.
18:36:09 <amrith> after all on the instance (the original) with root enabled, I could have perpetrated some weird thing that makes its way into the restored instance. Therefore, I think we should certianly show root-enabled.
18:36:10 <amrith> Yes?
18:37:02 <pmalik> Yes. But this does not have impact on the root state.
18:37:24 <pmalik> The reported state will be root-enabled and we specifically test that.
18:37:59 <pmalik> This is that we also change the restored root password which kinda does not make much sunse and is probably not what the user would expect.
18:39:03 <amrith> I'm with you. do you have a proposal? such as report root-enabled and don't change the root password (which I think is fine).
18:39:18 <amrith> unless I'm missing dougshelley66's point.
18:39:42 <amrith> in any event, is this something we can discuss on #openstack-trove or in a smaller group?
18:39:43 <dougshelley66> no my point was to make sure it stays root enabled
18:39:50 <dougshelley66> if that is ok, i guess the pwd should stay
18:40:11 <dougshelley66> but someone is specifically preventing that, it would be good to know why
18:40:14 <dougshelley66> but that may not be possible
18:40:49 <amrith> dougshelley66, I agree with all that you say. I'm not sure why the pwd is being changed.
18:40:57 <amrith> maybe we can ask the old-timers offline.
18:41:08 <pmalik> The root state is reported here: https://github.com/openstack/trove/blob/master/trove/guestagent/datastore/mysql_common/manager.py#L232
18:41:10 <amrith> I can't think of a good reason.
18:41:46 <pmalik> Line 231 is what generates a new password...
18:42:09 <amrith> pmalik, the issue is why this behavior (not where this behavior is in the code).
18:42:17 <amrith> and for that we need to ask someone with some history
18:42:30 <amrith> I think it makes sense not to change the password.
18:42:37 <amrith> but, let's get some more information.
18:42:40 <amrith> if we can.
18:42:43 <amrith> ok?
18:43:23 <amrith> pmalik ... ok?
18:43:45 <pmalik> yes, I can push up a review and we can discuss there...
18:43:52 <amrith> ok, works for me.
18:43:59 <amrith> other topics for open discussion?
18:44:23 <amrith> going once
18:44:26 <imandhan> yes
18:44:32 <amrith> go ahead imandhan
18:44:44 <imandhan> Mariam wanted to let everyone know that her patch is up for review
18:45:08 <amrith> got a number?
18:45:26 <imandhan> https://review.openstack.org/#/c/270443/
18:45:38 <amrith> ok, what about it?
18:45:49 <imandhan> she just wanted to give a status update I think
18:45:59 <amrith> ok, thanks
18:46:00 <imandhan> that's what I got from her email, since she's out of office today can't speak for her much
18:46:17 <amrith> sounds good
18:46:49 <amrith> fyi dougshelley66 I sent up a fix for https://bugs.launchpad.net/trove/+bug/1546861
18:46:49 <openstack> Launchpad bug 1546861 in Trove "excessive log messages in unittests" [High,In progress] - Assigned to Amrith (amrith)
18:46:58 <amrith> https://review.openstack.org/284299
18:47:23 <amrith> This does NOT address https://bugs.launchpad.net/trove/+bug/1549291
18:47:25 <openstack> Launchpad bug 1549291 in Trove "Error in taskmanager.test_pxc_clusters.PXCClusterTasksTest.test_shrink_cluster_does_not_exist" [Medium,Confirmed]
18:48:01 <amrith> other things for open discussion
18:48:12 <amrith> going once
18:48:32 <amrith> going twice
18:49:03 <amrith> #endmeeting