18:00:05 <cp16net> #startmeeting trove
18:00:06 <openstack> Meeting started Wed Dec 16 18:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:09 <openstack> The meeting name has been set to 'trove'
18:00:29 <cp16net> howdy everyone
18:00:35 <amrith> howdy cp16net
18:01:00 <cp16net> i'll give a few minutes for people to trickle in
18:01:09 <vgnbkr> o/
18:01:22 <cp16net> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:44 <pmalik> !/
18:01:45 <openstack> pmalik: Error: "/" is not a valid command.
18:01:45 <imandhan> o/
18:02:23 <mvandijk> ./
18:02:52 <atomic77> ~\\o//~
18:04:15 <cp16net> #topic pulse update
18:04:17 <cp16net> #link http://bit.ly/1VQyg00
18:04:45 <cp16net> we've dropped down a bit and the queue is growing
18:05:23 <cp16net> this is probably due to the holidays coming up and working on new features
18:05:25 * amrith mumbles that review.openstack.org has been down for a bit
18:05:38 <amrith> 503 Service Unavailable
18:05:54 <cp16net> yeah i saw an announcement that it will be down 1700-2100 today
18:06:07 <dougshelley66> o/
18:06:54 <amrith> I was going to do all the reviews and make everything good again. but damnit, they are down ;)
18:07:05 <cp16net> i'd expect the reviews to continue on a low pace as the holidays are coming up over the next couple weeks
18:07:15 <dougshelley66> this is when everyone says they had blocked out the whole afternoon to do reviews
18:07:36 <cp16net> i'm sure many will be out
18:07:40 <cp16net> (i will be)
18:08:23 <cp16net> i'll bring up more about that a little later
18:08:33 <cp16net> any other comments on the reviews?
18:08:44 <cp16net> other than they are down atm
18:08:45 <cp16net> :-P
18:09:54 <cp16net> ok
18:09:56 <cp16net> moving along
18:10:01 <cp16net> #topic spec approvals
18:10:48 <cp16net> there were a few emails on the ML about specs in the pipe line
18:11:32 <cp16net> i want to reiterate that these are welcome
18:12:25 <cp16net> the reason for pushing for the specs to be approved in the last few weeks was so that we dont have them waiting till the last minute to be approved
18:12:40 <cp16net> i really appreciate everyone stepping up and helping make that happen
18:13:29 <cp16net> so there are a few specs still in the queue
18:13:33 <cp16net> #link https://review.openstack.org/#/q/status:open+project:openstack/trove-specs,n,z
18:13:41 <cp16net> if gerrit was working...
18:13:44 <amrith> ;)
18:14:03 <cp16net> one of them is the pxc grow shrink
18:14:13 <amrith> didn't that merge?
18:14:18 <cp16net> it did not
18:14:31 <cp16net> there were comments on it and i updated it
18:15:07 <cp16net> i recall seeing a few others yesterday in the queue as well
18:15:49 <imandhan> my couchdb operations one is in queue. I'll be updating it tonight based on feedback I've gotten. was out for a couple days hence the delay
18:15:54 <cp16net> wrt the new specs mentioned on the ML
18:16:17 <cp16net> lets get those written up soon
18:16:35 <dougshelley66> i was hoping that Santa would put them under the tree....
18:16:43 <cp16net> soon ~= before the end of the year
18:17:25 <dougshelley66> well that could be tough
18:17:36 <cp16net> yeah
18:18:11 <cp16net> dougshelley66: is it reasonable to think that they could be done by the end of the first week of jan?
18:18:44 <dougshelley66> by "done" i assume you mean in review?
18:18:56 <dougshelley66> i have no control over having them merge
18:18:57 <cp16net> i mean reviewable
18:19:01 <cp16net> right
18:19:18 <dougshelley66> Jan 8th is probably a reasonable goal
18:19:42 <cp16net> ok lets shoot for the new specs to be up by then
18:20:39 <cp16net> so that leads to some announcements
18:21:12 <cp16net> if there are no other comments reguarding the specs
18:21:29 <imandhan> and if I remember correctly by M2, the implementation should be delivered for review?
18:21:49 <cp16net> imandhan: i was getting to that in the announcements :0
18:21:50 <cp16net> :)
18:22:02 <cp16net> #topic announcements
18:22:17 <cp16net> #info Last week of February is Feature freeze for M-3
18:22:25 <cp16net> #link http://docs.openstack.org/releases/schedules/mitaka.html
18:22:38 <amrith> cp16net, I'm confused
18:22:50 <amrith> it would be good if you could summarize the timeline you expect.
18:22:59 <amrith> I thought deliverables were by m3
18:23:12 <cp16net> amrith: ok
18:23:33 <cp16net> so i'll work backwards from the m3 time
18:23:55 <cp16net> m-3  Feb29-mar4
18:24:07 <cp16net> this is when the m3 milestone will be cut
18:25:10 <cp16net> at that time bp new features will not be allowed to be merged without exceptions
18:26:13 <cp16net> so to help combat this issue that we had at the end of the cycle last time i'd like see reviews made by the time m-2 rolls around
18:26:40 <cp16net> at the latest the beginning of feb
18:26:56 <cp16net> so that we dont compete with the gate as much
18:27:35 <cp16net> these are soft dates that i would like shoot for
18:27:56 <vgnbkr> What does "reviews made" mean?
18:28:11 <cp16net> reviews made means code proposed
18:30:00 <vgnbkr> I don't think our issue is getting people to put code up, the issue is getting +2's on either the bp or the change.
18:30:38 <cp16net> vgnbkr: yeah but we should have time to get that resolved as well
18:31:43 <cp16net> i'm mentioning this in hopes that this could help and bring up issues earlier
18:32:06 <cp16net> if this is crazy please call me out on it
18:33:11 <cp16net> but i think this time line follows closely with the release schedule
18:33:28 <dougshelley66> cp16net I don't think you are crazy. The implication of pulling them deadlines in/enforcing them more is that some stuff will end up out of Mitaka
18:34:23 <cp16net> dougshelley66: right and if the features are not complete by m-3 then its very likely to be out of Mitaka
18:34:27 <dougshelley66> I assume your goal is to attempt to achieve a higher quality deliverable at the end of teh cycle. This comes with a coset
18:34:31 <dougshelley66> s/coset/cost/
18:35:12 <dougshelley66> and in the case of a fixed time release cycle the cost is the # of included fixes/features
18:35:30 <cp16net> yeah
18:35:57 <cp16net> there has been talk about changing the release cycle
18:37:00 <cp16net> if trove didnt follow the release milestones we might not have the same issues
18:37:35 <cp16net> the release team is working on making this easier for projects if they so choose
18:38:38 <cp16net> dougshelley66: we've always had the 3rd milestone deadline feature freeze
18:38:43 <cp16net> so this is not new
18:39:42 <cp16net> i'm hopeful that we can complete the features proposed and get them merged
18:40:41 <cp16net> but with the # of them proposed and judging from the past we may need a plan to move them forward
18:41:16 <cp16net> ok any other comments on this?
18:41:39 <cp16net> one other announcements i'd like to remind everyone of if the voting
18:41:42 <cp16net> #inf find an email sent out yesterday to vote for the N and O release
18:41:49 <cp16net> #info find an email sent out yesterday to vote for the N and O release
18:42:11 <cp16net> #topic open discussion
18:43:37 <amrith> I have one
18:43:46 <cp16net> amrith: go ahead
18:43:47 <amrith> I'd love to share the link to a review but ...
18:43:53 <cp16net> lol
18:44:08 <cp16net> which one?
18:44:10 <amrith> I was fixing a bug https://bugs.launchpad.net/python-troveclient/+bug/1461196
18:44:10 <openstack> Launchpad bug 1461196 in python-troveclient "eliminate some of the last vestiges of 'slave_of'" [Medium,In progress] - Assigned to Amrith (amrith)
18:44:25 <amrith> the idea was to remove the use of slave in the API
18:44:29 <amrith> in favor of replica
18:44:39 <amrith> as we had agreed when replication came out originally.
18:44:55 <amrith> The review is hung up because a couple of people want me to change the name of variables in the code.
18:45:21 <amrith> it is (a) not within scope of the fix, and (b) I see no point in changing variable names in one file when the same issue is all over the source code.
18:45:39 <amrith> I guess the question falls kind-of flat given that gerritt is down
18:45:52 <amrith> but I don't want to waste time on this fix if it is going to languish
18:46:01 <amrith> so I'd like some guidance.
18:46:34 <cp16net> worst case is make an action item to bring it up at the next meeting or in the channel once gerrit is back up
18:46:45 <amrith> sounds good
18:46:47 <cp16net> maybe not "wosrt" case
18:46:58 <amrith> but "worst" case ;)
18:47:02 <cp16net> lol
18:47:04 <cp16net> :)
18:47:15 <amrith> ok, next week it is.
18:47:23 <cp16net> understandable concern tho
18:48:15 <cp16net> #action amrith bring up concerns on review https://review.openstack.org/245738
18:48:22 <cp16net> anything else?
18:48:40 <cp16net> thanks everyone
18:48:45 <cp16net> #endmeeting