18:01:33 <peterstac> #startmeeting trove
18:01:34 <openstack> Meeting started Wed Nov 25 18:01:33 2015 UTC and is due to finish in 60 minutes.  The chair is peterstac. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:37 <openstack> The meeting name has been set to 'trove'
18:01:45 <atomic77> \-o-/
18:01:47 <vkmc> o/
18:01:53 <pmalik> ./
18:02:06 <johnma> hello
18:02:14 <peterstac> Hi all
18:02:25 <schang> o/
18:02:36 <vgnbkr> o/
18:02:38 <pmackinn> atomic77, that a tie fighter?
18:02:49 <imandhan> ./
18:02:58 <atomic77> pmackinn, i thought of it as a guy doing squats
18:03:01 <mvandijk_> (-o-)
18:03:07 <mvandijk_> |-o-|
18:03:08 <atomic77> trying to keep fit
18:03:21 <peterstac> There's nothing on the agenda, so we'll move right to ...
18:03:27 <peterstac> #topic Open Discussion
18:03:54 <pmackinn> https://etherpad.openstack.org/p/mitaka-trove-midcycle-rsvp as usual
18:04:52 <ashleighfarnham> o/
18:04:57 * pmackinn tries to emoji an x-wing fighter, #fail
18:05:53 <peterstac> Do we have an agenda yet for midcycle?
18:06:01 <peterstac> cp16net?
18:06:04 <peterstac> (jk)
18:06:50 <ashleighfarnham> Just wanted to remind people that if they want to give input on the new cli with the integration with openstack client.
18:06:51 <peterstac> So once travel plans are finalized, please update the etherpad
18:06:56 <atomic77> could we perhaps take some of the extra time this meeting gives us to look at some of the outstanding blueprints in the queue?
18:07:01 <peterstac> #link https://etherpad.openstack.org/p/mitaka-trove-midcycle-rsvp
18:07:03 <ashleighfarnham> https://wiki.openstack.org/wiki/Trove/OpenstackClient
18:07:12 <vkmc> that's a good idea atomic77
18:09:11 <vkmc> https://launchpad.net/trove/+milestone/mitaka-1
18:09:21 <amrith> ./
18:09:58 <atomic77> so atm we have about 10 specs in review that have been udpated in the last two weeks
18:10:35 <vkmc> #link https://review.openstack.org/#/q/status:open+project:openstack/trove-specs,n,z
18:11:30 <amrith> Some of them (four) are rather old.
18:12:10 <amrith> sorry, 6
18:12:23 <amrith> two of them are updated with the question "is it time to abandon this yet".
18:12:48 <atomic77> amrith, a great example of where metrics can mislead :)
18:12:53 <peterstac> unfortunately, asking that question throws them back on top of the list ...
18:13:33 <amrith> which tees up the conversation of a bug/spec/bp/review scrub
18:14:05 <atomic77> so 8 "live" specs . imo we should prioritize specs over bugs especially at the early stage of a cycle
18:15:05 <pmalik> I think we should just abandon them with a nice message. They can restore them any time if they wish.
18:15:20 <atomic77> pmalik, this is a whole can of worms we opened last week :)
18:16:20 <pmackinn> https://review.openstack.org/#/c/164881/ should be put aside imho
18:17:11 <tellesnobrega> hi, i was looking at trove db migration files and found that all of them still contains the downgrade method, its been a while since there was a cross-project spec to remove downgrades, is there a reason we are keeping this? or we just forgot about it?
18:17:15 <amrith> pmackinn, would you update the review with that comment. it makes it much easier at a later date to see the rationale.
18:17:24 <pmalik> Owner of these review are likely going to ignore the message anyways - otherwise they would be responding. I am just saying that instead of asking a nice question we should abandon them with a nice message that they can restore the review any time.
18:18:10 <pmalik> Asking like this just moves all those reviews to the top of the list pushing important stuff down...
18:18:11 <amrith> tellesnobrega, would you please share a link to the downgrade spec you refer to?
18:18:27 <tellesnobrega> pmackinn, https://review.openstack.org/#/c/152337/5
18:18:34 <tellesnobrega> sorry amrith https://review.openstack.org/#/c/152337/5
18:19:00 <amrith> has anyone implemented this?
18:19:37 <tellesnobrega> yes, i believe keystone has, not sure about nova
18:19:45 <tellesnobrega> i think sahara has done it as well
18:20:04 <tellesnobrega> i can confirm that, but i think we should move this here
18:20:14 <tellesnobrega> i can start that (actually have)
18:20:18 <peterstac> tellesnobrega, are you volunteering to do the work?  ;)
18:20:38 <tellesnobrega> peterstac, yes, i already started it
18:20:38 <SlickNik> o/ sorry I'm late — previous meeting ran wayy over.
18:20:39 <amrith> considering that we just went through a lot of trouble to get downgrade to work, I'd like to get some confirmation that people using Trove don't want the capability.
18:21:07 <amrith> the spec by the TC is nice and all but if people use the capability, and right now it still works, why throw it away?
18:21:10 * peterstac hands the reigns over to SlickNik
18:21:31 <SlickNik> nooo — I'm still reading scrollback for context.
18:21:37 <atomic77> sorry to interject again on the specs -- but is it safe to assume most of the specs we'll deliver in mitaka have already been put on our queue?
18:21:52 * peterstac s/reigns/reins/
18:22:02 <imandhan> I'm working on another one, will add it today
18:22:19 <amrith> I think the deadline for specs is mitaka-1, no?
18:22:30 <tellesnobrega> amrith, makes sense. Downgrade can be a big source of problems, it is a easy way to break your db and that is why this spec was put in motion
18:23:08 <SlickNik> #link https://wiki.openstack.org/wiki/Mitaka_Release_Schedule
18:23:10 <atomic77> ok, so in that case does it make sense to prioritize getting those that are on the queue approved so that development can begin?
18:23:23 <peterstac> amrith, I believe cp16net just said he'd like them all in by m-1
18:23:29 <atomic77> we're already nearly in december and the holiday season will slow things down
18:23:32 <peterstac> I don't think that's a hard rule
18:23:44 <atomic77> we'll blink and we'll be at the midcycle vowing "never again"... again :)
18:23:49 <amrith> we also talked about delaying our release from the rest of the projects (at summit).
18:23:59 <amrith> I'd like to first figure out when our release dates are going to be.
18:24:58 <johnma> I missed that part about delaying our release date. wonder why but dont want to hold up the meeting agenda for that
18:27:13 <SlickNik> I think we were still planning to release as part of the all-up Mitaka final release.
18:27:26 <tellesnobrega> what is the decision on the downgrade? go or no go? I can send an email on the mailing list as well to see if anyone responds that downgrades are really necessary
18:27:55 <peterstac> tellesnobrega, why don't you submit a Trove bp/spec?
18:28:21 <SlickNik> The idea was to figure out if we could do something more along the lines of Swift / Ironic, where they have their own release train for intermediate releases (like mitaka-1,etc) , but still release as part of the major OpenStack releases.
18:28:21 <peterstac> you can reference the TC spec - then you'd hopefully get some valid feedback
18:28:52 <SlickNik> But I'm not sure how far we got along that avenue.
18:29:13 <amrith> we took a note (the penultimate one) in https://etherpad.openstack.org/p/trove-mitaka-contributors-meetiup
18:31:29 <tellesnobrega> peterstac, sure, i will do that
18:31:53 <SlickNik> Yup noted — we'd probably want to look into freezing (cut branch) early, but I think we'd still want to release (announcement / wiki-page) all up with the rest of the OpenStack releases.
18:32:26 <amrith> SlickNik, maybe we should table that and discuss formally at the next meeting (and decide).
18:32:28 <amrith> ?
18:32:41 <SlickNik> amrith: ++
18:33:00 <SlickNik> Fighting the gate during the release crunch is always fun! /s
18:33:45 <amrith> and since we are all about taking the joy out of software development, we will deny people that fun by changing our freeze date. Good.
18:34:05 <amrith> #action next week's agenda to discuss early (or late) branch cut
18:34:08 <peterstac> #action Add meeting agenda item for next week wrt trove early freeze
18:34:23 <SlickNik> Should probably talk to dhellmann or someone else on the release team to figure out the possibility of doing such a thing.
18:34:34 <amrith> #action tellesnobrega to write BP on trove and eliminating downgrade.
18:35:07 <amrith> #action pmackinn to remind people about mid-cycle reservations and confirmations
18:35:16 <amrith> what else?
18:35:35 <amrith> atomic77, pmalik was there a concrete action item on specs, old specs, bug/spec/review scrub
18:36:14 <atomic77> amrith, what i had hoped to propose was to set a goal for getting that queue down to or close to zero
18:36:17 <peterstac> #chair amrith SlickNik
18:36:18 <openstack> Current chairs: SlickNik amrith peterstac
18:37:02 <amrith> #unchair amrith
18:37:03 <openstack> Current chairs: SlickNik peterstac
18:37:18 * amrith currently lying down and in pain. no chair for me for a while
18:37:31 <SlickNik> Wow peterstac I didn't know you could do that.
18:37:56 <amrith> peterstac can do some amazing things. some of them are legal in most states.
18:38:06 <peterstac> ;D
18:38:26 <amrith> SlickNik, ... what say re: atomic77's suggestion?
18:38:28 <SlickNik> #action SlickNik to go through reviews / specs and scrub old reviews.
18:38:53 <atomic77> perhaps i'm unnecessarily raising the alarm on that, i don't know if this is a normal review velocity in a release cycle for openstack
18:39:22 <amrith> SlickNik, happy to help.
18:39:32 <SlickNik> #undo
18:39:33 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x95d3b90>
18:39:50 <peterstac> If we want to have all mitaka specs approved by m-1, then we've only got another week
18:39:52 <SlickNik> #action SlickNik amrith to go through reviews / specs and scrub old reviews.
18:39:55 <atomic77> just seems logical to me that we priortize getting specs reviewed and approved asap, that's all
18:39:58 <SlickNik> thanks amrith :)
18:40:02 <amrith> atomic77, I am concerned about the review velocity as well.
18:40:06 <amrith> SlickNik, happy to help.
18:41:38 <peterstac> #action Finalize spec approval for Mitaka (next meeting)
18:42:33 <amrith> anything else?
18:42:46 <peterstac> Going once ...
18:42:58 <peterstac> Twice ...
18:43:00 * atomic77 inhales
18:43:02 <SlickNik> not from me.
18:43:03 <atomic77> j/k :)
18:43:11 <peterstac> Thanks everyone!
18:43:13 <peterstac> #endmeeting