18:00:25 <cp16net> #startmeeting trove
18:00:26 <openstack> Meeting started Wed Oct  7 18:00:25 2015 UTC and is due to finish in 60 minutes.  The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:30 <ashleighfarnham> o/
18:00:30 <openstack> The meeting name has been set to 'trove'
18:00:38 <peterstac> o/
18:00:39 <cp16net> hello everyone
18:00:45 <schang> o/
18:01:03 <mat-lowery> o/
18:01:10 <ramashri> o/
18:01:49 <dougshelley66> o/
18:01:53 <vkmc> o/
18:01:59 <cp16net> give a min for others
18:02:04 <jianxuz> o/
18:02:09 <vgnbkr> o/
18:02:31 <amrith> ./
18:03:09 <cp16net> #topic Trove pulse update
18:03:13 <cp16net> #link https://etherpad.openstack.org/p/trove-pulse-update
18:03:20 <edmondk> o/
18:03:54 <cp16net> peterstac: did you build that graph for these metrics in google docs?
18:04:09 <peterstac> no, I used excel
18:04:14 <cp16net> ok
18:04:23 <nshah> o/
18:04:30 <amrith> ah .. a mac running ubuntu in a VM, running excel on Vine
18:04:32 <amrith> technology!
18:04:33 <peterstac> I could redo it pretty easily in google docs though
18:04:37 <cp16net> i was thinking about making something i could update to link here for this
18:05:00 <cp16net> i think it would be helpful
18:05:24 <cp16net> peterstac: lets work together to get something setup
18:05:31 <peterstac> cp16net, sounds good
18:05:45 <cp16net> not sure if everyone will be able to view it but we'll figure something out
18:05:56 <cp16net> because looking at the metrics makes me miss that graph :-P
18:06:15 <cp16net> looks like a little more drop off this week
18:06:31 <cp16net> everyone must be busy with new feature work :-P
18:06:47 <amrith> yup, that's it!
18:06:54 <cp16net> and getting ready for the summit
18:07:01 <atomic77> o/
18:07:39 <cp16net> any other comments or questions on this?
18:08:11 <cp16net> mat-lowery: you there?
18:08:19 <mat-lowery> cp16net: present
18:08:28 <cp16net> #topic Trove community and containers [mlowery]
18:08:49 <mat-lowery> This has the potential for a long discussion so please cut me off when necessary.
18:08:54 <mat-lowery> As Docker and Kubernetes gain in popularity, I'm seeing problems they can solve in Trove. I wanted to know if either of these technologies (or similar ones) are candidates for adoption in Trove. I have only a superficial familiarity with both--this is just a very high level direction of Trove question.
18:09:36 <mat-lowery> As a concrete example of container adoption, consider the guest agent. When we upgrade our trove-guestagents, we have to care about the starting point of the upgrade (e.g. what libs are installed) and frankly, that drifts over time. (Some guests missed the last upgrade or we simply forgot to test some really old image.) In contrast, containers have everything they need to run.
18:10:47 <cp16net> i know theres a containers project that is working on bringing containers to openstack
18:10:58 <amrith> see magnum
18:11:11 <amrith> #link https://wiki.openstack.org/wiki/Magnum
18:11:11 <cp16net> yeah thats the name
18:11:46 <amrith> I've done some work on this. I have trove running against nova-docker which is great, not much change but not a very stable setup.
18:11:46 <amrith> Moving forward, I think this container conversation is a bigger conversation that we should look into for a couple of reasons, the ones that Matt suggests for starters, but there are others.
18:12:25 <vkmc> would it be possible to discuss this in a design session in Mitaka? seems really interesting
18:12:39 <amrith> great idea vkmc
18:12:57 <cp16net> yeah i think this brings up some interesting things
18:12:59 <vkmc> I'm personally interested about the upgrades management
18:13:10 <cp16net> mat-lowery: will you be in tokyo?
18:13:20 <vkmc> #link https://etherpad.openstack.org/p/mitaka-trove-summit
18:13:24 <mat-lowery> cp16net: I will not be in Tokyo.
18:13:37 * amrith volunteers to drive
18:13:59 <cp16net> ok we should definately talk about this there and get the conversation started
18:14:47 <mat-lowery> I'll add some bullets to the etherpad you linked to. Is there any remote participation? Not sure what crazy hour it will be in the US.
18:15:07 <cp16net> i'm not sure
18:15:15 <vkmc> its like 12 hours difference from where I'm based
18:15:16 <amrith> in the past it has been hard
18:15:16 <peterstac> mat-lowery, yeah, linking in live wouldn't be fun
18:15:19 <dougshelley66> historically remote participation has been by etherapd
18:15:23 <vkmc> so US is probably similar... depending on which coast you are
18:15:25 <amrith> given the numberof people and the bandwidth into the facility
18:15:45 <cp16net> yeah conf bandwidth has been bad in the past
18:15:50 <vkmc> so if we have it very early, it could be possible
18:16:23 <amrith> if it is very very early, most people will have 'sake' breath ;) they'll be discussing a different kind of container.
18:16:29 <cp16net> i'll see if there are any plans for streaming sessions
18:16:31 <vkmc> mat-lowery, are you a contributor for Magnum?
18:16:38 <vkmc> amrith++ lol
18:16:40 <mat-lowery> I'm happy just to get the conversation started. So why don't I just add to etherpad for now. What's the date on the summit?
18:16:51 <cp16net> #action cp16net check on remote participation at summit
18:16:52 <amrith> week of 26th nov
18:16:58 <peterstac> October 26-29
18:17:06 <cp16net> last week of oct
18:17:17 <mat-lowery> vkmc: No. But Magnum is an even more interesting discussion because of Kubernetes. If Trove used Magnum, control would be given over to Kubernetes to some degree.
18:17:21 * amrith wonders what summit cp16net is going to
18:17:32 <atomic77> how far along in terms of adoption are nova-docker and magnum?
18:17:48 <vkmc> mat-lowery, interesting
18:18:07 <peterstac> sorry, October 27-30
18:18:10 <amrith> atomic77, magnum is recent, nova-docker has been around a bit.
18:18:18 <amrith> yes, I guess I'm off by a month
18:18:26 <amrith> I wonder what summit I'd have ended up at
18:18:42 <amrith> #action amrith must check m tickets and make sure I have the right dates.
18:19:00 <cp16net> yikes
18:19:03 <vkmc> seems we already have the slots https://www.openstack.org/summit/tokyo-2015/schedule/design-summit
18:19:06 <dougshelley66> can you at least send me your credit card if you got the dates wrong
18:19:28 * amrith has an oh shit moment
18:19:42 <vkmc> the earliest we have is Oct 29 at 11am
18:20:42 <cp16net> ok i think this is something that more conversation and research needs to go into
18:20:55 <cp16net> is there anything else related to this?
18:21:12 <mat-lowery> cp16net: ok for now I'll add stuff to the etherpad. we can sync back up after summit
18:21:17 <mat-lowery> I'm all done.
18:21:28 <amrith> mat-lowery, we can chat offline if you'd like and I'll take notes to summit
18:21:37 <cp16net> that sounds great! thanks mat-lowery
18:21:39 <mat-lowery> amrith: sounds good
18:22:37 <cp16net> chat in the chan because i'd like to know as well
18:22:43 <cp16net> ok moving ok...
18:22:49 <vkmc> me too
18:22:54 <vkmc> cp16net++
18:23:08 <cp16net> #topic Refactor of Manager class [peterstac]
18:23:24 <cp16net> ok peterstac
18:23:42 <peterstac> I think I put most of the info in the agenda item
18:23:47 <peterstac> but to recap:
18:24:15 <peterstac> If we want to create a base manager class to make datastore management easier, now is the time to do it
18:24:54 <peterstac> I've done a simple refactor locally and added code to fix the state change issue
18:25:00 <peterstac> (to prove the concept works)
18:25:20 <peterstac> So I pushed up a spec outlining the details
18:25:34 <peterstac> #link  https://review.openstack.org/#/c/231572
18:25:52 <peterstac> If we're going to do this, we
18:25:53 <cp16net> #link http://docs-draft.openstack.org/72/231572/1/check/gate-trove-specs-docs/c7d09a0//doc/build/html/specs/mitaka/datastore-manager-refactor.html
18:26:04 <peterstac> we'd need some feedback soon
18:26:06 <amrith> I've read the spec, I like it
18:26:26 <cp16net> i need to look it over
18:26:27 <amrith> we've talked about this before
18:26:40 <amrith> in the context most recently of some stuff that was done late in liberty
18:26:49 <cp16net> i agree that things like this need to be done early
18:26:51 <amrith> don't recall the exact thing; it was during or just after mid-cycle
18:27:03 <amrith> and we said we'd do it early (like 1st thing) in m release.
18:27:09 <cp16net> yup
18:27:20 <amrith> I would like to put foot-on-gas-pedal and move this one up
18:27:35 <dougshelley66> cp16net maybe we can ask for some review priority on it?
18:27:38 <peterstac> It wasn't as big a change as I originally thought it would be - a lot of it was just deleting code once it'd been added to the base class ;)
18:27:40 <amrith> Ctrl-C/Ctrl-V based coding is getting very hard to maintain.
18:28:25 <cp16net> yeah lets get eyes on it so we can work out issues early in the cycle
18:28:58 <amrith> cp16net, can we set a target of getting reviews on this during this week and target to have code reviews in shortly thereafter?
18:29:00 <peterstac> I'm hoping to push up the actual changeset for the code in the next day or two (just finalizing it) but I don't want to spend too much time just in case there's a problem with the spec
18:29:10 <amrith> peterstac, perfect
18:29:18 <peterstac> :D
18:29:51 <cp16net> sounds good we can see where we are at the next meeting on this
18:29:59 <cp16net> to keep it on peoples minds
18:30:24 <peterstac> ok, I'll take it on myself to keep bugging people about it ;)
18:30:28 <amrith> ++
18:30:41 <cp16net> i'll also look over the blueprints to see which ones should be looked at
18:30:48 <vkmc> ++
18:31:03 <cp16net> #action cp16net priotitize blueprints for mitaka
18:31:28 <peterstac> sounds good; that's all I had
18:31:56 <cp16net> we can talk about them next meeting
18:32:00 <cp16net> sound good?
18:32:07 <cp16net> or at least at the summit for sure
18:32:17 <amrith> (if not sooner than next meeting)
18:32:23 <amrith> I'd love to see this merged quickly
18:32:32 <amrith> so that we don't have a lot of people who have to deal with merges
18:32:33 <amrith> later
18:32:51 <cp16net> i'd agree
18:32:59 <cp16net> ok moving on...
18:33:15 <cp16net> #topic Is it time to merge https://review.openstack.org/#/c/220288/1 [amrith]
18:33:21 <amrith> this should be quick
18:33:23 <cp16net> lets do this now...
18:33:27 <amrith> ok
18:33:29 <amrith> done
18:33:33 <amrith> moving along
18:33:47 <cp16net> +2
18:34:15 <amrith> I'll let you approve the review.
18:34:23 <amrith> this doesn't seem like the kind of thing I'd 'fast track'
18:34:28 <amrith> given that we aren't in crunch-time.
18:34:40 <amrith> hey, that was quick!
18:34:44 <amrith> thanks folks
18:34:48 <cp16net> awesome
18:34:56 <cp16net> ok moving along
18:35:04 <amrith> who said we had a velocity of reviews problem in trove ... bah, humbug.
18:35:18 <cp16net> #topic Open Discussion
18:36:10 <cp16net> only other thing i wanted to let everyone know about is the mitaka release schedule
18:36:15 <cp16net> 18:26 < peterstac> we'd need some feedback soon
18:36:24 <cp16net> whoops bad paste
18:36:33 <cp16net> #link https://wiki.openstack.org/wiki/Mitaka_Release_Schedule
18:37:26 <amrith> interesting schedule
18:37:54 <cp16net> then the next summit everyone is coming to my neck of the woods :)
18:38:25 <vkmc> are we going to focus on something in particular this cycle? it would be nice to discuss that if there is something clear
18:38:46 <amrith> every 13th summit is in Austin, or so I hear
18:39:31 <amrith> cp16net, do you know if there's any movement on https://review.openstack.org/#/c/203880/?
18:39:53 <amrith> I would like to get something related to that into the m release (from trove).
18:40:02 <cp16net> i wasnt aware of that
18:40:12 <cp16net> thanks for bringing it up
18:41:23 <vkmc> that looks interesting
18:41:25 <cp16net> i starred it to keep it on my list of pataches to watch
18:41:51 <amrith> in other 'open discussion' stuff, oslo is looking to us for things we'd like oslo to do.
18:42:06 <amrith> I suggested that oslo.messaging should provide the option for a client to create an encrypted channel.
18:42:22 <amrith> rather than the current 'solution' that you configure rabbit SSL/TLS under the covers.
18:42:25 <vkmc> a topic I wanted to bring for the open discussion is, once again, the problem we have with the guestagent not being secure enough
18:42:33 <vkmc> I've got some questions related to that in the last couple of weeks
18:42:41 <vkmc> and I think it makes sense to discuss this again
18:42:54 <amrith> vkmc, I'd love to have a discussion of that. I think there is way too much misinformation about that subject floating around.
18:43:07 <amrith> maybe a good topic for summit.
18:43:07 <vkmc> I guess that yes
18:43:16 <vkmc> indeed
18:43:24 <cp16net> yeah that is something we should probably document
18:43:54 <vkmc> the tenant isolation patch SlickNik made got merged on RC1 for Liberty
18:44:12 <vkmc> still, seems like that approach is not considered to be the enough
18:44:20 <cp16net> i think SlickNik had documented some of the new single_tenant_remote.py but i'm not sure where that is
18:44:25 <amrith> vkmc, by whom?
18:44:48 <amrith> or more importantly, why?
18:45:02 <vkmc> amrith, by customers trying to deploy that
18:45:13 <cp16net> i recall someone in the channel saying that its bad that the guest instance is connected to the infra rabbit queue
18:45:21 <amrith> see previous comment about misinformation.
18:45:27 <vkmc> I'm personally not very convinced with it... but maybe is because I don't understand it properly
18:45:37 <amrith> so, lets do this.
18:45:44 <amrith> (a) let's discuss it at summit
18:45:47 <amrith> (b) let's document
18:45:57 <amrith> (c) let's make the changes that we think are required.
18:46:09 <vkmc> sounds very good to me
18:46:15 <dougshelley66> i would think it would make sense to have vkmc document the challenges she has heard from the field before summit
18:46:16 <cp16net> yeah i think that sounds like a plan
18:46:31 <vkmc> dougshelley66, will do that :)
18:46:36 <dougshelley66> vkmc thanks
18:46:51 <vkmc> I cannot use the bot but still...
18:47:04 <amrith> cp16net, please give vkmc an action ;)
18:47:10 <amrith> you are the BOSS!
18:47:34 <vkmc> #action vkmc create an etherpad with the concerns raised with the tenant isolation solution for the trove deployment concern
18:47:37 <vkmc> or something like that
18:47:38 <vkmc> heh
18:47:42 <cp16net> sounds good
18:47:47 <amrith> he who says #startmeeting assigns the #actionitems, old jungle saying.
18:47:49 <cp16net> btw anyone can make an action
18:48:00 <vkmc> really? sweet
18:48:06 <amrith> but I can't use #link
18:48:12 <cp16net> you can
18:48:12 <amrith> #link www.google.com
18:48:31 <cp16net> just cant change topics and start/end meeting
18:48:41 <cp16net> unless you are added as a chair
18:48:45 <amrith> oh, ok.
18:48:56 <cp16net> anything else?
18:49:39 <cp16net> #action add items we would like from oslo.messaging
18:50:44 <dougshelley66> cp16net I don't know if it was just oslo.messaging
18:50:46 <cp16net> vkmc: re: focus for cycle i'd say i'm working on that with the blueprints and will have more ideas laid out for the next meeting
18:50:57 <vkmc> cp16net++
18:51:12 <cp16net> ok thanks everyone
18:51:19 <cp16net> #endmeeting