18:01:44 <SlickNik> #startmeeting trove
18:01:45 <openstack> Meeting started Wed Sep 23 18:01:44 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:47 <mvandijk> ./
18:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:49 <openstack> The meeting name has been set to 'trove'
18:01:54 <SlickNik> Hi folks.
18:01:58 <peterstac> hi there
18:02:03 <schang> o/
18:02:08 <cp16net> helo
18:02:14 <pmalik> ./
18:02:15 <vkmc> o/
18:02:31 <vkmc> \o) (o/
18:03:02 <SlickNik> meeting agenda at:
18:03:05 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:07 <ashleighfarnham> o/
18:03:18 <SlickNik> #topic Trove pulse update
18:03:35 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:04:35 <SlickNik> Around the same number of reviews as last week — still a little slow.
18:04:37 <peterstac> I notice that the reviews are still pretty low - do we need to put back the top 10 list? ;)
18:04:49 <vgnbkr> o/
18:06:06 <SlickNik> peterstac: hah, I thought that that was something that folks at the mid-cycle decided to take out
18:06:28 <cp16net> it was talked about removing it
18:06:30 * SlickNik still hasn't had a chance to follow up with amrith about the pulse update conversation that happened at the mid-cycle
18:07:12 <peterstac> SlickNik, I agree.  Maybe it's a coincidence, but they've dropped off a lot since the list disappeared - just sayin'  :D
18:07:15 <mvandijk> how are we doing on other metrics though? it may just be that spammed +1/-1s are reduced
18:07:50 <SlickNik> mvandijk:   Changes merged in the last 7 days: 4 (0.6/day)
18:07:55 <SlickNik> Which is also low.
18:08:13 <cp16net> you can always peek at the stackalytics if you are curious
18:08:22 <SlickNik> But it's hard to compare because 1. we're in RC right now and 2. Gate issues.
18:08:30 <peterstac> SlickNik, I'd like to maybe graph some of the metrics so we can see trends easier
18:08:39 <SlickNik> peterstac: ++
18:08:56 <peterstac> if we could decide on the important ones, I'd take a stab at it for next week
18:09:11 <peterstac> just something to think about
18:09:29 <cp16net> i like it
18:10:45 <SlickNik> Maybe start with something like "Total Reviews", "New changes", "Changes Merged" and "Queue Growth (New changes - Changes Merged)" for the different weeks.
18:12:05 <cp16net> open reviews? maybe
18:13:07 <peterstac> Ok, I'll put something together for next week - we can always tweak it as we go
18:13:45 <SlickNik> Open reviews to me isn't super interesting since there can be quite a few crufty patches in the system at any given time.
18:13:57 <SlickNik> But it is another data point.
18:14:00 <SlickNik> peterstac: ++
18:14:07 <cp16net> #action peterstac put together a graph for week over week
18:14:08 <SlickNik> That would be ossum
18:14:52 <SlickNik> Alright, let's move on to the next topic if there aren't any more comments / observations.
18:15:18 <SlickNik> #topic Liberty RC1 release this week
18:15:31 <SlickNik> #link https://launchpad.net/trove/+milestone/liberty-rc1
18:16:33 <SlickNik> 4 bugs remaining
18:17:02 <SlickNik> Some of them are already in progress.
18:17:15 <cp16net> SlickNik: could we add https://bugs.launchpad.net/trove/+bug/1494584
18:17:16 <openstack> Launchpad bug 1494584 in Trove "pxc should allow more instances than the cluster_member_count config" [Undecided,In progress] - Assigned to Craig Vyvial (cp16net)
18:17:19 <SlickNik> s/in progress/in the gate
18:18:08 * SlickNik runs over to take a look at 149484
18:18:27 <peterstac> SlickNik, when (specifically) are you targeting to cut rc1 ?
18:19:03 <SlickNik> had a conversation with the release team yesterday, and will talk to them again tomorrow morning.
18:19:23 <SlickNik> The plan was to cut rc1 when I talk to them tomorrow morning.
18:19:37 <SlickNik> cp16net: Yeah, that seems like something that we should target to RC1
18:20:28 <SlickNik> If we come across other blocking bugs, we can cut another RC.
18:20:50 <SlickNik> (for another week or so, if I remember correctly)
18:20:54 <cp16net> sounds good
18:21:10 <SlickNik> But the good thing about cutting RC1 is that it opens development for Mitaka.
18:21:35 <SlickNik> s/But/Also
18:22:13 <peterstac> Well, we still shouldn't commit anything until we're sure RC1 is good to go, though, right?
18:22:14 <cp16net> i striked out the ones on the etherpad that are done
18:23:05 <SlickNik> peterstac: no once we cut rc1, we will have a proposed/liberty branch.
18:23:13 <SlickNik> master then becomes mitaka.
18:23:16 <cp16net> we can continue work but new features wont be merged until after its cut
18:23:51 <SlickNik> So if we fine a blocking bug we will have to commit to master and then backport to proposed/liberty
18:23:57 <peterstac> ah, so any extra bug fixes would need to be backported, right
18:24:02 <SlickNik> yup, exactly
18:24:08 <peterstac> got it, thx
18:24:29 <vkmc> when is the deadline to cut rc1?
18:25:14 <peterstac> vkmc ^^^ SlickNik was going to do it tomorrow morning if everything looks good
18:25:36 <vkmc> k, thx
18:26:01 <SlickNik> If things are still not looking good, we might be able to wait till tomorrow afternoon or so, but we should definitely  do it by tomorrow.
18:26:32 <SlickNik> any more RC1 related questions / comments?
18:27:33 <SlickNik> Also the etherpad that cp16net is talking about:
18:27:35 <SlickNik> #link https://etherpad.openstack.org/p/TroveLibertyRC1Reviews
18:28:23 <cp16net> some need rebase/updates
18:29:23 <SlickNik> This one does: https://review.openstack.org/#/c/213155/
18:30:28 <SlickNik> vgnbkr: can you rebase when you get a moment?
18:30:31 <SlickNik> Thanks!
18:31:07 <vgnbkr> I think someone (cp16net?) put a patch in that superceeded that patch, so I didn't go back to it.
18:32:51 <SlickNik> Strange, I only see the one patchset — I can attempt a rebase after the meeting as well. Let's discuss next steps on the channel after the meeting.
18:33:24 <SlickNik> the channel being #openstack-trove
18:33:35 <SlickNik> #topic Mitaka Summit Design Sessions
18:33:52 <cp16net> k
18:33:56 <SlickNik> #link https://etherpad.openstack.org/p/mitaka-trove-summit
18:34:10 <vgnbkr> Sorry, I meant a different change, not patch.
18:35:56 <SlickNik> So for the design summit in Tokyo we've got 2 Fishbowl sessions, 4 working sessions and a collaborators meetup session on Friday.
18:36:26 <SlickNik> cp16net set up this etherpad so that folks can propose sessions that they'd want to see happen.
18:37:19 <SlickNik> We can go over the proposals during the next meeting.
18:37:22 <cp16net> add your ideas and the last mid-cycle and summit sessions are linked there
18:38:27 <SlickNik> Just as a reminder — Fish bowl sessions are sessions in a larger room, which will be publicized so that folks from other groups and operators can come be part of the discussion.
18:39:21 <vkmc> wouldn't make sense to propose sessions, and then vote which ones should be in the fishbowl format?
18:39:56 <SlickNik> Working sessions are sessions in a smaller room, which aren't publicized as much, which are more conducive to conversation amongst just the contributors.
18:40:40 <SlickNik> vkmc: For some sessions it might. Others like sessions that are specifically asking for feedback, or cross project might make more sense as a fishbowl session.
18:41:17 <vkmc> yeah certainly
18:41:28 <SlickNik> So if you think your proposal makes more sense as a fishbowl session, please note it in the proposal (maybe along with a short reason as to why you think so)
18:42:01 <SlickNik> And we can go over it at the next meeting.
18:42:25 <cp16net> that sounds good
18:42:28 <edmondk> Is there a list of topics for the working group sessions?
18:42:40 <edmondk> because I have some smaller items to discuss that wouldn't need a fishbowl
18:43:26 <SlickNik> edmondk: the etherpad is for proposals for both — just denote if the proposal is meant to be for a fishbowl or working session (or either)
18:43:55 <SlickNik> I see cp16net just added that info to the template (thanks!)
18:44:08 <cp16net> yup
18:45:30 <SlickNik> I'm seeing proposals already being added to the etherpad page. Awesome!
18:45:59 <SlickNik> Any further questions regarding this?
18:46:46 <SlickNik> .
18:46:52 <SlickNik> #topic Open Discussion
18:47:33 <peterstac> One issue I'm aware of
18:48:02 <SlickNik> yes peterstac?
18:48:21 <peterstac> The gate for troveclient seems to be broken
18:48:29 <peterstac> (along with saharaclient)
18:48:58 <cp16net> ah yes the tempest test gate
18:48:59 <peterstac> it has to do with the LIBS_FROM_GIT change, and the fact that troveclient doesn't install the trove plugin
18:49:01 <SlickNik> peterstac: Yes, it came up on the mailing list this morning (I think Doug Hellmann brought it up)
18:49:06 <peterstac> #link http://eavesdrop.openstack.org/irclogs/%23openstack-qa/%23openstack-qa.2015-09-23.log.html#t2015-09-23T15:04:52
18:49:24 <peterstac> yeah, we should probably have someone look into it ;0
18:49:27 <peterstac> ;)
18:49:37 <SlickNik> Is there someone looking into it already?
18:49:59 <peterstac> I was poking around a bit, but I'm not committed to it :)
18:50:39 <peterstac> if someone else wants to volunteer ...
18:51:06 <SlickNik> any takers?
18:51:18 <cp16net> i can look into it
18:51:22 <peterstac> It might be as simple as waiting until sahara fixes their issue and piggybacking off of it
18:51:49 <peterstac> (our plugin mimics theirs very closely, so any change they make should work for us)
18:51:59 <SlickNik> Yeah, it sounded like sergey was looking at it already.
18:52:12 <peterstac> cp16net, sold! :D
18:52:27 <cp16net> #action cp16net look into troveclient tempest gate failures
18:53:23 <SlickNik> Any other items for open discussion?
18:53:26 <pmackinn> SlickNik, +1 single tenant remote.py; more patch sets coming there?
18:54:16 <SlickNik> pmackinn: Already updated with a new patchset.
18:54:43 <SlickNik> pmackinn: current state at: https://review.openstack.org/#/c/193010/
18:56:02 <pmackinn> ack great
18:56:23 <SlickNik> Anything else?
18:56:33 <SlickNik> going once
18:56:46 <SlickNik> going twice
18:56:58 <SlickNik> #endmeeting