18:01:09 <SlickNik> #startmeeting trove
18:01:10 <openstack> Meeting started Wed Sep 16 18:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:13 <openstack> The meeting name has been set to 'trove'
18:01:17 <dougshelley66> o/
18:01:18 <amrith> ./
18:01:21 <ashleigh> o/
18:01:27 <edmondk> o/
18:01:33 <SlickNik> Hi Trove folks!
18:01:34 <atomic77> O//~-~
18:01:48 <SlickNik> meeting agenda at: https://wiki.openstack.org/wiki/Meetings/TroveMeeting#Trove_Meeting.2C_Sept_16.2C_2015
18:01:59 <dougshelley66> SlickNik wanted to say thanks for your last 3 cycles of leadership and PTLness :)
18:01:59 <cp16net> heyo
18:02:13 <mvandijk> ./
18:02:21 <vgnbkr> o/
18:03:17 <SlickNik> dougshelley66: No worries, and I'll be sticking around — just want to make sure we increase our PTL bus factor to something other than 1 :)
18:03:20 <amrith> PTLAwesomeness is a word I'll have y'all know.
18:03:28 <cp16net> ++
18:03:35 <cp16net> :)
18:03:35 <vkmc> o/
18:03:50 <pmalik> ./
18:03:55 <schang> o/
18:04:47 <SlickNik> So let's take a look at reviewstats as we give folks a few more minutes to trickle in.
18:05:01 <SlickNik> #topic Trove pulse update
18:05:06 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:05:16 <peterstac> o/
18:05:52 <SlickNik> Fewer reviews last week — I think most folks are still recovering from the Liberty-3 craze.
18:06:09 <SlickNik> We'll have to step up our review game to get the RC1 bugs through this week and next, though.
18:07:32 <SlickNik> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
18:07:49 <SlickNik> According to the release schedule, our first RC1 will be cut next week.
18:08:35 <SlickNik> Incidentally this will be the time that the Mitaka branch will open for submissions — I know we have at least a couple of BPs on hold for that which we can get through once the branch opens.
18:09:03 <cp16net> yeah i think we do
18:10:24 <SlickNik> So let's make one more last push to get most of the RC1 bugs in flight reviewed for Liberty-RC1.
18:10:31 <SlickNik> Almost across the finish line here :)
18:11:01 <SlickNik> Speaking of the Liberty release — this is a good transition to the next topic.
18:11:08 <SlickNik> #topic Trove client 1.3.0 released
18:11:24 <SlickNik> We just cut a release for a new version of python-troveclient
18:11:34 <SlickNik> #link https://github.com/openstack/python-troveclient/tree/1.3.0
18:12:16 <SlickNik> Basically it's the current master of the python-troveclient repo.
18:12:23 <cp16net> nice looks good
18:12:44 <SlickNik> Was working with the release-management team to cut the stable/liberty branch of the client based on this release.
18:13:23 <SlickNik> Any objections to that? I didn't see anything else in the pipeline for the client that seemed essential for the liberty release.
18:13:23 <cp16net> SlickNik: "cut" means create a stable/liberty branch on the repo?
18:13:49 <SlickNik> cp16net: yes — the current master will become stable/liberty of python-troveclient.
18:13:58 <cp16net> sounds gravy to me
18:15:13 <SlickNik> Sounds good.
18:15:23 <SlickNik> Will make it so.
18:16:07 <SlickNik> #action SlickNik to follow up with release-mgmt team to cut the 1.3.0 release of the troveclient as the stable/liberty release
18:16:20 <SlickNik> #topic Liberty RC1 release
18:16:36 <amrith> this may be a mea-culpa
18:16:41 <amrith> cut and paste legacy
18:16:44 <SlickNik> #link https://launchpad.net/trove/+milestone/liberty-rc1
18:17:07 <SlickNik> Just want to go over this one nevertheless.
18:17:42 <SlickNik> We currently have a list of bugs targeted for liberty-rc1, some of which are not super-critical and others which aren't started yet.
18:18:19 <SlickNik> I was going to make a triage pass over the list, bumping any non-critical bugs that haven't been started out of liberty-rc1 into the mitaka relase.
18:19:35 <cp16net> looks like there are some bugs there that we need to work on for the rc1
18:21:08 <SlickNik> cp16net: Yes, there are a few that are still not "In Progress" so I suspect that they probably will not land next week for Liberty-1.
18:22:46 <SlickNik> Looking at that list, I see quite a few that aren't critical or high priority for rc1, so we should be okay moving them out to Mitaka.
18:23:20 <SlickNik> I'll be reaching out to folks who the bugs are assigned to, to figure out if they're on track or need to be moved out.
18:24:15 <SlickNik> Also if there are any bugs that folks are working on that they feel are critical enough to be in Liberty-RC1 but are not part of that list, please reach out to me and let me know so that we can add it to the RC1 bug list.
18:25:15 <SlickNik> Any other questions or clarifications regarding any of this?
18:25:57 <SlickNik> .
18:26:00 <SlickNik> #topic Is there anything we want from the OSLO team?
18:26:14 <amrith> that's me
18:26:24 <amrith> the question was from the oslo team
18:26:36 <amrith> is there something we want from them for the next release
18:26:51 <amrith> if anyone has ideas, please let me know or come to the next oslo meeting, monday at noon (eastern).
18:26:58 <amrith> thanks!
18:27:42 <cp16net> amrith: the only thing i can think of is using the rcp version stuff i think that they already have but we just need to look into
18:27:53 <SlickNik> amrith: I can't think of anything specific at the moment.
18:28:05 <cp16net> but yeah nothing *new* from them
18:28:21 <amrith> cp16net, what's rcp version stuff?
18:28:28 <amrith> oh
18:28:29 <amrith> rpc
18:28:30 <amrith> never mind
18:28:33 <SlickNik> amrith: Also one thing that's on my list for the next cycle(oslo-related) is to try and switch trove over to using oslo config generator for the trove configs.
18:28:36 <amrith> yes, they have it.
18:29:10 <amrith> SlickNik, yes that's a trove thing. Is there something we need from oslo for that?
18:29:14 <SlickNik> But I believe all of that's already in place, we just have some dev work to go ahead and switch over to using that.
18:29:20 <amrith> I think that's more like a work item for us, yes?
18:29:26 <SlickNik> Nope, purely trove related work, yes.
18:29:31 <amrith> ok
18:29:35 <cp16net> yeah i think most of them are work for us to do :-P
18:30:14 <SlickNik> Okay, anything more related to this topic?
18:30:42 <SlickNik> .
18:30:48 <SlickNik> #topic Open Discussion
18:31:00 <amrith> I have two
18:31:03 <SlickNik> Any topics for Open Discussion?
18:31:07 <SlickNik> go for it amrith
18:31:26 <amrith> topic 1, email from Bruno, nova (and other project) protected resources
18:31:38 <amrith> topic 2, getting SlickNik's change for remote.py merged
18:32:02 <amrith> so, on #1 ... for those of you who were in Vancouver, we had a conversation about how we could protect resources launched by Trove.
18:32:10 <amrith> I'd proposed a bp which went nowhere in a real hurry.
18:32:30 <amrith> Bruno proposed one that (it appears from his email) that the Nova team is smiling on.
18:32:41 * amrith looks for a number
18:33:08 <SlickNik> #link https://review.openstack.org/#/c/203880/
18:33:15 <amrith> thanks SlickNik
18:33:19 <dougshelley66> 42
18:33:25 <amrith> I'd like all of us to take a look at this spec
18:33:36 <amrith> that's where the number went, Doug took it ...
18:33:43 <amrith> OK, so please take a gander at that spec.
18:33:43 <cp16net> uy/me stared it
18:34:03 <amrith> hope we get this implemented in the M release, but the targets and priority are unspecified at this time.
18:34:08 <amrith> That's all I had for topic #1
18:34:16 <amrith> anyone have thoughts, comments ...
18:34:26 <amrith> .
18:34:34 <amrith> moving on
18:34:45 <amrith> topic #2. SlickNik ... how're we doing on this one?
18:35:06 <amrith> https://review.openstack.org/#/c/193010/
18:35:11 <amrith> not 42
18:35:22 * amrith hands microphone over to SlickNik
18:35:47 <SlickNik> amrith: I plan on fixing that review up in time to merge for the Liberty-rc period.
18:36:04 <amrith> sold!
18:36:20 <amrith> will look out for the review
18:36:22 <amrith> I'm all set
18:36:49 * amrith wonders whether anyone can help me understand why my laptop is so noisy today
18:37:09 <SlickNik> Will drop folks  a line in #openstack-trove once I have the tests cleaned up and review comments addressed for that review.
18:37:16 <cp16net> changes in that remote.py will help resolve the periodic exist events
18:37:51 <cp16net> at least last time i ran into an issue testing that
18:37:57 <cp16net> some of those changes helped
18:38:04 <cp16net> :)
18:38:25 <SlickNik> cp16net: Plus there was discussion in an earlier ML thread about folks who were interested to know how to use trove to deploy instances all in a single hidden "admin" tenant.
18:39:01 <SlickNik> And this follows up with showing them how do to that.
18:39:37 <cp16net> yeah i was just mentioning that on a side note this also helps other things in our project :)
18:39:37 <SlickNik> I suspect we'll need a bit more documentation / explanation, but that's not subject to the liberty release date and can come in the subsequent days. :)
18:39:44 <SlickNik> yup, agreed.
18:41:03 <SlickNik> Any other items for Open Discussion?
18:43:06 <SlickNik> In that case, let's call it a wrap.
18:43:11 <SlickNik> Thanks all!
18:43:15 <dougshelley66> thanks
18:43:15 <SlickNik> #endmeeting