17:59:52 <SlickNik> #startmeeting trove
17:59:53 <openstack> Meeting started Wed Jun  3 17:59:52 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:56 <openstack> The meeting name has been set to 'trove'
18:00:20 <SlickNik> Giving folks a couple of minutes to trickle in.
18:00:30 * amrith trickles in slowly
18:00:33 <pmalik> ☺/
18:00:38 <vgnbkr> o/
18:00:39 <atomic77> |o|  \o/  --o--
18:01:00 <ashleighfarnham> o/
18:01:04 <amrith> atomic77, what's the third one?
18:01:07 <dougshelley66> o/
18:01:13 <peterstac> \o
18:01:20 <atomic77> i'm stretching :)
18:01:22 <SlickNik> Meeting Agenda at: https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:26 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:44 <ashleighfarnham> atomic77 i thought you were being an aeroplane
18:01:51 <sushilkm> i m in
18:02:57 <atomic77> ashleighfarnham,  haha actually now that i look at it again, it seems that way
18:03:06 <georgelorch> o/
18:03:10 <mvandijk> o/
18:03:10 <SlickNik> Okay — Let's get started.
18:03:12 <amrith> o----
18:03:24 <SlickNik> #topic Trove Pulse Update
18:03:34 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:05:05 <SlickNik> Looks like we're making good process on getting open specs reviewed for liberty — and they are moving. :)
18:06:35 <SlickNik> Any questions / concerns with reviews?
18:06:44 <vkmc> o/
18:06:51 <amrith> trying to formulate one
18:06:56 <amrith> there seems to be a lot of activity
18:07:03 <amrith> I'm trying to get a sense for progress
18:07:55 <SlickNik> So, what metric would you use for progress as opposed to activity?
18:08:10 <amrith> I'm not sure
18:08:16 <amrith> let me take an action item on that
18:08:29 <amrith> no point having everyone watch me think (hint: it is boring, like paint drying)
18:08:45 <SlickNik> I'm specifically looking at the "Changes merged in the last 7 days" for that.
18:09:05 <peterstac> yeah, 10 seems to be a fairly good number there
18:09:31 <SlickNik> We're at 10 — which seems to be par for most weeks.
18:09:34 <amrith> double the reviews (106 vs 213), double the reviewers (12 vs 21), yet total open reviews is about the same.
18:10:11 <SlickNik> more substantial / controversial changes might explain that.
18:10:52 <amrith> I don't know that we've had anything really that controvertial in the last week
18:11:09 <pmalik> Reviews come and go. There is a ton of -1 patchsets with no progress.
18:11:32 <amrith> pmalik, may have the answer.
18:11:43 <pmalik> It just happens the net number of open reviews is roughly constant.
18:12:12 <pmalik> Also because the number of stale reviews is so large.
18:13:54 <SlickNik> pmalik: There's only so much time folks have for updating patchsets — If a -1 patchset isn't updated / replied to it's going to stay that way. Not sure what the solution here is.
18:14:42 <edmondk> expire patchsets would be the answer
18:15:19 <sushilkm> yup, the auto-job to abandon -1 patches does not works any more ... and the queue keeps up growing
18:15:51 <SlickNik> #action SlickNik to follow up with Infra folks to see what happened to the auto-abandon job.
18:16:20 <SlickNik> Okay, I'll take that action item.
18:17:05 <SlickNik> Anything else before we move on?
18:17:07 <amrith> So, the key seems to be the 1st quartile time
18:17:14 <amrith> it is now 6 days
18:17:18 <amrith> a week ago it was 11 hours.
18:17:40 <amrith> Oddly enough, the 3rd quartile was 18 days but in a week it has become 35 days.
18:17:46 * SlickNik thinks there's only one more item on the agenda — so it's okay to spend a few more minutes on this.
18:18:33 <ashleighfarnham> what do you mean by 1st quartile time?
18:18:41 <amrith> all set (for now). don't want to make everyone spend a lot of time on this.
18:18:48 <dougshelley66> amrith - a week ago it was 11 days, no?
18:18:50 <amrith> better to think about it and post more details later.
18:19:01 <amrith> dougshelley66, that was average.
18:19:08 <amrith> 10d 21h
18:19:35 <SlickNik> Also there have been a couple of really old changes that were restored lately - that could be messing with the average times.
18:20:02 <SlickNik> Okay, let's move on.
18:21:04 <SlickNik> #topic Next steps on protected instance review.
18:21:10 <amrith> moving right along ...
18:21:17 <amrith> was wondering what we want to do with this
18:21:24 <amrith> a couple of you have reviewed it (thanks).
18:21:34 <amrith> shayneburgess_,  has some good points
18:21:38 <dougshelley66> how does this mess with the spec from Bruno
18:21:45 <amrith> but not something that gates our pushing it forward to Nova.
18:21:49 <dougshelley66> s/mess/mesh
18:21:53 <amrith> then (as dougshelley66 points out) there's a note from Bruno
18:22:02 <SlickNik> I think the next step is to take the discussion to the mailing list and have folks from other projects chime in.
18:22:09 <amrith> I agree SlickNik
18:22:20 <amrith> The question is this ...
18:22:34 <amrith> I think Bruno's note is more prescriptive and a bit more opinionated than I like
18:22:38 <amrith> but that's my point of view
18:22:46 * amrith realizes that some people are saying Bruno who?
18:23:02 <amrith> Bruno is the guy from CatalystIT
18:23:02 <dougshelley66> why didn't he send that to the ML
18:23:20 <amrith> Well, we've been pestering him
18:23:26 <amrith> and he sent us a reply to an email thread.
18:23:41 <amrith> I would like to take something (TBD) and hurl it at the ML today.
18:23:57 <amrith> it has been two weeks since Vancouver and there are only 24 before the next release.
18:24:09 <amrith> so if we want stuff to happen in Liberty, time is our enemy
18:24:13 <SlickNik> amrith: I basically sent him a reply to the same effect.
18:24:22 <SlickNik> I'd really like to get something on the ML asap
18:24:42 <SlickNik> I'm sure that this will generate enough discussion once it's on the ML as well.
18:25:01 <amrith> so, may I post my notes and a link to the trove review to the ML
18:25:08 <amrith> that way, we get feedback in a structured way
18:25:36 <amrith> rather than having to read the mail threads and de-multiplex them and the various ratholes that could result
18:25:42 <tobe> Hi all
18:26:17 <SlickNik> amrith: I'm good with that.
18:26:21 <SlickNik> hi tobe
18:26:41 <amrith> thx SlickNik ... hi tobe, go ahead.
18:27:38 <tobe> Thansk amrith SlickNik . I'm a little late :)
18:28:25 <SlickNik> Okay, anything more on this topic?
18:29:11 <amrith> not for me, thanks all.
18:29:19 <SlickNik> tobe: not a problem — better late than never :)
18:29:44 <SlickNik> #topic Open Discussion
18:30:21 <SlickNik> Anything for open discussion?
18:30:39 <johnma> I have one and this is regarding nosql datastores
18:31:15 <johnma> specifically related to database and user management functionalities we have specs for some of those datastores.
18:31:54 <SlickNik> johnma: sure, go for it.
18:32:35 <johnma> I remember last time (during Kilo) why none of these datastores implemented th database and user management functionalities
18:33:59 <johnma> I dont remember the exact reason given for it but now with alot of specs to implement this for some nosql datastores, i am wondering whether this becomes a requirement to move them from experiemental to stable
18:34:53 <johnma> I think the reason given then was there wasnt a need since these datastores already provided a UI for these functionalities
18:35:25 * amrith doesn't remember that explanation
18:35:48 <SlickNik> johnma: user / db management have been considered API extensions, and I don't think this is currently a requirement for the move from experimental to stable.
18:35:49 <pmalik> johma I think experimental -> stable is more about the amount of testing (+ some minimal functionality)
18:35:51 <amrith> also don't see the rationale for that; mysql also provides a UI for this.
18:36:03 <johnma> i am trying to find the link to that
18:36:12 <cp16net> hi everyone
18:36:40 <amrith> hi cp16net
18:36:46 <SlickNik> hey
18:36:53 <peterstac> hi cp16net
18:37:23 <cp16net> :-D
18:37:37 * cp16net forgot the time of the meeting...
18:37:55 <dougshelley66> cp16net, can't you come up with something more original?
18:37:57 <SlickNik> johnma: Okay — maybe this is something I can take offline with you and help clarify further.
18:38:04 <amrith> That's fine, you are forgiven, you are the "new guy".
18:38:11 <amrith> Welcome to Trove ;)
18:38:21 <tobe> johnma: You mean providing a web UI to execute sql or other nosql operations, right?
18:38:45 <cp16net> amrith: you are going to have to help me understand what "trove" is since i'm the new guy
18:38:53 <johnma> yeah, in the mean time I will try to find the link. I dont have any problems with implementing these features. Was just curious if something changed from last time in terms of implementing these features. Thats all
18:39:22 <amrith> johnma, I think it has always been an issue of prioritization.
18:39:35 <amrith> as people start using a datastore, they will progress along with the capabilities.
18:39:44 <johnma> that makes sense to me.
18:39:45 <amrith> initially a single instance is fine, later you need more capabilities.
18:39:50 <amrith> one of the benefits of trove
18:39:53 <amrith> is that it simplifies usage
18:40:00 <amrith> giving you one interface to a plurality of databases.
18:40:11 <amrith> the fact that you can create a user on mysql the same way you would on ibm/db2
18:40:15 <amrith> is a great simplicity.
18:40:19 <amrith> and people want that.
18:40:19 <SlickNik> johnma: I think the user / db mgmt features are being added because folks are asking for them as datastores evolve. it's not born out of experimental -> stable graduation requirements.
18:40:28 <amrith> but it won't be the thing that makes them want to use a particular datastore.
18:40:35 <amrith> hence the rationale for the sequence.
18:40:47 <johnma> ok, that sounds good to me
18:40:56 <amrith> sorry if it wasn't clear
18:41:12 <amrith> but if you'd like to clarify it in the document that describes the phases, that would be welcome.
18:41:35 <SlickNik> Sounds good.
18:41:38 <johnma> thanks Amrith & SlickNik.
18:41:45 <SlickNik> Any other items for open discussion?
18:41:59 <amrith> cp16net, I'm writing a book about it. Will send you a copy. It will help you get "up to speed".
18:42:16 <SlickNik> .
18:42:26 <SlickNik> #endmeeting