18:01:22 <SlickNik> #startmeeting trove
18:01:22 <openstack> Meeting started Wed May  6 18:01:22 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:25 <openstack> The meeting name has been set to 'trove'
18:01:37 <peterstac> o/
18:01:41 <vgnbkr> o/
18:01:42 <sushilkm> Hello all mates
18:01:45 <pmalik> #/
18:01:50 <georgelorch> o/
18:01:51 <schang> 0/
18:01:51 <SlickNik> Giving folks a couple of minutes to trickle in
18:01:59 <atomic77_> \\o
18:02:21 <SlickNik> Meeting agenda at:
18:02:24 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:26 <vkmc_> o/
18:02:54 <SlickNik> #topic Trove pulse update
18:03:02 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:03:52 <dougshelley66> o/
18:04:17 <SlickNik> From the latest numbers, it looks like the number of reviews + patches proposed have gone down this last week (almost by half)
18:04:41 <SlickNik> Probably because people are gearing up for the summit?
18:05:41 <SlickNik> I know that's at least partially true in my case. :)
18:06:40 <dougshelley66> hangover from Kilo?
18:06:47 <SlickNik> Also, I know that folks are working on getting specs lined up to propose for Liberty
18:06:50 <SlickNik> dougshelley66: lol
18:07:31 <SlickNik> So I'm looking forward to see a barrage of new specs over then next couple of weeks. :P
18:07:45 <vkmc_> the summit is in less than ten days :)
18:08:15 <vkmc_> certainly getting ready for it
18:08:26 <sushilkm> is there any cut-off date for specs for Liberty-1
18:08:49 <dougshelley66> vkmc_ which summit?
18:08:56 <dougshelley66> it is in 12 days
18:09:05 <peterstac> #link https://www.openstack.org/summit/vancouver-2015/
18:09:17 <peterstac> ^^^ top left corner ;)
18:09:23 <SlickNik> sushilkm: No — the feature proposal freeze only happens during Liberty-3 for _all_ of Liberty.
18:09:25 <vkmc_> dougshelley66: ah well, I'm having a problem with the calendar
18:10:01 <SlickNik> Unless there are any further questions, let's move on.
18:10:51 <SlickNik> sushilkm: Also the dates for FPF get set during the summit, so not sure of the exact date for FPF yet.
18:11:18 <SlickNik> #topic Updates taskamanager to use datastore specific timeouts
18:12:03 <schang> The details is pretty much in the agenda
18:12:08 <SlickNik> From the agenda:
18:12:14 <SlickNik> We need to discuss this patchset, vote for an implementation option, and move forward: https://review.openstack.org/#/c/164640/9
18:12:16 <schang> so I'll just let you guys to read through it and we'll discuss
18:12:24 <SlickNik> #link https://review.openstack.org/#/c/164640/9
18:12:46 <schang> I want to expedite it
18:13:09 <SlickNik> During our last discussion, I believe we had a slight preference for option #1
18:13:26 <SlickNik> Option 1: Define a default usage_timeout setting at the global level, the setting is optional at the datastore level, used only for the purpose of overriding the global default value.
18:13:26 <SlickNik> Option 2: Define a mandatory usage_timeout option for each datastore.
18:13:55 <vkmc_> option one sounds good
18:14:22 <vkmc_> we avoid defining extra options if there is no need
18:14:29 <schang> I also prefer option 1
18:14:41 <peterstac> SlickNik: Yeah, however the action that Amrith entered didn't reflect that ...
18:14:58 <peterstac> Plus neither did the implementation ;)
18:16:17 <SlickNik> peterstac: Yes, I see that at least a couple of -1's on that patch are for that reason.
18:16:38 <SlickNik> sushilkm: So we have a way forward with this, yes?
18:17:07 <sushilkm> so, last time when we discussed it was to include both at datastore level and default level which was implemented
18:18:00 <dougshelley66> so is there more discussion or should we just have an official vote
18:18:05 <SlickNik> sushilkm: I believe the idea was to only have a datastore level timeout if the default level timeout needed to be overridden.
18:18:10 <peterstac> sushilkm: You implemented a default, and then datastore-specific entries that had the same value ...
18:19:02 <pmalik> let's vote
18:19:47 <SlickNik> pmalik / dougshelley66: I'm not hearing anyone who is a proponent of Option 2.
18:20:06 <sushilkm> yeah i kept the values same because i did not know the differing values for other datastores
18:20:08 <edmondk> Yeah option 1 is preferred
18:20:11 <dougshelley66> SlickNik ok sounds like a plan
18:20:20 <edmondk> has the best of both worlds
18:20:21 <sushilkm> and for mysql i have witnessed that it takes more than 400secs on gates
18:20:22 <peterstac> pmalik and I voted for opt 2 in the patchset, but I'm ok to switch
18:20:25 <edmondk> still can override or provide a default
18:20:38 <pmalik> am ok with option 1 as well
18:20:49 <sushilkm> option 1 is my vote
18:20:50 <dougshelley66> seems like a decision has been made...onward
18:21:06 <vkmc_> option 1 +1
18:21:16 <SlickNik> sushilkm: If so, let's open a separate bug to fix that concern and up the timeout value in that case.
18:22:04 <SlickNik> but for this bugfix, let's just implement the datastore specific timeout, and fallback.
18:22:34 <SlickNik> That would give us better tracking of the fixes as well — better separation of concern.
18:23:17 <sushilkm> okies, but that fix also needs to go in same patch because if we go with datastore specific timeouts and mysql has already a value of 400 which is less than what it takes on gate :)
18:23:49 <SlickNik> Also FWIW, I'm not entirely convinced that we should change the default for the gate. If we need to change the gate value, we can probably update the config file that the gate uses in devstack.
18:24:35 <peterstac> SlickNik +1
18:24:58 <vkmc_> SlickNik +1
18:25:11 <sushilkm> okies
18:25:35 <schang> ok, option 1 it is.  thanks :)
18:25:39 <peterstac> #action sushilkm to implement default usage_timeout, with overriding values on datastores (where the value is different)
18:25:47 <peterstac> hope that sums it up
18:25:57 <sushilkm> was not aware if we have a different config for gate :)
18:26:09 <sushilkm> yup, got my action item :)
18:26:19 <SlickNik> thanks peterstac — looks good to me
18:26:26 <SlickNik> #topic Open Discussion
18:27:06 <vkmc_> I wanted to ask about the design sessions for the summit
18:27:30 <vkmc_> can we add proposals to the Etherpad, and then vote?
18:27:54 <vkmc_> or how do you guys are used to manage this?
18:28:10 <SlickNik> vkmc_: so far we have 3 proposals on the Etherpad.
18:28:33 * SlickNik goes to find a link to the etherpad
18:29:19 <SlickNik> #link https://etherpad.openstack.org/p/trove-liberty-proposed-sessions
18:29:53 <vkmc_> cool!
18:30:14 * SlickNik pulled that from the meeting agenda history.
18:30:51 <SlickNik> I just found out the new procedure for updating the sched site with the info
18:31:27 <SlickNik> So I was planning to do that and propose these sessions as fishbowls.
18:31:28 <vkmc_> I wanted to propose something too but it needs some polishing... hence my question
18:32:14 <SlickNik> vkmc_: Please add it to the etherpad — you can always polish as we go along (plenty of time till the summit).
18:32:32 <vkmc_> k :)
18:32:41 <vkmc_> thanks SlickNik
18:32:46 <johnma> and SlickNik, do we know when these sessions are going to happen - THursday?
18:33:32 <SlickNik> johnma: great question — that info was published on the sched site recently as well.
18:33:43 <SlickNik> one sec, let me grab a link.
18:33:52 <johnma> thanks SlickNik
18:34:12 <SlickNik> #link https://libertydesignsummit.sched.org/overview/type/design+summit/trove
18:34:44 <johnma> great, thanks
18:34:57 <SlickNik> So the three fishbowl sessions are on Wednesday, the work sessions are on Thursday, and the contributors' meetup is on Friday.
18:35:21 <SlickNik> (Wednesday afternoon p.m.)
18:36:28 <SlickNik> Please feel free to add more proposals to the etherpad page at: https://etherpad.openstack.org/p/trove-liberty-proposed-sessions
18:36:47 <SlickNik> I'll be looking at this when coming up with the agenda for the work sessions.
18:37:17 <johnma> so what kind of topics will be discussed during the work sessions?
18:38:25 <johnma> or do we just make proposals on the etherpad and then we decide what a good candidate for a fishbowl session vs the work sessions
18:39:53 <SlickNik> Examples of some sessions I'm thinking about: Clustering, OpenStack testing, integration with other projects,  overflow from the fishbowls,
18:40:33 <SlickNik> Ideally folks can propose what topics are interesting to them to bring in front of the community.
18:41:10 <SlickNik> And I'm happy to fill in places in the agenda with what I think is important / makes sense for Trove.
18:42:27 <SlickNik> johnma: Yes we have leeway on what we think would be more effective as a fishbowl session vs. a work session.
18:42:48 <johnma> sounds good. Thanks SlickNik
18:43:46 <SlickNik> Okay, I'll get a tentative schedule done on the sched site for sessions, and let folks know. We can revisit and make any changes if needed at next week's meeting.
18:44:12 <SlickNik> Any other questions / comments for open discussion?
18:44:36 <SlickNik> .
18:44:47 <SlickNik> #endmeeting