18:00:27 <SlickNik> #startmeeting trove
18:00:28 <openstack> Meeting started Wed Mar 11 18:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:32 <openstack> The meeting name has been set to 'trove'
18:00:49 <SlickNik> Hello there
18:01:16 <peterstac> o/
18:01:19 <jodah> o/
18:01:24 <SlickNik> Giving folks a few minutes to trickle in to the Trove meeting.
18:01:28 <SlickNik> Agenda at:
18:01:30 <georgelorch> o/
18:01:30 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting#Trove_Meeting.2C_March_11.2C_2015
18:01:37 <mattvd> o/
18:01:51 <schang> o/
18:01:53 <dougshelley66> o/
18:03:11 <vgnbkr> o/
18:03:15 <SlickNik> Okay, let's get started
18:03:23 <SlickNik> #topic Trove pulse update
18:03:28 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:03:53 <SlickNik> Nice job on keeping the reviews moving!
18:04:14 <SlickNik> Thanks to folks who have been active with reviews.
18:04:41 <edmondk> o/
18:04:53 <nshah> o/
18:04:57 <esmute> 0/
18:05:24 <pmalik> \0/
18:05:33 <SlickNik> For folks wondering — I pulled the numbers this morning instead of last night — which is why we have numbers for the last 8 days (instead of 7)
18:06:47 <atomic77> o/
18:06:55 <SlickNik> Our average wait times (for incoming patches) have been consistently going down — which is really nice to see.
18:07:40 <amrith> ./
18:07:51 <edmondk> Yeah on Feb 18th average wait times were 14 days
18:07:58 <edmondk> now they are 5 days
18:08:33 <SlickNik> Any questions regarding this — if not, let's move on.
18:09:08 <SlickNik> #topic Feature Freeze Next Week (March 19)
18:09:58 <SlickNik> So next week is FF, which means that we won't be accepting patches for any feature work for kilo after that.
18:10:12 <SlickNik> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
18:11:10 <SlickNik> We have 2-3 weeks of stabilization time after that, where we will focus on bugfixes for the Kilo release.
18:11:43 <SlickNik> So specifically for the kilo-3 blueprints, we have quite a few outstanding reviews.
18:12:23 <SlickNik> I've created an etherpad page to aggregate the open BP's and their associated reviews here: https://etherpad.openstack.org/p/TroveKilo3Blueprints
18:12:36 <vkmc> o/
18:12:39 <SlickNik> #link https://etherpad.openstack.org/p/TroveKilo3Blueprints
18:14:10 <SlickNik> Let's prioritize getting these reviews looked at and merged before feature freeze next week.
18:14:28 <johnma> do the patches for the new features need to be merged by March 19th?
18:14:43 <johnma> just trying to understand the process
18:15:02 <SlickNik> johnma: yes — if they are to be part of the Kilo release.
18:15:20 <johnma> ok, sounds good. Thanks SlickNik
18:15:23 <SlickNik> If not, we will have to move them to Liberty.
18:17:29 <SlickNik> While compiling the list, I noticed that some of the reviews needed some TLC wrt merge conflicts.
18:17:55 <SlickNik> So I was going to do that today to ensure that they were in a good reviewable state.
18:18:22 <SlickNik> There are a couple that are still waiting on code to be pushed up — towards the bottom of that list.
18:19:24 <johnma> yes I need to do that for the couchdb work. Will push one out today.
18:19:36 <SlickNik> I'm still assuming that that's in the pipeline — any update on ETAs for those?
18:19:45 <SlickNik> cool, thanks johnma!
18:20:16 <SlickNik> vgnbkr: Any update on the replication v2 patchset?
18:21:01 <vgnbkr> SlickNik, yeah, it's done except for one small piece of functionality.  I'm working on tests now.
18:21:09 <johnma> I have to push the patchset for the DB2 guest agent as well. I am just cleaning up some stuff but should have that in today as well.
18:21:58 <SlickNik> vgnbkr / johnma: sounds good. Thanks!
18:22:39 <SlickNik> Any other questions / clarifications regarding Feature Freeze or any of this?
18:22:45 <johnma> I have a question about the DIB elements for DB2 and Vertica but I can wait until Open Discussion time
18:23:14 <SlickNik> johnma: okay
18:23:21 <johnma> its not related to the feature freeze item
18:23:32 <SlickNik> Let's move on then, to allow more time for Open Discussion
18:23:51 <SlickNik> #topic Coming down the pike for Liberty
18:24:03 <SlickNik> amrith: around?
18:25:03 <SlickNik> (he mentioned earlier that he might be on a plane)
18:26:15 <dougshelley66> he was travelling today - i don't think he has a wifi signal ATM
18:26:16 <SlickNik> Basically these changes are for oslo-config-generator which will allow us to generate sample configs based on the values in code.
18:27:01 <SlickNik> This is one of the oslo changes that we can take in Liberty.
18:27:22 <SlickNik> There were a couple of questions folks had around BPs / specs for Liberty.
18:28:01 <SlickNik> Feel free to submit a spec for liberty — just ensure that in your submission the spec.rst is in the liberty folder.
18:28:11 <SlickNik> (in trove-specs)
18:29:34 <SlickNik> More info on the oslo config-generator changes: http://docs.openstack.org/developer/oslo.config/generator.html
18:29:41 <SlickNik> #link http://docs.openstack.org/developer/oslo.config/generator.html
18:32:03 <SlickNik> Looking at the config-generator docs, I have a couple of questions related to namespacing — I'll follow up with _amrith_ on this once he's back.
18:32:11 <SlickNik> Any other questions?
18:33:24 <SlickNik> #action SlickNik follow up with _amrith_ on config parameter namespacing and different confs in trove (eg. taskmanager vs conductor)
18:33:40 <SlickNik> Okay, let's move on then.
18:33:48 <SlickNik> #topic Open Discussion
18:34:10 <SlickNik> johnma: I know you had a question here
18:35:29 <peterstac> I have one
18:35:40 <johnma> If I may about the DIB elements I mentioned earlier - I know this is up for review but I thought it might be good to have a consistent way of providing DIB elements for datastores that require the packages to be downloaded to a local file system or provide a private repository
18:36:03 <johnma> oh sorry Peterstac, I was just going on and on typing
18:36:10 <johnma> you may go ahead
18:36:34 <peterstac> johnma: go ahead, you were first
18:37:50 <johnma> sorry, I didnt mean to interrupt. But I will just  type this out and rest my case. My only point about the DIB elements for such datastores is that we have a consistent env variable name for defining for example, the download location, etc
18:38:21 <johnma> and folks can review and leave their comments in there but just wanted to bring this up
18:38:55 <johnma> so that we dont have different datastores defining variables that have the same function
18:39:07 <johnma> thats it from my side.
18:39:16 <SlickNik> johnma: That sounds like a good idea — let me take a look at the vertica review — we can hash out a consistent design with some standard ENV vars to set which the elements can use?
18:39:43 <SlickNik> Then DB2 can use a similar pattern
18:40:32 <johnma> that would be great SlickNik, appreciate it. From the DB2 side, I would like to follow the method Amrith had mentioned in his doc for building guest images - to define an extra-data.d to download the packages
18:40:44 <johnma> right now its all in the install.d
18:41:11 <johnma> its a good thing we have a process
18:41:29 <peterstac> johnma: looks like that's how the Vertica patchset is doing it
18:42:11 <peterstac> although the variable names are Vertica-specific
18:42:39 <SlickNik> peterstac: Yes, I think the concern is that the changes to https://review.openstack.org/#/c/156149/3/scripts/functions_qemu,cm are too Vertica specific
18:43:39 <peterstac> SlickNik: Yes, in https://review.openstack.org/#/c/156149/3/scripts/files/elements/ubuntu-vertica/extra-data.d/93-copy-vertica-deb,cm too
18:44:05 <SlickNik> Yes — I agree with that, let's take the comments to the review and continue from there.
18:44:10 <johnma> I havent spend much time doing reviews on the Vertica patchset I must admit but I thought since the process of downloading the packages for DB2 and Vertica are similar, there should be consistency between both, thats all
18:44:16 <peterstac> sounds good
18:44:37 <johnma> sounds good to me. Thank you SlickNik and peterstac. Appreciate it
18:45:09 <SlickNik> Okay, peterstac — you had an item for Open Discussion as well?
18:45:36 <peterstac> yep
18:45:43 <peterstac> I was just going to point out that until the trove-integration patchsets for DB2 and Vertica land
18:45:51 <peterstac> we won't be able to test the datastores
18:46:08 <peterstac> but I guess that was driven home by the above discussion :)
18:47:28 <johnma> thats true. I will push another patch today with the extra-data changes and will wait for other reviews on the env variables and push another one
18:47:37 <SlickNik> peterstac: Yes, that's the case. They will have to land as experimental at first — is that what you meant to clarify?
18:48:42 <peterstac> sure, that too, but mostly that we have up to three patches to review on each datastore, and each one depends on the one before it being completed
18:49:32 <peterstac> and the trove-integration ones should be done first, IMO
18:50:03 <peterstac> that's it
18:50:24 <SlickNik> peterstac: Ah, I recall sushil had a cheat-sheet on instructions in case you wanted to take the vertica patches for a spin — https://gist.githubusercontent.com/sushilkm/9206a9d61ee9a9046f89/raw/68cd427afe3b3727679f02bf5d2d745c70adb513/gistfile1.txt
18:50:46 <SlickNik> agree that the trove-integration ones should merge first, since that's what's needed for the image.
18:52:14 <SlickNik> I'll follow up with the reviews on the trove-integration patches today so that we can get some closure on that as soon as possible.
18:52:25 <johnma> and the instructions for getting the DB2 packages are included in the element itself
18:52:26 <peterstac> great!
18:52:53 <SlickNik> johnma: ++
18:54:02 <SlickNik> Okay — anything else for Open Discusssion?
18:54:46 <SlickNik> .
18:54:50 <SlickNik> #endmeeting