18:01:01 <amrith> #startmeeting Trove
18:01:02 <openstack> Meeting started Wed Oct 15 18:01:01 2014 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:05 <openstack> The meeting name has been set to 'trove'
18:01:11 <denis_makogon> o/
18:01:14 <grapex> o/
18:01:15 <georgelorch> o/
18:01:18 <schang> o/
18:01:31 <amrith> I'll give folks a couple of minutes to filter in.
18:01:36 <tomblank> o/
18:01:38 <amrith> expect to start at :02
18:02:14 <amrith> .
18:03:58 <amrith> ok, let's get started
18:04:00 <denis_makogon> seems like waiting for Robert to appear
18:04:11 <amrith> SlickNik isn't here today and I offered to run the meeting
18:04:29 <amrith> Meeting agenda at https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:04:40 <amrith> #link  https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:04:42 <robertmyers> o/
18:04:54 <amrith> and since robert is here now, let's get on with the first item
18:04:58 <robertmyers> sorry
18:05:04 <robertmyers> forgot to join
18:05:10 <amrith> #topic Discuss the timing of trove-guestagent refactoring.
18:05:18 <amrith> robertmyers, the floor is yours
18:05:20 <mattgriffin> o/
18:05:28 <robertmyers> #link https://review.openstack.org/#/c/119425/
18:05:46 <robertmyers> so basically the idea to move the guest to its own module
18:06:02 <robertmyers> that will cause problems with reviews in flight
18:06:23 <robertmyers> so I wanted to talk about priorities
18:06:38 <robertmyers> what should we merge first/second
18:06:40 <robertmyers> etc
18:07:07 <denis_makogon> there's a problem
18:07:14 <amrith> robertmyers, do you have a recommendation?
18:07:24 <denis_makogon> we still don't know actual road map for this release
18:07:44 <robertmyers> amrith: merge the move first :)
18:08:07 <denis_makogon> so we can only predict about priorities taking into account Nikhil's PTL letter
18:08:08 <amrith> OK, is this part of the change or the whole change (I assume it is part of the change)
18:08:09 <robertmyers> but that is selfish of me
18:08:09 <dougshelley66> o/
18:08:42 <robertmyers> amrith: this is just the first part
18:08:49 <robertmyers> making a new module
18:08:58 <amrith> so, this change, at this stage, is not ready to merge.
18:09:05 <amrith> it (at least) needs a rebase
18:09:15 <robertmyers> true
18:09:21 * nikhil_k finds name tagged. Hoping is not the Nikhil in question.
18:09:33 <robertmyers> but the more we merge the harder it will be to mantain it
18:09:35 <amrith> nikhil_k, sorry, no
18:09:37 <grapex> I feel like this is one of those changes that will always need a rebase until the day it gets merged. :p
18:09:38 <amrith> different nikhil
18:09:42 <nikhil_k> :)
18:09:46 <schang> I did a rebase this morning, and now the int test fails. Working on the issue now.
18:10:10 <robertmyers> yes it will have a lot of rebase issues
18:10:22 <amrith> robertmyers, I think the approach you are advocating is one where you get close enough and want all other merges to hold for a bit while you drop this, yes?
18:10:24 <robertmyers> So rather than just continually doing that
18:10:27 <amrith> I think that is workable.
18:10:33 <robertmyers> amrithyes
18:10:50 <grapex> I think we all agree we should do this. I think now its just about messaging to everyone when to expect the pain. :)
18:10:57 <amrith> when do you anticipate being at that point? are all review comments done at this point, is it at the point where you think it is good to go.
18:11:16 <amrith> modulo fixing whatever ails int tests now
18:11:28 <robertmyers> amrith: I think after the tests pass it should be good
18:11:38 <robertmyers> unless someone finds a big issue
18:11:58 <amrith> Could I get a couple of core reviewers to take a crack at it. it should be straightforward but having you look at it would be good.
18:12:02 <amrith> grapex, have you reviewed it?
18:12:12 <amrith> I'm assuming yes?
18:12:25 <johnma> robertmyers: can you provide the link to the review for this? Would like to take a look
18:12:33 <amrith> https://review.openstack.org/#/c/119425/
18:12:40 <grapex> amrith: I only looked at its last incarnation
18:12:44 <grapex> I can review
18:12:47 <amrith> grapex, that's fine
18:12:51 <johnma> oh yes you already did. thank you
18:12:53 <amrith> I assumed you had
18:13:02 <amrith> and were working with robert and simon on this
18:13:14 <amrith> I'll look at it as well, it seems like just a move at this point
18:13:14 <grapex> I did, months and month ago. But there's no point unless we all agree we're ready to do this
18:13:32 <robertmyers> Yeah we sort of tabled it waiting for kilo
18:13:44 <robertmyers> as this is a big change :)
18:13:45 <grapex> rmyers: and you're pinky-swearing to us that you aren't also added a bunch of tiny refactorings that you've always wanted, right? ;)
18:14:04 <robertmyers> grapex: maybe
18:14:12 <grapex> robertmyers: Oh you
18:14:15 <robertmyers> :)
18:14:19 <amrith> so, here's a proposal. Let's all take a look at the change and put our comments in.
18:14:33 <amrith> schang, robertmyers you'll handle the current issues with gte
18:14:35 <amrith> gate
18:14:39 <robertmyers> sure
18:14:45 <SlickNik> o/ Sorry folks, on the road today, so will be on and off IRC.
18:14:54 * SlickNik reads scrollback
18:15:06 <schang> amrith: yes I will
18:15:07 <amrith> at the point where this is approaching touchdown, I'm ok with the notion of giving you a clear window to merge this change.
18:15:52 <amrith> amcrn, you here?
18:15:56 <robertmyers> ok, so maybe we should look and see if any other reviews should go in soon
18:16:02 <grapex> SlickNik: Don't IRC and drive
18:16:03 <amrith> yes, there is one
18:16:10 <robertmyers> like log messsages
18:16:13 <amrith> and that is one of amcrn's that is sitting around
18:16:19 <amrith> and I have one (log messages for redis)
18:16:30 <grapex> SlickNik: Just say no to FreeNode on the open road
18:16:31 <amrith> a quick look at outstanding reviews pointed me to those.
18:16:42 <robertmyers> maybe we can approve those to clear the way for this change
18:16:49 <SlickNik> ++ I think this is repaying valuable technical debt, so if we need to quiesce reviews for a little bit to get this in, I'm all for it.
18:16:50 <amrith> I'll work with amcrn to get the clustering one in; his needs a rebase
18:17:01 <amrith> my redis change is pending CI
18:17:05 <amrith> otherwise good to go.
18:17:20 <amrith> We will give you a clear running room to merge this change after those.
18:17:23 <amrith> ok?
18:18:07 <amrith> schang, robertmyers, please keep me in the loop on the progress and we'll make this work.
18:18:16 <robertmyers> amrith: will do
18:18:17 <schang> amrith: ok
18:18:26 <amrith> all: please take a minute to review https://review.openstack.org/#/c/119425/
18:18:28 <cp16net> tite
18:18:31 <amrith> get your comments in soon
18:19:07 <amrith> .
18:19:25 <amrith> .
18:19:32 <amrith> ok, hearing nothing further
18:19:39 <amrith> #topic Open Discussion
18:20:22 <amrith> anyone ...
18:20:27 <denis_makogon> if there's nothing more, i'd like to remind, again, about reviewing specs
18:20:33 <johnma> Amrith: do we we have a list of topics for the summit.
18:20:44 <johnma> I dont see anything on the etherpad yet
18:21:12 <amrith> johnma, I will follow-up with SlickNik on the topics for summit
18:21:21 <johnma> ok, thanks.
18:21:31 <SlickNik> Folks need to start adding proposals that they have.
18:21:33 <denis_makogon> johnma, we're free to propose topics and core team will decide what to take
18:21:59 <SlickNik> I have a couple I plan to add to the etherpad, and will do that by this weekend.
18:22:00 <amrith> ... see, I told you I'd follow-up with SlickNik ...
18:22:08 <johnma> :)
18:22:42 <denis_makogon> i'd like to ask core team to review specs, since they are hanging already too long
18:22:46 <SlickNik> But let's plan on going through the proposals during next weeks meeting.
18:22:57 <johnma> so the topic that we propose, can they be topics we are interested in hearing more about or are they more in the line of topics we want to present
18:23:21 <amrith> johnma, I'd say both
18:23:28 <johnma> ok, sounds good
18:23:31 <amrith> please indicate which is which
18:23:39 <johnma> sure
18:23:46 <SlickNik> johnma: Yes, if you're planning on driving a session please mention your name / nick as the driver.
18:24:09 <johnma> sure, will do.
18:24:15 <cp16net> or if you want to put someone else on the spot put their name
18:24:18 <cp16net> :-P
18:24:18 <amrith> SlickNik, I'm adding this review of proposals to next weeks meeting
18:24:37 <SlickNik> amrith: ++ Thanks!
18:25:38 <johnma> on the side I have couple of blueprints I need to write. When I have them ready, I guess I need to bring it up during the Monday meetings, am I right. I am not sure whether I have been missing those or whether we havent been having them lately
18:25:41 <amrith> #action ALL update etherpad for summit sessions, indicate which ones you'd like to lead or listen. (nominate cp16net for all other sessions)
18:26:33 <amrith> does anyone have a link to the etherpad handy
18:26:45 <cp16net> lol
18:26:47 <johnma> yes https://etherpad.openstack.org/p/kilo-trove-summit-topics
18:26:51 <cp16net> amrith: <3
18:26:53 <amrith> johnma, re: bp's yes. please put them on the monday meeting agenda
18:27:14 <cp16net> i like the topic of '<'
18:27:39 <SlickNik> #link https://etherpad.openstack.org/p/kilo-trove-summit-topics
18:27:51 <amrith> johnma, please note that the BP process is subtly different from last cycle
18:28:13 <amrith> for an example, please take a look at https://review.openstack.org/#/c/123571/
18:28:25 <amrith> or ping me after the meeting and I'll give you more details
18:28:30 <johnma> Amrith: ok, I will take a look at it
18:28:35 <johnma> sure, sounds good
18:29:29 <amrith> .
18:29:32 <vgnbkr> johnma: Be wary of the template.rst in the root directory if it's still there - you want to start with the one in the specs directory.
18:29:50 <amrith> vgnbkr, ++
18:30:21 <johnma> ok, sure. Thanks alot. appreciate the feedback
18:30:52 <amrith> vgnbkr, it appears to have been deleted
18:31:22 <amrith> .
18:31:43 <amrith> anyone have other topics for open discussion ...
18:32:16 <amrith> .
18:32:33 <amrith> .
18:32:49 <amrith> ... going once ...
18:33:11 <amrith> ... going twice ...
18:33:27 <amrith> #endmeeting