18:01:14 <hub_cap> #startmeeting trove
18:01:15 <openstack> Meeting started Wed Nov 20 18:01:14 2013 UTC and is due to finish in 60 minutes.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:19 <openstack> The meeting name has been set to 'trove'
18:01:28 <kiall> hub_cap: lol .. you stalking me now?
18:01:38 <juice> o/
18:01:39 <hub_cap> possibly
18:01:40 <kevinconway> o/
18:01:46 <cp16net> o^/
18:01:55 <robertmyers> o/
18:02:12 <pdmars> o/
18:02:13 <vipul> o/
18:02:15 <datsun180b> oh of course i'm here
18:02:16 <redthrux> o/
18:02:23 <hub_cap> liar datsun180b
18:02:36 <hub_cap> ok lol @ the fact that all the mirantis guys arent here, smiling cuz its earlier now
18:02:45 <SlickNik> here
18:02:51 <hub_cap> denis_makogon: around? ikhudoshyn? isviridov?
18:03:00 <datsun180b> Good thing we log our meeting notes
18:03:14 <hub_cap> ok so this meeting is pretty short this wk... there is very little on the agenda
18:03:20 <hub_cap> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting#Agenda_for_the_next_meeting
18:03:20 <grapex> o/
18:03:34 <hub_cap> #topic action items
18:03:36 <hub_cap> i did none of my items
18:03:39 <esp> o/
18:03:43 <hub_cap> i was supposed to get a thread started w/ replication
18:03:49 <hub_cap> its still on my todo list
18:04:00 <vipul> re-action it
18:04:06 <hub_cap> which is totally orgmode datsun180b
18:04:13 <datsun180b> what
18:04:21 <hub_cap> #action get a thread started wrt clustering/replication/recipes
18:04:25 <hub_cap> #undo
18:04:25 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3653fd0>
18:04:32 <hub_cap> #action hub_cap get a thread started wrt clustering/replication/recipes
18:04:34 <SlickNik> you need a name :P
18:04:53 <hub_cap> i bestow ron and ziggy upon myself as names
18:05:04 <grapex> #vote ziggy
18:05:10 <hub_cap> :)
18:05:22 <hub_cap> #topic old version history in gerrit
18:05:32 <hub_cap> ok so... maybe im the only person here who didnt know about it
18:05:34 <cp16net> amazingnewss
18:05:38 <hub_cap> but u can diff patchsets in gerrit
18:05:51 <vipul> umm old news :D
18:05:58 <hub_cap> by changing "Old Version History:" dropdown to the previous patchset, you can see the diffs between them
18:06:04 <grapex> I can't believe I was on top of how OpenStack collaboration tooling worked for once.
18:06:09 <juice> Yeah I was doing that in 6th grade
18:06:10 <hub_cap> vipul: ya not for me :)
18:06:20 <robertmyers> juice: lol
18:06:23 <grapex> They have those seminars at the summit, "Gerrit and You"
18:06:24 <hub_cap> juice: lol drinkin yourself and diffing patchsets
18:06:37 <hub_cap> oh grapex i missed that... i was drunk
18:06:57 <juice> Ha ha ha
18:06:58 <grapex> hub_cap: Ah, the other seminar they hold each summit.
18:07:28 <vipul> i thought that _the_ seminar
18:07:41 <hub_cap> ok so then il be moving on
18:08:25 <hub_cap> #topic Moving the reference agent
18:08:34 <robertmyers> lets do it!
18:08:40 <hub_cap> im all for it
18:08:51 <hub_cap> let me touch base w/ the infra folks about removing the guest agent
18:08:58 <grapex> We should give it a name too- like "Reffy" or something.
18:09:15 <grapex> It's mascot could be an adorable cartoon dog.
18:09:17 <vipul> we should ask them how they gate these sorts of things
18:09:22 <vipul> sucks to have to manually coordinate
18:09:49 <hub_cap> grapex: lets go w/ ruff pup
18:09:49 <grapex> vipul: What if we start the repo now, and see if we can set up gating
18:10:02 <grapex> then once it works with all the CI goodness we can begin moving the code over.
18:10:03 <SlickNik> I'm familiar with how to create a new repo...
18:10:08 <robertmyers> can't trove just install the latest form git
18:10:13 <robertmyers> like the client?
18:10:29 <vipul> well what if you have a change that touches both
18:10:36 <datsun180b> i propose the name trove-man-about-town for the liberated reference guest agent
18:10:38 <vipul> you have to make sure the guest goes in first
18:10:38 <hub_cap> mordred said moving it is fine, no formal approval needed
18:10:39 <grapex> vipul: That concern already arises with the client.
18:11:00 <cp16net> yeah sounds like the same issues we have seen already
18:11:02 <vipul> yea.. i just fear adding more of those unless there is a easy way to have Jenkins do that
18:11:05 <robertmyers> I think it should be hard to change it.. cause it is too easy now
18:11:14 <SlickNik> Basically you have to have another github repo somewhere, and update the ci codebase with a few things including name / permissions of the codebase, and which repo to suck in the initial code from.
18:11:57 <vipul> just means we'll be merging things in Guest with a trust me (tm)
18:12:20 <datsun180b> right, we've never ever done that before
18:12:51 <hub_cap> guys
18:12:52 <hub_cap> trust me
18:12:55 <hub_cap> its gonna work
18:13:05 <robertmyers> (tm)
18:13:11 <hub_cap> thx robertmyers
18:13:12 <hub_cap> :P
18:13:12 <vipul> i'm all for moving the guest out.. let's see if tehre is a way to test multiple repos together
18:13:13 <datsun180b> (cc na)
18:13:22 <cp16net> where has trust gotten us?
18:13:24 <cp16net> :-P
18:13:24 <SlickNik> but tm is ™
18:13:33 <robertmyers> SlickNik: lol
18:13:47 <hub_cap> devstack tests should handle that vipul
18:13:54 * hub_cap thinks heh
18:14:00 <hub_cap> but i agree
18:14:06 <hub_cap> lets not move the client unless its easier to tests
18:15:23 <juice> Is this thing on?
18:15:30 <datsun180b> juice: yes hello
18:15:46 <hub_cap> yea lets talk to infra
18:15:49 <hub_cap> SlickNik:  wanna take that?
18:15:58 <SlickNik> sure
18:16:20 <SlickNik> #action: SlickNik to talk to infra on what the best way to split out reffy is.
18:16:38 <hub_cap> ruff pup
18:16:50 <kevinconway> i hope that name doesn't catch on
18:16:54 <vipul> i dunno about reffy.. but i'm bad with naming things
18:16:54 <hub_cap> ok so we moving on?
18:17:05 <SlickNik> I only used it cause it's easier to type.
18:17:05 <grapex> #action Someone comes up with a drawing of a puppy to apply to the reference guest.
18:17:15 <grapex> #undo
18:17:19 * hub_cap claps
18:17:20 <kevinconway> #disagree
18:17:28 <grapex> Sorry, I didn't realize that would actually apply if I wasn't holding the meeting. :)
18:17:34 <hub_cap> LOLOLOL
18:17:40 <SlickNik> only meeting organizer can #undo, I think
18:17:41 <hub_cap> im so not undoing it either
18:17:42 <esp> I volunteer datsun180b for a graphic
18:17:50 <hub_cap> #topic Party and Profit
18:18:01 <hub_cap> so open discussion time
18:18:13 <hub_cap> everyone rebase your shiz cuz of the new types/versions stuff
18:18:14 <robertmyers> vote end early?
18:18:17 <hub_cap> and retun your tests
18:18:19 <datsun180b> https://gist.github.com/ed-/e09316c5d33e7562dd25
18:18:25 <hub_cap> we will robertmyers if no one else has anything
18:18:35 <hub_cap> lol @ datsun180b
18:18:36 <grapex> hub_cap: should we rewind the tests first?
18:18:37 <robertmyers> datsun180b: nice
18:18:40 <vipul> datsun180b: awesome
18:18:46 <grapex> datsun180b: wow
18:18:55 <grapex> Is that a picture of a turkey?
18:18:57 <esp> datsun180b: nice!
18:19:08 <hub_cap> grapex: what do u mean?
18:19:17 <juice> I get it
18:19:20 <grapex> hub_cap: Like in first grade, when you trace your hand and it becomes a turkey
18:19:21 <vipul> although that does look like the wrong finger
18:19:29 <datsun180b> it is deliberately the wrong finger
18:19:33 <datsun180b> rax inside joke
18:19:41 <hub_cap> grapex: i meant the "rewind the tests'
18:19:50 <juice> I was thinking of a dog lifting it's leg to take a leak on a db cylinder
18:19:55 <grapex> vipul: At Rax it means "you're number one" which for some reason is a bad thing #dumbinsidejokes
18:19:59 <hub_cap> lol @ vipul "the wrong finger"
18:20:02 <SlickNik> datsun180b: That's so... beckoning.
18:20:06 <grapex> juice: LOL!
18:20:07 <grapex> That's perfect
18:20:16 <grapex> juice: With a thought bubble that says "I'm securing it for you."
18:20:20 <hub_cap> so if we have nothing else to talk about sans datsun180b wrong middle finger
18:20:34 <robertmyers> lets
18:20:35 <datsun180b> well one moment, i'll update the image
18:20:35 <hub_cap> we can take this professional banter to #openstack-trove
18:20:46 <cp16net> LOl
18:20:51 <grapex> hub_cap: Best meeting ever.
18:20:56 <hub_cap> ++
18:21:06 <grapex> hub_cap: Totally lived up to the original agenda.
18:21:12 <hub_cap> pssh
18:21:14 <hub_cap> exceeded
18:21:15 <SlickNik> I'm good.
18:21:27 <hub_cap> everyone make sure u update your bugs / blueprints to say "icehouse-1" so i dont have to :)
18:21:42 <robertmyers> hub_cap: I can't change my bugs
18:21:43 <hub_cap> also, file blueprints u want to see in icehouse.. by tuesday next wk i need to organize them
18:21:55 <hub_cap> robertmyers: LOL blame SlickNik
18:21:58 <robertmyers> I don't see a option to do it
18:22:14 <datsun180b> updated. you're very welcome
18:22:15 <robertmyers> SlickNik: why you hate me?
18:22:18 <SlickNik> wait: what did I do?
18:22:34 <datsun180b> on a serious note: conductor better get through those gates
18:22:43 <SlickNik> robertmyers: afaik you should be able to change bugs you've filed.
18:23:07 <robertmyers> SlickNik: I can just not the milestone
18:23:41 <robertmyers> I can change blueprints tho
18:23:44 <esmute> Hey guys, take a look at the dns designate support patch. It needs some eyes
18:23:50 <SlickNik> robertmyers: I believe the openstack way is that only members of the "drivers" team can change the milestone.
18:24:14 <robertmyers> I am in reddwarf-drivers
18:24:31 <SlickNik> We're using trove-drivers now.
18:24:41 <grapex> esmute: I'll try to look at that soon.
18:24:48 <datsun180b> i thought all reddwarf-drivers had were reddwarf job retrigger powers
18:25:00 <esmute> grapex: <3
18:25:02 <SlickNik> datsun180b: correct.
18:25:20 <kevinconway> what's the difference between reddwarf-drivers and trove-drivers?
18:25:30 <robertmyers> are we all suppose to be in both?
18:26:01 <SlickNik> robertmyers: I don't think so.
18:26:22 <robertmyers> SlickNik: ok, then hub_cap you update my bugs :)
18:26:38 <hub_cap> robertmyers link them in the room
18:26:42 <hub_cap> lets call this a day?
18:27:05 <SlickNik> robertmyers: Send out a list, I can update them for you as well.
18:27:08 <SlickNik> Sounds good.
18:27:22 <cp16net> sure
18:27:25 <vipul> we can go home now?
18:27:25 <robertmyers> sure
18:27:32 <SlickNik> lol@vipul
18:27:43 <cp16net> yes i give you premission vipul
18:27:45 <cp16net> :-P
18:27:46 <esmute> vipul: Are you in India?
18:27:58 <grapex> vipul: I asked Amy if we could go home after this meeting just like we used to even though it moved.
18:28:02 <vipul> esmute: i probably wouldn't have internet if i were
18:28:10 <SlickNik> esmute: He's across the table from you…
18:28:15 <SlickNik> lol
18:28:26 <vipul> grapex: amy's nice
18:28:55 <esmute> vipul: Take some notes :P
18:29:05 <vipul> lol
18:29:08 <demorris> hey I am late to the party, still room for more topics?
18:29:15 <robertmyers> #link https://bugs.launchpad.net/trove/+bugs?search=Search&field.assignee=rmyers
18:29:20 <robertmyers> hehe
18:29:22 <kevinconway> demorris: it's open discussion
18:29:25 <hub_cap> demorris: sure its open talkings
18:29:30 <demorris> k
18:29:46 <demorris> so now that versions / types merged, I wanted to chat about upgrades
18:30:21 <demorris> I had submitted a BP long ago on this, back when we were Reddwarf - https://wiki.openstack.org/wiki/Trove/maintenance-windows-and-version-updates
18:31:02 <hub_cap> i like it
18:31:04 <demorris> this was inclusive of what I called upgrades and maintenance windows...
18:31:05 <redthrux> *ahhheemmmmbadidea*
18:31:17 <demorris> but take away maintenance windows for now
18:31:22 <demorris> and focus on upgrades
18:31:36 <hub_cap> yes fucus on upgrades
18:31:42 <redthrux> lol hub_cap
18:31:48 <demorris> the basic idea is expose a call to return if updates are available
18:31:50 <hub_cap> lets split them up into 2 blueprints
18:31:57 <redthrux> is it minor versions only demorris
18:31:57 <ashestakov> demorris: i think now upgrades by backup/restore should works
18:32:06 <demorris> and another to apply it
18:32:08 <redthrux> +1 ashestakov
18:32:18 <datsun180b> I don't know about this splitting up business. Let's start a blueprint to document that splitting-up process
18:32:29 <demorris> ashestakov: okay so maybe we separate out upgrade vs. update
18:32:38 <redthrux> +1 demorris
18:32:38 <kevinconway> demorris: is there a difference?
18:32:39 <demorris> minor version upgrades should not require a backup and restore
18:32:45 <redthrux> yes - kevinconway
18:33:07 <vipul> don't you need maintenance windows for that?  or are you proposing user initiated
18:33:14 <demorris> I am all for y'all jumping in on this and morphing the BP, just getting the conversation going here
18:33:16 <kevinconway> so is an update a minor version and upgrade a major?
18:33:18 <redthrux> kevinconway - some major upgrades can hose a db; if it's security updates, that's safe
18:33:28 <ashestakov> demorris: i think need research inplace upgrades
18:33:40 <kevinconway> so mysql 5.1 to 5.5 is a minor update right?
18:33:48 <robertmyers> kevinconway: no
18:34:00 <hub_cap> not if 5.1 and 5.5 are diff datastore_types kevinconway
18:34:09 <demorris> i think there are cases across different DBMS's where you could accomplish major version upgrades, but there are tons of caveats
18:34:22 <demorris> if you use MySQL as the base case, just go look at the MySQL docs and see the list of caveats
18:34:44 <ashestakov> hub_cap: why not allow upgrdes with different types, but same manager?
18:34:46 <demorris> it IS possible that you could have a databases/tables that don't hit any restrictions on an upgrade
18:35:06 <hub_cap> ashestakov: lets focus on building out minor upgrades before we tackle things like that ashestakov
18:35:39 <demorris> so I would think that it makes sense to have upgrades be set up to handle it longer term and have that be provider specific on if they want to support it in their deployment
18:35:47 <hub_cap> ++
18:35:55 <SlickNik> +1 to building out minor (security) upgrades before tackling major/inter-type upgrades.
18:35:56 <vipul> why do you need an API that tells you that an 'update' is available.  You know what version you're on.. and you can always list avaialble versions
18:36:18 <redthrux> I'd have to agree with you there vipul - now you're asking for trove to be package management aware
18:36:44 <demorris> so updates will be disruptive
18:36:53 <demorris> because you have to restart the DBMS
18:36:54 <hub_cap> hey i had hoped to cut this short.. lets take this convo about design to #openstack-trove. i need to go to the city to return a laptop
18:37:02 <ashestakov> hub_cap: i think there is same way for upgrade, we can start from just update packages
18:37:21 <demorris> with versions/types we are already managing packages and versions
18:37:26 <esmute> hub_cap: Didnt like your celeron chrome book?
18:37:27 <demorris> thats done
18:37:31 <SlickNik> okay. let's move this party to #openstack-trove.
18:37:34 <hub_cap> esmute: hehe this is my loaner HK lappy
18:37:35 <demorris> okay moving
18:37:37 <hub_cap> SlickNik: ++
18:37:40 <vipul> demorris: So maybe a PATCH on instance is what we need to implement
18:37:55 <hub_cap> GOTO #openstack-trove
18:37:59 <vipul> PATCH with a new 'datastore'/'version' == update + restart
18:38:00 <vipul> :p
18:38:00 <redthrux> more PATCH goodness
18:38:08 <hub_cap> #endmeeting