20:00:10 <hub_cap> #startmeeting trove
20:00:11 <openstack> Meeting started Wed Oct 30 20:00:10 2013 UTC and is due to finish in 60 minutes.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:14 <openstack> The meeting name has been set to 'trove'
20:00:25 <grapex> o/
20:00:27 <cp16net> o^/
20:00:41 <SlickNik> o/
20:00:46 <amcrn> o/
20:00:49 <kevinconway> o/ o/ o/ o/
20:00:57 <hub_cap> kevinconway: has multiplied
20:01:05 <hub_cap> #topic action items
20:01:10 <hub_cap> #link http://eavesdrop.openstack.org/meetings/trove/2013/trove.2013-10-23-20.01.html
20:01:16 <hub_cap> grapex to fix issue where instances in BUILDING_ERROR_DNS cannot be deleted.
20:01:37 <grapex> hub_cap: Sorry, was tied up with a few other things.
20:01:51 <hub_cap> k
20:01:55 <hub_cap> #action grapex to fix issue where instances in BUILDING_ERROR_DNS cannot be deleted.
20:02:00 <hub_cap> datsun180b to make conductor no longer optional
20:02:12 <datsun180b> working on it
20:02:17 <hub_cap> k
20:02:36 <hub_cap> write up wiki article wrt testing + tempest + trove <--- fail, i didnt do any of it
20:02:37 <datsun180b> review's up, but i've got one more patchset to push
20:02:42 <SlickNik> yep, some good progress on it datsun180b!
20:02:55 <hub_cap> but i suspect a good bit will be done at the summit, since SlickNik has a talk on it
20:03:10 <vipul> o/
20:03:10 <hub_cap> ok time to move on
20:03:26 <grapex> hub_cap: make sure your talk isn't just a bunch of sketches of the sea.
20:03:29 <hub_cap> So... the only thing i have on the list is to talk about the summit
20:03:33 <kevinconway> hub_cap: did you want to retask that item?
20:03:34 <hub_cap> grapex: shit
20:03:41 <imsplitbit> or pictures of chicken and waffles
20:03:46 <SlickNik> #link https://review.openstack.org/#/c/53972/ <= started on some of the pieces to get the ball rolling
20:03:51 <hub_cap> #action write up wiki article wrt testing + tempest + trove (hub_cap SlickNik)
20:04:20 <hub_cap> #topic talk about the summit
20:04:50 <hub_cap> so one thing to note
20:04:55 <denis_makogon> o/
20:05:15 <kevinconway> summit |ˈsəmit| noun
20:05:16 <kevinconway> 1 the highest point of a hill or mountain.
20:05:17 <kevinconway> 2 a meeting between heads of government:
20:05:19 <juice> o/
20:05:21 <SnowDust> hub_cap : some draft review was shared with you around tempest cli test
20:05:23 <hub_cap> the core team will be mostly radio silent for the next week (starting next week)
20:05:31 <hub_cap> SnowDust: yes for some of it
20:05:40 <hub_cap> im more concerened about the integration tests
20:05:41 <hub_cap> err
20:05:46 <hub_cap> the scenario tests
20:05:49 <SnowDust> ok
20:05:52 <hub_cap> and how to parallelise them
20:06:09 <cweid> [0]
20:06:20 <hub_cap> SnowDust: but u should totally add that to the summit session etherpad
20:06:24 <hub_cap> SlickNik:  can u link them
20:06:28 <SlickNik> Yes
20:06:33 <SlickNik> #link https://wiki.openstack.org/wiki/Summit/Icehouse/Etherpads#Trove
20:06:51 <SlickNik> ^^All the summit etherpads
20:07:52 <hub_cap> ok cool
20:08:00 <hub_cap> so does anyone else have anything to really discuss?
20:08:20 <hub_cap> or have questions / comments about the summit
20:08:20 <ashestakov> datastore types?
20:08:25 <vipul> So do we have names for the session leads?
20:08:40 <hub_cap> names vipul?
20:08:53 <vipul> everyone know which sessions they are leading?
20:09:06 <vipul> and are there sessions without leads.. that we can assign people to
20:09:10 <hub_cap> oh its the one u submitted :)
20:09:13 <hub_cap> it says "submitted by"
20:09:27 <vipul> ok.. i know which one i'm doing.. jsut making sure other do too :)
20:09:32 <hub_cap> #link http://icehousedesignsummit.sched.org/overview/type/trove
20:09:35 * juice is happy to volunteer
20:10:01 <amcrn> will the etherpads be updated during the conference? that way folks like myself, who were sabotaged by calendar conflicts, can review them after the fact?
20:10:03 <grapex> I'm leading the Guest Agents in Trove
20:10:16 <SlickNik> amcrn: yes!
20:10:18 <hub_cap> amcrn: yes they will be updated
20:10:22 <amcrn> stellar
20:10:40 <hub_cap> hey whos going to the summit?
20:10:41 <SlickNik> speaking of calendar conflicts.
20:10:56 <hub_cap> id like ot get a feel for whos gonna be there
20:11:03 <vipul> o/
20:11:06 <juice> o/
20:11:10 <hub_cap> \o
20:11:13 * SlickNik will be there
20:11:13 <grapex> o/
20:11:37 <hub_cap> i think isvidriov will be there too, right dmakogon?
20:11:40 <hub_cap> denis_makogon: ^ ^
20:12:17 <imsplitbit> I'm stowing away in grapex's luggage
20:12:27 <denis_makogon> hub_cap, yes
20:12:52 <hub_cap> imsplitbit: if he packs like you, he will def have enough luggage
20:13:08 <SlickNik> FYI to all going: this year there are _two_ calendars.
20:13:21 <SlickNik> #link http://openstacksummitnovember2013.sched.org/
20:13:22 <hub_cap> ok so do we have more stuff to talk about wrt the summit?
20:13:31 <SlickNik> #link http://icehousedesignsummit.sched.org/
20:13:59 <SlickNik> make sure you look at both when picking which sessions to go to.
20:14:18 <hub_cap> also there is like a 10 minute walk between the 2 sched's
20:14:58 <hub_cap> ok ill open this up to open discussion now
20:15:10 <hub_cap> #topic open discussion
20:15:12 <hub_cap> lets chat anything
20:15:14 <SlickNik> I've got something
20:15:33 <imsplitbit> I'll take the mic after SlickNik
20:15:41 <SlickNik> There's a time change coming up this weekend
20:15:46 <hub_cap> lol yes there is
20:15:55 <hub_cap> which means meeting time change right :)
20:16:03 <SlickNik> yup.
20:16:09 <cp16net> silly UTC....
20:16:10 <hub_cap> for the DST'ers
20:16:12 <cp16net> :-P
20:16:16 <SlickNik> for the DST'ers
20:16:19 <vipul> why can't it always be DST
20:16:40 <hub_cap> arizona, youre not invited to this conversation
20:16:41 <imsplitbit> because when everyone is DST then noone is DST
20:16:52 <vipul> woah imsplitbit
20:17:02 <kevinconway> it's so kids don't have to wait for the bus in the dark
20:17:04 <grapex> imsplitbit: That's deep
20:17:19 <kevinconway> momma says...
20:17:26 <SlickNik> So is the plan then to keep to the same UTC time?
20:17:42 <hub_cap> maybe we should try another 'redo' w the time
20:17:46 <imsplitbit> no we're moving them to 9am CST
20:17:53 <imsplitbit> right kevinconway
20:17:54 <imsplitbit> ?
20:17:55 <hub_cap> since we actually have multiple continents who are contributing now
20:18:02 <kevinconway> at least imsplitbit
20:18:38 <vipul> so is that 12pm or 2pm for us
20:18:58 <SlickNik> 12 noon, I believe for PST
20:19:29 <imsplitbit> man I wish I could mozy into work after 10am...
20:19:33 * imsplitbit is jealous
20:19:39 <SlickNik> actually let me double check
20:20:12 <vipul> imsplitbit: you work from home :p
20:20:33 <hub_cap> so lets keep the same time for now
20:20:44 <SlickNik> yup it's noon
20:21:08 <imsplitbit> vipul: I wish
20:21:29 <SlickNik> I'm fine with it keeping it the same for now.
20:21:56 <SlickNik> Heads up that if you follow DST, the meeting time will be different for next week.
20:22:03 <hub_cap> correct ^ ^
20:22:10 <vipul> is there a meeting next week?
20:22:21 <vipul> i wonder what time that is in Hong Kong time
20:22:40 <hub_cap> and obvi we skip next wks meeting
20:22:48 <grapex> vipul: I vote we change the meeting time for one week while we're in HKG and then change it back afterwards. Would that be fair?
20:22:58 <vipul> totally
20:22:58 <SlickNik> 4:00 am HKT :)
20:23:02 <datsun180b> isn't putting all the core members in one building the plot of the newest star trek movie
20:23:03 <hub_cap> #link https://www.google.com/search?q=what+time+is+it+in+hong+kong
20:23:24 <imsplitbit> ok so have we decided?
20:23:24 <SnowDust> its 2 AM IST .. my time .. already !
20:23:28 <imsplitbit> can I get the mic?
20:23:34 <imsplitbit> I'll be relatively quick
20:23:36 <hub_cap> imsplitbit: talk
20:23:41 * SlickNik passes imsplitbit the mic
20:23:43 <cweid> SPIT IT DAWG
20:23:44 <imsplitbit> #link https://wiki.openstack.org/wiki/Trove-Replication-And-Clustering-API
20:24:19 <hub_cap> we will be discussing this in the summit for sure
20:24:35 <imsplitbit> ok well then I'll hold off until it has been discussed
20:24:44 <imsplitbit> see that was fast.
20:25:02 <vipul> I think this is pretty good
20:25:11 <hub_cap> lol imsplitbit
20:25:14 <vipul> don't forsee much change after the summit
20:25:18 <hub_cap> also, just so everyone knows, https://review.openstack.org/#/c/54510/
20:25:22 <hub_cap> that should fix our build
20:25:26 <hub_cap> right SlickNik?
20:25:54 <SlickNik> yup
20:25:59 <imsplitbit> should/can I at least start adding the metadata attribute to the instances??
20:26:10 * imsplitbit is chomping at the bit to get started
20:26:16 <SlickNik> once we have a new pbr pushed to pypi
20:26:18 <hub_cap> imsplitbit: if u want to risk throwing code away, start on anything u want ;)
20:26:20 <grapex> SlickNik: Thanks!
20:26:29 <imsplitbit> dude I just threw away a bunch of code
20:26:32 <imsplitbit> I'm totally ok with that
20:26:40 <imsplitbit> at the risk of getting ahead of the game??
20:26:46 <imsplitbit> I'll take that
20:27:05 <hub_cap> SlickNik: your review is merged
20:27:34 <ashestakov> guys, can we discuss datastore types review now?
20:27:46 <grapex> PS: I want the mic after ashestakov.
20:28:05 * imsplitbit drops the mic and storms off stage
20:28:10 <imsplitbit> :)
20:28:15 * hub_cap wallops imsplitbit with a golden cup
20:28:17 <SlickNik> hub_cap: waiting for mordred to push a new release to pypi. He said he'd get to it after he gets out of meetings.
20:28:22 * grapex hands the mic to ashestakov
20:28:33 <hub_cap> aww grapex u forgot to pick up the mic
20:28:40 <hub_cap> -10 exp
20:28:42 <ashestakov> vipul: did you saw my answer for your comment?
20:28:52 <grapex> hub_cap: harsh
20:29:00 <hub_cap> -5 more for whining grapex
20:29:13 <hub_cap> ashestakov: lets brign up the topic, explain it
20:29:15 <amcrn> where's the talking pillow
20:29:16 <hub_cap> *bring
20:29:38 <ashestakov> ok, this review https://review.openstack.org/#/c/47936/
20:29:53 <hub_cap> amcrn: /me needs to watch breaking bad
20:30:05 <ashestakov> commants at https://review.openstack.org/#/c/47936/15/troveclient/v1/datastore_types.py L91
20:30:33 <amcrn> hub_cap: word
20:30:51 <hub_cap> ashestakov: bring up the topic more than showing links
20:30:53 <hub_cap> whats the issue
20:30:56 <hub_cap> what do u want to talk about
20:31:04 <grapex> ashestakov: You should probably requote your comments for everyone's convience.
20:31:10 <hub_cap> vipul: whats the issue?
20:31:46 <ashestakov> will better if vipul describe issue againe, maybe i missung something
20:32:10 <hub_cap> k ashestakov
20:32:13 <hub_cap> vipul: go
20:32:19 <SlickNik> The issue seems to be that there are 2 different routes, one for types and a separate one for versions.
20:32:44 <esp> vipul has stepped away for a min.
20:32:59 <esp> I can go hunt around the office for him
20:33:08 <SlickNik> When really, the versions are linked to the types and not independent of them.
20:33:12 <hub_cap> lol esp we can give him a few min
20:33:21 <vipul> back
20:33:33 <esp> phew, thought I was gonna have to check the restrooms
20:33:39 <SlickNik> lol esp
20:33:44 <kevinconway> so on the type and version deal, what was the reason for not simply using glance images?
20:33:45 <vipul> ok my concern on that was.. why do we need that route?
20:34:02 <vipul> by keeping that route in place we are treating versions as a higher level resource..
20:34:21 <vipul> if we agree that vesions are sub-resources of Types
20:34:35 <vipul> then a valid route would be /datastore_types/{id}/versions/{v_id}
20:36:12 <SlickNik> I agree with vipul on this — it hardly makes sense to request a list of all versions without type information.
20:36:41 <robertmyers> SlickNik: vipul: +1
20:36:45 <amcrn> +1, even if you added a filtering mechanism, the version "belongs" to the type
20:36:54 <ashestakov> SlickNik: you cant list all versions
20:37:03 <ashestakov> SlickNik: only for certain type
20:37:33 <vipul> ashestakov: that route doesn't alllow you to specify the type
20:37:45 <ashestakov> you can list like: trove datastore-verion-list Mysql
20:37:59 <ashestakov> vipul: that route only for one specified version
20:38:37 <amcrn> [13:36:44] <amcrn>	 +1, even if you added a filtering mechanism, the version "belongs" to the type
20:39:18 <SlickNik> ashestakov: That's exactly it. I believe, the RESTful way to do this is not to specify it as a separate query param, but have it as part of the URI of the resource.
20:39:21 <robertmyers> +1 versions are a sub resource
20:40:39 <ashestakov> but if use this /datastore_types/{id}/versions/{v_id}, then need to specify type and version to get info about version
20:41:02 <grapex> ashestakov: There are already cases where people must specify two ids
20:41:06 <vipul> yes.. take for example 'instance' and 'users'
20:41:07 <robertmyers> ashestakov: exactly
20:41:16 <grapex> the database and user calls always force you to specify instance IDs
20:41:47 <ashestakov> ok, that was my single point
20:41:53 <SlickNik> ashestakov: And a GET on /datastore_types/{id}/versions would list all version of a particular datastore type.
20:42:01 <ashestakov> yes
20:42:35 <ashestakov> if decided, ill fix it
20:42:39 <ashestakov> any other issues?
20:42:42 <vipul> ok cool
20:42:54 <vipul> nope looks good otherwise
20:43:04 <ashestakov> will you approve it?
20:43:11 <vipul> maybe
20:43:14 <vipul> of course :P
20:43:44 <SlickNik> if you fix it, they will come :)
20:43:45 <amcrn> i'll but this on the review, but why datastore_types vs. datastores
20:43:49 <amcrn> s/but/put
20:44:13 <vipul> amcrn yea that's a good point
20:44:23 <vipul> type seems redundant
20:45:29 <hub_cap> lol @ amcrn where were u like a wk ago
20:45:41 <amcrn> dealing with internal infra stuff :P
20:45:55 <amcrn> sowwy
20:46:15 <hub_cap> so ashestakov its called a datastore { "type".., "version"..} in the create, right?
20:46:36 <ashestakov> hub_cap: yes
20:46:36 <vipul> https://review.openstack.org/#/c/47936/15/troveclient/v1/instances.py
20:46:37 <vipul> seems to be
20:46:59 <hub_cap> see to me, if we are putting that "datastore" as the object, it should also be the collection, like /datastores, and should return type and avail versions in a single call
20:47:32 * hub_cap takes amcrns wrench and jams it further into the gears
20:48:43 <kevinconway> do we really want to call it datastore? i like informationstation
20:48:56 <grapex> kevinconway: Oh my God that's pefect!
20:48:59 <hub_cap> kevinconway: lol
20:49:08 <ashestakov> it killing me
20:49:18 <hub_cap> informationstation: { dial1: blah, dial2: blah}
20:49:26 <amcrn> hub_cap: so to summarize: /datastores is a summary of all datastores, /datastores/:id is a summary of one datastore, /datastores/:id/versions is for a list of versions for one datastore, and /datastores/:id/versions/:id is the verbose information for a particular version of a datastore
20:49:44 <hub_cap> yes
20:49:54 <hub_cap> ill let yall duke it out after todays stuff
20:50:05 <amcrn> ok, just typing it out for posterity's sake
20:50:08 <vipul> amcrn: +1
20:50:09 <SlickNik> amcrn: I like that
20:50:11 <cp16net> sounds logical
20:50:13 <hub_cap> id almost say that amcrn should do the work to fix it tho since hes so late to the party
20:50:23 * amcrn runs into the night
20:50:23 <cp16net> heh
20:50:25 <hub_cap> poor ashestakov has been going rounds w/ it already
20:51:27 <amcrn> +/u/bitcointip @ashestakov $1
20:51:32 <grapex> hub_cap: I
20:51:36 <grapex> 'd like to discuss something
20:51:44 <hub_cap> grapex: K
20:51:59 <ashestakov> i think just datastores is confusing
20:52:00 <hub_cap> ashestakov: amcrn duke it out after the meeting in #openstack-trove
20:52:06 <grapex> https://review.openstack.org/#/c/54565/  <-- This is a tiny fix for backups and the testing of backups.
20:52:41 <SlickNik> grapex: I'll take a look this afternoon.
20:52:45 <grapex> SlickNik: Thanks
20:53:11 <robertmyers> I have a slightly larger review, which could use some eyes
20:53:13 <robertmyers> https://review.openstack.org/#/c/53381/
20:53:45 <robertmyers> Basically removing a bunch of tests that are Rackspace specific and general cleanup
20:53:56 <amcrn> nice
20:55:03 * SlickNik will spend some time reviewing tests this afternoon/evening.
20:55:14 * SlickNik adds robertmyers review to list
20:55:30 <hub_cap> ok so we good to go?
20:55:36 <kevinconway> did we decide on if we're having a meeting next week?
20:55:39 <robertmyers> SlickNik: thanks!
20:55:42 <cp16net> there is a list of reviews on the site too :-P
20:55:44 <hub_cap> kevinconway: no meeting
20:55:48 <hub_cap> by decree of me
20:56:04 * hub_cap puts any cp16net reviews to the bottom of said list
20:56:05 <SlickNik> I know cp16net, I'm gonna take a look at everything that looks ready for review.
20:56:06 <kevinconway> decree |diˈkrē| noun
20:56:07 <kevinconway> an official order issued by a legal authority.
20:56:08 <kevinconway> verb
20:56:09 <kevinconway> order (something) by decree:
20:56:18 <cp16net> i can make them show up at the top
20:56:20 <kevinconway> LGTM
20:56:33 <cp16net> well the gate needs to be rerun on everything...
20:56:43 <hub_cap> #endmeeting