20:00:29 <hub_cap> #startmeeting trove
20:00:30 <openstack> Meeting started Wed Jul 31 20:00:29 2013 UTC and is due to finish in 60 minutes.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:34 <vipul> o/
20:00:34 <openstack> The meeting name has been set to 'trove'
20:00:37 <SlickNik> o/
20:00:50 <KennethWilke> o/
20:00:52 <datsun180b> o/
20:00:54 <esp1> o/
20:00:55 <kevinconway> \o
20:01:14 <SlickNik> thanks for not leaving me hangin' kevinconway
20:01:32 <hub_cap> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
20:01:35 <hub_cap> short meeting
20:02:05 <hub_cap> #topic action items
20:02:11 <SlickNik> the one action item, I still have to work on.
20:02:12 <grapex> o/
20:02:24 <hub_cap> #link http://eavesdrop.openstack.org/meetings/trove/2013/trove.2013-07-24-20.00.html
20:02:27 <SlickNik> Will get that done this week.
20:02:37 <imsplitbit> o/
20:02:39 <SlickNik> #action SlickNik to change the group for pypi upload
20:02:46 <hub_cap> lol SlickNik
20:02:55 <hub_cap> ok done w/ the action items
20:03:01 <hub_cap> #topic clustering api update
20:03:13 <hub_cap> imsplitbit: yer on
20:03:15 <imsplitbit> I've got a clustertype api mocked up
20:03:24 <imsplitbit> I'm writing the unittests now
20:03:30 <vipul> sweet
20:03:32 <imsplitbit> then I'll create some CI tests
20:03:32 <esp1> nice
20:03:45 <imsplitbit> should be done by EOB friday for cluster types
20:03:48 <KennethWilke> sounds good
20:03:50 <imsplitbit> then I'll move onto clusters
20:03:54 <hub_cap> wow this is a stupid short meeting.................................................
20:04:02 <vipul> what is the first impl?
20:04:10 <vipul> mysql replication?
20:04:11 <imsplitbit> I think we talked about everything over the last few days
20:04:11 <hub_cap> cassandra vipul
20:04:11 <SlickNik> imsplitbit: looking forward to seeing it.
20:04:20 <esp1> hub_cap: lol
20:04:27 <vipul> :|
20:04:31 <konetzed> hub_cap: thought we were supposed to stay on track
20:04:36 <hub_cap> :P:
20:04:36 <KennethWilke> lololol
20:04:39 <hub_cap> LOL
20:04:43 <imsplitbit> the default clustertype is master-slave it's description is "Master/Slave Replication/Clustering"
20:04:53 <esp1> cool so my cassandra db book might get some love soon
20:04:56 <imsplitbit> but I'll be implementing master slave mysql replication
20:05:06 * hub_cap added a item to the agenda, refresh
20:05:16 <hub_cap> ok so next item
20:05:22 <KennethWilke> do we get to see this beautiful api soon?
20:05:31 <hub_cap> #topic incubation update
20:05:42 <hub_cap> so i talked w/ the TC
20:05:57 <hub_cap> and they said that there dont seem to be issues w/ amending to go nosql
20:06:08 <hub_cap> assuming we push up the POC i published for redis
20:06:26 <hub_cap> so im doing that today
20:06:32 <KennethWilke> woohoo, that sounds exciting
20:06:33 <hub_cap> and they will rule on it next wk
20:06:40 <SlickNik> are they done with discussion, or discussing again next week?
20:06:41 <SlickNik> ah, okay
20:06:43 <hub_cap> but things are looking good
20:06:53 <vipul> cool
20:07:11 <hub_cap> ok any Qs w that?
20:07:32 <SlickNik> hope that allays some of the concerns mordred may have had.
20:07:39 <SlickNik> sounds good.
20:07:46 <hub_cap> yes it does
20:07:48 <hub_cap> or should
20:07:54 <hub_cap> #link h3 blueprints
20:07:57 <mordred> what?
20:07:58 <hub_cap> oops
20:08:01 <hub_cap> mordred: we <3 u
20:08:06 <mordred> w00t!
20:08:14 <KennethWilke> are there any docs for the clustering api? i know it's a work in progress but i'd like to see what it's looking like so far
20:08:20 <hub_cap> just talking about nosql+trove mordred
20:08:33 <hub_cap> yes KennethWilke ask imsplitbit
20:08:36 <hub_cap> he can send to you
20:08:36 <KennethWilke> kk will do
20:08:36 * mordred throws a nosql at hub_cap
20:08:48 * hub_cap dodges and parrys
20:08:57 <imsplitbit> #link https://wiki.openstack.org/wiki/Trove-Replication-And-Clustering-API-Using-Instances
20:08:59 * hub_cap socks mordred with an impervious sheet of paper
20:08:59 <vipul> KennethWilke: +1, we had some changes that might not be reflected on the original doc
20:09:22 <hub_cap> ok moving on?
20:09:23 <vipul> imsplitbit: i see what you did there
20:09:32 <hub_cap> #topic h3 blueprints
20:09:43 <hub_cap> #link https://launchpad.net/trove/+milestone/havana-3
20:09:51 <hub_cap> so we have _no_ low blueprints
20:09:57 <hub_cap> only essential/high/medium
20:10:12 <hub_cap> core team, lets go thru and deprio any we dont feel are 100% necessary for h3 / havana release
20:10:30 <hub_cap> ie, SlickNik grapex vipul ^  ^
20:10:38 <vipul> I think 3 of those at least have reviews up
20:10:52 <vipul> but yes, I'll see if anything needs to be lowered
20:10:56 <hub_cap> if they have reviews up, they should be in "codr review" status
20:10:58 <hub_cap> *code
20:11:02 <hub_cap> we need to get better about that
20:11:23 <hub_cap> and thats everyone. i think you can edit the status of a BP if its assigned to you
20:11:36 <imsplitbit> brb
20:11:50 <hub_cap> ok so thats really everything...
20:11:54 <hub_cap> any Qs on h3?
20:11:59 <hub_cap> next is open discusion
20:12:01 <vipul> when's the deadline
20:12:04 <SlickNik> 2013/09/05
20:12:15 <SlickNik> is the expected cut, I believe.
20:12:19 <vipul> cool
20:12:21 <grapex> hub_cap: Will do. That minor extensions fix (not the topic of the recent meetings, but something unrelated) should be done very soon.
20:12:22 <hub_cap> remember the deadline is always on the page
20:12:28 <hub_cap> #link https://launchpad.net/trove/+milestone/havana-3
20:12:28 <vipul> duh
20:12:32 <hub_cap> ^  ^ "Expected"
20:12:42 <hub_cap> ya i think it was asked like 2 meetings in a row for h2 lol
20:12:49 <hub_cap> great grapex
20:13:10 <hub_cap> #topic open discussion
20:13:16 <hub_cap> ok do we have anything we need to discuss?
20:13:18 <hub_cap> its time now
20:13:32 <datsun180b> well i've got something
20:13:32 <SlickNik> I don't have anything.
20:13:33 <hub_cap> everyone. go. at once.
20:13:36 <hub_cap> datsun180b: go
20:13:41 <imsplitbit> :)
20:14:16 <vipul> SlickNik: can you link the devstack patch
20:14:41 <datsun180b> concerning https://github.com/ed-/trove-vagrant-vmware and its use outside our very specific env at rax
20:14:58 <hub_cap> #link https://review.openstack.org/#/c/38169/
20:15:28 <datsun180b> for now, it's built with vmware fusion in mind but should we have more success in say vbox i'd like to gauge interest on adding it into maybe trove-integration as it's proven fruitful for us at rax so far
20:15:28 <SlickNik> thanks hub_cap
20:15:47 <vipul> datsun180b: thanks for sharing this!
20:15:52 <hub_cap> datsun180b: id like to keep it separate
20:15:59 <hub_cap> id like to see trove-integration get smaller
20:16:05 <hub_cap> instead of having stuff added to it
20:16:05 <imsplitbit> +1
20:16:18 <datsun180b> okay, so then another option is it's simply a fourth component/repo for trove
20:16:40 <datsun180b> i mean, i love owning it because i can push to master whenever i like, but i'd like more oversight from anyone else that finds it useful
20:16:42 <hub_cap> are you asking if it should go in the openstack org?
20:16:49 <imsplitbit> I think theres alot of value there for us at rax but maybe we need to figure out what makes the best general purpose solution
20:16:51 <datsun180b> no, i'm not going to reach that far
20:16:55 <hub_cap> im fine w/ you owning it
20:17:06 <hub_cap> you can always add people you deem necessary to push to the repo
20:17:12 <datsun180b> the goal is to remove "worked on my box" syndrome
20:17:20 <hub_cap> def
20:17:24 <grapex> hub_cap: What about contrib?
20:17:24 <datsun180b> especially between trovers that don't share a building
20:17:28 <imsplitbit> I'm def on board with removing that
20:17:30 <imsplitbit> :)
20:17:38 <hub_cap> it doesnt belong _in_ the trove codebase grapex
20:17:47 <kevinconway> +1 datsun180b
20:17:59 <cp16net> what about a submodule? (oh no!...)
20:18:03 <hub_cap> LOL
20:18:10 <cp16net> :-P
20:18:16 <datsun180b> right, not in the codebase, but it's at least a development tool that should come packaged in specially marked boxes of trove and apple cinnamon trove
20:18:21 <SlickNik> datsun180b: maybe we should talk on how we can get some more hp'ers to use / contribute to this.
20:18:29 <hub_cap> the contrib codebase will be gone soon too
20:18:34 <SlickNik> And I guess I should start with myself.
20:18:47 <hub_cap> err contrib folder
20:18:55 <datsun180b> SlickNik: the vbox stuff is skeletal, but the vmware stuff is hand-built
20:19:15 <hub_cap> i think its great to have, and to advertise on the ML if you'd like. but its not integral to trove
20:19:26 <datsun180b> agreed wrt not being integral
20:19:27 <imsplitbit> datsun180b: I'd like to contribute to the vbox stuff
20:19:28 <imsplitbit> soon
20:19:31 <hub_cap> just like people have built ones for the rest of the openstack stuff
20:19:44 <vipul> yea i see devstack is kinda separate too https://github.com/bcwaldon/vagrant_devstack
20:19:46 <datsun180b> so then i guess the question is, where does it live
20:19:46 <imsplitbit> after I finish with unittests for clustertype I will need to run a vm to run integration
20:19:57 <datsun180b> well, answers that question
20:20:25 <hub_cap> datsun180b: http://www.rhonabwy.com/wp/2012/10/28/cloudenvy-vagrant-for-openstack/
20:20:44 <hub_cap> maybe talk to them
20:20:49 <datsun180b> so final answer, i get to remain as emperor of my tiny planet
20:21:07 <vipul> unless vagrant has some community repo or something
20:21:18 <hub_cap> it doesnt vipul
20:21:28 <hub_cap> its always been "outside" the reach of openstack itself
20:21:30 <SlickNik> not that I'm aware of.
20:21:32 <datsun180b> i built that vmware box myself
20:21:39 <vipul> http://www.vagrantbox.es
20:21:42 <datsun180b> uh huh
20:21:50 <hub_cap> datsun180b: id say your best bet is twofold
20:21:58 <cp16net> vagrant has plugins for anything now
20:22:02 <hub_cap> 1) search the ML archives for anyone who houses common vagrant repos
20:22:13 <hub_cap> 2) announce it on the ML if you want to get more people to use it
20:22:20 <cp16net> you can make it work with openstack/rackspace/hp/amazon
20:22:22 <cp16net> anything
20:22:55 <SlickNik> is possible at zombo.com
20:22:56 <datsun180b> well i know it works with vmware fusion, that's all i'm putting on the sign
20:23:05 <cp16net> although i would never want to use it with a public cloud...
20:23:09 <kevinconway> hub_cap: houses vagrants? can you do that?
20:23:11 <hub_cap> WTF SlickNik
20:23:16 <kevinconway> are they still vagrants at that point?
20:23:22 <hub_cap> as in, the configs etc
20:23:24 <hub_cap> like his code
20:23:26 <hub_cap> not the boxes
20:23:42 <hub_cap> like a common codebase for it so he doesnt have to own it kevinconway
20:23:58 <kevinconway> vagrant: Noun
20:23:58 <kevinconway> A person without a settled home or regular work who wanders from place to place and lives by begging.
20:24:00 <esp1> SlickNik: did you just rickroll us?
20:24:16 <hub_cap> LOL kevinconway
20:24:24 <hub_cap> nice
20:24:28 <SlickNik> lol, nice
20:24:32 <hub_cap> esp1: yes yes he did
20:24:46 <SlickNik> esp1: sorry, after what cp16net said, it was too tempting.
20:24:49 <esp1> damn, I always fall for those.
20:25:30 <hub_cap> so SlickNik whats up w/ devstack?
20:25:47 <hub_cap> yo shiz be abandoned
20:26:04 <SlickNik> haven't had a chance to work on it last week.
20:26:23 <SlickNik> need to make a couple more changes to split out some of the testing specific configuration.
20:26:26 <hub_cap> k. still on the radar i assume? itll be nice ot have before we leave incubation
20:26:35 <SlickNik> Yes, it's def on the radar.
20:26:41 <hub_cap> great
20:26:43 <SlickNik> Hope to get to it by end of this week.
20:26:45 <datsun180b> i guess i've got my work cut out for me if i want to see wider adoption of vagrant for trove then
20:26:53 <cp16net> SlickNik: lolz
20:27:15 <esp1> datsun180b: I'll try it out.  seems pretty cool.
20:28:30 <datsun180b> glad to hear it
20:28:40 <hub_cap> and for the record, https://github.com/cloudenvy/cloudenvy looks cool too
20:29:37 <hub_cap> you may look into that datsun180b in your free time ;)
20:29:44 <esp1> yep, that look interesting as well
20:29:57 <hub_cap> not sure if it still has active development tho lol
20:30:07 <hub_cap> ok so anything else?
20:30:15 <datsun180b> i'll keep it in mind
20:30:34 <KennethWilke> i like the principles there
20:30:47 <hub_cap> seems similar to vagrant but tied directly to openstack, and looks the keystone ptl + last glance ptl wrote it
20:30:58 <vipul> uses fabric ?
20:31:04 <hub_cap> LOL
20:31:06 <hub_cap> does it?
20:31:09 <SlickNik> looks like it
20:31:10 <KennethWilke> yep
20:31:21 <hub_cap> https://github.com/cloudenvy/cloudenvy/blob/master/requirements.txt
20:31:31 <hub_cap> KennethWilke: shouldve used salt right? ;)
20:31:37 <KennethWilke> on it already :)
20:31:41 <hub_cap> HAHAHAH
20:31:43 <vipul> salt FTW!
20:31:46 <hub_cap> ok so im going to call this
20:31:53 <KennethWilke> vipul: +1
20:31:58 <KennethWilke> ;)_
20:32:00 <SlickNik> sounds good
20:32:02 <hub_cap> before everyone goes salt fabric chef puppet crazy
20:32:11 <hub_cap> anyone else have anything /useful/ to add
20:32:40 <hub_cap> going once
20:32:47 <grapex> Oh my god, thirty minutes left
20:32:50 <grapex> is this a dream?
20:32:53 <hub_cap> i know crazy right?
20:32:55 <hub_cap> #endmeeting