20:00:09 <hub_cap> #startmeeting trove
20:00:10 <openstack> Meeting started Wed Jul 10 20:00:09 2013 UTC.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:13 <openstack> The meeting name has been set to 'trove'
20:00:15 <hub_cap> heyo lets give stragglers some time
20:00:19 <vipul> \m/
20:00:32 <hub_cap> but id like to confine to 1 hr
20:00:43 <hub_cap> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
20:00:44 <cp16net> \o^
20:00:51 <djohnstone> o/
20:01:23 <hub_cap> cp16net: what is that?!
20:01:38 <djohnstone> he broke his arm
20:01:48 <cp16net> haha yeah
20:02:07 <hub_cap> cp16net: u broke your arm?!?!?
20:02:19 <cp16net> no
20:02:21 <SlickNik> o/
20:02:24 <hub_cap> coo 100% core is here lets get this rolling
20:02:29 <imsplitbit> o/
20:02:39 <cp16net> but my ascii art did
20:02:41 <esmute> \o
20:02:41 <hub_cap> https://wiki.openstack.org/wiki/Meetings/TroveMeeting <-- already linked in #link so i wont do it 2x
20:02:49 * esmute is left-handed
20:02:55 <djohnstone> wow
20:03:03 <djohnstone> wrong window
20:03:05 <cp16net> esmute: but thats your right hand
20:03:05 <grapex> o/
20:03:11 <hub_cap> #topic Update to Action items
20:03:27 <vipul> cp16net: good catch lol
20:03:29 <hub_cap> vipul: did u do any link stuff? cuz i sure didnt
20:03:37 <esmute> cp16net: I didnt say where i was facing :P
20:03:37 <SlickNik> yes cp16net: for esmute his left hand is his right hand.
20:03:38 <vipul> hub_cap: Yes, i fixed most of them
20:03:42 <hub_cap> GOOD!
20:03:45 <cp16net> lol
20:03:49 <hub_cap> did u move pages to /Trove/blah ?
20:03:53 <vipul> https://wiki.openstack.org/wiki/Trove
20:03:58 <vipul> yep, a few remaining at the bottom
20:04:00 <SlickNik> nice
20:04:06 <hub_cap> oh did u just fix the ones on that page?
20:04:10 <hub_cap> there is a whole slew of reddwarf references
20:04:13 <hub_cap> if u search for em
20:04:27 <vipul> Yea just started with the jump off page
20:04:30 <hub_cap> ok cool
20:04:35 <vipul> probably need to look closer
20:04:36 <hub_cap> so u gonan work on it ongoing?
20:04:45 <hub_cap> #action vipul to keep cleaning up the wiki
20:04:47 <vipul> #action Vipul to continue to update reddwarf -> trove
20:04:47 <hub_cap> :)
20:04:50 <hub_cap> LOL
20:04:54 <hub_cap> #undo
20:04:55 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3370290>
20:04:58 <hub_cap> u like that!!?!?
20:04:59 <vipul> woah
20:05:00 <hub_cap> BOOYA
20:05:05 <cp16net> nioce
20:05:07 <hub_cap> #undo
20:05:08 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3370950>
20:05:10 <SlickNik> w00t!
20:05:11 <hub_cap> #action Vipul to continue to update reddwarf -> trove
20:05:14 <hub_cap> there now its proper
20:05:22 <hub_cap> yours was nicer than mine anyway
20:05:24 <vipul> so you can keep undoing eh
20:05:28 <hub_cap> yup
20:05:32 <hub_cap> prolly undo all of time
20:05:37 <hub_cap> undo big-bang
20:05:52 <hub_cap> SlickNik: ci job for docs?
20:05:53 <SlickNik> #redo
20:05:55 <hub_cap> hows that goin
20:05:59 <hub_cap> lol SlickNik
20:06:20 <SlickNik> I looked into it.
20:06:30 <SlickNik> The job already exists.
20:06:36 <hub_cap> :o
20:06:38 <SlickNik> It's just a conf change once we have the docs.
20:06:46 <hub_cap> sweet
20:06:52 <hub_cap> so lets get the docs :D
20:06:55 <grapex> SlickNik: Awesome!
20:07:08 <SlickNik> I need to write the docs.
20:07:11 <hub_cap> omg im freezing here
20:07:27 <SlickNik> Basically the job builds them using sphinx.
20:07:32 <cp16net> weak
20:07:37 <hub_cap> i gotta go back in my house, vipul talk about the next action after SlickNik is done. brb 2 min
20:08:06 <vipul> k
20:08:19 <SlickNik> The format is .rst (same as docutils)
20:08:47 <SlickNik> I need to convert our redstack docs to .rst files to have some initial trove dev docs.
20:09:03 <vipul> cool.. which repo do we push them to
20:09:10 <hub_cap> brr back
20:09:26 <imsplitbit> what is brr back?
20:09:32 <SlickNik> trove/trove-integration?
20:09:45 <vipul> oh ok.. it's part of our stuff
20:09:50 <hub_cap> brr is the onomonopia of me being cold
20:09:53 <hub_cap> and back is im back
20:10:05 <SlickNik> Yeah, most projects have it in a doc folder in the main project.
20:10:12 <vipul> it's probably warmer up in seattle than where you at hub_cap
20:10:13 <hub_cap> thats quite nice SlickNik
20:10:29 <hub_cap> vipul: im not in the sun. in the sun its perfect
20:10:41 <hub_cap> anyhoo... lets try to write some docs!
20:10:50 <SlickNik> So I was thinking of adding it under trove/docs.
20:11:00 <hub_cap> id say spend some time getting it started
20:11:06 <hub_cap> so we have a jumping off point
20:11:10 <SlickNik> #action SlickNik write initial dev docs.
20:11:14 <hub_cap> and its a smaller barrier to have other people do it
20:11:19 <imsplitbit> docs good
20:11:22 <hub_cap> ++
20:11:34 <SlickNik> Yeah, I can get it started.
20:11:36 <hub_cap> so moving on to the next AI
20:11:48 <SlickNik> And that's good, because it'll let me test the CI job's configuration as well.
20:11:54 <SlickNik> Cool, moving on.
20:11:56 <hub_cap> erxactly SlickNik
20:12:14 <vipul> So I gave the BPs a quick look, and i think we got them all marked
20:12:18 <hub_cap> vipul: grapex SlickNik and hub_cap need to look @ the blueprints
20:12:19 <vipul> at least the ones that are in h1
20:12:20 <vipul> h2
20:12:36 <vipul> i didn't check trove-integration or troveclient
20:12:56 <hub_cap> ya lets spend some time on em too
20:12:59 <SlickNik> I checked trove-integration and cleaned up a bunch of bugs (there were no bps)
20:13:00 <hub_cap> i have let them rot too
20:13:12 <hub_cap> as a core group we need to keep on em
20:13:44 <hub_cap> ok moving on
20:13:59 <hub_cap> seems like thats the rest of the AI's
20:14:15 <hub_cap> #topic h2-blueprints
20:14:17 <hub_cap> #link https://launchpad.net/trove/+milestone/havana-2
20:14:42 <hub_cap> we have < 7 days till h2 is cut
20:14:49 <hub_cap> i should have mine done
20:14:59 <hub_cap> is there anything _not_ on that list that shoudl be?
20:15:15 <hub_cap> h3 will have some code freeze but it wont affect us till we are out of incubation
20:15:38 <hub_cap> tap tap tap... is this thing on?
20:15:41 <SlickNik> Nothing that I can think of that's not on that list that should be.
20:15:49 <vipul> Add backup volume size to database	is anyone looking at this?
20:15:52 <hub_cap> SlickNik: as for your comment to my review on the config stuff, i totally agree
20:16:04 <vipul> https://blueprints.launchpad.net/trove/+spec/backup-volume-size
20:16:09 <vipul> if not, probably should be out of h2
20:16:11 <hub_cap> i dont know vipul but i remember it being a problem in us doing impl'ing
20:16:25 <hub_cap> grapex: do u know if anyone is lookin @ that?
20:16:36 <hub_cap> robert mightve been....
20:16:44 <hub_cap> robertmeyers is out, his baby was born
20:17:13 <vipul> another one bites the dust :)
20:17:17 <hub_cap> lol
20:17:18 <grapex> hub_cap: I'm not sure off hand, which probably means no. :(
20:17:22 <hub_cap> poop
20:17:47 <hub_cap> cool then we should move it to h3
20:17:48 <SlickNik> hmm…anyone else who might be able to take this on?
20:18:02 <hub_cap> i think we are stretched thin @rax currently
20:18:07 <hub_cap> grapex: would make that call
20:18:19 <grapex> hub_cap SlickNik: Yeah, lots of people are out at the moment.
20:18:34 <SlickNik> I'm okay with h3 if it's okay with you grapex / hub_cap.
20:18:36 <hub_cap> grapex: cool w/ movin it to h3?
20:18:43 <grapex> And we're dealing with some internal matters... trust me, it sucks. We want to be back out here. In the sunlight. :)
20:18:45 <vipul> yep, don't think it'll make it in 7 days
20:18:47 <hub_cap> as in, are u confident no one will touch from rax for a wk
20:19:08 <grapex> Right away, one issue I see with that BP I don't think anyone thought of
20:19:08 <vipul> grapex: yea you guys have been quiet, do come out :)
20:19:22 <hub_cap> vipul: im never quiet
20:19:26 <hub_cap> when i have electricity
20:19:26 <grapex> The disk utilization may not be the size required by the backup
20:19:48 <hub_cap> grapex: plz add comments to the bp to help make it mo-better
20:19:53 <hub_cap> ill move it to h3
20:19:56 <grapex> Because I've been testing backup stuff lately, you can fill up a volume adding a huge table filled with rows, then drop the table but you don't get that disk space back.
20:20:00 <grapex> hub_cap: Ok
20:20:11 <demorris> grapex: the issue is that you have no way to know how big the volume needs to be
20:20:12 <hub_cap> <3
20:20:31 <grapex> demorris: Yeah, even when we're done with the backup there's no good way to check
20:20:37 <hub_cap> ugh grapex that sounds....fun.......
20:20:38 <grapex> unless xtrabackup can figure it out for us somehow
20:20:39 <demorris> either you provide something in the DB that says how big the DB on the instance was, or you have the restore process override and rightsize the volume during the restore
20:20:50 <demorris> but I am talking about the size on disk before the backup
20:20:50 <hub_cap> ok lets add thsi stuff to the BP
20:20:53 <demorris> thats what matters
20:20:57 <demorris> backups are compressed, etc.
20:21:02 <demorris> so the size of the backup is meaningless
20:21:06 <hub_cap> otherwise itll fall in to the aether
20:21:12 <demorris> right now, its a guessing game
20:21:16 <grapex> demorris: Size on disk though may be more than you need if you've deleted a lot of stuff.
20:21:17 <demorris> unless the original instance is around
20:21:18 <hub_cap> so is that it for them?
20:21:20 <vipul> yea but we could store the uncompressed size though right?
20:21:32 <grapex> http://stackoverflow.com/questions/5983814/reclaim-disk-space-after-drop-database-in-mysql
20:21:54 <SlickNik> demorris / grapex: is the scenario to be able to move from a bigger volume to a smaller one?
20:21:55 <demorris> grapex: sure, but either way, how do you know how big of a volume you need?
20:21:56 <grapex> Maybe we should talk about this particular aspect after the meeting?
20:21:57 <vipul> initially we can require that the new size > than original (reclaimed or not)
20:22:29 <hub_cap> #topic disk space for backups
20:22:41 <SlickNik> yeah, might need further discussion.
20:22:43 <konetzed> vipul: uncompressed size wouldnt work you need size on disk
20:22:48 <demorris> the scenario is, I take a backup of my database and it gets stored in cloud files
20:22:48 <demorris> later I want to restore to a new instance...
20:22:48 <demorris> how big should my volume be?
20:23:11 <konetzed> can we put up a meta data file for the backup on how large it was on disk at time of backup?
20:23:20 <hub_cap> did the topic not get changed?
20:23:24 <hub_cap> am i even online??
20:23:29 <vipul> you is
20:23:30 <konetzed> hub_cap: i see ya
20:23:32 <hub_cap> hmm thats odd
20:23:33 <imsplitbit> I see you
20:23:35 <cp16net> openstack is not on
20:23:36 <hub_cap> i dont see the topic change
20:23:42 <konetzed> there was a netsplit
20:23:42 <cp16net> netsplit al day
20:23:46 <SlickNik> it didn't get changed.
20:23:53 <hub_cap> geez netsplit
20:24:04 <cp16net> the openstack chan op is not here
20:24:08 <demorris> we also have to consider the behavior here
20:24:10 <hub_cap> ya i see that hes gone
20:24:14 <hub_cap> ok so shoudl we discuss this now?
20:24:23 <hub_cap> we dont ahve a ton of stuff to discuss honestly in the emeting this wk
20:24:27 <hub_cap> we can make this an official topic
20:24:33 <demorris> we allow you to specify a volume, so lets say you save the original disk util size in the DB and you use that when doing a create
20:24:37 <grapex> If we're ok with restores not being able to reclaim space perhaps on a smaller volume, that seems like an easy thing to add
20:24:54 <hub_cap> aww hell who needs topics lol we are already discussing
20:25:02 <demorris> hub_cap: exactly :)
20:25:08 <datsun180b> freenode services are disabled today due to some sort of attack
20:25:29 <imsplitbit> when *isn't* freenode under attack?
20:25:33 <grapex> It's because the attackers hate our free(dom)node
20:25:36 <hub_cap> lol
20:25:48 <hub_cap> i think grapex is talking xml now
20:26:00 <grapex> I can implement that one bk blue print
20:26:03 <grapex> when is the deadline?
20:26:13 <hub_cap> next tue
20:26:19 <grapex> hub_cap: Sign me up!
20:26:35 <demorris> so the BP is missing something
20:26:43 <SlickNik> demorris / grapex: If you don't need to support the downgrade scenario, the simplest thing to do would be to save the volume size with the backup and ensure that restore happens on a volume at least as big.
20:26:45 <hub_cap> demorris: that why i said put nots on the bp
20:26:47 <hub_cap> *notes
20:27:01 <demorris> if we store this value in the DB, when do you use it?  What if I specify a volume size on the create?  who wins?
20:27:02 <hub_cap> #link https://blueprints.launchpad.net/trove/+spec/backup-volume-size
20:27:04 <vipul> https://blueprints.launchpad.net/percona-xtrabackup/+spec/compact-backups
20:27:11 <hub_cap> ^ ^ sign yourself up grapex thre are like 3 tim simpsons
20:27:15 <vipul> looks like teh --compact option might work?
20:27:22 <demorris> SlickNik: yeah, that could work
20:27:24 <grapex> SlickNik: Agreed. That's how I'll fix it. If we can think of a fix for that downside issue before next Tue I'll add it
20:27:24 <imsplitbit> demorris: would you store it in a db or with the backup?
20:27:35 <demorris> imsplitbit: I don't care where you store it
20:27:43 <hub_cap> lies demorris u do care
20:27:47 <hub_cap> do u want it on the list backups
20:27:51 <hub_cap> if so it needs to be in the db
20:27:58 <hub_cap> we had this talk already
20:28:02 <imsplitbit> ok
20:28:26 <konetzed> i think it would need to be in the db
20:28:31 <demorris> hub_cap: i see, well I did not realize initially that was limiting that
20:28:35 <konetzed> so you could get the info for restore
20:28:41 <imsplitbit> I was more curious from a resilience/dr situation as an ops person how would I know how big the backup was if the db got nixed
20:28:44 <demorris> what would you call it?  Minimum volume size?
20:28:51 <demorris> sizeOnDisk?
20:28:56 <hub_cap> we can figure it out
20:28:59 <hub_cap> lets not get too into it now
20:29:03 <imsplitbit> np
20:29:08 <demorris> okay
20:29:12 <hub_cap> lets let tim get into impl'ing it and he can propose names
20:29:25 <hub_cap> i prefer size_in_grains_of_rice personally
20:29:26 <SlickNik> I <3 grapex's anems.
20:29:31 <imsplitbit> lol
20:29:36 <hub_cap> ++ SlickNik
20:29:55 <hub_cap> so just a reminder
20:29:59 <demorris> as long as we understand the scenario…today we have a guessing game where potentially the users gets to guess on how big the volume needs to be until they get it right...
20:30:15 <hub_cap> #topic next replication meeting Thursday, 11th July 1 p.m. PST/3 p.m. CST
20:30:19 <hub_cap> that is all
20:30:24 <hub_cap> CMON THIS SUX
20:30:29 <SlickNik> sounds good
20:30:38 <imsplitbit> what sucks about it?
20:30:42 <SlickNik> I know, no bot :(
20:30:51 <imsplitbit> oh
20:30:56 <konetzed> bots make everthing better
20:30:58 <hub_cap> woot
20:31:01 <imsplitbit> yeah
20:31:05 <SlickNik> he's back?
20:31:06 <imsplitbit> #agree
20:31:06 <hub_cap> #topic next replication meeting Thursday, 11th July 1 p.m. PST/3 p.m. CST
20:31:12 <vipul> so it's likely this meeting notes are not being captured?
20:31:19 <konetzed> vipul: i would say no
20:31:19 <hub_cap> yea prolly not
20:31:20 <SlickNik> very likely.
20:31:22 <imsplitbit> vipul: correct
20:31:22 <hub_cap> :(
20:31:25 <hub_cap> he prolly died
20:31:25 <jeblair> actually
20:31:27 <jeblair> they might be
20:31:33 <hub_cap> well only 1 way to find out!!!!!
20:31:34 <jeblair> i think the bot just doesn't have ops to set the channel
20:31:35 <konetzed> someone can check
20:31:37 <jeblair> topic
20:31:53 <jeblair> which meeting is this?
20:31:55 <hub_cap> ya anyway we have to update that blueprint w/ the stuff we talked about
20:31:58 <hub_cap> trove jeblair
20:32:07 <SlickNik> http://eavesdrop.openstack.org/meetings/trove/2013/
20:32:13 <jeblair> yeah http://eavesdrop.openstack.org/meetings/trove/2013/trove.2013-07-10-20.00.log.txt
20:32:16 <jeblair> it's being recorded
20:32:24 <vipul> cool
20:32:24 <hub_cap> i think if anyone knows whats goin on w the blueprint, grapex does, so its all good
20:32:48 <hub_cap> so i didnt have anythign to say about that topic
20:32:51 <hub_cap> jsut bringing it up
20:32:52 <hub_cap> moving on
20:33:06 <hub_cap> #topic Mission stmt finalized
20:33:08 <hub_cap> no one has sent me any updates
20:33:19 * datsun180b end-zone dances
20:33:21 <hub_cap> so im going to send that mission statement out
20:33:21 <vipul> has it been sent out to ML?
20:33:24 <hub_cap> not yet
20:33:26 <imsplitbit> oh I must have missed this
20:33:28 <hub_cap> i wanted us, as a gropu to update it
20:33:36 <hub_cap> did we still get no change to topic
20:33:38 <hub_cap> BOOOOOOOOO
20:33:46 <vipul> https://wiki.openstack.org/wiki/Trove
20:33:49 <hub_cap> jeblair: its broken again me thinks
20:33:50 <imsplitbit> we have a mission statement now?
20:33:54 <vipul> it's there
20:33:56 <imsplitbit> sweet
20:34:03 <hub_cap> thx for the update jeblair
20:34:06 <grapex> So wait are we now a Mission or a Program?
20:34:14 <hub_cap> Program w a mission
20:34:21 <grapex> I'm holding out until we're a Strike Force.
20:34:33 <imsplitbit> I'm with grapex on that one
20:34:37 <hub_cap> u should call your internal team that grapex
20:34:39 <datsun180b> grapex: Agent of S.H.I.E.L.D.
20:34:43 <hub_cap> stroke force delta tacos
20:34:46 <hub_cap> LOL
20:34:47 <hub_cap> strike
20:34:54 <hub_cap> wow talk about a bad misspel
20:34:57 <SlickNik> lol
20:35:08 <hub_cap> and yes this meeting _is_ being recorded
20:35:30 <hub_cap> #topic extensions
20:35:40 <hub_cap> ps topic changes arent being recorded but thats ok
20:35:52 <hub_cap> so, we discussed last wk that they were a big ole fail
20:36:06 <hub_cap> i think that grapex needs to discuss how they are broken currently as well
20:36:22 <hub_cap> we all know that we need to use stevedore and junk like that eventually
20:36:28 <hub_cap> but hes got a intermediary problem
20:36:36 <hub_cap> grapex: care to divulge
20:37:14 <grapex> hub_cap: Sure! Is this extensions?
20:37:23 <hub_cap> yes
20:37:28 <imsplitbit> #topic extensions
20:37:32 <imsplitbit> boo
20:37:36 <hub_cap> imsplitbit: i already did that
20:37:37 <hub_cap> its nto working
20:37:41 <hub_cap> #topic extensions
20:37:43 <hub_cap> maybe it is now
20:37:47 <grapex> So we've noticed that in trove/extensions/ there are a series of Python files which have the same names as the directories
20:37:47 <hub_cap> jeblair:  is on it
20:37:48 <SlickNik> woot!
20:37:48 <imsplitbit> I saw openstack joined
20:37:54 <imsplitbit> thought I'd try
20:38:08 <hub_cap> imsplitbit: i think only meetin chair can change topic
20:38:09 <SlickNik> imsplitbit: only the person who started the meeting can change the topic.
20:38:10 <grapex> so if you try to import the modules in those directories from anywhere other than those particular files it won't work
20:38:14 <imsplitbit> ah
20:38:22 <imsplitbit> well fooey
20:38:27 <grapex> So for example
20:38:46 <grapex> In many contexts, "from trove.extensions.account import models" fails
20:38:57 <grapex> because it finds "trove/extensions/account.py"
20:39:31 <grapex> I was thinking, the several files in trove/extensions could be moved to somewhere else, and then we could just make that the default place for extensions
20:39:33 <grapex> like maybe
20:39:47 <grapex> contrib/extensions/account.py, contrib/extensions/mgmt.py etc
20:40:05 <grapex> Then point the extensions to contrib/extensions, since the current (yucky) way extensions works is file based
20:40:41 <grapex> Then, we could put any useful classes that are in those bad files such as trove/extensions/mgmt.py's "Mgmt" class into the __init__.py sitting in the folder of the appropriate name
20:40:41 <vipul> yea that would work.. do we have stuff that needs to go into trove/extensions that is not part of the exisitng API extensions?
20:41:20 <grapex> Well at Rax we do. We actually have some billing code which we need a MGMT API extension for. It's all stuff that talks to the Rax system.
20:41:57 <grapex> So we went to make an extension directory of our own and figured out if we did that we wouldn't be able to import any of the modules sitting in the current extension directory.
20:42:08 <vipul> Ok, yea i'm fine with it..
20:42:18 <SlickNik> I know the extension classes have changed upstream in oslo quite a bit.
20:42:19 <vipul> we would jsut module extensions in trove/extensions
20:42:51 <hub_cap> SlickNik: they dont exist anymore in oslo lol
20:42:55 <vipul> SlickNik: would it be worth pulling in latest to see if it satisfies what grapex wants to do?
20:42:56 <SlickNik> Wonder if there are any changes to address this problem that you mention grapex...
20:43:04 <vipul> hub_cap: oh
20:43:19 <SlickNik> hub_cap; I think they have plugins now.
20:43:20 <hub_cap> #link https://github.com/openstack/oslo-incubator/tree/master/openstack/common
20:43:21 <grapex> vipul: The issue isn't entirely the Oslo extension feature as much as that we have import failures.
20:43:30 <SlickNik> I don't know how similar or different they are to extensions.
20:43:39 <hub_cap> whatever they have, its not in oslo as i se it
20:43:47 <hub_cap> so this is 2 things
20:43:58 <hub_cap> 1) tim needs to import stuff and cant -- needs to get fixed
20:44:01 <SlickNik> ah, maybe they took that out too...
20:44:10 <hub_cap> 2) we need to update extensions, period, and use stevedore
20:44:17 <hub_cap> he cares less about #2 now
20:44:18 <grapex> hub_cap: Yes
20:44:36 <hub_cap> so there will be a small extension refactor i think coming down the line for #1
20:44:40 <hub_cap> and then later a big one for #2
20:44:45 <SlickNik> I'm okay with moving extensions so that grapex is unblocked.
20:44:46 <hub_cap> just wanted to make everyone aware
20:44:54 <hub_cap> grapex: plz BP it ;)
20:44:55 <grapex> hub_cap: Good summary.
20:44:57 <grapex> Will do
20:45:11 <hub_cap> ok thats really it...
20:45:19 <hub_cap> #topic open discussion
20:45:23 <hub_cap> we have 15 min now
20:45:39 <hub_cap> i want to reiterate that h2 is < 1 wk away from being cut
20:45:54 <hub_cap> id love to get the config stuff merged by then *wink wink*
20:46:07 <hub_cap> and possibly the rpm stuff as well
20:46:14 <hub_cap> which is still a WIP
20:46:25 <grapex> hub_cap: I'll try to look at that
20:46:26 <imsplitbit> well hurry up
20:46:31 <imsplitbit> :)
20:46:31 <hub_cap> lol right imsplitbit?!?
20:46:36 <hub_cap> plz do grapex
20:46:42 <SlickNik> hub_cap: when's the cut date?
20:46:45 <hub_cap> im going to use a __metaclass__ thing
20:46:51 <hub_cap> #link https://launchpad.net/trove/+milestone/havana-2
20:46:56 <hub_cap> under Expected
20:47:05 <vipul> hub_cap: you forgot my topic :P
20:47:06 <vipul> https://blueprints.launchpad.net/trove/+spec/admin-create-restore-backups
20:47:13 <vipul> i wanted to run this by you guys...
20:47:19 <hub_cap> oi sry vipul
20:47:20 <SlickNik> hub_cap: thanks
20:47:32 <hub_cap> hehe refresh was needed vipul
20:47:36 <hub_cap> lets talk about that
20:47:37 <hub_cap> #undo
20:47:37 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x2fc5710>
20:47:45 <hub_cap> oops i hop ethat didnt undi the last action
20:47:49 <hub_cap> fudge lemme go find it
20:47:53 <vipul> so we'd like to introduce an Admin api to take backups on behalf of customer
20:48:12 <hub_cap> #action SlickNik write initial dev docs.
20:48:12 <vipul> I think this will be useful down the road when we do scheduled backups anyway
20:48:30 <vipul> since we'd want the scheduled backups to be iniated by us
20:48:38 <hub_cap> vipul: youre a lawbreaker making your own bps
20:48:49 <vipul> sshhh..don't tell anyone :)
20:48:51 <hub_cap> hehe
20:48:58 <imsplitbit> vipul fought the law and the law won
20:49:00 <hub_cap> i think that a sensible admin api call
20:49:06 <hub_cap> LOL imsplitbit
20:49:08 <imsplitbit> agree
20:49:12 <konetzed> vipul: makes perfect sense to me
20:49:12 <hub_cap> grapex: seem sensible to u?
20:49:18 <vipul> what about the restore use case?
20:49:23 <vipul> agree to that one as well?
20:49:39 <hub_cap> i dont see how it would be a bad thing
20:49:39 <konetzed> vipul: yes
20:49:43 <grapex> hub_cap: I think so
20:49:45 <vipul> cool then that was easy
20:49:48 <hub_cap> ya
20:49:52 <hub_cap> i mean its admin api
20:49:55 <SlickNik> vipul: I'm convinced on the scenarios.
20:49:56 <hub_cap> u can do whateveru want in admin api
20:50:01 <imsplitbit> I think it is sensible for an admin to take backups and restore them on behalf of users
20:50:06 <hub_cap> u could even... dleete a whole host
20:50:10 <konetzed> hub_cap: pony and shake machine?
20:50:11 <SlickNik> vipul: the design and implementation may be a bit trickier.
20:50:14 <hub_cap> god i wish erik was in here for that joke
20:50:14 <vipul> yup, just making sure it aligned with what we want to do with automated backups
20:50:17 <hub_cap> konetzed: done
20:50:22 <redthrux> HAAAA
20:50:25 <hub_cap> oh he is
20:50:26 <hub_cap> :)
20:50:30 <redthrux> HECK YEAH I AM
20:50:32 <redthrux> where's morris
20:50:41 <SlickNik> he's here too.
20:50:52 <hub_cap> nope he was on the bad side of the netsplit
20:50:56 <SlickNik> (or at least was here)
20:51:01 <hub_cap> lol
20:51:09 <konetzed> morris pinged out
20:51:13 <djohnstone> He had to run home for something.
20:51:16 <hub_cap> i have approved your BP vipul
20:51:26 <vipul> sweet <3
20:51:29 <hub_cap> ok back to the open conversation
20:51:36 <hub_cap> anything else anyone wants to discuss?
20:51:49 <grapex> hub_cap: https://blueprints.launchpad.net/trove/+spec/fix-extensions-imports <-- extension stuff
20:52:03 <grapex> hub_cap: Sure... where do we go when we die?
20:52:05 <SlickNik> #link https://blueprints.launchpad.net/trove/+spec/fix-extensions-imports
20:52:13 <hub_cap> plz put series goal and milestone grapex
20:52:21 <hub_cap> ive approve the direction for that grapex
20:53:04 <SlickNik> These are h3, I take it?
20:53:12 <hub_cap> grapex: listen to this and u will know http://en.wikipedia.org/wiki/Are_We_Not_Horses
20:53:12 <grapex> hub_cap: Done... I put 2. Too soon?
20:53:28 <hub_cap> are u doing it?
20:53:42 <hub_cap> if u feel confident itll be done / merged in < 1 wk
20:53:45 <hub_cap> then its not too soon
20:53:46 <hub_cap> ;)
20:53:58 <hub_cap> LOL
20:54:00 <grapex> hub_cap: Well, pdmars will probably do it. I'll reassign
20:54:01 <hub_cap> the more stuff the better in h2
20:54:06 <hub_cap> itll make us look cool
20:54:16 <grapex> hub_cap: Is this like at Rax where we get points?
20:54:31 <hub_cap> yes
20:54:48 <hub_cap> http://bittetumirnichtsaberschenll.files.wordpress.com/2012/01/tumblr_lpyxbhxroc1r1rvcno1_5001.gif
20:55:08 <esp> lol
20:55:10 <SlickNik> …and so are fez's.
20:55:13 <esp> I like bow ties
20:55:17 <hub_cap> EXACTLY SlickNik
20:55:25 <konetzed> SlickNik: fez's arnt cool
20:55:36 <hub_cap> so if pd is working on it grapex i feel confident itll get done in h2
20:56:06 <hub_cap> http://25.media.tumblr.com/53de2142353b6be0fb09cf7be4ca9b7b/tumblr_mnfscjWStQ1s7931jo1_500.jpg
20:56:12 <hub_cap> anyhoo
20:56:19 <hub_cap> anyone have anything else to discuss?
20:56:29 <hub_cap> weve got a good bit of open reviews so lets spend smoe time reviewing
20:56:36 <hub_cap> LOL Guest5565
20:56:47 <SlickNik> There are a couple that need rebasing.
20:56:53 <hub_cap> i saw SlickNik
20:57:00 <hub_cap> go look @ the reviews youve posted... see if they need rebase
20:57:02 <hub_cap> plz :)
20:57:20 <SlickNik> yes, please look if you need a rebase.
20:57:23 <hub_cap> lets make it a point to cover the reviews in the next day or 2 grapex SlickNik vipul
20:57:31 <vipul> word
20:57:36 <hub_cap> id like to get as much merged as possible for our h2 release
20:57:37 <SlickNik> roger that.
20:57:44 <hub_cap> and vipul hate to say this but
20:57:58 <hub_cap> it might be better to wait for h3 to open to merge the oslo stuff
20:58:00 <hub_cap> juuuuuuuust in case
20:58:11 <hub_cap> or wait till h2 is cut at least
20:58:15 <hub_cap> u ok w/ that?
20:58:21 <vipul> i'll get it to pass
20:58:26 <vipul> actually the tests passed.. just timed out
20:58:30 <hub_cap> kk
20:58:39 <vipul> would be cool if we could get it in sooner, unless thre are other reasons
20:58:39 <hub_cap> lets chat it offline. i guess its ok for now since we arent official
20:58:43 <hub_cap> but in the future
20:58:52 <hub_cap> we need to consider people might be pullnig down these artifacts and using them
20:58:58 <hub_cap> as opposed to flying w/ trunk
20:59:06 <hub_cap> so large changes, begin of milestones
20:59:12 <vipul> sure.. makes sense
20:59:13 <hub_cap> im coo w/ it for this one
20:59:24 <hub_cap> ok w/ that
20:59:26 <hub_cap> #endmeeting