20:02:49 <hub_cap> #startmeeting trove
20:02:50 <openstack> Meeting started Wed Jul  3 20:02:49 2013 UTC.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:53 <openstack> The meeting name has been set to 'trove'
20:02:55 <hub_cap> i almost did startmeeting reddwarf
20:03:05 <vipul> o/
20:03:07 <hub_cap> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
20:03:13 <hub_cap> \o
20:03:17 <kevinconway> \o/
20:03:21 <hub_cap> hands across america
20:03:22 <datsun180b> o7
20:03:28 <robertmyers> \o
20:03:41 <datsun180b> does that actually take role for us?
20:03:53 <vipul> don't think so
20:03:53 <SlickNik> o/
20:03:58 <kevinconway> i think just saying something in the channel logs you
20:03:59 <hub_cap> nope
20:04:01 <hub_cap> its just cool
20:04:12 <datsun180b> oh it's roll call anyway
20:04:18 <hub_cap> so lets get started seems like we have enough people
20:04:22 <hub_cap> whers grapex_?
20:04:29 <hub_cap> hes the only one from core i dont see here
20:04:34 <konetzed> hub_cap: i thought he said he would be late
20:04:40 <datsun180b> he did
20:04:43 <hub_cap> ok
20:04:49 <hub_cap> #topic action items
20:04:53 <hub_cap> #link http://eavesdrop.openstack.org/meetings/trove/2013/trove.2013-06-25-21.04.html
20:05:12 <hub_cap> esmute SlickNik vm-gate integration status?
20:05:49 <hub_cap> tap tap tap... is this thing on
20:05:50 <esmute> Damn.. feel bad.. been dragging this for a while
20:05:54 <hub_cap> its ok
20:05:56 <SlickNik> still work in progress...
20:06:00 <hub_cap> no update is a status
20:06:11 <hub_cap> re-action it plz
20:06:14 <hub_cap> wait
20:06:22 <hub_cap> just add it ot the meeting as a thing to talk about each wk
20:06:28 <hub_cap> then it will annoy u enough to do it
20:06:30 <hub_cap> :D
20:06:35 <SlickNik> Okay, I will do that. :)
20:06:42 <hub_cap> juice: vipul whats this about packaging in heat?
20:06:46 <esmute> i spoke briefly with clarkb and he gave me some points where to start
20:06:58 <hub_cap> heat doesnt define the "how" for packaging
20:07:02 <vipul> hub_cap: didn't get a chance to look into this yet
20:07:10 <hub_cap> vipul: can u add to agenda
20:07:12 <vipul> this was supposed to be used as an example for how we'd split guestagent
20:07:14 <hub_cap> so i can get caught up on your conerns
20:07:21 <hub_cap> ok
20:07:21 <vipul> Sure
20:07:24 <hub_cap> lets talk about it
20:07:28 <juice> hub_cap: I think it's less about heat and more about coming up with better packages for trove
20:07:32 <juice> yes?
20:07:36 <juice> vipul?
20:07:39 <vipul> yep
20:07:43 <hub_cap> sure, dont u mean tarballs :P
20:07:47 <vipul> using heat's example pretty much
20:07:59 <juice> no zip files
20:08:02 <juice> :)
20:08:06 <hub_cap> HA
20:08:10 <hub_cap> ok we talked about replication
20:08:17 <hub_cap> and ive added a "lets talk about it again" to the agenda
20:08:24 <hub_cap> we should pick another time to meet
20:08:37 <hub_cap> oh and this time, lets do it _in_ a room w/ meetbot
20:08:46 <hub_cap> so we can have minutes etc for it
20:09:07 <SlickNik> that sounds good.
20:09:12 <hub_cap> tehre was some concern on our end about /instances and /clusters not overlapping but we can talk about that during the next meeting
20:09:18 <vipul> sure
20:09:25 <hub_cap> vipul: i updated the wiki article already ;)
20:09:35 <vipul> noticed that :) thanks hub_cap
20:09:41 <vipul> we got a bunch of broken links though..
20:09:53 <vipul> #action vipul to fix broken links hanging off wiki.openstack.org/trove
20:10:10 <hub_cap> #action hub_cap to help out w/ the changes
20:10:21 <hub_cap> ive done, id say, 30% of the changes to random pages from a search i had done
20:10:41 <hub_cap> SlickNik: looks like the last one is u
20:10:49 <hub_cap> im assuming the rename+jenkins is ok
20:10:54 <hub_cap> so lets talk about those dev dox
20:11:00 <SlickNik> Yeah, I looked into it a bit.
20:11:04 <grapex_> o/
20:11:13 <hub_cap> hello grapex_!
20:11:22 <SlickNik> These are built by the CI infra team as part of a different "documentation" job.
20:11:25 <hub_cap> you havent missed much still in action items territory
20:11:31 <grapex_> hub_cap: I read.
20:11:40 <vipul> looks like you've inherited an _ isntead of a character :)
20:11:42 <hub_cap> ok so we need to spend some cycles on the CI infra/docs stuff then eh?
20:11:49 <hub_cap> lol vipul
20:12:03 <grapex_> vipul: I hopped over another user on freenode. It's like getting crowned in checkers.
20:12:09 <SlickNik> Yes. Building it is fairly straightforward.
20:12:23 <hub_cap> ok good deal
20:12:24 <SlickNik> We need to figure out what we want to publish in these docs.
20:12:27 <hub_cap> grapex_: ghost cmd
20:12:39 <robertmyers> grapex_: register your nick
20:12:53 <hub_cap> ok seems a bit low prio to me, but we are getting more and more questions about deving in trove
20:13:17 <SlickNik> Perhaps some of the trove-integration docs would be a good start and we can build on that.
20:13:32 <hub_cap> probably so SlickNik
20:13:37 <hub_cap> lets do this
20:13:46 <hub_cap> next n00b in trove writes docs ;)
20:13:50 <datsun180b> I don't know if people trying to develop with/on Trove should be "low prio"
20:13:51 <SlickNik> lol
20:13:57 <juice> ha ha
20:14:03 <juice> that's a new one :)
20:14:03 <hub_cap> datsun180b: tahts not a low prio docs are
20:14:10 <SlickNik> I'll get a job up and running so that there will be a place to write them too.
20:14:13 <hub_cap> but as soon as more people ask, theyu become a high prio
20:14:20 <datsun180b> right
20:14:26 <vipul> one thing that would really be good is a install guide
20:14:27 <hub_cap> basically the ammt of uptick defines the priority
20:14:29 <hub_cap> now its low :)
20:14:32 <SlickNik> s/too/to
20:14:33 <vipul> like what all the configuration params mean
20:14:40 <vipul> kinda like Nova has an op's guide
20:14:41 <hub_cap> vipul: yes thats a good idea
20:14:57 <datsun180b> I'm trying to leapfrog install guides with vagrant with moderate success
20:15:00 <hub_cap> the CERN guys are asking how to install this in a non 'dev env' way
20:15:21 <SlickNik> #action SlickNik to look into getting a documentation ci-infra job up.
20:15:24 <vipul> SlickNik: where would such guides be committed?
20:15:34 <datsun180b> deployment guides would be really nice
20:15:50 <hub_cap> #agreed
20:15:55 <hub_cap> lets move on we have a big agenda
20:16:07 <hub_cap> vipul: get w/ SlickNik to see where they go, im interested as well
20:16:14 <vipul> coo
20:16:14 <hub_cap> #topic h2 blueprints
20:16:21 <SlickNik> vipul: I think a different repo, although I've seen some variations in what other projects do.
20:16:37 <hub_cap> fwiw, since we are incubated, we need to keep better track of the blueprints and when they are integrated
20:16:40 <hub_cap> err implemented
20:16:52 <hub_cap> ive seen a lot of code go thru the last few wks but no blueprints actually marked as implemented
20:17:01 <hub_cap> there is no automated process for this
20:17:07 <hub_cap> its your mouse and clicking
20:17:08 <hub_cap> :D
20:17:13 <datsun180b> and hudson doesn't actually close the bps does he
20:17:14 <SlickNik> vipul: so will talk to clarkb to see what the intended location is.
20:17:15 <hub_cap> #link https://launchpad.net/trove/+milestone/havana-2
20:17:20 <hub_cap> datsun180b: correct
20:17:36 <datsun180b> it might help if we approved the bps ahead of merges too
20:17:39 <SlickNik> hub_cap: I don't use a mouse.
20:17:44 <hub_cap> plz go over the blueprints you have implemented in havana and make sure they are there
20:17:51 <vipul> is this list ok to change? meaning can i add stuff to H2?
20:17:53 <hub_cap> SlickNik: s/mouse/trackpad
20:18:03 <hub_cap> vipul: if u think it can be implemented in 2wks yes
20:18:07 <hub_cap> or if its alrady done
20:18:07 <vipul> adn what is the date for the h2 milestone
20:18:10 <hub_cap> then hell yes
20:18:17 <hub_cap> its on that page vipul
20:18:22 <hub_cap> 2013-07-18
20:18:23 <vipul> oh
20:18:25 <vipul> got it thanks
20:18:50 <hub_cap> #action hub_cap vipul to make sure all blueprints that are actually in master are in h2 + implemented status
20:18:55 <hub_cap> lets split it up vipul and do it
20:19:03 <SlickNik> hub_cap: I see you've already marked a bunch of them as completed.
20:19:04 <SlickNik> Thanks
20:19:07 <vipul> Ok sounds good.. i know half of those may have already been complete
20:19:07 <hub_cap> cp16net: you have a BLOCKED bp in h2
20:19:09 <hub_cap> SlickNik: correct
20:19:14 <hub_cap> vipul: im sure they are
20:19:20 <cp16net> oh
20:19:21 <hub_cap> we just ahvent been diligent about it (yet!)
20:19:28 <hub_cap> should that be in h2?
20:19:32 <hub_cap> is it completely necessary?
20:20:07 <hub_cap> and juice i assume yours will be done by then eh? i think grapex_ +2'd u today
20:20:40 <vipul> does this mean we tag on 7/18?
20:20:41 <cp16net> hmm i forgot about that
20:20:43 <hub_cap> im going to look @ it after i eat some lunch today juice as well
20:20:48 <hub_cap> vipul: on or around yes
20:20:57 <hub_cap> and we dont, ttx does
20:21:03 <hub_cap> he has some automation for all of this
20:21:08 <vipul> sweet
20:21:16 <SlickNik> nice
20:21:20 <hub_cap> so we will have official h2 pkgs
20:21:24 <cp16net> its a good bp but i havnt had time to go back and fix it up with other things i have been working on
20:21:33 <hub_cap> ok cp16net plz move it to h3
20:21:45 <hub_cap> core team
20:21:50 <hub_cap> we need to sit down and look @ all the bps
20:21:59 <hub_cap> and decide whats 100% necessary for havana
20:22:14 <hub_cap> #action hub_cap to grab core and discuss blueprints sometime next wk
20:22:20 <hub_cap> ill take a pass
20:22:25 <hub_cap> and then we can discuss the rest
20:22:30 <hub_cap> ive taken a few passes already too
20:22:39 <SlickNik> Sounds good, hub_cap.
20:22:44 <hub_cap> aight horse beaten. anything else on the subject?
20:22:56 <vipul> how many milestones are there in havana
20:23:01 <vipul> and how long is each
20:23:02 <hub_cap> vipul: 3 in all releases
20:23:07 <hub_cap> 2mo ea
20:23:22 <vipul> k
20:23:22 <cp16net> hub_cap: moved to h3
20:23:26 <hub_cap> #link https://launchpad.net/trove/havana
20:23:32 <hub_cap> ttx deleted our h1 since we didnt push a release
20:23:42 <hub_cap> and moved all the h1 completed stuff to h2
20:23:48 <SlickNik> hub_cap: There are a few bps that are still marked as grizzly. Probably want to reset them as you're taking a pass.
20:23:58 <hub_cap> SlickNik: ya i saw that yest
20:24:01 <hub_cap> if they arent in already def
20:24:23 <hub_cap> moving on, eh?
20:24:32 <SlickNik> cool, sounds good.
20:24:43 <hub_cap> #topic Cluster+Heat findings
20:24:53 <hub_cap> #link https://wiki.openstack.org/wiki/Trove/HeatIntegration
20:25:07 <hub_cap> i had some misconceptions from the #heat channel a few days ag
20:25:08 <hub_cap> *ago
20:25:23 <hub_cap> heat will fit into clustering quite nicely
20:25:51 <hub_cap> but it dropped on my prio list a bit
20:26:03 <hub_cap> so im going to finish rhel integration and then move to heat
20:26:44 <datsun180b> Those last allcaps notes make it sound like Mr. Hyde took over while you were editing
20:27:07 <hub_cap> datsun180b: he did
20:27:11 <hub_cap> hes my sanity
20:27:28 <hub_cap> ok so does anyone have anything to add here?
20:27:43 <vipul> I guess some background on how you had originally planned to use it
20:27:44 <hub_cap> itll be pretty straightforward. ill push things in small reviews
20:27:52 <vipul> and how do you see things now
20:28:11 <hub_cap> sure vipul there is a email that explains things well but ill summarize (more context in email if needed)
20:28:19 <hub_cap> datsun180b:  can u find the pipermail link to that email chain?
20:28:39 <hub_cap> so 1) launch configuration defines the flavor for a grouping of instances
20:28:41 <datsun180b> I don't know all of those words
20:29:02 <hub_cap> datsun180b: like http://lists.openstack.org/pipermail/openstack-dev/2013-May/009666.html
20:29:09 <hub_cap> but for our email
20:29:12 <hub_cap> the one that i sent to the list while im typing this stuff
20:29:24 <SlickNik> #link http://lists.openstack.org/pipermail/openstack-dev/2013-July/011289.html
20:29:35 <SlickNik> got it.
20:29:37 <hub_cap> so we dont need to specify a launch configuration and one of the core devs doesnt even like them
20:29:41 <datsun180b> with the heat reasons?
20:29:43 <hub_cap> originally i thought it had to be homogeneous
20:29:48 <hub_cap> datsun180b: SlickNik linked it
20:29:50 <datsun180b> there you go
20:29:56 <datsun180b> i'm helping!
20:30:07 <hub_cap> but thats not the case, resizes on individual instances in a stack are a-ok
20:30:17 <vipul> ok so that allows us to have differnt flavors for instances in a single template?
20:30:19 <hub_cap> which is necessary
20:30:23 <hub_cap> correct vipul
20:30:27 <hub_cap> so it meets that criteria
20:30:41 <hub_cap> also you can add/remove pretty easily, just by specifying changes to your yaml config
20:30:48 <hub_cap> s/config/template
20:31:01 <hub_cap> so that meets the criteria of scaling up/down
20:31:23 <hub_cap> and the nodes can be different, as in u can have a primary and a secondary in the same template
20:31:53 <SlickNik> I think the last point is key for us.
20:31:54 <hub_cap> so they can all be easily grouped together (i was originally told that the secondarys/replicas/etc could be one stack but the primary had to be its own)
20:31:56 <vipul> Ok makes sense
20:32:46 <SlickNik> i.e. the fact that we can have multiple heterogenous nodes in the same template.
20:32:59 <vipul> but so some work is needed in Heat to support all this?
20:33:33 <hub_cap> vipul: not really
20:33:40 <hub_cap> lol heat is talking about trove in #openstack-meeting
20:33:46 <hub_cap> HAAHAHHA circular dependency
20:33:50 <asalkeld> hey ...
20:34:20 <asalkeld> (probably other heaters here if you have questions)
20:34:22 <SlickNik> I think we need to come up with the right templates that suit our needs.
20:34:36 <amytron> heaters gonna heat
20:34:36 <hub_cap> SlickNik: ive got a template already
20:34:40 <hub_cap> LOL
20:34:56 <hub_cap> but thats about as far as i got SlickNik, was testing and getting a template working
20:35:14 <SlickNik> lol@amytron
20:35:17 <hub_cap> BUT ill only be impl'ing it for single instances for now, obvi since we dont have clusters yet
20:35:25 <hub_cap> but ill help guide the integration for clusters
20:36:40 <hub_cap> ok this is hard doing both
20:36:42 <hub_cap> lets move on
20:36:46 <SlickNik> sounds like a plan, hub_cap
20:36:47 <vipul> heh
20:36:58 <hub_cap> #topic next replication meeting
20:37:08 <hub_cap> someone spit out some times
20:37:21 <vipul> Thursday @1pst
20:37:34 <SlickNik> That works for me.
20:37:51 <datsun180b> I can't use doodle again, my free trial expired
20:38:11 <datsun180b> at least i don't get the full feature set or something
20:38:14 <SlickNik> heh, hopefully we won't have to resort to doodle again..
20:39:01 <hub_cap> yes i dont care about a doodle, lets say sometime tomorrow
20:39:08 <hub_cap> LOL JK
20:39:10 <hub_cap> monday
20:39:11 <hub_cap> what time
20:39:12 <SlickNik> lol
20:39:19 <hub_cap> when was the last oen? lets do it again at the same time next wk
20:39:23 <hub_cap> day/time
20:39:32 <vipul> thursday 1pst?
20:39:36 <vipul> :)
20:40:08 <SlickNik> Last one was on Thursday 1PST/ 3CST
20:40:19 <SlickNik> Ah, I see what you did there, vipul :)
20:40:41 <hub_cap> :P
20:40:46 <hub_cap> do we want to hold the next one tomorrow
20:40:49 <hub_cap> HEHE
20:40:52 <hub_cap> next thr?
20:41:05 <SlickNik> Yeah, I think that's what vipul was suggesting.
20:41:20 <SlickNik> (Or at least I hope that's what he was suggesting)
20:41:31 <vipul> oh yea i meant next week lol
20:41:38 <esp> phew!
20:41:45 <hub_cap> ok good
20:41:50 <hub_cap> someone #action it and we can move on
20:41:57 <hub_cap> i have averted my double meeting crisis
20:41:57 <kevinconway> tomorrow 8:00 AM CST is good for me
20:42:15 <hub_cap> kevinconway: im glad you dont care about your 4th of july holiday
20:42:16 <hub_cap> but the rest of us do
20:42:19 <hub_cap> :P
20:42:20 <vipul> kevinconway always suggesting those gawd awful times
20:42:40 <SlickNik> #action Next meeting to discuss replication: Thursday, 11th July 1 p.m. PST/3 p.m. CST
20:42:44 <hub_cap> kevinconway must not understand >1 TZ for trove hehe
20:43:00 <datsun180b> i think he exactly understands
20:43:07 <hub_cap> i know ;)
20:43:09 <hub_cap> moving on?
20:43:18 <vipul> o7
20:43:23 <hub_cap> #topic guest-agent packaging
20:43:39 <hub_cap> i was literally JUST talking about this in #openstack-meeting w/ heat
20:43:56 <hub_cap> we came to the conclusion of no pypi lol
20:44:00 <vipul> this kinda force our hand in splitting the repo?
20:44:23 <vipul> what's the suggestion instead
20:44:29 <hub_cap> no suggestion instead
20:44:37 <hub_cap> just dont use pypi
20:44:47 <hub_cap> id like to help yall w/ this
20:45:01 <hub_cap> since itll affect the heat-trove integration as well
20:45:15 <hub_cap> i dont think i have any good ideas as of now tho
20:45:21 <vipul> well we have the ability to bake into images
20:45:30 <hub_cap> NO
20:45:41 <hub_cap> then we need to roll a new image to test any guest changes
20:45:46 <vipul> yup
20:45:47 <hub_cap> thats the opposite of what we want :D
20:46:06 <vipul> so are we talking in devstack context or how heat would consume the agent?
20:46:08 <hub_cap> itll be interesting, cuz it has to be different
20:46:15 <hub_cap> vipul: i dont know
20:46:22 <hub_cap> what are we talking about lol
20:46:35 <vipul> hmm
20:46:37 <hub_cap> im starting (mentally) from local development
20:46:39 <vipul> :|
20:46:55 <hub_cap> if what yall were talking about last wk was different then plz correct me!!
20:47:18 <hub_cap> im like a child that wanders into the middle
20:47:18 <SlickNik> Aren't there really 2 different issues here. PyPi only talks about the vector of delivery. The work to split the guest agent to live in its own separate repo is tangential...
20:47:22 <vipul> So we talked about splitting out guest-agent inot own repo..
20:47:38 <vipul> SlickNik: it actualy solves the packaging issue
20:47:49 <hub_cap> yes im ok w/ splitting repos
20:47:51 <hub_cap> that makes sense
20:47:55 <vipul> Since we could just have a setup.py in the new repo that pushed to pypi
20:48:12 <vipul> and you'd be able to release a version of guest agent in the same cycle as Trove
20:48:16 <hub_cap> the heat guys seem to dislike pypi cuz of its speed / reliability
20:48:21 <SlickNik> Well, you could have the setup.py and still not use pypi.
20:48:34 <vipul> correct..
20:48:39 <SlickNik> (but use something like tarballs instead)
20:48:47 <SlickNik> But we can cross that bridge when we get to it.
20:49:03 <vipul> Basically we have no way to independently version the guest agent currently
20:49:07 <hub_cap> so we need to solve 1) local dev, 2) devstack, 3) production-esque installations
20:49:08 <vipul> so how do we solve that
20:49:43 <hub_cap> tripleo can help us solve #2 and #3
20:50:08 <hub_cap> #link https://github.com/stackforge/tripleo-image-elements/blob/master/elements/heat-cfntools/install.d/05-heat-cfntools
20:50:20 <hub_cap> this is how heat-cfntools is installed in an element
20:50:26 <hub_cap> we can install the guest in the same way
20:50:59 <vipul> yea that would be fine.. so a requirement for that is to split the repo
20:51:07 <hub_cap> correct
20:51:09 <hub_cap> i mean its not honestly
20:51:14 <hub_cap> but its a nicety
20:51:21 <hub_cap> so really the _only_ reason we _have_ to split
20:51:24 <hub_cap> is for pypi
20:51:54 <SlickNik> hub_cap: there's a couple of other advantages to splitting the repo as well.
20:51:58 <hub_cap> sure
20:51:59 <vipul> when trove is tagged with havana-2.. what's the deliverable of that?
20:52:08 <vipul> i think it just means that it goes to pypi
20:52:16 <hub_cap> server/guest are deliverables
20:52:23 <SlickNik> We'd be able to use endpoints for the guestagent.
20:52:26 <hub_cap> so it makes sense to have independent ones
20:52:31 <hub_cap> SlickNik: endpoints?
20:52:51 <SlickNik> Enabling us to use stevedore, for instance.
20:52:55 <hub_cap> and are you solving 1, 2, or 3?
20:52:58 <vipul> entrypoints
20:52:58 <SlickNik> sorry entry_points
20:53:00 <juice> our personal little packaging of trove that annashen did supports separate versions of guest and trove-api
20:53:11 <juice> using the current layout
20:53:17 <hub_cap> for sure juice
20:53:32 <hub_cap> mordred: says pypi hates > 1 deliverable in 1 project ( i believe)
20:53:47 <hub_cap> but regardless, im not arguing against splitting
20:53:58 <hub_cap> im just trying to figure out what the higest prios are
20:54:02 <mordred> well, the other reason you have to split is for OpenStack CI
20:54:07 <juice> pypi doesn't seem to support much of anything AND in any case it's a bit ugly but it does seem to work fine
20:54:09 <esp> does splitting guest agent to another repo imply that we will have a common-trove package?
20:54:33 <hub_cap> mordred: sure
20:54:34 <mordred> we're not going to write custom it-works-different-for-this-proejct automation. so, the rule is one tarball per repo
20:54:49 <vipul> esp: i don't think it has to introduce another repo
20:54:54 <hub_cap> mordred: we arent unique snowflakes?!?!
20:55:05 * mordred hands hub_cap a bunny rabbit
20:55:10 <esp> vipul: gotcha, juice set me straight :)
20:55:15 * hub_cap shreds mordred with a sensational knife
20:55:29 <hub_cap> so srsly im not arguing against splitting, im just trying to figure priorities here
20:55:33 <hub_cap> lets take it offline
20:55:38 <hub_cap> i think a split is necesary
20:55:41 <hub_cap> just not sure when we shoudl do it
20:55:50 <hub_cap> im sure itll be done before icehouse
20:56:01 <hub_cap> i just want to see whats necesary first, if anything
20:56:10 <vipul> is that the name for hte next release?
20:56:15 <SlickNik> hub_cap: I'm +1 for splitting; what are we prioritizing against?
20:56:15 <hub_cap> vipul: aye
20:56:26 <hub_cap> i think heat + integration
20:56:45 <hub_cap> and making sure the 1, 2, 3 i mentioned above all work smoothly when we cut the rope
20:56:46 <grapex_> +1 for splitting too
20:56:58 <hub_cap> i guess im saying we need a plan :D
20:57:09 <hub_cap> and how we will integrate once we cut it
20:57:10 <kevinconway> i think we need 16 repos
20:57:17 <vipul> i think we need to figure out if we need to do anythigin speical for heat
20:57:19 <hub_cap> kevinconway: you arelady have that many
20:57:28 <hub_cap> kevinconway: https://github.com/openstack
20:57:37 <hub_cap> acutally 45!
20:57:46 <hub_cap> anyhoo lets move on and talk about it in #openstack-trove
20:57:54 <hub_cap> we have 3 min and i wanted to briefly talk about the next item
20:58:01 <vipul> go for it
20:58:06 <hub_cap> #topic Mission stmt
20:58:20 <hub_cap> so if you follow the TC meetings / list, u know now that projects are now called programs
20:58:27 <hub_cap> and that each program needs a mission statement
20:58:42 <hub_cap> nothing persay is different in our incubation, but we are now a program
20:58:50 <SlickNik> Yes, heard about that.
20:58:50 <hub_cap> and Nova, Glance, Infra, etc... are too
20:58:54 <kevinconway> Trove Mission: Needs more Heat!
20:59:09 <cp16net> whats cookin on the heat?
20:59:14 <grapex_> kevinconway: The heat is on.
20:59:18 <grapex_> It's on the street.
20:59:23 <hub_cap> kevinconway: remind me to never let u or cp16net or grapex_ write a mission stmt
20:59:27 <hub_cap> #link https://wiki.openstack.org/wiki/Trove#Mission_Statement
20:59:32 <hub_cap> thats the current mission
20:59:33 <cp16net> <3
20:59:39 <hub_cap> feel free to help me make it better
20:59:47 <vipul> hmm
20:59:47 <hub_cap> thx to datsun180b for making it good currently
20:59:49 <vipul> looks familiar
20:59:51 <cp16net> let bender write it for us
20:59:57 <hub_cap> Bender: Life is hilariously cruel.
21:00:02 <hub_cap> THATS PERFECT
21:00:06 <grapex_> hub_cap: That should be it!
21:00:08 <hub_cap> ok its 2pm gotta call this
21:00:16 <hub_cap> lets chat if u have updates
21:00:23 <hub_cap> ill be sending that to the -dev list in a wk
21:00:30 <vipul> hub_cap: is that a good enough mission statement
21:00:34 <vipul> or are they asking for more
21:00:36 <hub_cap> no time for open discussion lets move it to #openstack-trove
21:00:39 <hub_cap> vipul: they arent asking for more
21:00:40 <hub_cap> ore less
21:00:43 <vipul> k
21:00:43 <hub_cap> im aksing us to look @ it
21:00:48 <hub_cap> no one has seen it but us as of now
21:01:06 <hub_cap> we are previewing it b4 i send it to the ML
21:01:11 <hub_cap> #endmeeting