21:04:59 <SlickNik> #startmeeting trove
21:05:00 <openstack> Meeting started Tue Jun 25 21:04:59 2013 UTC.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:05:03 <openstack> The meeting name has been set to 'trove'
21:05:17 <SlickNik> #topic Action Items
21:05:27 <vipul> #link http://eavesdrop.openstack.org/meetings/trove/2013/trove.2013-06-18-21.04.html
21:05:42 <SlickNik> thanks Vipul.
21:05:52 <SlickNik> 1.	esmute and SlickNik to look into what happened to devstack-vm-gate integration.
21:06:37 <SlickNik> I was mostly busy with the rename changes among other things, so I didn't have much time to look into this.
21:07:19 <SlickNik> esmute isn't here yet, but I don't think he's made much progress on this front either.
21:07:35 <SlickNik> Gonna action it again to look into it for this week.
21:07:41 <vipul> o
21:07:43 <vipul> whoops
21:07:44 <vipul> ok
21:07:48 <cp16net> sounds good
21:07:59 <SlickNik> #action esmute and SlickNik to look into what happened to devstack-vm-gate integration.
21:08:21 <SlickNik> 2. juice / vipul to look into how Heat achieves packaging / repo organization for its agent
21:08:41 <vipul> I haven't had a chance to look into this yet
21:08:56 <vipul> now that we have the trove renamed, might be logical next thing to split up repos
21:09:05 <vipul> but will need more time to look into Heat's approach
21:09:21 <kevinconway> what's the desire to split up trove?
21:09:25 <esmute> no progress yet on that.
21:09:40 <vipul> primarily makes packaging easier kevinconway
21:10:04 <kevinconway> let me rephrase that, what things did you plan to break out of trove?
21:10:05 <vipul> also easier from a review perspective, to look at code that only effects guest
21:10:10 <vipul> guest agent
21:10:21 <SlickNik> kevinconway: only the guestagent
21:10:47 <vipul> #action juice / vipul to look into how Heat achieves packaging / repo organization for its agent
21:11:10 <SlickNik> okay, moving on.
21:11:16 <kevinconway> so if we decide to split up trove and trove-agent, what is the process for getting the new repo on openstack github?
21:11:42 <vipul> that part is handled by openstack infra
21:11:56 <SlickNik> we can get the openstack infra guys to do that for us.
21:11:57 <vipul> need to send a patch to openstack-ci project, and it takes care of it
21:12:00 <SlickNik> yup
21:12:11 <SlickNik> 3. imsplitbit, SlickNik, vipul and others to discuss the replication and clustering API
21:12:24 <imsplitbit> that didn't happen :)
21:12:26 <imsplitbit> been busy
21:12:33 <imsplitbit> I'd like to do that this week tho
21:12:36 <vipul> let's try to get to it
21:12:40 <SlickNik> So we had some discussion, but not enough methinks.
21:12:42 <imsplitbit> I'm out next week getting my knee whittled on
21:12:51 <vipul> i had a couple of additional items i'd like to bring up
21:13:00 <vipul> but i can hold them for that conversaion
21:13:04 <imsplitbit> ok
21:13:12 <imsplitbit> is tomorrow good for you guys?
21:13:20 <vipul> Tomorrow it is :)
21:13:22 <imsplitbit> I'm basically open all day
21:13:26 <kevinconway> 8:00am?
21:13:27 <SlickNik> Tomorrow sounds good.
21:13:33 <SlickNik> PST?
21:13:41 <vipul> 8am is not cool
21:13:41 <imsplitbit> sure I'm up and online at 630 CST
21:13:42 <kevinconway> #agreed Meet tomorrow 8:00am CST
21:13:47 <imsplitbit> lol
21:13:51 <SlickNik> heh
21:14:06 <vipul> 1pst?
21:14:11 <imsplitbit> as I understand it nothing happens until after 11CST due to pst folks
21:14:39 <imsplitbit> we have a meeting tomorrow from 3-4pm
21:14:41 <imsplitbit> cst
21:14:43 <datsun180b> Well, when you phrase it in terms of CST, yeah
21:14:47 <imsplitbit> thats all I have going on all day
21:15:06 <imsplitbit> 11CST?
21:15:19 <vipul> i get in at 10 pst :p
21:15:22 <datsun180b> exactly
21:15:27 <imsplitbit> ahhh
21:15:32 <imsplitbit> late riser
21:15:39 <imsplitbit> I'd start working at 4am if they'd let me
21:15:57 <vipul> we dont' get the sun very much, so makes it easier to sleep in til late :)
21:15:58 <imsplitbit> ok well then lets do 1pm pst thursday
21:16:04 <vipul> ok that works
21:16:11 <SlickNik> I'm fine with 1pm PST Thurs
21:16:20 <imsplitbit> works for me too
21:16:28 <kevinconway> 11:00AM CST 1:00PM PST?
21:16:43 <SlickNik> I think that's 3pm CST
21:16:47 <imsplitbit> 3pm cst
21:16:56 <imsplitbit> they're 2 hours behind *us*
21:17:00 <kevinconway> one of these days i'm going to get this meeting super early
21:17:10 <imsplitbit> and by *us* I mean those in the civilized state of texas :)
21:17:15 <robertmyers> ha
21:17:21 <kevinconway> #agreed 1pm PST
21:17:22 <SlickNik> #action imsplitbit, SlickNik, vipul and others to discuss the replication and clustering API at 11a.m. PST / 3p.m. CST on Thursday Jun 27
21:17:30 <imsplitbit> done and done
21:17:32 <imsplitbit> next
21:17:44 <SlickNik> 4. SlickNik look into publishing to pypi based on tags.
21:18:07 <SlickNik> So, I looked into this, and it looks like the awesome infra team has hooked us up real good here.
21:18:28 <SlickNik> Easy publish to pypi based on a tag of the code-base.
21:18:47 <SlickNik> Right now, the only one allowed to do this is hub_cap.
21:18:58 <annashen> and git tag will override the version in setup.cfg
21:18:59 <SlickNik> The permissions are based off of groups in gerrit.
21:19:16 <annashen> maybe we are talking about diff thing
21:19:21 <annashen> forget about that
21:19:32 * cp16net is confused how many hours are there between PST and CST?
21:19:46 <yidclare1> 2?
21:19:46 <annashen> 2?
21:19:48 <SlickNik> annashen: you speak correctly.
21:20:00 <imsplitbit> cp16net: 2 IIRC
21:20:01 <cp16net> ok and that action SlickNik said is 4 hours difference
21:20:05 <annashen> slicknik: thx :)
21:20:08 <cp16net> lol
21:20:16 <SlickNik> whoops
21:20:16 <imsplitbit> ah
21:20:19 <SlickNik> mistake in action tag.
21:20:25 <imsplitbit> didn't check that
21:20:27 <imsplitbit> :)
21:20:32 <cp16net> as long as you know what the times are :-P
21:20:33 <grapex_> We need to get a clock up in the Austin office that's set to PST and labeled "HP Time" so we stop having to think about this. :)
21:20:42 <cp16net> haha
21:20:47 <SlickNik> irc://15.185.114.44:5000/#action imsplitbit, SlickNik, vipul and others to discuss the replication and clustering API at 1p.m. PST / 3p.m. CST on Thursday Jun 27 (really)
21:20:59 <SlickNik> gah
21:21:02 <vipul> woah
21:21:03 <cp16net> LOL
21:21:07 <cp16net> try again
21:21:09 <SlickNik> #action imsplitbit, SlickNik, vipul and others to discuss the replication and clustering API at 1p.m. PST / 3p.m. CST on Thursday Jun 27 (really)
21:21:16 <SlickNik> better now?
21:21:18 <SlickNik> swee
21:21:19 <SlickNik> t
21:21:27 <SlickNik> need more coffee :)
21:21:28 <yidclare1> HP + hub_cap time
21:21:38 <imsplitbit> yep
21:22:00 <grapex_> We'll get a custom clock from Cafe Press with hub_cap's smiling face on it.
21:22:14 <SlickNik> So that covers action items.
21:22:49 <SlickNik> #topic Next Meeting Time
21:22:56 <SlickNik> take it away datsun180b!
21:23:14 <datsun180b> Okay, I closed the poll at http://doodle.com/fvpxvyxhmc69w6s9
21:23:43 <vipul> lol and we don't have an unanimous choice
21:23:50 <vipul> i feared this would happen
21:23:59 <datsun180b> The resulting winner is 3pmC/1pmP on Wednesday, but it isn't a shutout
21:24:21 <annashen> what's shutout?
21:24:27 <imsplitbit> I'll be the tie breaker
21:24:27 <grapex_> datsun180b: Not quite a knock out.
21:24:30 <datsun180b> a complete victory
21:24:33 <imsplitbit> 8am monday morning CST
21:24:39 <grapex_> imsplitbit: Sounds good!
21:24:42 <datsun180b> ^^ banned
21:24:55 <vipul> one way to make these meetings short :)
21:24:55 <datsun180b> Runner-up is 3pm/1pm Tuesdays, with 13 votes
21:25:14 <grapex_> Will Tuesday conflict with an other OpenStack meetings?
21:25:23 <SlickNik> hub_cap was mentioning that he'd rather not do Tuesday
21:25:27 <yidclare1> per hub_caps comments I think wed  is the better option
21:25:34 <imsplitbit> I thought tuesday was out because of hub_cap's other meetings
21:25:34 <grapex_> Does anyone have carrier pigeons or smoke signals we can send to hub_cap to confirm that? ;)
21:25:35 <datsun180b> Since hub_cap is the missing 14th vote on Tuesday, I'd think so
21:25:36 <SlickNik> grapex_: yes, it will.
21:25:55 <imsplitbit> 8am cst mondays it is
21:25:56 <datsun180b> So then, I ask you, Democratic Process, how do we proceed?
21:26:03 <grapex_> Would anyone be broken-hearted if we chose Wednesdays?
21:26:03 <imsplitbit> :-P
21:26:08 <yidclare1> Wed got the most votes
21:26:15 <imsplitbit> so there you have it
21:26:25 <SlickNik> we can try asking the reds…
21:26:38 <datsun180b> Well, is that slot absolutely impossible, reds?
21:27:01 <SlickNik> (kevinconway, esp, annashen, Riddhi)
21:27:20 <robertmyers> peer pressure
21:27:22 <kevinconway> wednesday works for me i guess.
21:27:24 <annashen> i am fine with wednesday
21:27:32 <SlickNik> lol@robertmyers
21:27:32 <Riddhi> me too:)
21:27:33 <kevinconway> i feel like my vote didn't have the weight it deserved though
21:27:36 <datsun180b> For the record I'm glad that Vipul asked me to knock the half-hours out
21:27:44 <kevinconway> every weekday at 12:00pm CST
21:28:08 <grapex_> This poll is biased too because it didn't include the weekends
21:28:09 <datsun180b> kevinconway: if you could convince us all of that what are you doing not running for President
21:28:24 <SlickNik> okay, in effect next week?
21:28:39 <robertmyers> new poll
21:28:41 <vipul> Wednesdays @ 1 PST / 3 CST ?
21:28:42 <datsun180b> sounds good, would you prefer to make the action # ?
21:28:53 <SlickNik> yeah, vipul
21:29:09 <SlickNik> go for it datsun180b, all yours
21:29:23 <datsun180b> #action Trove meetings now Wednesdays, 3pm C/1pm P
21:29:29 <grapex_> Ahhhhh yeeaaaah
21:29:30 <vipul> datsun180b: plz update the openstack meetings wiki page
21:29:41 <datsun180b> oh, now you want me to do TWO things?!
21:29:58 <vipul> can't let you off that easy
21:30:08 <datsun180b> It's a <Bender> quote, just ask cp16net
21:30:08 <kevinconway> #agreed
21:30:30 <SlickNik> okay, moving on?
21:30:52 <imsplitbit> next
21:31:03 <SlickNik> #topic Reddwarf -> Trove move
21:31:15 <datsun180b> augh, UTC? Aren't we at -5 during DST?
21:31:28 <kevinconway> datsun180b: yes
21:31:33 <datsun180b> danke
21:31:49 <SlickNik> The rename happened. Thanks hub_cap / datsun180b.
21:32:11 <datsun180b> Renaming that wiki page too fyi
21:32:33 <kevinconway> now that we have an official name and official github, can we get on the official project lists
21:32:53 <SlickNik> I noticed some files still had older name (possibly due to changes merged between when hub_cap made the change and when it actually got merged).
21:33:04 <vipul> kevinconway: what do you mean?
21:33:17 <SlickNik> Actually esmute noticed it, thanks!
21:33:19 <kevinconway> if you don't search for trove you will never find it by looking through openstack docs
21:33:50 <vipul> hmm i notice we're here: https://wiki.openstack.org/wiki/Projects
21:33:55 <SlickNik> https://review.openstack.org/#/c/34459/1 should get the remaining of it.
21:34:31 <kevinconway> we should be at the top of the page though, and <h1> at least
21:35:26 <vipul> #agreed
21:35:46 <robertmyers> kevinconway: <h1> is asking too much
21:35:57 <SlickNik> heh
21:36:20 <SlickNik> we're on the unofficial list as well.
21:36:35 <vipul> lol good catch
21:37:15 <SlickNik> okay, any more discussion regarding the rename?
21:37:21 <vipul> #action vipul to update https://wiki.openstack.org/wiki/Trove and remove 'reddwarf'
21:37:53 <SlickNik> #action SlickNik to check on rdjenkins to make sure it's working okay with the rename
21:38:12 <kevinconway> #link #link http://docs.openstack.org/developer/openstack-projects.html
21:38:54 <vipul> kevinconway: how is that generated? docbook?
21:39:27 <vipul> we don't have a developer doc, that's probably why we are left out
21:39:47 <SlickNik> vipul: I think there is a CI-infra job that generates them (per project).
21:39:57 <SlickNik> I think we still need to set this up for trove.
21:40:10 <vipul> can you look into it?
21:40:34 <vipul> #action SlickNik to look into developer docs so we are visible here https://wiki.openstack.org/wiki/Trove
21:40:34 <SlickNik> yeah, I was talking to clarkb about it earlier last week, will dig in to it some more.
21:40:41 <vipul> aah crap, bad link
21:41:07 <vipul> #action ^^ http://docs.openstack.org/developer/openstack-projects.html
21:41:18 <SlickNik> cool, thanks for the action.
21:41:40 <SlickNik> anything else to do with renaming?
21:41:49 <vipul> i think we good
21:41:51 <SlickNik> ...
21:41:54 <SlickNik> okay moving on
21:42:20 <SlickNik> I think this is left over from last meeting
21:42:22 <SlickNik> API Validation update
21:42:25 <SlickNik> #topic API Validation update
21:42:37 <vipul> old news i think
21:42:57 <SlickNik> Yah, juice completed it and it was merged.
21:43:08 <SlickNik> so, moving on...
21:43:20 <SlickNik> everyone's favourite topic...
21:43:29 <SlickNik> #topic Open Discussion
21:43:57 <vipul> I did want to bring up that we should now probably use the ML more
21:44:15 <vipul> so wonder if the Clustering stuff is a good candidate for ML discussion
21:44:24 <SlickNik> +1
21:44:28 <vipul> imsplitbit: ?
21:44:43 <imsplitbit> hai!
21:44:50 <imsplitbit> ML...
21:44:51 <vipul> \o
21:44:57 <SlickNik> mailing list
21:45:00 <imsplitbit> oh
21:45:04 <imsplitbit> yes mailing list
21:45:07 <kevinconway> do we have one?
21:45:07 <imsplitbit> good call
21:45:14 <kevinconway> it's not on launchpad
21:45:15 <vipul> openstack-dev
21:45:17 <imsplitbit> I wasn't aware we had one
21:45:21 <imsplitbit> thats pretty open
21:45:29 <imsplitbit> my fear would be it would get lost in the noise
21:45:34 <vipul> right, teams don't have spearate ones
21:45:41 <imsplitbit> wow
21:45:43 <imsplitbit> why not?
21:45:46 <SlickNik> it's at openstack-dev@lists.openstack.org
21:45:48 <vipul> [trove] in the subject line
21:45:50 <kevinconway> just title it [Trove]
21:45:56 <imsplitbit> ah
21:45:58 <imsplitbit> okie
21:46:04 <imsplitbit> for sure we can discuss things there
21:46:15 <imsplitbit> I just find that if you can tie people down for one hour you tend to get more done
21:46:19 <SlickNik> #link http://lists.openstack.org/cgi-bin/mailman/listinfo for subscription info
21:46:22 <imsplitbit> email arguments can go on for days
21:46:35 <imsplitbit> I'm not opposed to discussing it there tho
21:46:41 <vipul> imsplitbit: agreed, but you tend to get a larger audinece
21:46:43 <datsun180b> imsplitbit: are you related to Snidely Whiplash, tying people down
21:46:44 <vipul> which is a good and a bad thing
21:47:13 <vipul> we can definitely discuss #trove, but we're pretty quiet for an incubated project
21:47:14 <imsplitbit> yeah vipul
21:47:18 <vipul> on ML that is
21:47:30 <imsplitbit> ok well lets nail down some details on thurs
21:47:36 <imsplitbit> then I'll spam the mailing list
21:47:46 <vipul> ok
21:47:50 <imsplitbit> with "this is what we're thinking..."
21:47:56 <SlickNik> sounds good imsplitbit.
21:48:00 <imsplitbit> kk
21:48:08 <imsplitbit> I've kept everything in the openstack wiki
21:48:13 <imsplitbit> so it's all open
21:48:38 <vipul> nice, hopefully we'll get some good feedback
21:49:20 <SlickNik> Any other orders of business at hand?
21:49:59 <SlickNik> going once
21:50:03 <SlickNik> going twice
21:50:07 <kevinconway> $10
21:50:16 <SlickNik> #endmeeting