14:02:29 <slagle> #startmeeting TripleO Edge Squad Meeting
14:02:29 <openstack> Meeting started Thu Jan 31 14:02:29 2019 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:32 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek, bogdando, dtantsur, rbrady, d0ugal, toure, abishop
14:02:34 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:02:34 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:02:38 <d0ugal> o/
14:02:40 <jaosorior> o/
14:02:41 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-common master: Make the image pulling optional for tripleo-container-tag role.  https://review.openstack.org/634239
14:02:42 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:02:43 <abishop> o/
14:02:45 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:02:48 <slagle> hey!
14:02:49 <hjensas> beagles: makes wonder how on earth things promoted to that state in the repos ...
14:02:52 <hjensas> o/
14:03:00 <owalsh> o/ (might be afk for a few mins)
14:03:32 <slagle> #topic Agenda
14:03:35 <slagle> * Review past action items
14:03:37 <slagle> * Goals/action items for the week
14:03:48 <slagle> #topic Review past action items
14:03:53 <bogdando> o/
14:04:02 <slagle> our AI's are from 2 weeks ago as we didn't meet last week
14:04:42 * slagle slagle/fultonj try multi-ceph deployments with DCN
14:05:04 <fultonj> i didn't get to
14:05:11 <slagle> oh good me neither :)
14:05:11 <fultonj> slagle: did you?
14:05:18 <fultonj> punt to next week?
14:05:21 <slagle> sure
14:05:23 <openstackgerrit> Natal Ngétal proposed openstack/tripleo-common master: [Core] Be pep8 compliant.  https://review.openstack.org/634241
14:05:26 <fultonj> i've only done it with standalone
14:05:32 <slagle> #action slagle/fultonj try multi-ceph deployments with DCN
14:05:46 * slagle review https://etherpad.openstack.org/p/tripleo-edge-glance-deployment
14:06:22 <slagle> abishop: i took a look. seems bogdando and I had a similar question about glance-api at the edge using the central DB
14:06:43 <slagle> does it require a direct DB connection from the edge to the central site?
14:07:06 <abishop> quick answer (and I'll update etherpad) is yes, it does
14:07:22 <abishop> all part of the common control plane
14:08:00 <slagle> what functionality is affected if the connection is lost?
14:09:04 <abishop> well, I think the whole central control plane model presumes control plane is key to everything
14:09:10 <bogdando> I think the anwer is the same as for DCN in general
14:09:18 <bogdando> everything but running workloads
14:09:21 <abishop> if connectino is lost, no new instances, no new volumes, no nothing
14:09:31 <abishop> bogdando: ack!
14:09:51 <slagle> ok, makes sense. just wanted to double check
14:10:03 <fultonj> which is an accepted limitation of DCN from what i have heard
14:10:12 <slagle> right
14:11:06 <owalsh> mschuppert added libvirt-guest support too, so we could restart the VMs on reboot
14:11:12 <owalsh> node reboot
14:11:21 <slagle> abishop: do you plan to propose the work from your repo as patches, etc?
14:11:27 <fultonj> owalsh: oh nice, on ephemeral volumes?
14:11:27 <slagle> abishop: just wondering what the next steps are
14:11:54 <owalsh> fultonj: yea, I expect there are caveats... volumes, networking etc...
14:11:54 <fultonj> owalsh: cinder backed VMs too?
14:12:05 <abishop> slagle: right now they're mainly a set of THT parameter values, but no new parameters
14:12:19 <abishop> so not sure what I'd be patching
14:12:34 <slagle> abishop: mostly just thinking environment files, roles, and docs
14:13:00 <owalsh> fultonj: not quite sure TBH
14:13:43 <abishop> slagle: I can ponder, and will start with fresh review of what's out there (in tht tree) and suggest a place to make some updates
14:14:20 <abishop> I'm still working on getting a glance expert involved (jokke) but his time is extremely limited
14:14:30 <slagle> ack
14:14:46 <slagle> ok, and the last action item...
14:14:53 * slagle continue investigating glance and nova image caching status/options
14:15:00 <slagle> guess we kind of already talked about it
14:15:11 <slagle> unless there are other proposals not caputred in the etherpad/
14:15:13 <slagle> ?
14:17:03 <mschuppert> owalsh: the instances get started again via nova, so yes neutron needs to be available, also cinder if volumes are used.
14:17:23 <owalsh> mschuppert: so we'd need the control plane
14:17:29 <slagle> #topic Goals/action items for the week
14:17:32 <mschuppert> owalsh: yes
14:17:38 <owalsh> dang
14:17:58 <fultonj> there was an item regarding the split control plane ci
14:18:24 <fultonj> update: the job is extracting control plane data and putting it where it needs to be on the separate compute node
14:18:27 <fultonj> progress ^
14:18:30 <slagle> fultonj: i had attempted to keep it moving forward when you were in brno
14:18:36 <fultonj> slagle: yes, thank you
14:18:41 <slagle> i haven't revisited yet though :/
14:18:43 <fultonj> it helped
14:18:51 <slagle> i'll take another look. is there a current issue?
14:18:54 <fultonj> the current status is...
14:18:56 <fultonj> #action fultonj (et al) get split control plane ci job to not crash on podman container restart
14:19:00 <fultonj> #link http://logs.openstack.org/88/615988/14/check/tripleo-ci-centos-7-split-controlplane-standalone/cd1a87f/logs/subnode-2/home/zuul/standalone_deploy.log.txt.gz
14:19:09 <fultonj> #link https://review.openstack.org/#/c/615988/
14:19:11 <slagle> oh ok. yea i had to switch the job to podman
14:19:24 <fultonj> yeah, so controller goes up with podman fine; compute fails on ^
14:19:43 <fultonj> error restarting $container0, $container1, ... on step 3
14:22:15 <bogdando> so, https://review.openstack.org/#/c/632089/ needs more eyes
14:22:27 <slagle> fultonj: strange. wonder if it's a podman issue or something else
14:22:42 <bogdando> attempts describe negative scenarios and expectations for failure modes supported
14:23:14 <fultonj> slagle: right. i was going to try to reproduce in my env. last time i did edge in my env was w/ docker
14:23:33 <slagle> #action review https://review.openstack.org/#/c/632089/
14:23:37 <slagle> bogdando: will review it
14:23:46 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-heat-templates master: Do not pull image while tagging pcmk images in upgrade_tasks.  https://review.openstack.org/634243
14:24:56 <slagle> anything else that folks want to highlight this week?
14:25:31 <openstackgerrit> Sagi Shnaidman proposed openstack/tripleo-quickstart master: Use force_tcg by libguestfs is not ok  https://review.openstack.org/633444
14:25:49 <fultonj> mschuppert: when you said 'yes' to owalsh...
14:26:10 <fultonj> did you mean reboots of instances on edge nodes
14:26:21 <fultonj> which were backed by cinder and ephemeral volumes?
14:26:27 <fultonj> or is that still not known?
14:27:01 <mschuppert> fultonj: yes, compute needs neutron to be up. doesn't matter if ephemeral or cinder
14:27:54 <fultonj> mschuppert: thanks. so is the problem then that neutron may not be up?
14:28:02 <mschuppert> fultonj: yes
14:28:14 <bogdando> no rebooting, no live migration will be possible indeed
14:28:35 <fultonj> is that someone we need to track or simply state as a known limitation?
14:28:50 <fultonj> running workloads keep running. if they stopped running, then you need the ctl plane back
14:29:02 <fultonj> even with that nova chnage, no reboot
14:29:08 <bogdando> that should be a known limitation IMO, we can't do that w/o control plane
14:29:17 <fultonj> works for me
14:29:20 <fultonj> thanks mschuppert
14:29:41 <mschuppert> :)
14:31:44 <slagle> thanks folks!
14:31:46 <slagle> #endmeeting