14:01:55 <slagle> #startmeeting TripleO Edge Squad Meeting
14:01:56 <openstack> Meeting started Thu Dec  6 14:01:55 2018 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:59 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:02:08 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek, bogdando, dtantsur, rbrady, d0ugal, toure
14:02:10 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:02:12 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:02:15 <dtantsur> o/
14:02:24 <toure> o/
14:02:27 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:02:29 <slagle> #topic Agenda
14:02:31 <slagle> * Review past action items
14:02:33 <slagle> * One off items
14:02:35 <slagle> * Goals for the week
14:02:56 <slagle> hi dtantsur
14:02:59 <slagle> hi toure
14:03:08 <marios_|ruck> gfidente: fultonj o/ folks can you please check comment #1/2 here https://bugs.launchpad.net/tripleo/+bug/1806853 when you get some time thanks. ceph-ansible/packaging issue blocking the scen1/4 jobs.
14:03:09 <openstack> Launchpad bug 1806853 in tripleo "python-dockery-py package conflict causing jobs to fail" [High,Triaged] - Assigned to Marios Andreou (marios-b)
14:03:09 <toure> hello
14:04:01 <slagle> #topic Review past action items
14:04:13 <slagle> all review split-controlplane CI / docs
14:04:17 <fultonj> marios_|ruck: ok, i'll ping you after the edge meeting
14:04:26 <fultonj> split-controlplane CI, need to figure out how to get inventory generation to include subnode2; questions asked in review at
14:04:29 <fultonj> #link https://review.openstack.org/#/c/617368/9..10/playbooks/split-controlplane-standalone.yml
14:04:42 <slagle> i reviewed the docs and walked through them on baremetal which uncovered a few issues
14:04:54 <slagle> tried to address those here: https://review.openstack.org/#/c/621716/
14:04:56 <openstackgerrit> Ben Nemec proposed openstack/puppet-tripleo master: Nothing to see here  https://review.openstack.org/623214
14:04:59 <slagle> #link https://review.openstack.org/#/c/621716/
14:05:25 <fultonj> slagle: ^ LGTM but i added a comment about getting some context on the .25 network
14:05:45 <gfidente> marios we should be skipping with_pkg tag
14:05:47 <slagle> fultonj: i actually wasn't sure what that was either :)
14:06:02 <slagle> i'll see if i can figure it out and will update the patch
14:06:16 <gfidente> marios https://github.com/openstack/tripleo-heat-templates/blob/master/docker/services/ceph-ansible/ceph-base.yaml#L65
14:06:23 <fultonj> slagle: i assumed your .25 was your mgmt network (similar to your deployed server doc)
14:06:30 <marios_|ruck> gfidente: please join oooq we are polluting meeting sorry slagle didn't notice you started it before i posted
14:07:30 <fultonj> #action fultonj keep collaborating with slagle to get https://review.openstack.org/#/c/621716 + https://review.openstack.org/#/c/614636 done
14:08:34 <slagle> fultonj: for 617368...i dont think you need the 2nd node added to the inventory there
14:08:48 <slagle> you still want those tasks just run on the undercloud
14:09:14 <slagle> but we need the 2nd node's data be what we populate into the DeployedServerPortMap/HostnameMap parameter
14:09:33 <slagle> and then when tripleclient generates the inventory for config-download, it will be for that 2nd node
14:10:20 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1806521
14:10:21 <openstack> Launchpad bug 1806521 in tripleo "deployment fails on Ensure system is NTP time synced" [Critical,In progress] - Assigned to Alex Schultz (alex-schultz)
14:10:39 <fultonj> slagle: i assumed one playbook to deploy a standalone on the first node and then the second node and then test the first node can use the second node as an edge node
14:11:33 <slagle> fultonj: oh right, i think i misunderstood
14:12:09 <slagle> fultonj: well we can always add the node to the inventory with an ansible task
14:12:25 <slagle> with add_host
14:13:16 <fultonj> that might work
14:13:27 <fultonj> i would need to refer to variables from the zuul inventory http://logs.openstack.org/88/615988/5/check/tripleo-ci-split-controlplane-standalone/89f1976/zuul-info/inventory.yaml
14:14:41 <slagle> fultonj: yea we can look at how this is done for a multinode job, because i'm pretty sure the 2nd node is added to the inventory for those as there are some prep tasks we run on it
14:15:05 <slagle> so instead of those prep tasks, we'd run the standalone playbook for compute
14:15:46 <fultonj> i'll need to look at what runs the prep tasks to see how to hook in
14:16:14 <fultonj> slagle: perhaps we can collab on this more post meeting?
14:16:21 <slagle> yep, i'll look it up post meeting
14:16:27 <fultonj> thanks
14:16:54 <slagle> i think that was it for past action items
14:17:18 <slagle> besides honor timezones, which we've done :)
14:17:31 <slagle> #topic One Off / Goals
14:18:01 <fultonj> #action fultonj collab w/ slagle to get split-controlplane-standalone.yml for CI using second node
14:18:08 <slagle> i've been looking at the undercloud driven split-controlplane on baremetal after i finished up with the standalone setup
14:18:28 <slagle> not much progress yet, but hope to document something this week
14:18:55 <openstackgerrit> Marios Andreou proposed openstack/tripleo-heat-templates master: Remove CephAnsibleSkipTags from scenario1/4 standalone ci envs  https://review.openstack.org/623217
14:19:31 <fultonj> slagle: owalsh got something working like that
14:19:56 <fultonj> i think he used
14:20:00 <fultonj> #link https://review.openstack.org/#/c/600042/
14:20:19 <fultonj> #link https://github.com/olliewalsh/split/tree/fix_computes
14:20:57 <slagle> yea, trying something similar
14:21:04 <openstackgerrit> Marios Andreou proposed openstack-infra/tripleo-ci master: WIP: Add new tripleo-ci-centos-7-scenario001-standalone job  https://review.openstack.org/619508
14:21:24 <openstackgerrit> Marios Andreou proposed openstack-infra/tripleo-ci master: WIP: Add tripleo-ci-centos-7-scenario004-standalone job  https://review.openstack.org/619520
14:22:39 <slagle> any other progress updates from anyone?
14:23:13 <abishop> still working to resolve "cinder needs a DLM"
14:23:59 <fultonj> abishop: did you find anyone intersted in helping maintain a DLM config in tripleo?
14:24:00 <slagle> abishop: great. is there any update to share?
14:24:36 <abishop> I chatted w/ bnemec and he's looking for solution as well (for designate)
14:25:00 <abishop> there's a discussion on openstack-discuss, but it's drifting off topic a bit
14:25:23 <abishop> I'm currently using tripleo's Etcd service, which deployes etcd3 just fine
14:25:36 <slagle> ok, was wondering if that still worked
14:25:46 <abishop> the missing bits are I need python-etcd3gw package for cinder to actually *use* the service
14:26:17 <abishop> I have succesfully added that package (via pipinstall) to a custom cinder-volume container image, and it seems to work!
14:26:23 <openstackgerrit> Gael Chamoulaud proposed openstack/tripleo-validations master: Add SSL certificate validation  https://review.openstack.org/590214
14:26:40 <abishop> my cinder peers are now testing cinder active-active
14:28:48 <fultonj> abishop: do you think a patch to add python-etcd3gw as a dep for cinder-volume is a good move?
14:28:57 <fultonj> abishop: i think you had a topic of patches for this right?
14:29:14 <abishop> the problem is I don't see the package available as an rpm anywhere useful
14:29:49 <abishop> I also had a discussion w/ rdo folk to see if they can help get it packaged
14:30:22 <abishop> the part that needs resolution (and I'm working on it) is getting someone to step up and own the package
14:31:26 <abishop> fultonj: I have a puppet-cinder patch already merged, but holding off posting puppet-tripleo and tht patches
14:31:36 <fultonj> #link https://review.openstack.org/#/q/topic:bp/split-controlplane-cinder-volume-az+(status:open+OR+status:merged)
14:31:39 <abishop> I suppose I should post them as WIP
14:32:18 <abishop> fultonj: that's separate topic (az != cinder a/a)
14:35:40 <slagle> any other business?
14:36:14 <slagle> thanks folks!
14:36:17 <slagle> #endmeeting