14:01:43 <slagle> #startmeeting TripleO Edge Squad Meeting
14:01:45 <openstack> Meeting started Thu Oct 25 14:01:43 2018 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:48 <slagle> ping slagle, emilien, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek,thrash, bogdando, dtantsur, rbrady, d0ugal, toure
14:01:48 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:01:51 <d0ugal> o/
14:01:53 <fultonj> o/
14:01:55 <owalsh> o/
14:01:56 <bogdando> o/
14:01:59 <jaosorior> o/
14:02:00 <jtomasek> o/
14:02:01 <toure> o/
14:02:01 <hjensas> o/
14:02:09 <dtantsur> o/
14:02:20 <slagle> hello
14:03:41 <slagle> #topic Agenda
14:03:41 <slagle> * Review past action items
14:03:41 <slagle> * One off items
14:03:43 <slagle> * Goals for the week
14:03:59 <slagle> #topic Review past action items
14:04:27 <slagle> ok, let's take a look at the past AI's
14:04:36 <slagle> fultonj work on split-controlplane-ci
14:04:46 <fultonj> my edge w/ ceph prototype stopped working; neutron issues still debugging; likely my env; will do the docs patch when working again; this affects my ci work too
14:05:20 <slagle> ack
14:05:23 <fultonj> #action fultonj make progress on split-controlplane-ci
14:05:36 <slagle> dtantsur to discuss edge/far edge terminology concerns with WG
14:05:45 <dtantsur> and I did!
14:05:50 <slagle> thanks :)
14:05:58 <dtantsur> the output is not clear so far
14:06:00 <slagle> #link http://lists.openstack.org/pipermail/openstack-dev/2018-October/135840.html
14:06:02 <chem> o/
14:06:09 <dtantsur> but there was a link so a glossary, where "Far Edge" does nto seem to appear
14:06:09 <slagle> yea, good progress though
14:06:11 <chem> oups
14:06:42 <bogdando> for aligning terms (Goal 1 in https://etherpad.openstack.org/p/tripleo-edge-mvp), we may have a solution  perhaps, which is use terms as of https://github.com/State-of-the-Edge/glossary and propose changes there :)
14:06:44 <dtantsur> #link https://github.com/State-of-the-Edge/glossary
14:07:08 <slagle> slagle to work on documenting some terms and gathering links/references
14:07:17 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-terms
14:07:25 <slagle> dtantsur: bogdando : i've included that there ^
14:07:31 <slagle> with some context
14:08:04 <slagle> particularly, Access Edge ~= Far Edge
14:08:18 <slagle> Aggregation Edge ~= Edge
14:08:24 <slagle> afaict
14:08:24 <dtantsur> so, no consistency already? :)
14:08:30 <bogdando> why not Edge distance 0/1/2/n? :(
14:08:37 <dtantsur> but "Access Edge" makes more sense to me than "Far"
14:08:53 <openstackgerrit> Emilien Macchi proposed openstack/instack-undercloud master: Pin openstacksdk and fix pep8 stricter requirement about backslash (W605)  https://review.openstack.org/613267
14:08:54 <slagle> dtantsur: well, i'd be happy to say we adopt the Open Glossary
14:09:06 <slagle> just wanted to lay it all out first
14:09:26 <slagle> and that doesnt mean other groups would, but we could at least map other terms to what we choose to adopt and use
14:09:32 <fultonj> +1
14:09:43 <bogdando> slagle: did you address all of the terms I mentioned at mvp etherpad?
14:09:46 <openstackgerrit> Emilien Macchi proposed openstack/instack-undercloud master: Include local_ip & undercloud_admin_host in docker_insecure_registries  https://review.openstack.org/613166
14:10:09 <bogdando> would be nice to have a proposal to that https://github.com/State-of-the-Edge/glossary with all things set
14:10:10 <fultonj> split control plane deploys controllers and remote computes+ceph they could be applied into the deloyments described in more than one way
14:10:14 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1797525
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1798195
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1799786
14:10:17 <openstack> Launchpad bug 1797525 in tripleo "After the switch to podman & skopeo, undercloud deployment takes +60% longer" [Critical,In progress] - Assigned to Steve Baker (steve-stevebaker)
14:10:18 <openstack> Launchpad bug 1798195 in tripleo "rdo-cloud yum repos unavailable during container updates and failing the undercloud install " [Critical,Triaged]
14:10:19 <openstack> Launchpad bug 1799786 in tripleo "puppet-openstack-unit-5.5-centos-7 broken due to updated puppet 5.5.7" [Critical,In progress] - Assigned to Alex Schultz (alex-schultz)
14:10:22 <slagle> bogdando: it's a work in progress and living document
14:10:42 <bogdando> thanks
14:10:49 <slagle> bogdando: i'm just gathering terms atm, and grouping related things
14:10:59 <slagle> then we can move towards agreement on what to use
14:11:32 <openstackgerrit> Marios Andreou proposed openstack-infra/tripleo-ci master: Removes EXTRA_TAGS from toci_gate_test&quickstart.sh.j2  https://review.openstack.org/604768
14:12:06 <slagle> #action slagle to conintue on terms etherpad
14:12:14 <bogdando> would be nice to add federated term
14:12:19 <slagle> alright, the last 2 action items we already added
14:12:41 <slagle> bogdando: ok done. and anyone can edit the etherpad
14:13:10 <slagle> anything else for this topic?
14:13:57 <slagle> #topic One Off
14:14:23 <slagle> gfidente: you're up
14:14:33 <gfidente> slagle ack thanks
14:14:48 <gfidente> I wanted to know what you guys think about those services which should scale with every compute instance, in the edge zone
14:14:54 <gfidente> like ceph-mon or cinder-volume
14:15:08 <gfidente> shall we create "special" tripleo roles to cope with that?
14:15:43 <gfidente> or rather let people organize those with custom roles as necessary
14:16:00 <slagle> gfidente: are you talking about a specific role that includes compute+cinder-volume+ceph-mon?
14:16:07 <gfidente> amend: those services which should *not* scale
14:16:20 <gfidente> slagle for example yes
14:16:30 <gfidente> slagle others might want compute+ceph ; compute+cinder ; compute-only
14:16:36 <slagle> gfidente: sure, i don't see why not
14:16:40 <gfidente> so I wasn't sure what would be the right approach here
14:16:54 <gfidente> creating roles vs pushing on custom roles
14:16:58 <slagle> i have no issue with adding role examples
14:17:05 <gfidente> ack
14:17:15 <slagle> gfidente: the other way to do would be to have a single role, that can be used with different environments
14:17:47 <slagle> so environments for compute+ceph, compute+cinder, etc. where the environment mapped services to implementations or None
14:18:01 <openstackgerrit> Michael Bayer proposed openstack/tripleo-heat-templates master: Implement Global Galera database  https://review.openstack.org/609738
14:18:42 <gfidente> slagle we can't do it with environments only though, cause you might want ceph/cinder enabled both but on different roles
14:19:28 <owalsh> yea, +1 for adding roles for the common cases
14:19:31 <slagle> gfidente: ok, true. i had it in mind that each DCN deployment was a separate stack
14:19:48 <slagle> with 1 role, but no specific reason we need to restrict it that way
14:20:12 <gfidente> yep 1 all-in-one is probably the start
14:20:32 <gfidente> we might also just use the regular compute nodes for additional scaleout
14:20:37 <openstackgerrit> Mike Fedosin proposed openstack/tripleo-heat-templates master: WIP: Set container images for openshift 3.11  https://review.openstack.org/613165
14:20:44 <gfidente> *compute role
14:20:49 <slagle> yep
14:20:56 <slagle> so i would say add new roles
14:20:58 <gfidente> ok so no more sample roles for now
14:21:23 <gfidente> we want the AIO
14:21:27 <gfidente> but not more for now
14:21:34 <gfidente> did I get it right?
14:22:02 <slagle> yes, for the initial work
14:22:20 <slagle> i'd say...add new roles if you need them. but dont do it just to do it
14:22:27 <slagle> b/c then we'll have a lot more roles to maintain
14:22:57 <owalsh> inheritance would be really useful
14:23:03 <slagle> it'll be nice if we can get the role inheritance thing one day. so we don't have to copy/paste services around
14:23:11 <gfidente> ok
14:23:12 <slagle> owalsh: :)
14:23:19 <owalsh> snap
14:23:27 <trown> mfedosin: have you been able to get 3.11 working in a local environment? ... wrt your WIP patch that sets the container images ^
14:23:27 <gfidente> thanks
14:24:01 <slagle> alright any other items?
14:24:05 <fultonj> #action fultonj docs patch for standalone edge example
14:24:23 <mfedosin> trown, actually no
14:25:11 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-heat-templates stable/queens: Revert "Don't run host_prep_tasks from {{role}}HostPrepDeployment"  https://review.openstack.org/613259
14:25:15 <mfedosin> I'm going to use the reproducer script for that
14:25:20 <trown> mfedosin: ok, me neither :P ... I get stuck before your patch would be relevant I think though... the kube-system pods hang in pending
14:25:40 <slagle> alright folks, we'll wrap up. thanks for participating!
14:25:47 <slagle> #endmeeting