14:00:32 <slagle> #startmeeting TripleO Edge Squad Meeting
14:00:33 <openstack> Meeting started Thu Oct  4 14:00:32 2018 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:37 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:00:47 <slagle> ping slagle, emilien, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek,thrash, bogdando, dtantsur, rbrady
14:00:50 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:00:52 <dtantsur> o/
14:00:53 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:00:55 <gfidente> o/
14:00:56 <jaosorior> o/
14:00:59 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:01:02 <fultonj> o/
14:01:29 <slagle> #topic Agenda
14:01:29 <slagle> * Review past action items
14:01:29 <slagle> * One off items
14:01:30 <slagle> * Goals for the week
14:02:22 <slagle> #topic Review past action items
14:02:39 * slagle all: review https://etherpad.openstack.org/p/tripleo-edge-mvp and discuss (slagle, 14:10:04)
14:02:50 <slagle> we said we'd review that etherpad from bogdando
14:03:03 <slagle> i see comments from a few folks
14:03:20 <slagle> i reviewed it, especially around Goal 4 since that was the ask
14:03:35 <fultonj> me too
14:03:46 <slagle> i found it a little difficult to understnad, but I left some comments there
14:04:20 <fultonj> bogdando: anything we should talk about now?
14:04:22 <slagle> bogdando: perhaps you could take a look and we can continue the discussion on the etherpad for now?
14:04:32 <cgoncalves> mwhahaha, EmilienM: hi. could you please approve https://review.openstack.org/#/c/587015/ ? thanks!
14:04:44 <zzzeek_> jaosorior: i know nova is one, i'd have to run a test to find all the rest
14:05:39 <fultonj> #agreed continue disucssion in etherpad
14:05:45 <slagle> hehe :)
14:05:48 <slagle> ok, next up
14:05:54 * slagle fultonj to    get feedback from tripleo CI group on    https://blueprints.launchpad.net/tripleo/+spec/split-controlplane-ci    (fultonj,    14:29:39)
14:06:36 <bogdando> slagle, fultonj: yes, pleae let's keep it for offline
14:07:00 <fultonj> that AI will be ongoing
14:07:11 <fultonj> planning to...
14:07:13 <fultonj> 1. prototype
14:07:30 <fultonj> 2. then get feedback on submission which uses standlone like https://github.com/openstack-infra/tripleo-ci/blob/master/zuul.d/standalone-jobs.yaml#L14
14:07:38 <fultonj> still workkig on prototype
14:08:12 <slagle> ok sounds good
14:08:24 <slagle> how is that going?
14:08:36 <slagle> or is that the next action item we were going to discuss...
14:08:36 <fultonj> #info - following https://etherpad.openstack.org/p/tripleo-compute-standalone
14:08:36 <fultonj> #info - few days ago ran into http://paste.openstack.org/show/731116
14:08:37 <fultonj> #info - Why is RoleNetIpMap missing new edge node 192.168.24.3? http://paste.openstack.org/show/731120
14:08:44 <fultonj> #info - Stack knows about new node http://paste.openstack.org/show/731121
14:08:44 <fultonj> #info - Reproducing in my env today and might ping for help if still stuck
14:08:45 <fultonj> #info - https://gitlab.com/fultonj/tripleo-standalone-edge
14:09:17 <fultonj> slagle: that's what i'm currently stuck on perhaps after meeting and after i reproduce i could get help dubbing?
14:09:20 <fultonj> debugging*
14:09:34 * dtantsur thinks fultonj just invented twitter over irc
14:10:00 <slagle> fultonj: sure, it probably didn't find an IP for the compute node
14:10:17 <slagle> maybe a problem with DeployedServerPortMap or HostnameMap
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1792872
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1793665
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1795718
14:10:20 <openstack> Launchpad bug 1792872 in tripleo "[queens] overcloud prepare image failed by giving IronicAction.node.set_provision_state failed: 'NoneType' object has no attribute '__getitem_" [Critical,Triaged] - Assigned to Marios Andreou (marios-b)
14:10:21 <openstack> Launchpad bug 1793665 in tripleo "multinode-oooq-container scenarios and Fs016/17/20 periodic jobs fails on validate-tempest: Unexpected response code received" [Critical,In progress] - Assigned to Juan Antonio Osorio Robles (juan-osorio-robles)
14:10:22 <openstack> Launchpad bug 1795718 in tripleo "Exception: Error inspecting image: docker://docker.io/ server misbehaving" [Critical,Triaged]
14:10:57 <slagle> #action fultonj and slagle to continue debugging standalone edge deployment
14:11:04 <fultonj> thanks slagle
14:11:13 <owalsh> o/
14:11:55 * slagle fultonj try    standalone for    https://blueprints.launchpad.net/tripleo/+spec/split-controlplane-ci    based on    https://github.com/openstack-infra/tripleo-ci/blob/master/zuul.d/standalone-jobs.yaml#L14    (fultonj,    14:38:07)
14:12:00 <slagle> alright, we just discussed that
14:12:14 <slagle> so moving on
14:12:22 <slagle> #topic One Off
14:12:29 <fultonj> #info - abishop not here but made progress on active/active cinder in standalone
14:12:56 <fultonj> and cinder AZs
14:13:00 <bogdando> #action https://etherpad.openstack.org/p/tripleo-edge-mvp is needs clarification for the special snowflakes, what do we understand as that when comparing it to the federated openstack services (perhaps)
14:13:16 <bogdando> dtantsur: ^^
14:13:35 <bogdando> just captured the irc logs, not really invented those snowflakes :)
14:13:52 <dtantsur> not sure I get it, what's the question for me?
14:14:21 <slagle> bogdando: the only context i was able to capture from the etherpad was that it was implied that "using ansible" = "special snowflake"
14:14:28 <bogdando> dtantsur: yes please as I think when we were talking about architecture differences for undercloud vs overcloud, we used that term
14:14:45 <slagle> so i don't understand what is meant by special snowflake
14:15:07 <dtantsur> let's probably try use less metaphors and more specific wording?
14:15:17 <fultonj> dtantsur: +1
14:15:31 <bogdando> agreeing on terms is already a goal 1 :D
14:16:00 <fultonj> w.r.t terms i think it helps to be consistent with edge working group
14:16:34 <slagle> fultonj: yes, so one of the things I was going to do try and do over the next week is gather all the links/references that we've been compiling into a single spot
14:16:44 <slagle> perhaps the sqaud etherpad for now
14:17:14 <dtantsur> I think what is meant under "special snowflake" here is actually a concern about growing the amount of logic specific to tripleo
14:17:22 <slagle> b/c there was also some confusion around "Far Edge" in the etherpad. it's a thing that's been defined outside of TripleO, so we need to understand what is meant by it
14:17:26 <dtantsur> as opposed to tripleo relying more on other upstream openstack projects
14:17:45 * dtantsur is the primary hater of the term "Far Edge"
14:17:55 <fultonj> https://www.dropbox.com/s/255x1cao14taer3/MVP-Architecture_edge-computing_PTG.pptx?dl=0#
14:18:11 <dtantsur> how do I block IRC messages containing ^^^
14:18:14 <dtantsur> ?
14:18:14 <slagle> dtantsur: understood :) but you'd have to convince the Edge WG to not use it
14:18:17 <fultonj> ^ i don't love the term but i'll use it because others do outside of tripleo in the dge working group
14:18:31 <bogdando> slagle, dtantsur: updated special snowflakes
14:18:34 <bogdando> https://etherpad.openstack.org/p/tripleo-edge-mvp
14:18:59 <dtantsur> slagle: maybe I'm just the grumpy old man here :)
14:19:20 <slagle> dtantsur: nah :). i hear where you're coming from
14:19:26 <dtantsur> I suspect the "Edge" terminology makes good marketing, so we may not be able to change it globally
14:19:48 <slagle> dtantsur: honestly it was driven by groups who are already actually deploying this stuff. and they found it useful to have these classifications
14:20:04 <bogdando> slagle: did I wrote that right?
14:20:09 <dtantsur> then I guess we should just start our documentation with a glossary :)
14:20:12 <dtantsur> which is a good idea anyway
14:20:20 <bogdando> dtantsur: ^^ please take a look that etherpad for 11th time :)
14:20:30 <bogdando> line 24-27
14:20:44 <dtantsur> bogdando: can we s/special snowflake/something non-metaphoric/g please?
14:20:55 <bogdando> go for it!
14:21:03 <dtantsur> I have a gut feeling it's not used exactly in this sense, but as a non-native speaking I cannot grasp it in full
14:21:18 <slagle> dtantsur: as for tripleo growing more logic that is not openstack, not sure i totally agree there. tripleo is part of openstack, as are all the other deployment projects
14:21:38 <bogdando> just please make sure it not gets too much of tripleo specific! :)
14:21:40 <dtantsur> slagle: right, it's not necessary a bad thing
14:21:55 <dtantsur> but it's maintenance cost, and if we can avoid it - let's avoid it
14:21:59 <bogdando> as every vendor these days seems like has a bunch of snowflakes for Edge thene
14:22:02 <bogdando> theme*
14:22:02 <slagle> dtantsur: openstack doesn't have a tenant facing API service for software config/deployment that is sufficient enough for openstack or edge deployment
14:22:10 <slagle> Heat is about it
14:22:12 <dtantsur> e.g. in metalsmith case, the metalsmith library is under ironic governance, so we share its maintenance
14:22:22 <dtantsur> we could write this code in tripleo-common, then we would have to maintain it
14:22:24 <slagle> and i don't plan on using Heat to deploy thousands of edge nodes :)
14:22:30 <dtantsur> lol, yeah
14:23:32 * dtantsur ponders an openstack software config service
14:23:32 <slagle> i do think it's important that we drive things with existing or new consistent interfaces. for now, that means t-h-t
14:24:06 <slagle> so i look at ansible/config-download as a potential way to scale that to the edge
14:25:10 <dtantsur> anyway, for me personally the most interesting things is what (if anything) happens with bm provisioning and management
14:26:22 <slagle> #action slagle to work on documenting some terms and gathering links/references
14:26:45 <owalsh> bogdando: for distributed undercloud, what exactly is the goal? is it federation to make is possible (fast) to deploy to edge from centre, a local undercloud at each edge to tolerate network partitions, both, neither?
14:27:06 <dtantsur> my concerns were around replacing ironic as an operator facing API (or completely) with something specific to tripleo
14:27:23 <dtantsur> this is *probably* where the snowflakes speech came from
14:27:47 <dtantsur> owalsh: that's the question, and I don't think we have solved it yet
14:27:59 <slagle> dtantsur: for bm? i don't think there's any reason to do that. i'm not aware of anything going in that direction
14:28:15 <owalsh> dtantsur: ack
14:28:21 <owalsh> dtantsur: so both :-)
14:29:03 <dtantsur> slagle: the question is how deeply we change the bm management workflow on the central undercloud (the Edge layer if I'm not mixing things up again)
14:29:57 <dtantsur> (it may not feel the right question for right now, but the resulting architecture of the undercloud may depend on it)
14:32:24 <slagle> well maybe the new workflow will be used for both
14:32:32 <slagle> or should be
14:32:36 <owalsh> +1
14:33:34 <slagle> anything else before we wrap up?
14:33:59 <slagle> #endmeeting