14:01:18 <slagle> #startmeeting TripleO Edge Squad Meeting
14:01:18 <slagle> ping slagle, emilien, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek,thrash, bogdando, dtantsur, rbrady
14:01:18 <openstack> Meeting started Thu Sep 27 14:01:18 2018 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:21 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:01:22 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:01:24 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:01:27 <slagle> Anyone can use the #link, #action, #help, #idea and #info commands, not just the moderatorǃ
14:01:30 <bogdando> o/
14:01:32 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:01:33 <hjensas> o/
14:01:34 <fultonj> o/
14:01:35 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:01:59 <owalsh> o/
14:02:02 <EmilienM> o/
14:02:02 <jaosorior> o/
14:02:38 <dtantsur> o/
14:02:46 <slagle> hi everyone
14:02:57 <shardy> o/
14:02:58 <slagle> #topic Agenda
14:02:59 <slagle> * Review past action items
14:02:59 <slagle> * One off items
14:02:59 <slagle> * Ongoing Work
14:02:59 <slagle> * New Work/Specs
14:03:01 <slagle> * Review Requests
14:03:03 <slagle> * Goals for the week
14:03:12 <slagle> #topic Review past action items
14:03:32 <slagle> bogdando fultonj gfidente refine tripleo split-controlplane use case and see how it lines up with proposed Edge architecture from PTG
14:03:37 <fultonj> Refine tripleo split-controlplane use case and see how it lines up with proposed Edge architecture from PTG
14:03:44 <slagle> :)
14:03:44 <fultonj> https://etherpad.openstack.org/p/tripleo-edge-working-group-split-control-plane
14:03:53 <fultonj> slagle: i think ^ might cover that
14:04:00 <fultonj> feedback welcome though
14:04:05 <bogdando> and from my side, there is also something to review and align with
14:04:13 <bogdando> #link https://etherpad.openstack.org/p/tripleo-edge-mvp
14:04:27 <fultonj> #link https://etherpad.openstack.org/p/tripleo-edge-working-group-split-control-plane
14:04:58 <slagle> great, this looks good. a lot of data to digest though
14:05:12 <slagle> anything to highlight?
14:05:18 <bogdando> concerns imo
14:05:30 <bogdando> we need to remove contradictional things
14:05:35 <bogdando> not now, ofc
14:05:52 <gfidente> slagle we don't cover yet how to deploy the "main site" and in that context the glance images distribution poses some more challenges
14:05:53 <openstackgerrit> Bob Fournier proposed openstack/tripleo-heat-templates master: In process-templates script write output files to provided dir when using base path  https://review.openstack.org/605736
14:06:43 <gfidente> slagle but it matches pretty closely the edge/far-edge scenario though we use different terminology : ctlplane/edge
14:06:47 <slagle> bogdando: would you say the point of your etherpad is to define the mvp?
14:06:49 <fultonj> my highlight is that the edge working group's diagrams and compatible with the proposal in the split control plane
14:06:59 <bogdando> slagle: there is 4 goals
14:07:10 <bogdando> one of those is indeed define MVP
14:07:18 <bogdando> and meet the goal 4 as well
14:07:29 <bogdando> so it wouldn't look contradictional
14:07:57 <slagle> bogdando: ok, so we may want to focus on what is needed in addition to split-controlplane to get to a MVP we agree on
14:08:05 <bogdando> right
14:08:12 <fultonj> bogdando: please be specific if you see contradictions in MVP defined in https://etherpad.openstack.org/p/tripleo-edge-working-group-split-control-plane
14:08:12 <slagle> b/c i think we all mostly agree split-controlplane is the first step
14:08:22 <slagle> but is not necessarily an MVP?
14:08:27 <bogdando> fultonj: not there, by another link
14:08:48 <fultonj> slagle: yeah, it doens't exactly have to be an MVP as much as step1
14:08:59 <bogdando> so I just captured all the contradictional view points there, raised just for a one day of discussions
14:08:59 <slagle> fultonj: yep, thinking the same
14:09:21 <slagle> bogdando: ok, i think this good to work through
14:09:23 <bogdando> so it's very high level
14:09:25 <dtantsur> one of the things is that someone do not consider MVP "V" without some provisioning approach
14:09:31 <bogdando> to agree on terms at very least
14:09:33 <slagle> let's all take an action to review your etherpad and continue the discussion there or on irc
14:09:38 <slagle> sound good?
14:09:50 <bogdando> yeah
14:10:04 <slagle> #action all: review https://etherpad.openstack.org/p/tripleo-edge-mvp and discuss
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1715374
14:10:18 <openstack> Launchpad bug 1715374 in tripleo "Reloading compute with SIGHUP prenvents instances to boot" [Critical,In progress] - Assigned to Bogdan Dobrelya (bogdando)
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1792560
14:10:20 <openstack> Launchpad bug 1792560 in tripleo "Upgrades in CI still using Q->master instead of R->master release" [Critical,Triaged] - Assigned to Jiří Stránský (jistr)
14:10:31 <bogdando> although I'd like to see the resulting bullet points (removed contradictional statements) in some spec... not just having discussions...
14:11:07 <bogdando> example: single operator view is a cool idea/is a must
14:11:10 <slagle> yes, one of the goals should be a spec documenting terms and the MVP
14:11:27 <slagle> we could start with that, and then have discussion on the spec patch?
14:11:34 <slagle> initially, etherpad seems a bit more fluid
14:11:48 <slagle> but no objection if you want to throw up an initial spec
14:11:58 <bogdando> I hope we already have some to edit?
14:12:10 <slagle> a spec?
14:12:12 <bogdando> yes
14:12:17 <fultonj> we don't
14:12:19 <fultonj> that i know of
14:12:23 <slagle> don't think so, other than split-controlplane
14:12:24 <bogdando> ok
14:12:32 <bogdando> so we can update that one
14:12:35 <bogdando> fits ideally
14:12:37 <openstackgerrit> Michele Baldessari proposed openstack/tripleo-heat-templates master: WIP DNR Unify rabbitmq bind mounts and env vars  https://review.openstack.org/605598
14:12:54 <slagle> i think it should be a new one
14:13:03 <bogdando> just that a person who updates it cannot resolve concerns on his/her own, cuz that's a conflicting view points we have
14:13:04 <fultonj> split control plane spec merged
14:13:15 <bogdando> we can amend
14:13:15 <fultonj> blue prints exist
14:13:20 <openstackgerrit> Athlan-Guyot sofer proposed openstack/tripleo-quickstart master: Put create repo script into its own tasks file.  https://review.openstack.org/605369
14:13:21 <openstackgerrit> Athlan-Guyot sofer proposed openstack/tripleo-quickstart master: Add new featureset 056 for standalone upgarde.  https://review.openstack.org/605363
14:13:35 <slagle> i don't really see much to amend in the split-controlplane spec
14:13:43 <slagle> again, that work stands on its own
14:13:55 <bogdando> I'm not sure we need another spec. The concerns and goals in that ehterpad ideally fit into the split control plane
14:14:14 <dtantsur> the split-controlplane lacks the main site, it only has edge and far edge (hell, I hate these terms :)
14:14:17 <bogdando> but if you insist...
14:14:28 <bogdando> yes, that's one of the concerns
14:14:32 <bogdando> worth amending
14:15:02 <dtantsur> only it completely omits any undercloud business, except for shy "Director" somewhere in the corner
14:15:12 <dtantsur> s/only/also/
14:15:14 <openstackgerrit> Athlan-Guyot sofer proposed openstack/tripleo-quickstart-extras master: Add standalone upgrade role and playbook.  https://review.openstack.org/604736
14:15:28 <fultonj> the UC is implicit we're deploying to heat stacks
14:15:44 <slagle> dtantsur: bogdando that's because it's not what you're trying to redefine it as
14:16:01 * dtantsur ParseError
14:16:10 <slagle> it's simply what we do today, deploy 2 heat stacks
14:16:31 <dtantsur> fultonj: if I take that picture literally, it implies one traditional undercloud per Edge
14:16:36 <owalsh> or three stack (should work too)
14:16:39 <fultonj> dtantsur: no
14:16:46 <dtantsur> fultonj: then it needs updating
14:16:47 <fultonj> i think there's a misunderstanding then
14:16:49 <slagle> owalsh: yes, multiple compute stacks
14:17:04 <owalsh> slagle: I mean tiers of stacks
14:17:04 <fultonj> one undercloud
14:17:12 <fultonj> multiple stacks
14:17:17 <bogdando> see, we reading that spec differently right now, again
14:17:21 <dtantsur> I think we should clean up and clarify that spec a bit, but not turn it into a full Edge spec
14:17:34 <slagle> ok
14:17:44 <bogdando> some of the points, captured by that etherpad, and I see the only action item is to update the spec so we all read it the same way
14:17:55 <slagle> who is going to propose the amendment? then we can figure it out in the review
14:18:04 <fultonj> split control plane covers a specific area
14:18:06 <bogdando> w/o asking would we have Ironic central or federated or none
14:18:20 <dtantsur> yeah, let's leave ironic for the 2nd spec
14:18:21 <fultonj> i think ironic federation would be compatible but a separate probelm
14:18:21 <openstackgerrit> Jiri Stransky proposed openstack/tripleo-upgrade master: Update required packages for containerized undercloud upgrade  https://review.openstack.org/605745
14:18:24 <bogdando> and more examples, just look into the open concerns please :)
14:18:29 <bogdando> goal 4
14:18:34 <jistr> quiquell: i think this is it, the patch ^^
14:18:37 <dtantsur> for now it's enough to provide some vision for the undercloud OR explicitly say we deal with it later
14:18:43 <jistr> quiquell: i'll add depends-on to the branch switch
14:18:44 <hjensas> don't we want to have some distribution of undercloud? i.e images, inspector dhcp etc. very light weight with focus on not having to transfer too much data all the way to main site? (so edge has tiny-uc's, far-edge just the overcloud) ?
14:18:45 <dtantsur> (later means in the next spec, not after MVP IMO)
14:18:47 <bogdando> ok then, not sure for the action here... 2nd spec or amending... or both
14:18:59 <fultonj> for the second AI i filed blueprints and it's clear how to proceed for me and others working on split control plane
14:19:05 <dtantsur> hjensas: we do, just not in this particular spec (again, IMO)
14:19:05 <slagle> fultonj: agreed
14:19:14 <bogdando> slagle: before amending, we need to resolve conflicts in the etherpad perhaps
14:19:15 <dtantsur> but we do need it for MVP
14:19:20 <bogdando> then just dump the resulting
14:19:26 <bogdando> I can do the latter
14:19:27 <slagle> bogdando: dtantsur : you seem to not be clear about the scope of the split-controlplane spec?
14:19:39 <dtantsur> slagle: actually, I suggest not to increase it
14:19:46 <fultonj> dtantsur: agree
14:19:49 <bogdando> ok, so another spec then
14:19:50 <slagle> yes
14:19:52 <dtantsur> only clarify and say explicitly what we leave out of it (e.g. undercloud)
14:19:53 <slagle> ok, then bogdando :)
14:19:55 <openstackgerrit> Jiri Stransky proposed openstack-infra/tripleo-ci master: Switch previous release of master from 'queens' to 'rocky'  https://review.openstack.org/590774
14:19:57 <quiquell> jistr: ack
14:19:59 <bogdando> just let please firstly fix contraditions )
14:20:02 <fultonj> thanks bogdando
14:20:07 <quiquell> jistr: let's see
14:20:12 <dtantsur> what I think we may disagree on is the scope of the MVP
14:20:16 <fultonj> i would love to identify any contradictions i don't see any but please show me
14:20:27 <fultonj> i think there will be many MVPs
14:20:37 <slagle> bogdando: i'm not seeing how your contradictions relate to the split-controlplane spec
14:20:54 <bogdando> fultonj: see lines 53 and to the end
14:20:57 <bogdando> https://etherpad.openstack.org/p/tripleo-edge-mvp
14:20:59 <slagle> bogdando: please make this part more clear, or propose an amendment to the existing spec so we can discuss there
14:21:13 <bogdando> those are all contradictional statements, including the scope of MVP
14:21:19 <fultonj> i read that we should unpack that more
14:21:38 <slagle> bogdando: again, what i'm asking for is, if you think the split-controlplane spec is not clear, to address that
14:21:44 <slagle> otherwise, let's move on
14:21:51 <bogdando> ok, that may be an action item, to unpack it, before drafting an MVP spec
14:21:57 <bogdando> makes sense?
14:22:39 <bogdando> as far as dtantsur agrees Ironic for edge fits a new spec, I agree as well, so we need no to update that spec
14:22:53 * dtantsur agrees
14:22:56 <fultonj> bogdando: ok
14:23:02 <openstackgerrit> Alex Schultz proposed openstack/tripleo-quickstart-extras master: Add ability to specify undercloud install command  https://review.openstack.org/605747
14:23:04 <fultonj> there was a second action item
14:23:06 <slagle> #agreed split-controlplane needs no updates and scope is clear based on filed blueprints
14:23:15 <fultonj> File blueprints for split-controlplane work in stein
14:23:34 <openstackgerrit> Athlan-Guyot sofer proposed openstack-infra/tripleo-ci master: New workflow for standalone upgrade.  https://review.openstack.org/604706
14:23:39 <fultonj> #link https://blueprints.launchpad.net/tripleo/+spec/split-controlplane
14:23:59 <fultonj> the above blueprint has 3 blueprints which depend on it
14:24:02 <slagle> i think it looks pretty good
14:24:06 <slagle> i added a couple
14:24:19 <dtantsur> yeah, the way this blueprint is written it's not even edge-specific, just a good feature to have
14:24:35 <fultonj> slagle: nice
14:24:42 <slagle> dtantsur: +1
14:24:49 <fultonj> template + workflow
14:24:56 <bogdando> to be clear, we have nothing to amend to that spec from https://etherpad.openstack.org/p/tripleo-edge-working-group-split-control-plane ?
14:25:01 <dtantsur> https://blueprints.launchpad.net/tripleo/+spec/split-controlplane-workflow may use some final decision on the ironic bits
14:25:09 <bogdando> indeed
14:25:11 <fultonj> dtantsur: yeah, it's something you can apply to edge
14:25:12 <slagle> bogdando: yes, see earlier #agreed
14:25:17 <slagle> it's settled :)
14:25:19 <bogdando> ok
14:25:36 <bogdando> ...some final decision on the ironic bits
14:25:39 <openstackgerrit> Kamil Sambor proposed openstack/tripleo-heat-templates master: Add posibilities to set tunnel_csum in ovs agent  https://review.openstack.org/605033
14:25:43 <bogdando> ruins a little bit that but ok
14:25:56 <dtantsur> well, the final decision for this blueprint can be: use pigeons
14:26:01 <bogdando> we'll make a 2nd spec for that, a partially contradictional to the split CP :)
14:26:10 <dtantsur> which is probably a good idea to avoid the scope creep
14:26:25 * fultonj awaits statements of the form (P & ~P)
14:26:50 <dtantsur> and then we need a blueprint to figure out provisioning the servers (with a long and contentious spec attached to it :)
14:27:04 <fultonj> dtantsur: yeah i agree
14:28:08 <slagle> alright, other AI's?
14:28:32 <slagle> dtantsur: do you plan to file this spec this week, or await more discussion?
14:29:07 <dtantsur> slagle: oh, I hope bogdando will do it :D
14:29:17 <dtantsur> but I can, if bogdando touched nose earlier :)
14:29:23 <bogdando> I can, just please see my comment for unpacking
14:29:31 <bogdando> that should predate creating spec
14:29:39 <fultonj> #action fultonj to get feedback from tripleo CI group on https://blueprints.launchpad.net/tripleo/+spec/split-controlplane-ci
14:29:41 <dtantsur> bogdando: I'll help with any assumptions/expectations around ironic
14:29:49 <slagle> alright, well we already took an action to review that etherpad
14:29:53 <slagle> so we'll wait on the spec
14:29:55 <bogdando> ok, thanks!
14:30:02 <slagle> #agenda One Off items
14:30:10 <slagle> #topic One Off items
14:30:13 <bogdando> note, it would be nice if someone can capture ongoing daily discussions in a from like that I did IMO
14:30:26 <bogdando> at least showing off contradictional things among folks
14:30:30 <openstackgerrit> Merged openstack/tripleo-common stable/queens: Fix nova-placement healthcheck  https://review.openstack.org/604272
14:31:03 <slagle> anything to highlight here?
14:31:06 <fultonj> we do have a meeting bot
14:31:11 <jistr> quiquell: sorry for pushing the tripleo-current promote, this time it was probably a red herring. It didn't click to me that it's actually t-h-t which is wrong, and that's taken from the bare metal host RPM. (Though if we don't have latest content in containers, we could still hit different issues potentially...)
14:31:18 <fultonj> regarding CI
14:31:44 <fultonj> i'm condering a using the standalone examples
14:31:50 <bogdando> fultonj: I did not mean the meeting notes
14:32:22 <slagle> fultonj: you mean standalone to deploy the separate compute?
14:32:30 <fultonj> slagle: yeah
14:32:47 <fultonj> tripleo-ci has stand-alone jobs...
14:32:49 <fultonj> https://github.com/openstack-infra/tripleo-ci/blob/master/zuul.d/standalone-jobs.yaml#L14
14:32:52 <fultonj> #https://github.com/openstack-infra/tripleo-ci/blob/master/zuul.d/standalone-jobs.yaml#L14
14:32:54 <slagle> it should work. EmilienM and I experimented with that a few weeks back
14:32:59 <fultonj> #link https://github.com/openstack-infra/tripleo-ci/blob/master/zuul.d/standalone-jobs.yaml#L14
14:33:28 <EmilienM> it was fun
14:33:30 <slagle> i agree it might be easier initially, until we have the whole workflow in place
14:33:39 <fultonj> #link https://gitlab.com/slagle/tripleo-standalone-edge/blob/master/standalone-central.sh
14:33:45 <openstackgerrit> Alex Schultz proposed openstack/tripleo-quickstart master: Pull in instack-undercloud  https://review.openstack.org/605753
14:33:57 <EmilienM> #link https://gitlab.com/emacchi/tripleo-standalone-edge
14:34:04 <EmilienM> oh thanks fultonj
14:34:05 <slagle> the job could even be 2 standalones. no UC
14:34:31 <EmilienM> (just a note about that repo: it was an afternoon project and really basic/RAW)
14:34:47 <gfidente> EmilienM I thought you only worked early mornings
14:34:48 <EmilienM> well I even got a PR from slagle so
14:34:51 <slagle> #idea use standalone for split-controlplane CI
14:35:07 <openstackgerrit> Alex Schultz proposed openstack/instack-undercloud master: DNM: testing ci  https://review.openstack.org/605755
14:35:48 <fultonj> owalsh: it would be an alternative to adding tripleo-quickstart/config/general_config/featureset056.yml
14:36:05 <fultonj> which could be based on https://github.com/olliewalsh/split/tree/fix_computes
14:36:33 <fultonj> any concerns about standalone not being sufficient to support the changes in the other blueprints?
14:36:34 <bogdando> +1 for the slagle's idea
14:36:52 <owalsh> fultonj: ack, good to test any custom roles etc... at least
14:38:07 <fultonj> #action fultonj try standalone for https://blueprints.launchpad.net/tripleo/+spec/split-controlplane-ci based on https://github.com/openstack-infra/tripleo-ci/blob/master/zuul.d/standalone-jobs.yaml#L14
14:38:16 <fultonj> EmilienM: i'll probably ask you for help :)
14:38:53 <openstackgerrit> Alex Schultz proposed openstack-infra/tripleo-ci master: Make standalone voting  https://review.openstack.org/605756
14:38:57 <mwhahaha> weshay, EmilienM -^
14:39:44 <slagle> #link https://etherpad.openstack.org/p/tripleo-compute-standalone
14:39:53 <slagle> fultonj: gfidente : there are notes i shared last week ^
14:40:04 <EmilienM> fultonj: please do
14:40:20 <EmilienM> fultonj: even if edge isn't my full time focus at this moment, I'm happy to contribute how I can
14:40:24 <gfidente> slagle yeah thanks I wanted to make sure we use same steps as I wanted to try some changes for cinder a/a
14:40:29 <fultonj> thanks EmilienM
14:40:43 <EmilienM> mwhahaha: it was about time
14:40:45 <EmilienM> :P
14:40:51 * mwhahaha blames tempest
14:41:07 <dtantsur> $ rm -rf tempest
14:41:16 <slagle> dtantsur: do you want to highlight what you added to the etherpad now?
14:41:37 <dtantsur> tl;dr is that I'm working on swiftless undercloud from ironic and inspector side
14:41:54 <dtantsur> overall, I guess, my focus is lightweight ironic in the undercloud
14:41:57 <slagle> awesome
14:42:03 <dtantsur> falling under the same topic is my metalsmith work
14:42:11 <dtantsur> (for which I responded to your comments slagle - thanks!)
14:42:16 <EmilienM> swiftless, novaless wow :)
14:42:21 <dtantsur> and glanceless, yes
14:42:26 <EmilienM> (and I'm not trolling)
14:42:26 <slagle> i may get around to filing a spec for a full swiftless
14:42:34 <slagle> it will take a lot of work around the plan management area
14:42:44 <mwhahaha> glance uses swift doesn't it
14:42:50 <mwhahaha> so we just need to switch to file based
14:42:50 <EmilienM> IIRC dprince mentioned some limitations if we get rid of Swift
14:42:53 <EmilienM> at PTG
14:43:04 <slagle> yes, there are some concerns
14:43:15 <slagle> but general agreement i felt
14:43:21 <slagle> hence, why a spec would be good
14:43:26 <shardy> One issue is we still need an API for the UI, so we'll need to work that out
14:43:31 <slagle> to get some concensus
14:43:41 <dtantsur> ironic-inspector is a big user of swift as well
14:43:51 <slagle> shardy: yea, ideally, the UI uses the mistral api for everything, and we can make changes transparently
14:44:12 <slagle> i guess we'll see if that's the case
14:44:26 <shardy> slagle: agreed but I don't think that is the case, jtomasek can confirm
14:44:39 <shardy> some things do still interact with swift directly IIRC
14:45:03 <slagle> ok
14:46:17 <dprince> regarding the plan operations we are already working on speed those up by avoiding exploading the templates in Swift here: https://review.openstack.org/#/c/581153/
14:46:47 <dprince> that isn't related to getting rid of swift... but it would mean we'd be using it more effectiently/correctly
14:46:59 <dtantsur> a question: if we switch the backend for introspection data, is it fine to just start from empty database?
14:47:01 <slagle> cool
14:47:18 <slagle> dtantsur: so delete all existing data?
14:47:28 <dtantsur> slagle: essentially
14:47:43 <slagle> dunno :/
14:47:46 <shardy> I don't think so, as on upgrade existing nodes would lose all their data?
14:47:48 <dprince> dtantsur: you would loose data. Like re-introspecting a deployed overcloud machine won't be an option in some cases
14:48:07 <shardy> yeah that's what I was thinking, migration would be better if possible
14:48:53 <dtantsur> I guess it boils down to whether people use introspection data after deployment
14:49:43 <dtantsur> if we come up with a separate script/playbook for migration, will it be okay?
14:49:51 <slagle> i'd think so
14:49:56 <slagle> as long as there's a way
14:50:04 <fultonj> +1
14:50:34 <dprince> what about swift-lite? :). Its like keystone-lite but faster
14:51:03 <EmilienM> no auth and basic middlewares only?
14:51:19 <slagle> i'd like a swift-lite. if it acted like a keystone authenticated file server
14:51:38 <weshay> bogdando, fyi.. I got master standalone deployed on f28 yesterday :)
14:51:46 <bogdando> weshay: \o/
14:51:47 <slagle> that's really all we need
14:51:55 <shardy> it can't be noauth because the plan contains passwords etc
14:51:58 <dprince> yeah, like a minimum usage front end for swift that gives us basic file storage
14:52:26 <slagle> +1
14:52:55 <slagle> alright, we're down to just a few mins left
14:53:00 <slagle> #topic Goals for the week
14:53:02 <dprince> honestly, swift isn't that heavy as is. and can be peeled down if we really wanted to (Emilien may be on the right track with pealing off the middleware)
14:53:11 <slagle> we've already captured a few AI's for the week
14:53:17 <slagle> are there any others folks can think of?
14:55:00 <fultonj> who wrote Anybody tried or is willng to do the work to have both isolated and shared networks in the Edge?
14:55:19 <slagle> dtantsur i think
14:55:30 <dtantsur> wut
14:55:36 <slagle> or not :)
14:55:42 <openstackgerrit> Alex Schultz proposed openstack/tripleo-heat-templates master: DNM: Ci test  https://review.openstack.org/605764
14:55:43 <dtantsur> no, I did not :)
14:55:47 <slagle> i'm not good at colors :)
14:55:56 <bogdando> pigeons
14:55:58 <bogdando> did
14:56:04 <fultonj> w.r.t. to that comment i assume we'll be doing both types of networks
14:56:25 <slagle> yea not sure if the comment is about undercloud or overcloud networks
14:56:50 <slagle> for the standalone separate compute we prototypes, we just used an isolated provider network on the compute node
14:58:02 <shardy> yeah with composable networks and/or separate stacks either should be possible
14:58:19 <shardy> but we'll need better validation in the multiple stacks case
14:58:26 <shardy> s/better/any
14:58:27 <bogdando> slagle: just a side rant, I wish we were talking the same thing, instead of undercloud vs overcloud. I mean really, the shared networking architecture should be the next step
14:59:06 <shardy> bogdando: the undercloud is one node, there's no need for multiple isolated networks?
14:59:13 <bogdando> yet
14:59:21 <openstackgerrit> Arx Cruz proposed openstack/tripleo-quickstart-extras master: WIP - Fix stackviz  https://review.openstack.org/605419
14:59:29 <bogdando> but there is some bug already, as a first messenger
15:00:00 <shardy> A multi-node undercloud is an overcloud with Ironic IMO, therefore the architecture is already the same
15:00:44 <slagle> feel free to continue discussion post-meeting :)
15:00:46 <slagle> #endmeeting