14:01:11 <cloudnull> #startmeeting tripleo
14:01:12 <openstack> Meeting started Wed Jul 31 14:01:11 2019 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:15 <openstack> The meeting name has been set to 'tripleo'
14:01:25 <EmilienM> tripleo is re-used? mhh ok
14:01:30 <gfidente> while we could keep things in different files, as provided by the user and leverage the native heat functionality
14:01:32 <cloudnull> welcome everyone to the new tripleo-transformation meeting time
14:01:35 <cloudnull> #topic rollcall
14:01:37 <cloudnull> o/
14:01:39 <ccamacho> o/
14:01:40 <ekultails> o/
14:01:41 <gfidente> o/
14:01:45 * EmilienM lurks
14:01:47 <mwhahaha> hi2u
14:01:51 <d0ugal> o/
14:01:59 <ccamacho> cd ..
14:02:01 <rbrady> o/
14:02:01 <ccamacho> ups
14:02:11 <dpeacock> o/
14:02:34 <gfidente> rbrady EmilienM d0ugal this guy here https://docs.openstack.org/heat/latest/template_guide/environment.html#environment-merging
14:02:57 <cloudnull> just a reminder.
14:02:59 <cloudnull> previous week minutes
14:02:59 <cloudnull> #link http://eavesdrop.openstack.org/meetings/tripleo/2019/tripleo.2019-07-25-13.00.html
14:02:59 <cloudnull> etherpad
14:02:59 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
14:02:59 <cloudnull> storyboard
14:03:00 <cloudnull> #link https://storyboard.openstack.org/#!/board/174
14:03:23 <cloudnull> we'll give a couple more minutes for folks to trickle in
14:04:12 <fultonj> o/
14:04:32 <openstackgerrit> Martin Schuppert proposed openstack/tripleo-heat-templates stable/queens: Add a ComputePPC64LE role  https://review.opendev.org/587701
14:05:02 <cloudnull> so lets get into it
14:05:04 <cloudnull> #topic Recap
14:05:17 * cloudnull cloudnull to send a note to the ML about the new meeting itme (cloudnull, 13:32:56) - done we're all here.
14:05:19 <cloudnull> :D
14:05:27 * cloudnull owalsh and cloudnull to get the osa connection plugin into a standalone repo and packaged (cloudnull, 13:28:49)
14:06:01 <cloudnull> owalsh wont be able to make it today, however, I suspect we're still in the planning phases of trying to get the connection plugin bits into a stand-alone repo
14:07:12 <cloudnull> I have not done anything with that just yet, though I hope to carve out some time a little latter this week to sync up with owalsh and mnaser to see what we can do, and what the best plan of attack is
14:07:26 <mnaser> ++
14:07:27 <cloudnull> #ACTION: owalsh and cloudnull to get the osa connection plugin into a standalone repo and packaged
14:07:37 <cloudnull> ^ just to carry that one forward.
14:07:57 <cloudnull> sshnaidm has there been any progress on the ARA front as of yet?
14:08:21 <openstackgerrit> Gael Chamoulaud proposed openstack/python-tripleoclient master: Mock deployment action in upgrade tests  https://review.opendev.org/673828
14:08:23 <sshnaidm> cloudnull, not yet
14:08:27 <cloudnull> np
14:09:21 <sshnaidm> cloudnull, I think we can back to it when ara will be rpm packaged
14:09:34 <cloudnull> #agreed
14:10:13 <cloudnull> #action look into ARA once its packaged
14:10:52 <cloudnull> #topic Open Discussion
14:11:02 <cloudnull> so I dont have a lot of structure topics today.
14:11:10 <cloudnull> anyone have anything they want to raise ?
14:12:46 <cloudnull> * last of the tripleo-common role import work is ready for review - https://review.opendev.org/#/q/topic:hieraroles+(status:open+OR+status:merged) - things are still gating but I've spent a lot of time working on these roles and making sure they're extremely well tested. We should have full coverage at this point, however, if there are any gaps ple
14:12:46 <cloudnull> ase let me know so we can get them addressed.
14:12:51 <ccamacho> cloudnull maybe a silly question
14:13:00 <ccamacho> should we create docs for tripleo-ansible?!
14:13:00 <cloudnull> ccamacho fire away
14:13:05 <ccamacho> like correct usage
14:13:11 <ccamacho> how to write the molecule tests
14:13:18 <cloudnull> #link https://docs.openstack.org/tripleo-ansible/latest/
14:13:28 <cloudnull> we have some, though it'd be great to create more
14:13:43 <openstackgerrit> Sagi Shnaidman proposed openstack/tripleo-ci master: Dump all hostvars to files  https://review.opendev.org/673829
14:14:15 <ccamacho> cloudnull awesome but I mean as an integration docs, from the main tripleo docs site
14:14:25 <ccamacho> cloudnull Ill try to create some
14:14:30 <cloudnull> +1
14:15:34 <cloudnull> ekultails and I are going to work on some contributing docs soon as well. maybe we can all team up on that front ?
14:16:11 <sshnaidm> I have a question about converting THT roles
14:16:20 <ekultails> Yeah, would be appropriate to work on some primary documentation about Molecule that's generic for all of TripleO.
14:16:29 <openstackgerrit> Merged openstack/tripleo-common master: Remove the tripleo.plan_management.v1.select_roles workflow  https://review.opendev.org/669164
14:16:36 <cloudnull> sshnaidm fire away
14:16:45 <sshnaidm> how to handle all these host_prep_tasks, post_upgrade_tasks, fast_forward_upgrade_tasks
14:17:29 <cloudnull> sshnaidm I've been trying to keep those sections in the heat templates as I've been converting things.
14:18:05 <cloudnull> this is a decent example https://review.opendev.org/#/c/671166/2/deployment/time/timezone-baremetal-ansible.yaml
14:18:18 <ccamacho> cloudnull awesome, Ill try to sync with ekultails
14:18:18 <openstackgerrit> Chandan Kumar (raukadah) proposed openstack/tripleo-quickstart master: [RHEL8] Fixed rdo_dlrn in release file  https://review.opendev.org/673738
14:18:28 <cloudnull> ccamacho ++
14:19:10 <sshnaidm> I see..
14:19:12 <cloudnull> #action ccamacho and ekultails to sync up on creating some more general molecule documentation within integrated tripleo
14:19:53 <cloudnull> sshnaidm I was trying not to disrupt the general workflow, as we convert from heat|ansible|puppet to ansible roles
14:20:28 <sshnaidm> cloudnull, I thought we are going to move all to ansible, getting rid off heat in some point, that's why was curios how to do it..
14:20:36 <cloudnull> I suspect there are steps we can remove, that may no longer be relevant as things are getting converted, however, I think that should be addressed on a case by case basis
14:21:16 <cloudnull> sshnaidm I believe that's the long term goal
14:21:49 <cloudnull> when I've been working on converting things I've been more focused on getting things our of puppet
14:22:57 <sshnaidm> cloudnull, ok, so for now we're fine with these _tasks, just throw puppets away
14:23:35 <cloudnull> I think once we've simplified the stack to just heat and ansible roles, we'll be able to further simplify some of these _tasks sections.
14:23:40 <openstackgerrit> Bogdan Dobrelya (bogdando) proposed openstack/tripleo-heat-templates master: Generate an unique prefix for each config worker  https://review.opendev.org/673802
14:23:52 <cloudnull> though I'm totally open to suggestions on that front .
14:25:46 <cloudnull> in the same vein, I do have a couple roles / heat templates I've converted which could use some review - https://review.opendev.org/#/q/topic:THT2TA+(status:open)
14:26:30 <sshnaidm> cloudnull, is it tested in running scenario jobs?
14:26:55 <cloudnull> I believe both of those are, yes.
14:27:38 <sshnaidm> cool
14:28:42 <cloudnull> anything else folks want to talk about today?
14:31:08 <openstackgerrit> Slawek Kaplonski proposed openstack/tripleo-quickstart-extras master: Add playbook and role to run tobiko  https://review.opendev.org/655423
14:31:18 <cloudnull> welp, if there's nothing else, I give you all back some time.
14:31:53 <cloudnull> thank you everyone
14:31:55 <cloudnull> #endmeeting