13:01:18 <cloudnull> #startmeeting tripleo
13:01:19 <openstack> Meeting started Thu Jul 18 13:01:18 2019 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:22 <openstack> The meeting name has been set to 'tripleo'
13:01:29 <cloudnull> #topic rollcall
13:01:42 <cloudnull> who's not here :D
13:02:11 <zbr> i have some news regarding molecule and rhel8
13:02:59 <cloudnull> very cool, lets make sure to raise that in open discussion.
13:03:07 <zbr> sure
13:03:11 <cloudnull> for a reminder
13:03:14 <cloudnull> #link https://storyboard.openstack.org/#!/project/openstack/tripleo-ansible
13:03:15 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
13:03:38 <cloudnull> etherpad and storyboard project
13:03:52 <gchamoul> weshay: o/
13:04:00 <cloudnull> #link https://storyboard.openstack.org/#!/board/174
13:04:10 <cloudnull> and our general work board.
13:04:19 <cloudnull> give folks a few more minutes to trickle in
13:05:21 <gchamoul> oh didn't notice that storyboard could replace trello! :D
13:05:46 <cloudnull> ++
13:05:59 <cloudnull> shameless plug https://cloudnull.io/2019/06/trello-to-storyboard-migration/
13:06:01 <Tengu> weshay: yep (sorry, on mtg until now). let's see how it goes with designate.
13:06:07 <cloudnull> gchamoul ^
13:06:24 <cloudnull> anyway, getting on with it
13:06:41 <cloudnull> #topic recap from past weeks
13:06:55 <weshay> Tengu you can add some services as well that may be better for validations
13:07:03 <cloudnull> previous ACTION: ekultails to work on getting tripleo-persist into tripleo-ansible
13:07:06 <gchamoul> cloudnull: impressive!
13:07:09 <cloudnull> ekultails hows that going?
13:08:12 <cloudnull> looks like there is a review for it
13:08:14 <cloudnull> #link https://review.opendev.org/#/c/670362/
13:08:28 <cloudnull> though its in merge conflict, is there anything we can do to help that along ?
13:08:56 <cloudnull> previous ACTION: cloudnull to start working on porting the hiera roles to tripleo-ansible
13:09:42 <cloudnull> ^ I've held back becuase the hiera roles are being worked on in tripleo-common. once we've stabalized those existing roles I'll work on porting them -cc EmilienM slagle
13:09:56 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-heat-templates master: Force removal of docker container in tripleo-docker-rm.  https://review.opendev.org/670796
13:10:02 <paramite> Guys, pretty please merge this: https://review.opendev.org/#/c/624325/
13:10:05 <paramite> panda, ^
13:10:24 <cloudnull> previous ACTION: sshnaidm to look into ARA.
13:10:27 <EmilienM> cloudnull: feel free to move it
13:10:28 <cloudnull> is that still on-hold at this point?
13:10:38 <EmilienM> cloudnull: I haven't been able to address slagle's review yet
13:10:39 <sshnaidm> cloudnull, started to play with it in molecule jobs, but no review still
13:11:01 <EmilienM> cloudnull: if you move it, I'll rework my patch on top of yours, so no biggies
13:11:16 <cloudnull> EmilienM ++ I just didn't want to impede progress, however I can get on that ASAP.
13:11:32 <EmilienM> +1
13:11:32 <cloudnull> #ACTION cloudnull to start porting hiera roles, for real this time
13:11:48 <openstackgerrit> Gael Chamoulaud proposed openstack/python-tripleoclient master: Add plan parameter to run_ansible_playbook function  https://review.opendev.org/671289
13:12:16 <cloudnull> once these three roles are moved over, we're out of tripleo-common
13:12:17 <cloudnull> #link https://github.com/openstack/tripleo-common/tree/master/roles
13:12:27 <Tengu> gchamoul: ok, I can open an issue against libpod "filter". Could prove the docker version does work with "foo|bar".
13:12:42 <cloudnull> and ekultails has taken care of the persist role.
13:12:45 <cloudnull> so good progress.
13:12:55 <cloudnull> sshnaidm cool
13:13:00 <cloudnull> anything we can help with on that front ?
13:13:09 <gchamoul> Tengu: like I said, we use it since Rocky so with docker.
13:13:12 <sshnaidm> cloudnull, not right now
13:13:40 <cloudnull> ++
13:13:53 <sshnaidm> cloudnull, I think we need to consider a standard way to add plugins/modules/whatever to ansible run in tripleo, not sure if it exists..
13:14:19 <sshnaidm> cloudnull, ara is not last plugin we'll want to use
13:14:39 <cloudnull> we have that here https://github.com/openstack/tripleo-ansible/tree/master/tripleo_ansible/ansible_plugins for plugins we make
13:15:13 <EmilienM> I think sshnaidm means a place where we control which ones we enable in a centralized way?
13:15:26 <sshnaidm> what EmilienM said ^
13:16:12 <sshnaidm> currently ara is installed in CI in mistral container in hacky way
13:16:19 <sshnaidm> it should change
13:16:32 <EmilienM> ok I see, we need an interface to configure which plugins we want to enable when deploying tripleo
13:16:40 <EmilienM> no matter it's standalone, undercloud or overcloud
13:16:51 <sshnaidm> yeah, install them, their dependencies and enable
13:17:09 <sshnaidm> because plugin have also dependencies we should care about them
13:17:09 <EmilienM> so for undercloud it could be a new parameter in undercloud.conf, and in overcloud/standalone, a heat parameter
13:17:17 <EmilienM> which would lay down the config
13:17:33 <mwhahaha> we already expose being able to provide the ansible.cfg, so what's missing?
13:17:45 <Tengu> gchamoul: https://github.com/containers/libpod/issues/3596
13:17:46 <mwhahaha> also we don't expect customers to add plugins
13:17:55 <sshnaidm> mwhahaha, I think installation and dependencies
13:18:03 <mwhahaha> should be rpms in standard locations
13:18:04 <cloudnull> we could edit the ansible action script to do that ?
13:18:07 <cloudnull> #link https://github.com/openstack/tripleo-common/blob/master/tripleo_common/actions/ansible.py#L52
13:18:09 <mwhahaha> if they aren't, we're doing it wrong
13:18:14 <sshnaidm> mwhahaha, ara doesn't have rpm afaik
13:18:23 <mwhahaha> ara won't be shipped
13:18:32 <gchamoul> Tengu: ++
13:18:32 <mwhahaha> so that's something specific to us and not part of tripleo proper
13:18:53 <mwhahaha> also ara 1.x is problematic so i don't really want to add ara support right now
13:19:00 <sshnaidm> mwhahaha, yes, but we still want it
13:19:05 <mwhahaha> i think that's an ara problem not tripleo
13:19:22 <cloudnull> -cc dmsimard
13:19:43 <sshnaidm> mwhahaha, it can work with <1 version like we have now in CI
13:20:13 <sshnaidm> mwhahaha, and maybe to enable it for undercloud eventually
13:20:29 <mwhahaha> after we get rid of mistral maybe
13:20:31 <mwhahaha> and then this is moot
13:20:41 <mwhahaha> i wouldnt' spend time trying to fix the mistral integration
13:20:45 <Tengu> poor mistral. nobody's loving it
13:20:49 <d0ugal> lol
13:21:03 <mwhahaha> which is why it's such a hack to enable
13:21:10 <sshnaidm> when do we plan to get rid of it?
13:21:15 * d0ugal ducks
13:21:18 <mwhahaha> soonish (tm)
13:21:19 <openstackgerrit> Giulio Fidente proposed openstack/tripleo-common master: Bump ceph/daemon container image to v4.0.1  https://review.opendev.org/671482
13:21:30 <mwhahaha> we're looking into it now
13:21:42 <sshnaidm> never liked it
13:22:08 <mwhahaha> point being, we should spend the resources to fix why we have this problem rather than working around it :D
13:23:01 <sshnaidm> ok, so leaving the old way of injecting ara in CI?
13:23:06 <mwhahaha> for now
13:23:11 <sshnaidm> ack
13:23:29 <sshnaidm> and what with other possible fancy plugins?
13:23:41 <mwhahaha> we revisit when we have new fancy plugin
13:24:09 <cloudnull> sshnaidm if its something we're shipping with tripleo I think we would just need to add them to
13:24:12 <cloudnull> #link https://github.com/openstack/tripleo-ansible/tree/master/tripleo_ansible/ansible_plugins
13:24:29 <cloudnull> unless its something that has to be specifically enabled, like a call back
13:24:39 <cloudnull> then we'd have to edit the tripleo action config too
13:25:03 <sshnaidm> cloudnull, ok
13:25:06 <cloudnull> things like action plugins, libraries, etc would get automatically picked up if we put them in that path
13:25:51 <cloudnull> we do have a few plugins, and they're doc'd
13:25:55 <cloudnull> #link https://docs.openstack.org/tripleo-ansible/latest/modules.html
13:26:10 <sshnaidm> cloudnull, well, we can't just take plugin of somebody and put in our repo
13:26:14 <sshnaidm> I think
13:26:30 <cloudnull> ++ correct, I think that would be bad form
13:26:32 <sshnaidm> is it's just python package
13:26:42 <mwhahaha> in order for it to be in tripleo it needs to be packageds
13:26:50 <mwhahaha> and should use standard paths that we can add
13:26:58 <sshnaidm> mwhahaha, in case we ship it
13:27:04 <sshnaidm> and it's part of the product
13:27:16 <cloudnull> the plugins in tripleo-ansible were all written by us.
13:27:21 <mwhahaha> unless you have a specific example i think we're going to keep going around in circles on this
13:27:29 <cloudnull> ++
13:27:33 <sshnaidm> yeah, agree, let's move on
13:27:48 <sshnaidm> we'll talk about it when I find next fancy callback plugin
13:27:52 <cloudnull> :)
13:27:54 <cloudnull> #topic THT 2 TripleO-Ansible
13:27:59 <cloudnull> Here is our current work-lists
13:27:59 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/685
13:27:59 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/711
13:28:07 <cloudnull> I started on a couple services/roles, which could use some reviews
13:28:07 <cloudnull> #link https://review.opendev.org/#/q/topic:podman-role+(status:open+OR+status:merged)
13:28:07 <cloudnull> #link https://review.opendev.org/#/q/topic:time-role+(status:open+OR+status:merged)
13:28:18 <cloudnull> but there are A LOT of things in those lists
13:28:25 <cloudnull> so help would be greatly appreciated.
13:29:02 <cloudnull> unless folks want to talk more about that, I'd like to move right in to Open Discussion
13:29:16 <cloudnull> #topic Open Discussion
13:29:27 <cloudnull> zbr what to kick us off with the RHEL 8 bits ?
13:30:28 <cloudnull> EmilienM new role for config things ?
13:30:34 <EmilienM> o/
13:30:49 <EmilienM> I'm currently exploring the replacement of Puppet by Ansible to generate config files
13:31:08 <EmilienM> we started the process to import ansible-config_template in RDO
13:31:28 <EmilienM> and I plan to create a basic role in tripleo-ansible to consume that plugin
13:31:46 <EmilienM> that module*
13:32:05 <cloudnull> #link https://review.rdoproject.org/r/#/q/(topic:ansible_config_template+OR+topic:pkg-config_template)+(status:open+OR+status:merged)
13:32:33 <EmilienM> this role would be the interface for THT to generate the configuration files
13:32:33 <cloudnull> thank you chandankumar and others for helping to move that along
13:33:00 <EmilienM> I'll give more updates when I have actual progress. I just wanted to share the plan
13:33:35 <cloudnull> cool!
13:33:43 * EmilienM done
13:34:09 <openstackgerrit> Martin Schuppert proposed openstack/tripleo-heat-templates master: Only run cellv2 host discovery on default cell  https://review.opendev.org/671486
13:34:16 <cloudnull> #link https://review.opendev.org/#/c/669672/
13:34:18 <zbr> cloudnull: re rhel8, I added some comments on the document. if we write molecule.yml files with overridable vars inside, we can test on alternative platforms.
13:34:20 <cloudnull> to EmilienM role
13:35:09 <cloudnull> zbr mind walking us through some of what you were thinking ?
13:36:06 <zbr> sadly i do not have something ready, but you can get an idea from https://review.rdoproject.org/r/#/c/21489/11/molecule/default/molecule.yml
13:36:29 <cloudnull> in tripleo-ansible we do have a couple roles running with the delegated driver, is there something we need to change to make what your thinking go ?
13:36:44 <zbr> if we put a single platform at platforms, and use envvars, we can create additional jobs that override default platform.
13:37:11 <cloudnull> oic
13:37:34 <cloudnull> so then we'd have 1 job per OS?
13:37:51 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common master: Skip standalone deploys if tox jobs fail  https://review.opendev.org/671071
13:38:01 <cloudnull> in most cases, at this point, that would be CENT7 and FED28 (for tripleo-ansible)
13:38:47 <marios> folks zbr is currently on the phone with tripleo-ci squad for sprint planning he might be a bit slow to respond for few mins
13:39:02 * mnaser lurks
13:39:15 <cloudnull> np
13:39:31 <cloudnull> sshnaidm want to talk about meeting times?
13:39:48 <sshnaidm> cloudnull, yeah :D we're double booked
13:40:09 <sshnaidm> cloudnull, I thought about voting on doodle or kind of
13:40:35 <cloudnull> there was a vote here in the last IRC meeting, however, nobody, except me, voted.
13:40:39 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common master: Revert "Linting hardening via pre-commit"  https://review.opendev.org/671056
13:41:03 <cloudnull> #link http://eavesdrop.openstack.org/meetings/tripleo/2019/tripleo.2019-07-11-13.00.html
13:41:07 <cloudnull> item 6.
13:41:24 <cloudnull> however we can do that again? or do we want to send something to the ML
13:42:50 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common master: Set container=oci for our containers  https://review.opendev.org/670574
13:43:35 <sshnaidm> cloudnull, whatever works, but not changing this after voting like we did :)
13:44:09 <cloudnull> hahaha.
13:44:48 <openstackgerrit> Gael Chamoulaud proposed openstack/python-tripleoclient master: Don't use local connection by default for the validations  https://review.opendev.org/671491
13:44:49 <mnaser> EmilienM, cloudnull: just fyi i'm going to be reviewing and clearing up all open ansible-config_template reviews, feel free to ping me if you need any review work
13:44:53 <sshnaidm> cloudnull, we can submit a patches with times and people can +1/-1 them
13:45:54 <cloudnull> #action cloudnull to send a message to the ML w/ a doodle so we can nail down an appropriate meeting time that works for more folks.
13:45:56 * mnaser has a small thing to bring up after the time discussion
13:46:25 <cloudnull> sshnaidm I'll take it to the ML so everyone has a chance to participate
13:46:38 * cloudnull hands mic to mnaser
13:46:42 <sshnaidm> cloudnull, ack, maybe using like that: https://doodle.com/poll/2hb42hhq678m9f5k
13:46:45 <ekultails> ++
13:46:48 <cloudnull> sshnaidm ++
13:47:19 <mnaser> so one of the things that's awesome is that we're sharing a lot of stuff together (yay), but i feel like an odd thing seems like one group or another has 'ownership' over the stuff we collaborate one
13:47:52 <mnaser> so triploe consumes ansible-config_template and os_tempest but its technically "openstack-ansible" yet no one from tripleo team is in openstack-ansible so logistically i feel like that might be limiting from time to time
13:48:33 <mnaser> i'm wondering if there maybe a good idea in possibly taking s ome openstack-ansible repos and having them with a shared core-wnership from tripleo-ansible and openstack-ansible
13:48:58 <EmilienM> we don't consume ansible-config_template yet btw, we're in the process to look at it :D
13:49:10 <EmilienM> but yeah
13:49:44 <mnaser> well just in general, yeah, as an overall idea
13:49:57 <EmilienM> +1 for shared ownership
13:49:59 <arxcruz> EmilienM, we use it on os_tempest
13:50:01 <cloudnull> mnaser that's a good idea
13:50:07 <ekultails> Definitely +1
13:50:48 <openstackgerrit> Alex Schultz proposed openstack/tripleo-heat-templates stable/stein: Add facter cache for container configurations  https://review.opendev.org/671492
13:51:02 <mnaser> totally ok with any other proposals but given the "openstack-ansible" seems like a pretty .. good namespace for shared workspace, i think it might be good to keep it and maybe create an acl called openstack-ansible-collab and have both OSA cores and tripleo-ansible cores in there?
13:51:08 <cloudnull> arxcruz ++ hopefully we can start using the shiny new package for the config_template plugin soon :)
13:52:29 <cloudnull> is still OSA core on all the things
13:52:32 * cloudnull hides
13:52:49 <mnaser> :P
13:52:50 <sshnaidm> mnaser, I think we don't have "tripleo-ansible" cores, tripleo has a shared cores space
13:53:15 <sshnaidm> mnaser, but could be a tripleo-ansible squad
13:53:31 <cloudnull> I think there is a project config for it, though im not sure anyone is in the group though
13:53:33 <mwhahaha> we can create a tripleo-ansible group
13:53:35 <mwhahaha> no big deal
13:53:46 <mnaser> i guess as long as we try to 'share' ownership (i.e. like at least have an OSA core 'ok' a patch alongside a tripleo one) that would be nice
13:53:49 <dmsimard> mwhahaha, sshnaidm, cloudnull: let's take a few mins to sync about the status of ara 1.x after meeting :)
13:53:49 <mwhahaha> might help with some of the ansible review thingies
13:54:01 <mnaser> but i think we all have been around enough to trust each other not to break eachother :D
13:54:04 <sshnaidm> dmsimard, sure
13:54:17 <mnaser> (and hopefully that encourages use of more cross-project jobs so we dont accidentally break each other anyways)
13:54:50 <cloudnull> mwhahaha https://review.opendev.org/#/admin/projects/openstack/tripleo-ansible,access - so maybe we just need to add people to that group?
13:55:06 <cloudnull> dmsimard ++
13:55:09 <mwhahaha> will need to check if that's actually in use
13:55:10 <mwhahaha> but yea
13:55:23 <mnaser> tripleo-ansible-core seems to have all of tripleo inside of it
13:55:32 <cloudnull> mnaser ++
13:55:32 <mnaser> which tbh, i dont really mind as long as people arent just merging random stuff anyways :p
13:55:46 * cloudnull broke the gate yesterday with my config_template patch ....
13:55:58 <mnaser> so not to complicate things, ill push up a patch for openstack-ansible-collab and add both tripleo-ansible-core and openstack-ansible-core to it
13:55:58 <mwhahaha> we'll just blame cloudnull
13:56:14 <cloudnull> a cross project gate would have been super useful
13:56:21 <cloudnull> mwhahaha that's fair
13:56:23 <arxcruz> cloudnull, https://www.youtube.com/watch?v=SrDSqODtEFM
13:56:26 <mnaser> and then maybe ansible-config_template or os_tempest could be the first target to add
13:56:32 <mnaser> does that sound good? :>
13:56:45 <cloudnull> arxcruz https://twitter.com/cloudnull/status/1151588948608802816
13:56:58 <arxcruz> cloudnull, i see that :)
13:57:02 <cloudnull> :D
13:57:08 <cloudnull> mnaser ++
13:57:22 <mnaser> ok ill try to do this today
13:57:26 <cloudnull> any takers to work on that ?
13:57:28 <cloudnull> cool !
13:57:32 <mnaser> ill do the acl-y stuff
13:58:02 <cloudnull> #action mnaser to see about setting up acl-y stuff for cross project thing-a-me's
13:58:18 <cloudnull> ok welp, we're just about out of time. anything else ?
13:58:53 <cloudnull> OK well, great meeting all!
13:58:59 <cloudnull> #endmeeting