13:00:16 <cloudnull> #startmeeting tripleo
13:00:17 <openstack> Meeting started Thu Jul 11 13:00:16 2019 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:20 <openstack> The meeting name has been set to 'tripleo'
13:00:33 <cloudnull> mornings all Tripleo-Transformation squad meeting time
13:00:42 <cloudnull> #topic RollCall
13:00:46 <cloudnull> o/
13:00:48 <ekultails> o/
13:00:53 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-common stable/stein: Add playbook to stop containers (stein only)  https://review.opendev.org/669345
13:01:21 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-ansible master: Add playbook to stop containers  https://review.opendev.org/669650
13:01:58 <cloudnull> ping cloudnull fultonj mwhahaha sshnaidm ekultails dpeacock openstackgerrit jistr zbr EmilienM slagle mnaser openstack dmsimard gfidente JqckB dciabrin Tengu
13:02:09 <openstackgerrit> Merged openstack/tripleo-ansible master: Fix setup.py for symlinked tripleo-docker-rm  https://review.opendev.org/670272
13:02:20 <Tengu> oh, right :)
13:02:20 <cloudnull> give folks a few min to trickle in
13:03:43 <EmilienM> openstack was pinged, we can start :P
13:03:55 <cloudnull> :D
13:04:59 <cloudnull> welp, lets just jump into it.
13:05:06 <cloudnull> here's our etherpad
13:05:10 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
13:05:20 <cloudnull> #topic recap from past weeks
13:05:36 <cloudnull> last week there was no meeting. so n/a
13:05:47 <cloudnull> but following up on previous action items,
13:05:55 <cloudnull> sshnaidm|ruck - ACTION: ping pabelanger and pester dmsimard about ARA
13:06:03 <cloudnull> is that something we've been able to look into ?
13:06:13 <sshnaidm|ruck> cloudnull, not today, on hold
13:06:19 <cloudnull> not limited to sshnaidm|ruck, curious if anyone has?
13:06:25 <cloudnull> sshnaidm|ruck ++
13:07:12 <cloudnull> I think it should be fairly straight forward now that we're not using tox, I'm not 100% sure but we may be able to use ARA as provided by infra in our native jobs?
13:07:33 <cloudnull> dmsimard I may bother you about that later this afternoon :D
13:07:58 <cloudnull> before we move on, did we have any other action items we wanted to talk about ?
13:08:13 <cloudnull> from previous weeks ?
13:08:49 <zbr> cloudnull: as i said before, the meeting overlaps with tripleo-ci scrum meetings, making hard to attend it.
13:09:11 <cloudnull> we should explore a new meeting time and day.
13:09:11 <sshnaidm|ruck> cloudnull, if it's not ansible "nested" we definitely can use ara provided by infra
13:10:00 <sshnaidm|ruck> but molecule afaik runs invokes ansible inside the job, so..
13:10:17 <ekultails> sshnaidm|ruck: Do you mean as long as we're testing pure Ansible (outside of Heat templates, etc.)?
13:10:18 <cloudnull> ^ that might be a problem
13:10:56 <zbr> sshnaidm|ruck: molecule in fact runs like this>.  tox > pytest > molecule > ansible
13:10:57 <sshnaidm|ruck> ekultails, as long as we use ansible of zuul executor, not running our "own" ansible inside the job
13:10:59 <cloudnull> zbr I will kick something out to the ML, is the tripleo-ci scrum only on Thursday's at this time?
13:11:26 <zbr> only on friday we do not have scrum
13:11:31 <cloudnull> ok
13:11:32 <sshnaidm|ruck> zbr, yeah, so we can't use this.. need to add ara plugin to molecule
13:11:34 <ekultails> sshnaidm|ruck: Gotcha, thanks for the clarification. That does make things tricky for us.
13:12:01 <sshnaidm|ruck> zbr, friday is not working day :)
13:12:26 <zbr> i did not explore ara+molecule so far because using pytest-html report was good-enough for me.
13:12:35 <sshnaidm|ruck> ekultails, in tripleo jobs we install ara in mistral container to make it available for ansible overcloud run, so it's solvable..
13:12:37 <zbr> but i see no problem with it, it is pure absible
13:13:09 <cloudnull> lots of folks don't work Friday so I'm thinking it needs to be Wednesday or Tuesday ?
13:13:52 <sshnaidm|ruck> cloudnull, Wed looks fine, also Tuesday after tripleo-ci mtg
13:13:55 <cloudnull> and I'm not sure we want to have this meeting any earlier for folks on the west coast of the US or much later for folks in the EU
13:14:45 <sshnaidm|ruck> is somebody from west coast here?
13:15:25 <cloudnull> #startvote What day should this meeting take place? Tuesday, Wednesday, Thursday
13:15:26 <openstack> Begin voting on: What day should this meeting take place? Valid vote options are Tuesday, Wednesday, Thursday.
13:15:27 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
13:16:08 <cloudnull> #vote Wednesday
13:16:31 <cloudnull> ekultails I dont think so, but I'd not like to alienate anyone
13:16:59 <sshnaidm|ruck> maybe to make doodle or kind of, we are limited more by day-hour combinations
13:17:58 <mwhahaha> i'm mountain and this is already too early
13:18:06 <mwhahaha> but i'll just not attend
13:18:27 <cloudnull> :'(
13:18:42 <cloudnull> but your my guide through the joy of heat :D
13:18:43 <mwhahaha> once school starts this is too early and especially when the time changes in the winter
13:19:00 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-upgrade master: Pass neutron-ovs.yaml environment in upgrade prepare.  https://review.opendev.org/670031
13:19:08 <mwhahaha> dat 6am irc meeting is not high on my list :D
13:19:22 <cloudnull> ok while this vote takes place, lets move on to the next topic
13:19:24 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-heat-templates master: Stop services for unupgraded controllers  https://review.opendev.org/669095
13:19:26 <cloudnull> #topic What's left to port over from tripleo-common
13:19:46 <cloudnull> we've made some excellent progress moving roles over to tripleo-ansible
13:19:53 <cloudnull> you can see what's left in tripleo-common here https://github.com/openstack/tripleo-common/tree/master/roles
13:20:15 <cloudnull> couple roles from stroyboard need to get picked up https://storyboard.openstack.org/#!/worklist/688
13:20:19 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/688
13:20:47 <cloudnull> dpeacock have you been able to make progress on tripleo-persist ?
13:20:49 <cloudnull> #link https://storyboard.openstack.org/#!/story/2006042
13:21:54 <openstackgerrit> Gael Chamoulaud proposed openstack/python-tripleoclient master: [WIP] Allow running validations with custom extra variables  https://review.opendev.org/670091
13:22:07 <dpeacock> cloudnull: not yet - my apologies - I've been tied up on other projects
13:22:28 <cloudnull> does anyone want to volunteer for the roles left in tripleo-common (todo)
13:22:28 <dpeacock> cloudnull: happy for someone else to step in and nab it if they are free and motivated
13:22:30 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/688
13:22:38 <cloudnull> dpeacock no worries
13:22:44 <openstackgerrit> mathieu bultel proposed openstack/python-tripleoclient master: Make mistral optional for Ansible Update and Upgrade  https://review.opendev.org/670295
13:22:47 <openstackgerrit> James Slagle proposed openstack/tripleo-common master: Also write NetworkConfig to role dir  https://review.opendev.org/670152
13:22:59 <cloudnull> its not like we're in a mad rush at this point
13:23:06 <ekultails> cloudnull, dpeacock: I can try to get it moved over.
13:23:14 <cloudnull> ekultails ++
13:23:17 <ekultails> Would be cool to see everything moved into tripleo-ansible. :-)
13:23:18 <dpeacock> ekultails: thanks
13:23:37 <ekultails> No problem, I'll bug you guys for reviews later.
13:23:44 <cloudnull> #ACTION ekultails to work on getting tripleo-persist into tripleo-ansible
13:24:37 <cloudnull> slagle I've kinda shy'd away from the hiera roles just because I know you were working on them, however, are they in a place now where we can port them over?
13:25:05 <sshnaidm|rover> cloudnull, isn't it a worklist? https://storyboard.openstack.org/#!/worklist/685
13:25:15 <slagle> cloudnull: yes, i think so. there aren't any outstanding patches atm
13:25:38 <sshnaidm|rover> cloudnull, oh, it's from tht, sorry
13:25:45 <cloudnull> sshnaidm|rover ++
13:26:17 <cloudnull> slagle cool , I'll try and get something together to move those roles over in the coming days. I just didn't want to step on your toes.
13:26:34 <cloudnull> #ACTION cloudnull to start working on porting the hiera roles to tripleo-ansible
13:27:00 <cloudnull> Ok next topic
13:27:12 <cloudnull> #topic Work to port over the tripleo-common playbooks is in need of reviews
13:27:22 <cloudnull> #link https://review.opendev.org/#/c/667247
13:27:30 <cloudnull> #link https://review.opendev.org/#/c/665256/
13:27:50 <cloudnull> those reviews round out porting over the playbooks that were found in tripleo-common to tripleo-ansible
13:27:59 <cloudnull> if we could get some reviews on those items it'd be great
13:28:52 <openstackgerrit> Martin Schuppert proposed openstack/tripleo-heat-templates master: Revert "Also set nova::network::neutron::dhcp_domain"  https://review.opendev.org/669270
13:29:38 <cloudnull> once those reviews are in, and the last three remaining roles are ported we're out of tripleo-common !
13:29:43 <cloudnull> which is pretty cool!
13:30:12 <mwhahaha> yay progress
13:30:22 <cloudnull> the wheel of progress :D
13:30:41 <mwhahaha> is square
13:30:46 <cloudnull> we're getting to the point where the real fun begins
13:30:52 <cloudnull> #topic We're ready to begin moving ansible tasks from heat templates into roles
13:31:02 <cloudnull> #link  https://storyboard.openstack.org/#!/worklist/685
13:31:32 <cloudnull> I did start with some simple roles
13:31:34 <cloudnull> #link https://review.opendev.org/#/q/topic:convertAide+(status:open+OR+status:merged)
13:31:51 <cloudnull> #link https://review.opendev.org/#/q/topic:convertTuned+(status:open+OR+status:merged)
13:32:13 <cloudnull> but this is where a large body of work will be.
13:32:13 <sshnaidm|rover> I started with login-defs role, just to try, and discovered it never worked in tht :D
13:32:24 <cloudnull> nice!
13:33:10 <cloudnull> I suspect we'll find more of those types of things and other gremlins as we convert things (puppet, heat, ansible)
13:33:27 * cloudnull shakes fist at heat data types
13:33:55 <sshnaidm|rover> mwhahaha, do you think it's worth to add some new resources like aide, login-defs to 004 scenario to keep them working? The don't take much place and resources..
13:34:06 <mwhahaha> yea probably
13:34:11 <mwhahaha> aide is another one that isn't covered (i don't think)
13:34:17 <cloudnull> if folks have a thing-a-me on the THT worklist that they'd like to do please feel free to jump in whenever, the list is not ordered in any particular priority
13:34:20 <sshnaidm|rover> mwhahaha, yeah, it's not
13:34:24 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-heat-templates stable/stein: Stop services for unupgraded controllers  https://review.opendev.org/669628
13:34:34 <mwhahaha> maybe not 4, maybe 2 or 3 i think those are quicker
13:34:38 <mwhahaha> but somewhere at least
13:36:14 <sshnaidm|rover> mwhahaha, well, I think 4 is fastest, and we already run it on tripleo-ansible
13:36:20 <sshnaidm|rover> mwhahaha, so less jobs! :D
13:36:26 <mwhahaha> sure
13:36:42 <mwhahaha> i always thought 1/4 were the slow ones because ceph
13:36:51 <mwhahaha> but i haven't paid attention in a while
13:37:42 <sshnaidm|rover> mwhahaha, yeah, I've compared them, 004 is quick
13:38:21 <sshnaidm|rover> but then we need to revisit our zuul layout when we added a lot of new roles again
13:38:32 <sshnaidm|rover> to keep it covered
13:40:27 <cloudnull> so moving on to our final topic
13:40:35 <cloudnull> #topic Open Discussion
13:41:00 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-common master: tripleo-hieradata: merge j2 hiera templates  https://review.opendev.org/669916
13:41:01 <cloudnull> what's good? anything anyone wants/needs to raise?
13:41:28 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-common master: tripleo-hieradata: include config_step into all_nodes_merged  https://review.opendev.org/669921
13:41:36 <ekultails> Yeah
13:41:48 * cloudnull hands mic to ekultails
13:42:21 <openstackgerrit> David Peacock proposed openstack/python-tripleoclient master: WIP - Implement tripleo container image show command  https://review.opendev.org/667988
13:42:39 <ekultails> A few weeks ago I came up with a list of difficulty for adding Molecule tests to the tripleo-validations repository. I wanted to try to tackle the "Hard (requires [a working] OpenStack)" use case. https://etherpad.openstack.org/p/tripleo-validations-molecule
13:43:02 <ekultails> It seems like deploying a standalone instance of TripleO in CI and then running Molecule tests against that might be our best bet.
13:43:13 <ekultails> Was wondering if zbr or anyone else from CI might have any suggestions on that.
13:43:21 <zbr> i will comment on it, give me few minutes.
13:44:15 <ekultails> zbr: No problem, I know you're busy with other meetings. We can even take this offline and discuss it more during our next meeting.
13:44:35 <openstackgerrit> Chandan Kumar (raukadah) proposed openstack/tripleo-ci master: DNM: RHEL8 support for containers build  https://review.opendev.org/669487
13:45:11 <EmilienM> slagle: if you're fine with it, you can approve https://review.opendev.org/#/c/669951/
13:46:29 <sshnaidm|rover> ekultails, you mean to run on localhost via delegated driver?
13:47:01 <openstackgerrit> Chandan Kumar (raukadah) proposed openstack/tripleo-ci master: DNM: RHEL8 support for containers build  https://review.opendev.org/669487
13:47:46 <cloudnull> ekultails sshnaidm|rover I think you'd have to run using the delegated driver when trying to interact with a running cloud on the same machine.
13:47:53 <slagle> EmilienM: done
13:48:02 <openstackgerrit> Chandan Kumar (raukadah) proposed openstack/tripleo-ci master: DNM: RHEL8 support for containers build  https://review.opendev.org/669487
13:48:20 <EmilienM> slagle: thx
13:49:25 <ekultails> sshnaidm|rover: No, not exactly. With tripleo-validations we need to run some tests to, for example, make sure baremetal nodes are properly added in Ironic. Or that specific nova services are running. I'm not sure of the extent of how well these validations would work on the cloud CI provides. We need to be able to look at what services are running, check logs, modify OpenStack configurations, etc.
13:53:46 <sshnaidm|rover> ekultails, I see, sorry, not familiar with validations ci tbh
13:56:07 <owalsh> cloudnull: hey, making some process with the OSA ssh connection plugin...
13:56:15 <cloudnull> awesome!
13:56:32 <cloudnull> ekultails ^ that might be useful for validations ?
13:56:37 <owalsh> required some minor hacks to the nsenter working with docker inspect to get the pid
13:57:14 <sshnaidm|rover> mwhahaha, can you review please? https://review.opendev.org/#/c/664877/ it's tested in https://review.opendev.org/#/c/668671/
13:57:17 <mwhahaha> sshnaidm|rover: probably because we don't really have any decent validations ci
13:57:26 <owalsh> cloudnull: problem I'm hitting now is the tmpdir
13:57:33 <cloudnull> owalsh I figured there might be some work required to make that go.
13:57:44 <cloudnull> what are you seeing ?
13:58:13 <cloudnull> -cc mnaser ^
13:58:17 <gchamoul> mwhahaha, sshnaidm|rover: I confirm ...
13:58:58 <owalsh> cloudnull: it's including the remote user in the tmp path e.g /proc/5772/root/~heat-admin/.ansible/tmp/ansible-tmp-1562853495.98-499502180359/command.py'
13:59:01 <cloudnull> welp that's about all the time we have for our meeting. I appreciate everyone take the time to contribute.
13:59:22 <cloudnull> #endvote
13:59:23 <openstack> Voted on "What day should this meeting take place?" Results are
13:59:24 <openstack> Wednesday (1): cloudnull
13:59:38 <cloudnull> given I was the only voter, I consider that null
13:59:50 <cloudnull> will try and send something to the ML later today
14:00:07 <mnaser> owalsh: oh pretty cool for the OSA ssh connection plugin, please feel free to reach out, we can work together to make things happen so you can use it upstream only
14:00:10 <cloudnull> ekultails sshnaidm|rover zbr please continue the conversation on the validations work offline
14:00:18 <cloudnull> #endmeeting