14:00:13 <mwhahaha> #startmeeting tripleo
14:00:13 <mwhahaha> #topic agenda
14:00:14 <mwhahaha> * Review past action items
14:00:14 <mwhahaha> * One off agenda items
14:00:14 <mwhahaha> * Squad status
14:00:14 <mwhahaha> * Bugs & Blueprints
14:00:14 <mwhahaha> * Projects releases or stable backports
14:00:15 <mwhahaha> * Specs
14:00:15 <mwhahaha> * open discussion
14:00:15 <openstack> Meeting started Tue May  7 14:00:13 2019 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:16 <mwhahaha> Hi everyone! who is around today?
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <jrist> o/
14:00:18 <openstack> The meeting name has been set to 'tripleo'
14:00:28 <fultonj> o/
14:00:33 <fmount> o/
14:00:46 <ksambor> o/
14:01:03 <bogdando> o/
14:01:16 <panda> o/
14:01:46 <marios> o/
14:01:58 <ekultails> o/
14:02:06 <arxcruz> o/
14:02:06 <beagles> o/
14:02:40 <dpeacock> o/
14:03:06 <rlandy> o/
14:03:17 <weshay> 0/
14:03:28 <openstackgerrit> mathieu bultel proposed openstack/tripleo-heat-templates master: Enable serial execution for ansible host  https://review.opendev.org/635730
14:03:47 <mwhahaha> alright looks like we have a few people here, let's go
14:03:55 <mwhahaha> #topic review past action items
14:03:55 <mwhahaha> None
14:04:07 <mwhahaha> no action items from the previous meeting
14:04:09 <mwhahaha> moving on
14:04:12 <openstackgerrit> mathieu bultel proposed openstack/tripleo-validations master: Add serial option in tripleo-ansible-inventory script  https://review.opendev.org/635860
14:04:12 <Tengu> \o/
14:04:18 <mwhahaha> #topic one off agenda items
14:04:18 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:29 <mwhahaha> (brault): Just wanted to get your attention on the following patch:
14:04:34 <mwhahaha> https://review.opendev.org/#/c/651751/ -- Modify udev rule for VF representor renam
14:04:53 <mwhahaha> looks like brault isn't here, that's an os-net-config patch
14:05:11 <mwhahaha> dsneddon: if you have some time to review -^
14:08:40 <chandankumar> o/
14:09:14 <mwhahaha> that's it on the agenda items
14:09:19 <mwhahaha> moving on to status
14:09:30 <mwhahaha> #topic Squad status
14:09:31 <mwhahaha> ci
14:09:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:09:31 <mwhahaha> upgrade
14:09:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:09:31 <mwhahaha> edge
14:09:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:09:32 <mwhahaha> integration
14:09:32 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:09:33 <mwhahaha> validations
14:09:33 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:09:34 <mwhahaha> networking
14:09:34 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:09:43 <mwhahaha> any status items that folks would like to highlight?
14:10:05 <fultonj> as mentioned at PTG default for stein/master is nautilus
14:10:18 <fultonj> for ceph
14:10:38 <marios> mwhahaha: i put up my ptg summary at http://tripleo.org/planet.html fwiw some brief notes on the tripleo sessions there
14:11:01 <mwhahaha> cool thanks
14:11:19 <slagle> i think we will be spinnig the edge squad back up
14:11:38 <fultonj> +1
14:11:42 <slagle> to focus on some upcoming work. and perhaps serve as an umbrella for some of the related scale work
14:12:12 <slagle> will send something to the ML as we get organized
14:12:23 <mwhahaha> sounds good
14:14:12 <mwhahaha> Any other status related items?
14:15:50 <fultonj> Tengu: are you going to mail openstack-discuss regarding the tag for tripleo validations?
14:16:16 <Tengu> fultonj: hmm yeah, right, that's this issue. have to build some question for that indeed.
14:16:23 <fultonj> basically, when you add validations tasks, tag them so they can be run independently or skipped
14:16:43 <openstackgerrit> Merged openstack/diskimage-builder master: Use fedora-release-common for fedora 30+  https://review.opendev.org/656905
14:17:02 <fultonj> we need a naming convention and agreed on names documented somewhere before other parts of tripleo can start adding them
14:17:08 <openstackgerrit> mathieu bultel proposed openstack/tripleo-common master: Add serial option in the inventory  https://review.opendev.org/635858
14:17:21 <Tengu> fultonj: yep! will sens an email in a couple of minutes.
14:17:29 <Tengu> *send
14:17:33 <Tengu> damn fingers....
14:17:36 <fultonj> ++
14:21:34 <mwhahaha> alright moving on
14:21:40 <mwhahaha> #topic bugs & blueprints
14:21:40 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/train-1
14:21:40 <mwhahaha> For Train we currently have 19 (+3) blueprints and 496 (-3) open Launchpad Bugs. 496 train-1.  104 open Storyboard bugs.
14:21:40 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:21:56 <mwhahaha> as a reminder from the PTG, please create any blueprints you'll be working on
14:22:11 <mwhahaha> The goal would be to get the feature set locked down by M1
14:22:32 <mwhahaha> #action mwhahaha to send a note to the ML about blueprints & specs for M1
14:22:47 <mwhahaha> any bugs/blueprints that folks would like to bring up?
14:24:09 <fultonj> https://blueprints.launchpad.net/tripleo/+spec/split-control-plane-unified-inventory
14:24:15 <fultonj> is still in discussion status
14:24:25 <fultonj> mwhahaha: do you want to move it to approved?
14:24:38 <fultonj> at ptg there didn't seem to be any disagreement
14:24:41 <mwhahaha> sure
14:24:44 <fultonj> anything more we need to talk about?
14:24:48 <fultonj> ok, tks
14:25:32 <fmount> fultonj: for ceph, we've also the first prototype of the dashboard bp
14:25:35 <fmount> https://blueprints.launchpad.net/tripleo/+spec/ceph-dashboard
14:26:04 <fmount> for the integration on tripleo ^
14:26:19 <fultonj> fmount: nice
14:28:12 <fultonj> fmount: so provided the dpends on ceph-ansible patch merges, you would just need to create a role?
14:28:18 <openstackgerrit> Jiri Stransky proposed openstack/tripleo-heat-templates master: Add operating system upgrade preparation via Leapp  https://review.opendev.org/657612
14:28:32 <fultonj> actually, you'd add the service and env file and test in ci too
14:28:41 <fultonj> I'm ok with approving it
14:28:47 <fultonj> comments anyone?
14:29:06 <fmount> fultonj: imho we can create a role
14:29:24 <fmount> and we can create or integrate it in a scenario
14:29:45 <fmount> for testing purposes
14:29:45 <fultonj> was thinking of creating service within controller role but only enabling it if a new env file is included int he deploy
14:30:31 <fmount> it could be a good idea, we still have an open topic to understand "how" the dashboard is deployed
14:30:52 <fmount> but from tripleo point of view we can add a service within controller role
14:31:08 <fultonj> fmount: maybe we revise a little and leave open for disucssion this week and present any changes next week
14:31:10 <fmount> and enable it if a env is added
14:31:47 <fmount> fultonj: yes, agree, it's a first prototype, I can improve it of course according to additional considerations
14:35:00 <fultonj> any other topics?
14:35:24 <Tengu> fultonj: http://lists.openstack.org/pipermail/openstack-discuss/2019-May/005938.html
14:36:33 <fultonj> thanks Tengu
14:36:38 <mwhahaha> alright moving on
14:36:39 <mwhahaha> #topic projects releases or stable backports
14:36:50 <mwhahaha> any backports people need to land?
14:37:03 <mwhahaha> I don't think we're scheduled for any releases in the up coming week
14:39:31 <mwhahaha> sounds like nope, moving on
14:39:35 <mwhahaha> #topic specs
14:39:35 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:39:43 <mwhahaha> as a reminder, please take a look at the open specs
14:39:52 <mwhahaha> also post your specs for the cycle as well
14:40:03 <mwhahaha> we'd like to get them merged by M1
14:41:41 <mwhahaha> any spec related comments?
14:43:59 <mwhahaha> sounds like nope
14:44:00 <mwhahaha> #topic open discussion
14:44:04 <mwhahaha> any other items?
14:46:20 <mwhahaha> alright thanks everyone
14:46:23 <mwhahaha> #endmeeting