14:00:56 <mwhahaha> #startmeeting tripleo
14:00:56 <mwhahaha> #topic agenda
14:00:56 <mwhahaha> * Review past action items
14:00:56 <mwhahaha> * One off agenda items
14:00:56 <mwhahaha> * Squad status
14:00:57 <mwhahaha> * Bugs & Blueprints
14:00:57 <openstack> Meeting started Tue Apr 16 14:00:56 2019 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:57 <mwhahaha> * Projects releases or stable backports
14:00:58 <mwhahaha> * Specs
14:00:58 <mwhahaha> * open discussion
14:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:59 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:59 <mwhahaha> Hi everyone! who is around today?
14:01:00 <openstack> The meeting name has been set to 'tripleo'
14:01:06 <beagles> o/
14:01:09 <ccamacho> o/
14:01:09 <marios> o/
14:01:10 <ksambor> o/
14:01:12 <chandankumar> \o/
14:01:13 <Tengu> \o/
14:01:19 <panda> o/\o
14:01:30 <dpeacock> o7
14:01:34 <Tengu> :]
14:01:37 <rh-jelabarre> o/
14:01:46 <Tengu> should have trade-marked that smiley, dpeacock XD
14:02:12 <rfolco> o/
14:03:44 <mwhahaha> alright let's get started
14:03:45 <openstackgerrit> David Peacock proposed openstack/python-tripleoclient master: WIP - Implement tripleo container image list command  https://review.openstack.org/649619
14:03:46 <mwhahaha> #topic review past action items
14:03:52 <mwhahaha> EmilienM to branch tripleoclient stable/stein this week - DONE.
14:03:58 <mwhahaha> we branched tripleoclient last week
14:04:04 <mwhahaha> we'll be working to branch the rest this week
14:04:14 <mwhahaha> so make sure you remember to backport all the things you want in stein
14:04:53 <mwhahaha> that's it on the previous action items
14:05:04 <mwhahaha> #topic one off agenda items
14:05:05 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:05:15 <mwhahaha> (mwhahaha) PTG schedule
14:05:20 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ptg-train
14:05:31 <mwhahaha> fyi, i've put together a basic schedule. I'll be sending a mail out later today
14:06:05 <fultonj> o/
14:06:06 <mwhahaha> let me know if anyone needs things moved around
14:06:31 * Tengu needs to prepare some slides then
14:06:34 <Tengu> :)
14:06:53 <mwhahaha> cool
14:06:55 <mwhahaha> (mwhahaha) Canceling the IRC meeting for the week of the PTG
14:07:07 <mwhahaha> fyi i'll send a note about this as well
14:07:15 <mwhahaha> #action mwhahaha to send ptg schedule to the ML
14:07:37 <fmount> o/
14:07:41 <mwhahaha> (ksambor) Make networking-ovn-tripleo-c7-s003-oooq-containers (fetureset 018) voting for tripleo
14:07:55 <ksambor> Case is similar to case from last week (voting multinode octavia job with mistral). We need in tripleo job similar to upstream neutron-ovn job networking-ovn-tripleo-c7-s003-oooq-containers (this job is multionode with mistral). Ovn is now default for tripleo so it will be good to have such job in upstream gate. It will help to avoid such cases like: https://bugs.launchpad.net/tripleo/+bug/1824326 If it's okay I want to talk with CI team about this.
14:07:56 <openstack> Launchpad bug 1824326 in tripleo "tripleo-create-admin failing to retrieve public key" [Medium,Triaged] - Assigned to Steve Baker (steve-stevebaker)
14:08:46 <weshay> 0/
14:08:56 <EmilienM> o/
14:09:05 <mwhahaha> did we switch a ovb job to ovn?
14:09:12 <openstackgerrit> Merged openstack/paunch master: Introduce paunch apply --healthcheck-disabled  https://review.openstack.org/652102
14:09:21 <mwhahaha> it might also be beneficial to switch fs001
14:11:04 <sshnaidm> mwhahaha, I think so
14:11:19 <mwhahaha> ok
14:11:36 <mwhahaha> any other comments on fs018?
14:12:19 <ksambor> fs001 was swithced with tht patch withc switch to ovn
14:12:52 <ksambor> mwhahaha, not from my site
14:12:59 <mwhahaha> yea so we do have coverage, it's just not blocking
14:13:19 <mwhahaha> anyway moving on
14:13:20 <mwhahaha> (rfolco): stein jobs: branching follow-up - branching/stein ci jobs, apparently python-tripleoclient went well - we'll be doing sanity checks this week for the other projects.
14:13:31 <panda> ksambor: I'll ping you after the meeting.
14:13:43 <ksambor> panda, ack
14:14:23 <rfolco> just checking if any concerns, branching should happen this week, so we're going to make sanity checks.
14:14:41 <mwhahaha> no i think everything has worked so far
14:14:46 <rfolco> k
14:14:47 <mwhahaha> so we'll just need to keep an eye on it this week
14:15:06 <rfolco> good, that's it from me, thx mwhahaha
14:15:17 <mwhahaha> k
14:15:21 <mwhahaha> (fultonj / fmount): nautilus as default ceph in stein
14:15:29 <fultonj> mwhahaha: ack
14:15:30 <mwhahaha> #link https://review.openstack.org/#/q/topic:ceph-nautilus
14:15:39 <fultonj> nautilus/stein work in rdo job with series of depends on, wanting to merge them see topic
14:15:48 <fultonj> wanted to let people know we're working on this
14:15:53 <fultonj> in case there's questions
14:16:00 <fultonj> otherwise that's all
14:16:22 <mwhahaha> sounds good
14:16:27 <mwhahaha> let us know if you need help with reviews
14:16:32 <fmount> we are able to have nautilus working with a series of deps, we're focusing in removing hacks and merging deps
14:19:10 <mwhahaha> that's it on one off items from the etherpad.  Anyone have anything else they'd like to talk about now?
14:19:57 <weshay> EmilienM can you chat w/ me re: buildah to push containers in the pipelines
14:20:03 <weshay> if you have a sec
14:20:16 <EmilienM> weshay: sure, I'm free now
14:20:27 <EmilienM> what's up?
14:22:37 <mwhahaha> alright lets move on with the meeting items
14:22:41 <mwhahaha> #topic Squad status
14:22:41 <mwhahaha> ci
14:22:41 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:22:41 <mwhahaha> upgrade
14:22:41 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:22:41 <mwhahaha> edge
14:22:41 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:22:42 <mwhahaha> integration
14:22:42 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:22:43 <mwhahaha> validations
14:22:43 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:22:44 <mwhahaha> networking
14:22:44 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:22:55 <mwhahaha> anyone have anything status related they would like to highlight?
14:23:02 <Tengu> Validations: we still need about 15 reviews on https://trello.com/c/k96ySxA0/18-review-migrating-validations-playbooks-to-their-own-ansible-role :)
14:23:25 <Tengu> would love to see that merged before the PTG :)
14:24:15 <openstackgerrit> Cédric Jeanneret proposed openstack/tripleo-common master: Inject validation roles path in ansible config  https://review.openstack.org/650852
14:24:26 <Tengu> also, that one would need some love -^^   :)
14:24:31 <Tengu> but that's another topic.
14:25:07 <mwhahaha> k i'll try and take a look today
14:25:09 <mwhahaha> anything else?
14:25:22 <Tengu> (that's it for me ;))
14:26:34 <mwhahaha> ok moving on
14:26:38 <openstackgerrit> Cédric Jeanneret proposed openstack/tripleo-heat-templates master: Simplify and correct how we provide the undercloud.conf to mistral  https://review.openstack.org/652599
14:26:38 <mwhahaha> #topic bugs & blueprints
14:26:38 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/stein-rc1
14:26:38 <mwhahaha> For Stein we currently have 20 blueprints and 1 open Launchpad bugs. 1 stein-rc1
14:26:38 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/train-1
14:26:38 <mwhahaha> For Train we currently have 16 blueprints and 484 open Launchpad Bugs. 484 train-1.  104 open Storyboard bugs.
14:26:39 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:26:58 <mwhahaha> we're going to try and release rc1 this week. I went through and moved bugs and blueprints out
14:27:17 <mwhahaha> We likely won't do an rc2 for stein so unless something major comes up, rc1 will be our ga
14:27:51 <Tengu> hmmm so yeah, we'd better ensure all the validation changes are merged quickly.
14:28:15 <Tengu> being in a transitionnal state isn't that great.
14:28:40 <mwhahaha> it's unlikely they will merge before rc1
14:28:51 <mwhahaha> but i'll take a look
14:29:01 <Tengu> baahh c'mon on, they are nice and tiny :)
14:30:11 <Tengu> or that would be a reason for rc2 - we've been asking for review for weeks ;)
14:30:32 <mwhahaha> yea well it's a bit late for features
14:30:41 <mwhahaha> so we should have really held off until train for all those
14:30:42 <mwhahaha> but anyway
14:31:22 <mwhahaha> along those lines
14:31:22 <mwhahaha> #topic projects releases or stable backports
14:31:34 <mwhahaha> so yea i'll review the validation stuff and lets see if we can land those today
14:31:45 <mwhahaha> other than that, rc1 this week
14:31:54 <mwhahaha> Any stable related items folks would like to highlight?
14:32:17 <EmilienM> I guess once we release stein
14:32:23 <EmilienM> we'll produce rocky and queens tags
14:32:26 <EmilienM> it has been some time
14:32:33 <EmilienM> and it's good for downstream to get rebases too
14:32:47 <EmilienM> i'll take an action on that, next week
14:33:28 <mwhahaha> cool, anything else?
14:35:00 <mwhahaha> sounds like nope
14:35:03 <mwhahaha> #topic specs
14:35:04 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:35:24 <mwhahaha> with the ptg coming up, please propose any specs you plan on bringing up
14:36:18 <mwhahaha> anyone one have any spec related items they would like to bring up?
14:36:26 <openstackgerrit> yatin proposed openstack-infra/tripleo-ci master: [DNM] Test integrity of container-build job  https://review.openstack.org/652508
14:39:58 <rlandy|ruck> EmilienM: weshay: for buildah, the initial bug was thttps://bugs.launchpad.net/tripleo/+bug/1824388. testproject results for the rpms built with updated buildah and podman: https://review.rdoproject.org/r/#/c/20160/
14:39:59 <openstack> Launchpad bug 1824388 in tripleo "periodic jobs are failing undercloud install - Not found image" [Critical,Fix released] - Assigned to Ronelle Landy (rlandy)
14:40:08 <EmilienM> rlandy|ruck: thank you, i'll take a look asap
14:40:27 <rlandy|ruck> EmilienM: here is the bug with your comments:  https://bugs.launchpad.net/tripleo/+bug/1819632
14:40:28 <openstack> Launchpad bug 1819632 in tripleo "[gate] Error pulling image: invalid character '<' parsing 404 response" [Medium,Triaged] - Assigned to Emilien Macchi (emilienm)
14:40:39 <rlandy|ruck> EmilienM: great, thanks
14:40:54 <EmilienM> rlandy|ruck: I know I have short term memory :P
14:40:54 <mwhahaha> #topic open discussion
14:41:00 <mwhahaha> anything else?
14:42:49 <openstackgerrit> Sagi Shnaidman proposed openstack-infra/tripleo-ci master: Collect logs and configs from BIND  https://review.openstack.org/653010
14:43:07 <mwhahaha> ok thanks everyone
14:43:10 <mwhahaha> #endmeeeting
14:43:13 <openstackgerrit> Sagi Shnaidman proposed openstack-infra/tripleo-ci master: Collect logs and configs from BIND  https://review.openstack.org/653010
14:43:19 <mwhahaha> #endmeeting