14:00:01 <EmilienM> #startmeeting tripleo
14:00:02 <openstack> Meeting started Tue Dec 11 14:00:01 2018 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'tripleo'
14:00:08 <arxcruz> o/
14:00:12 <weshay> o/
14:00:14 <rfolco> o/
14:00:14 <EmilienM> Welcome folks!
14:00:16 <ksambor> o/
14:00:23 <marios_|ruck> o/
14:00:28 <chandan_kumar> \o/
14:00:49 <EmilienM> #topic agenda
14:00:53 <EmilienM> * Review past action items
14:00:54 <EmilienM> * One off agenda items
14:00:56 <EmilienM> * Squad status
14:00:58 <EmilienM> * Bugs & Blueprints
14:01:00 <EmilienM> * Projects releases or stable backports
14:01:02 <EmilienM> * Specs
14:01:03 <dtantsur> marios_|ruck: ack
14:01:04 <EmilienM> * open discussion
14:01:07 <ccamacho> o/
14:01:10 <EmilienM> reminder: anyone can use the #link, #action and #info commands, not just the moderator
14:01:16 <chem> o/
14:01:21 <jbadiapa> o/
14:01:29 <EmilienM> #topic review past action items
14:01:34 <beagles> o/
14:01:35 <EmilienM> I think none, let me check
14:01:41 <rlandy> o/
14:02:00 <EmilienM> yes nothing
14:02:01 <EmilienM> #topic one off agenda items
14:02:04 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:02:22 <EmilienM> arxcruz: go ahead!
14:02:29 <arxcruz> So, it was a slow week, but we have some progress on os_tempest, we are implementing the blacklist and whitelist like we have in validate-tempest, so we can reuse the files from validate-tempest in os_tempest. On the other side, we are slowly adding rpm support to os_tempest, and creating a new option on python-tempestconf to pass a yaml file with all the options we need to pass to tempestconf
14:02:47 <arxcruz> this will reduce the number of template and if's and else's we have today in validate-tempest
14:02:52 <arxcruz> and the code will be clear
14:03:01 <EmilienM> sounds like nice plans
14:03:09 <EmilienM> thanks for the update !
14:03:22 <arxcruz> nothing else from my side, chandan_kumar weshay ?
14:03:33 <weshay> +1 from me
14:03:39 <weshay> thanks
14:03:48 <chandan_kumar> arxcruz: you already said all, thanks :-)
14:04:01 <EmilienM> good. Anything else to bring on this week before regular agenda?
14:04:36 <EmilienM> #topic Squad status
14:04:45 <EmilienM> ci
14:04:47 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:04:49 <EmilienM> upgrade
14:04:51 <openstackgerrit> Marco Passerini proposed openstack/tripleo-heat-templates stable/queens: Ignore if nova_wsgi is not running under systemctl  https://review.openstack.org/624404
14:04:51 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:04:53 <EmilienM> containers
14:04:55 <EmilienM> #link https://trello.com/b/S8TmOU0u/tripleo-podman
14:04:57 <EmilienM> edge
14:04:59 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:05:01 <EmilienM> integration
14:05:03 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:05:05 <EmilienM> ui/cli
14:05:07 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:05:09 <EmilienM> validations
14:05:11 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:05:13 <EmilienM> networking
14:05:15 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:05:17 <EmilienM> security
14:05:19 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:05:21 <EmilienM> do we have any outstanding news from the squads?
14:05:27 <jfrancoa> o/
14:05:31 <marios_|ruck> EmilienM: also ci ruck/rover status
14:05:42 <jrist> o/
14:05:43 <marios_|ruck> #link https://review.rdoproject.org/etherpad/p/ruckrover-sprint23
14:06:07 <EmilienM> marios_|ruck: thanks. Anything to bring up this week?
14:06:25 <marios_|ruck> EmilienM: zuul queue is much nicer these days. gates/check jobs generally behaving last 2 days
14:06:41 <EmilienM> I like good news :D
14:07:25 <EmilienM> is there any info from other squads?
14:07:54 <EmilienM> ok moving on
14:07:59 <EmilienM> #topic bugs & blueprints
14:08:05 <EmilienM> #link https://launchpad.net/tripleo/+milestone/stein-2
14:08:07 <EmilienM> #link https://storyboard.openstack.org/#!/project_group/76
14:08:41 <EmilienM> For Stein m2 we currently have 29 blueprints and about 665 open Launchpad bugs and 104 stories in Storyboard.
14:08:54 <EmilienM> is there any bug to discuss now? anything outstanding?
14:09:52 <EmilienM> alright moving on :)
14:09:56 <EmilienM> #topic projects releases or stable backports
14:10:02 <Tengu> no bug, all is working fine.
14:10:26 <EmilienM> #link https://releases.openstack.org/stein/schedule.html
14:10:38 <EmilienM> we are 4 weeks from stein m2
14:10:59 <EmilienM> then we'll haev a bit less than 2 months to produce stein m3
14:11:26 <quiquell> o/
14:11:37 <EmilienM> on another note, I'm working on tagging (and maybe branching some of our ansible roles in tripleo)
14:11:56 <EmilienM> #action EmilienM to branch & tag our Ansible roles used in Rocky
14:12:04 <EmilienM> mandre: based on our chat this morning ^
14:12:18 <EmilienM> anything else on releases?
14:12:27 <EmilienM> moving to specs then
14:12:29 <EmilienM> #topic specs
14:12:34 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:12:52 <EmilienM> does anyone want to bring up a spec here?
14:13:45 <EmilienM> #topic open discussion
14:14:34 <marios_|ruck> good progress on the standalone scenario jobs quiquell rfolco ++
14:14:38 <marios_|ruck> mwhahaha: ++
14:14:46 <EmilienM> yeah! nice work
14:15:09 <quiquell> also updates in the containers in working now in the review
14:15:10 <marios_|ruck> scen1 https://review.openstack.org/#/c/619508 scen 1
14:15:25 <altdc> hi, I'm trying to setup an Openstack cloud using tripleo-quickstart, however it gets stuck here "TASK [overcloud-prep-containers : Prepare for the containerized deployment]" and the undercloud VM starts dropping the connection "ssh_exchange_identification: Connection closed by remote host", any ideas on how to fix this issue?
14:15:26 <quiquell> but we will face the no promotion long updtes issue at standalone now :-(
14:15:49 <marios_|ruck> scen4 https://review.openstack.org/#/c/619520 scen 2 https://review.openstack.org/618709 https://review.openstack.org/618761 scen 3
14:16:16 <EmilienM> marios_|ruck: i'm a bit worried by using tripleo-ci (unbranched) for the job config
14:16:29 <EmilienM> what if in the next release we want to add specific tempest tests?
14:16:38 <marios_|ruck> quiquell: yes that is a concern since current scen1 is at 1.5 hours as we discussed earlier
14:16:51 <kashyap> Hey folks, does anyone have a URL to this "repo_setup.sh" script? -- https://bugs.launchpad.net/tripleo/+bug/1718965
14:16:52 <openstack> Launchpad bug 1718965 in tripleo "TripleO-Quickstart hanging on virt-customize call during execution of modify-image role" [Medium,Fix released]
14:17:05 <marios_|ruck> quiquell: i mean the time sorry  i thought that is what you write above i read too quickly. so yeah given the time it takes containers to update it might cause issues
14:17:07 <quiquell> EmilienM: well we can create branchfull jobs with specific featureset-overrides for that
14:17:17 <kashyap> I'm trying to debug the issue, and the reporter forgot to add a URL to it
14:17:20 <EmilienM> yes, we'll probably have to do that
14:17:33 <EmilienM> alright I'll end the meeting and let everyone go back to work
14:17:40 <marios_|ruck> quiquell: EmilienM yeah we can create a specific job for specific branch
14:17:45 <EmilienM> thanks everyone and have a nice week
14:17:48 <rfolco> CI community meeting (office hours) starts now at https://bluejeans.com/4113567798
14:17:53 <EmilienM> #endmeeting