14:01:40 <mwhahaha> #startmeeting tripleo
14:01:40 <mwhahaha> #topic agenda
14:01:40 <mwhahaha> * Review past action items
14:01:40 <mwhahaha> * One off agenda items
14:01:40 <mwhahaha> * Squad status
14:01:40 <mwhahaha> * Bugs & Blueprints
14:01:40 <mwhahaha> * Projects releases or stable backports
14:01:41 <mwhahaha> * Specs
14:01:41 <openstack> Meeting started Tue Jul 10 14:01:40 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:41 <mwhahaha> * open discussion
14:01:42 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:42 <mwhahaha> Hi everyone! who is around today?
14:01:45 <openstack> The meeting name has been set to 'tripleo'
14:01:47 <fultonj> o/
14:01:47 <beagles> o/
14:01:53 <ccamacho> heeello!
14:01:59 <abishop> o/
14:01:59 <EmilienM> o/
14:02:00 <rasca> hey everyone!
14:02:05 <jistr> hi
14:02:12 <openstackgerrit> Flavio Percoco proposed openstack/tripleo-heat-templates master: HA support for OpenShift  https://review.openstack.org/579609
14:02:13 <openstackgerrit> Flavio Percoco proposed openstack/tripleo-heat-templates master: Replace raw_get with dict access syntax  https://review.openstack.org/579843
14:02:30 <marios> o/
14:02:36 <chem> o/
14:03:28 <jrist> o/
14:03:56 <mwhahaha> #topic review past action items
14:04:06 <mwhahaha> dprince to start discussion on service renaming (puppet -> ansible) - DONE
14:04:06 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2018-July/132017.html
14:04:12 <mwhahaha> please review and provide feedback
14:04:20 <mwhahaha> that's it on the past action items
14:04:28 <mwhahaha> #topic one off agenda items
14:04:42 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:46 <mwhahaha> (mwhahaha) Containeried undercloud default cut over
14:04:53 <mwhahaha> so we need to land this before m3
14:05:04 <mwhahaha> we've been running partial containerized and non-containerized in CI
14:05:12 <mwhahaha> we would like to make the cut over but we've been having issues with CI perf
14:05:17 <mwhahaha> EmilienM what's the plan, where are the patches?
14:06:29 <EmilienM> the plan is to address the late reviews I have in my patch that switch tripleoclient
14:06:35 <EmilienM> to deploy a containerized undercloud
14:06:40 <EmilienM> in the meantime, improve the perfs
14:06:46 <EmilienM> so far we have 3 things going on :
14:06:54 <EmilienM> 1) Running the container prepare in pre
14:07:13 <EmilienM> 2) Being able to pre-deploy some rpms in pre as well (some rpms take almost 5 mins to deploy, like openstack-selinux)
14:07:27 <EmilienM> and 3) enable Ansible pipelining, which saves us some time as well it seems
14:07:37 <EmilienM> so we really hope to switch all scenarios to containerized undercloud soonish
14:08:47 <mwhahaha> k
14:08:48 <mwhahaha> thanks
14:09:17 <mwhahaha> that's it on the meeting items
14:09:23 <mwhahaha> moving on
14:09:25 <panda> o/
14:09:27 <mwhahaha> #topic Squad status
14:09:27 <mwhahaha> ci
14:09:27 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:09:27 <mwhahaha> upgrade
14:09:27 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:09:28 <mwhahaha> containers
14:09:28 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:09:29 <mwhahaha> config-download
14:09:29 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:09:30 <mwhahaha> integration
14:09:30 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:09:31 <mwhahaha> ui/cli
14:09:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:09:32 <mwhahaha> validations
14:09:32 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:09:33 <mwhahaha> networking
14:09:33 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:09:34 <mwhahaha> workflows
14:09:34 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:09:35 <mwhahaha> security
14:09:35 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:10:01 <Tengu> o/ (sorry)
14:10:26 <chkumar|ruck> \o/
14:10:40 <openstackgerrit> Martin Schuppert proposed openstack/tripleo-heat-templates master: Add NovaResumeGuestsStateOnHostBoot and NovaResumeGuestsShutdownTimeout  https://review.openstack.org/577414
14:10:55 <mwhahaha> any specific status related things folks would like to highlight?
14:11:22 <jfrancoa> o/
14:12:10 <mwhahaha> sounds like no
14:12:11 <mwhahaha> moving on
14:12:14 <mwhahaha> #topic bugs & blueprints
14:12:14 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-3
14:12:15 <mwhahaha> For Rocky we currently have 54 (+0) blueprints and about 739 (+18) open Launchpad bugs.  739 rocky-3, 3 stein-1.  102 (+2) open Storyboard bugs.
14:12:15 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:12:28 <mwhahaha> so be aware m3 is at the end of the month
14:12:40 <mwhahaha> so upate your blueprints and think about moving them out
14:12:57 <mwhahaha> i need to go through the list and ping folks where there haven't been any patches or movement
14:13:13 <Tengu> mwhahaha: want some help?
14:13:13 <mwhahaha> #action mwhahaha to review current open blueprints for progress
14:13:23 <mwhahaha> Tengu: sure
14:13:47 <Tengu> mwhahaha: we can check how I can help you after this meeting then :)
14:13:50 <mwhahaha> any bugs or blueprints that folks would like to highlight?
14:13:53 <mwhahaha> sure
14:15:34 <mwhahaha> ok sounds like no one has specific things they would like to talkg about
14:15:35 <mwhahaha> moving on
14:15:37 <mwhahaha> #topic projects releases or stable backports
14:15:47 <mwhahaha> we did a stable release on monday
14:15:50 <mwhahaha> so we'll be good for a bit
14:16:05 <mwhahaha> As previously mentioned Rocky M3 is at the end of the month
14:16:15 <mwhahaha> so please make sure you're finishing up any feature work
14:16:32 <mwhahaha> Along those lines since we're coming to the end of Rocky...
14:16:36 <mwhahaha> #topic specs
14:16:36 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:16:49 <mwhahaha> get your specs in for the PTG and Stein
14:17:04 <mwhahaha> we'll want to start thinking about larger things now so we can get ahead
14:17:57 <Tengu> :)
14:17:59 <mwhahaha> does anyone have a spec they would light to highlight?
14:18:20 <Tengu> well.. the integration of oslo.privsep in python scripts still needs some love.
14:18:32 <Tengu> https://review.openstack.org/580033
14:18:56 <Tengu> it needs more reviews, more discussions, and probably more details in order to go through.
14:19:03 <holser_> EmilienM left a comment in https://review.openstack.org/#/c/581362/1
14:19:22 <mwhahaha> cool
14:19:32 <mwhahaha> moving on to our final part
14:19:33 <mwhahaha> #topic open discussion
14:19:36 <mwhahaha> anything else?
14:19:49 <EmilienM> holser_: i think it's a separated effort/feature
14:20:02 <holser_> k
14:21:21 <openstackgerrit> Gabriele Cerami proposed openstack-infra/tripleo-ci master: [WIP] test direct ovb job  https://review.openstack.org/581309
14:21:30 <jistr> one shout out
14:21:49 <jistr> i have just sent an e-mail to the list about updates/upgrades for services using external_deploy_tasks
14:21:57 <jistr> mainly Ceph, OpenShift
14:22:17 <jistr> i have an approach proposed but there might be alternatives
14:22:33 <jistr> if you have an opinion on concern on any of that, please do reply there
14:22:36 <jistr> -- end -- :)
14:22:43 <mwhahaha> jistr: thanks
14:22:46 <fultonj> ack
14:23:15 <mwhahaha> anything else?
14:24:05 <rasca> I just want to ask for reviews on this https://review.openstack.org/#/c/575128/
14:24:14 <rasca> it's almost done and it's becoming old
14:24:24 <rasca> don't want to become out of date
14:26:16 <mwhahaha> alright thanks everyone
14:26:18 <mwhahaha> #endmeeting