14:00:23 <mwhahaha> #startmeeting tripleo
14:00:23 <mwhahaha> #topic agenda
14:00:23 <mwhahaha> * Review past action items
14:00:23 <mwhahaha> * One off agenda items
14:00:23 <mwhahaha> * Squad status
14:00:23 <mwhahaha> * Bugs & Blueprints
14:00:23 <mwhahaha> * Projects releases or stable backports
14:00:24 <mwhahaha> * Specs
14:00:24 <openstack> Meeting started Tue Apr 24 14:00:23 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:24 <mwhahaha> * open discussion
14:00:25 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:25 <mwhahaha> Hi everyone! who is around today?
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:27 <openstack> The meeting name has been set to 'tripleo'
14:00:39 <slagle> hi
14:00:47 <myoung> o/
14:00:53 <panda|ruck> o/
14:01:11 <openstackgerrit> Oliver Walsh proposed openstack/tripleo-heat-templates master: Set live_migration_inbound_addr for ssh transport  https://review.openstack.org/562818
14:01:14 <matbu> o/
14:01:26 <marios> o/
14:01:29 <EmilienM> o/
14:01:57 <mwhahaha> a massive turnout today
14:02:29 <gfidente> o/
14:02:34 <thrash> o/
14:03:01 <jtomasek> o/
14:03:03 <owalsh> o/
14:03:19 <mwhahaha> alright let's go, should be a quick one
14:03:28 <mwhahaha> #topic review past action items
14:03:29 <mwhahaha> None!
14:03:35 <mwhahaha> #topic one off agenda items
14:03:35 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:45 <mwhahaha> (myoung) CI Community Meeting starts immediately upon this meeting closing @ https://bluejeans.com/7050859455. All are welcome, ask/discuss anything!  Add to agenda (or just join): https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:04:12 <mwhahaha> come bring your CI issues -^
14:04:29 <mwhahaha> any questions, thoughts, etc?
14:05:42 <mwhahaha> ok moving on
14:05:46 <mwhahaha> #topic Squad status
14:05:46 <mwhahaha> ci
14:05:46 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:05:46 <mwhahaha> upgrade
14:05:46 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:05:47 <mwhahaha> containers
14:05:47 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:05:48 <mwhahaha> config-download
14:05:48 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:05:49 <mwhahaha> integration
14:05:49 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:05:50 <mwhahaha> ui/cli
14:05:50 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:05:51 <mwhahaha> validations
14:05:51 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:05:52 <mwhahaha> networking
14:05:52 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:05:53 <mwhahaha> workflows
14:05:53 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:05:54 <mwhahaha> security
14:05:54 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:06:18 <openstackgerrit> Florian Fuchs proposed openstack/tripleo-validations master: Fix the events db size validation  https://review.openstack.org/563973
14:07:28 <slagle> i'll highlight from the config-download squad that it's now the default when using tripleoclient
14:07:33 <mwhahaha> yay new defaults
14:07:48 <mwhahaha> seems to be working pretty well in CI at least
14:07:54 <slagle> and i (believe) i've switched over all relevant check/gate ci jobs
14:07:54 <mwhahaha> excellent job on that switch
14:08:25 <EmilienM> ++
14:08:25 <mwhahaha> do we have an ETA on the UI bits?
14:08:39 <mwhahaha> i know it what in progress last time we chatted about it
14:08:48 <slagle> "finalizing" :)
14:08:58 <slagle> jtomasek: this week maybe? anything you need assistance with?
14:09:38 <jtomasek> mwhahaha: I am updating deployment success components and UI integration should be finished. We are currently missing undeploy worklfows which we'll need to add too
14:09:59 <mwhahaha> sounds good
14:10:08 <mwhahaha> let us know if there is anything you need help on
14:10:16 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1766195
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1766406
14:10:18 <openstack> Launchpad bug 1766195 in tripleo "Error installing fluent-plugin-kubernetes_metadata_filter at pike" [Critical,Fix committed] - Assigned to Quique Llorente (quiquell)
14:10:19 <openstack> Launchpad bug 1766406 in tripleo "multinode-oooq-container-updates fails on master" [Critical,Fix committed] - Assigned to Carlos Camacho (ccamacho)
14:10:21 <jtomasek> mwhahaha: ack
14:10:40 <mwhahaha> alright moving on
14:10:45 <mwhahaha> #topic bugs & blueprints
14:10:46 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-2
14:10:46 <mwhahaha> For Rocky we currently have 54 (+3) blueprints and about 656 (+3) open Launchpad bugs.  648 rocky-2, 8 rocky-3.  99 (+2) open Storyboard bugs.
14:10:46 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:11:07 <mwhahaha> So I moved all the rocky-1 bugs and blueprints over to rocky-2
14:11:20 <mwhahaha> i sent an email about this, please check that your items are up to date
14:11:43 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2018-April/129628.html
14:11:58 <mwhahaha> any questions or issues about a specific bug or blueprint?
14:13:44 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-common stable/queens: Remove version section in overcloud_keystone_url.  https://review.openstack.org/563598
14:13:53 <mwhahaha> sounds like nope
14:13:56 <mwhahaha> moving on
14:13:57 <mwhahaha> #topic projects releases or stable backports
14:14:01 <mwhahaha> m1 was last week
14:14:12 <EmilienM> this week we released queens/pike/ocata/newton
14:14:38 <mwhahaha> cool
14:15:09 <mwhahaha> #topic specs
14:15:09 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:15:35 <mwhahaha> once again, i think we're good on specs. if you have any thing you need reviews on or questions, please send a note to the ML
14:15:46 <mwhahaha> #topic open discussion
14:15:48 <mwhahaha> any other business?
14:16:23 <EmilienM> sun is shining
14:16:30 <slagle> it looks like promotion jobs are failing on featureset021
14:16:50 <honza> jpich: how did your containerized undercloud install go?
14:16:51 <slagle> i mention it b/c yesterday I noticed that this job (along with 039) does not use containers
14:17:02 <slagle> and still uses puppet-pacemaker.yaml
14:17:11 <mwhahaha> do we have an open bug for those?
14:17:11 <EmilienM> mhh I thought all jobs were switched to containers
14:17:32 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-common stable/queens: Allow uploading big files to swift (5GB)  https://review.openstack.org/563977
14:17:42 <EmilienM> panda|ruck: ^ can we take care of this one please?
14:17:49 <slagle> i noticed this b/c i was working on https://review.openstack.org/#/c/560030/
14:17:58 <EmilienM> we shouldn't have non-containerized overcloud jobs anywhere, imho
14:17:58 <fultonj> o/
14:18:05 <slagle> among these points, i also wonder why experimental jobs are in the promotion chain?
14:18:26 <openstackgerrit> Saravanan KR proposed openstack/tripleo-heat-templates master: WIP: docker-puppet failure for ovs containers  https://review.openstack.org/563978
14:18:27 <EmilienM> slagle: correct, it sounds wrong
14:18:35 <slagle> not sure if that is intentional, but we promote with way more than we check/gate
14:18:38 <slagle> seems backwards to me
14:18:52 <mwhahaha> it might just need to be removed from the master/queens promotion criteria
14:19:00 <mwhahaha> it might still be in use for <=pike
14:19:05 <panda|ruck> I don't see f021 on the promotion pipeline
14:19:11 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-common stable/queens: Allow uploading big files to swift (5GB)  https://review.openstack.org/563977
14:19:58 <slagle> panda|ruck: ok. maybe i'm looking in the wrong place
14:20:05 <panda|ruck> slagle: what experimental job ? not all the jobs that are tested in the pipeline count as promotion
14:20:17 <slagle> panda|ruck: i was just looking here: http://cistatus.tripleo.org/promotion/ under RDO cloud OVB
14:20:37 <panda|ruck> adding them there it's one of the steps, when they are stable , they are added to the criterias
14:20:56 <openstackgerrit> Pranali Deore proposed openstack/tripleo-heat-templates master: Disable interoperable default image import method in THT  https://review.openstack.org/562930
14:21:29 <EmilienM> fs021 shouldn't be run on master neither queens anyway
14:22:47 <panda|ruck> I think that job is in the quickstart gates only
14:23:27 <slagle> ok, i'm just going to remove it from my patch then https://review.openstack.org/#/c/560030/ as we don't know what it's for
14:24:10 <mwhahaha> so it sounds like we should have  a bug opened for the fact that fs021 is running on master
14:24:51 <EmilienM> (and queens)
14:25:01 <mwhahaha> who wants an action item? :D
14:25:03 <slagle> maybe it doesn't? i don't know now. my oooq patch is master
14:25:19 <mwhahaha> well it's ruinning on 3rd party which is now voting
14:25:27 <mwhahaha> so it would seem that it's incorrectly configured
14:26:12 <panda|ruck> I'll check with the tempest squad
14:26:14 <quiquell|rover> Also we have this bug on fs021 still in progress
14:26:16 <quiquell|rover> https://bugs.launchpad.net/tripleo/+bug/1759876
14:26:17 <openstack> Launchpad bug 1759876 in tripleo "ovb 3ctrl 1comp fs021 mismatch_error: test_upload_too_many_objects" [High,Triaged] - Assigned to Arx Cruz (arxcruz)
14:26:31 <panda|ruck> it seems that job is an old test job for the full tempest run
14:26:48 <mwhahaha> #action ci team, panda|ruck, quiquell|rover to investigate why fs021 is running on master if it's not properly containerized
14:27:11 <mwhahaha> alright, anything else?
14:27:43 <sshnaidm> panda|ruck, for smoke tempest run, yet before we had tempest in all jobs
14:28:15 <panda|ruck> sshnaidm: ok, I think we can remove it, talking with tempest guys
14:29:34 <mwhahaha> alright thanks everyone
14:29:37 <mwhahaha> #endmeeting