14:01:16 <mwhahaha> #startmeeting tripleo
14:01:16 <mwhahaha> #topic agenda
14:01:16 <mwhahaha> * Review past action items
14:01:16 <mwhahaha> * One off agenda items
14:01:16 <mwhahaha> * Squad status
14:01:17 <mwhahaha> * Bugs & Blueprints
14:01:17 <mwhahaha> * Projects releases or stable backports
14:01:18 <mwhahaha> * Specs
14:01:18 <mwhahaha> * open discussion
14:01:19 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:19 <mwhahaha> Hi everyone! who is around today?
14:01:21 <bogdando> shardy: mind commenting the symlink vs copy saga? :)
14:01:22 <openstack> Meeting started Tue Feb 13 14:01:16 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:23 <EmilienM> o/
14:01:23 <dpeacock> o/
14:01:24 <beagles> o/
14:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:27 <openstack> The meeting name has been set to 'tripleo'
14:01:27 <matbu> o/
14:01:28 <gfidente> o/
14:01:32 <chem> o/
14:01:32 <bogdando> o/
14:01:33 <dprince> hi
14:01:51 <shardy> o/
14:01:55 <marios> o/
14:02:01 <slagle> hi
14:02:09 <florianf> o/
14:02:57 <owalsh> o/
14:03:57 <mwhahaha> ok lets get started
14:04:00 <mwhahaha> #topic review past action items
14:04:00 <mwhahaha> tbarron or EmilienM to send a note to ML to start discussion on python3 testing
14:04:16 <EmilienM> I don't think we have done that
14:04:33 <mwhahaha> nope
14:04:37 <mwhahaha> #action tbarron or EmilienM to send a note to ML to start discussion on python3 testing
14:04:48 <jrist> o/
14:04:49 <mwhahaha> EmilienM to help jpich with member role for horizon
14:04:56 <jpich> Done! Thanks :)
14:04:59 <EmilienM> merged!
14:05:03 <mwhahaha> cool
14:05:06 <EmilienM> did we backport it?
14:05:18 <jpich> I think it was only in not-yet-branches projects
14:05:21 <jpich> but I'll double check
14:05:25 <jpich> *branched
14:05:55 <EmilienM> jpich: do we need the fix in queens only?
14:06:00 <EmilienM> #link https://review.openstack.org/#/c/541300/
14:06:14 <jrist> I think queens is highest priority for that fix
14:06:18 <sshnaidm|ruck> o/
14:06:28 <EmilienM> but do we need it Pike, ocata and newton?
14:06:35 <jpich> EmilienM: Yes, I believe so (since the role creation was only removed in Keystone in Queens)
14:06:52 <jpich> I don't think so, _member_ should still get created normally there
14:07:22 <EmilienM> jpich: we removed it long time ago, isn't?
14:07:49 <EmilienM> we'll verify it, no backport for no
14:07:51 <EmilienM> now*
14:07:59 <jpich> EmilienM: Keystone stopped creating _member_ as part of https://review.openstack.org/#/c/522461/ and that wasn't backported, so AFAIU we're good
14:08:09 <EmilienM> ok good!
14:08:35 <EmilienM> mwhahaha: next
14:08:45 <mwhahaha> #topic one off agenda items
14:08:46 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:08:53 <mwhahaha> (slagle) new squad: config-download
14:09:11 <mwhahaha> i guess we can replace containers squad with config-download?
14:09:15 <slagle> hi, just wanted to bring to everyone's attention that i'm starting a new squad around config-download
14:09:23 <slagle> we'll be working on https://blueprints.launchpad.net/tripleo/+spec/non-config-download-deprecate and its deps
14:09:26 <EmilienM> w00t
14:09:31 <slagle> so far gfidente and beagles have agreed to do some work
14:09:36 <slagle> let me know if you want to join my squad
14:09:48 <EmilienM> do we have a tee-shirt?
14:09:49 <slagle> we're going to have a pub meetup with free beers in dublin
14:09:57 <slagle> just fyi
14:10:05 <mwhahaha> slagle: plz update the tripleo-docs as well with the new squad
14:10:08 <mwhahaha> if you haven't already
14:10:10 <shardy> mwhahaha: I think there's still some containers related activity around the undercloud and ultimately using the same approach for a single node installer
14:10:17 * dtantsur heard free beers
14:10:22 <slagle> mwhahaha: is there stuff in docs?
14:10:26 <slagle> i did do: https://review.openstack.org/#/c/543631/
14:10:36 <shardy> but I guess the original containers effort has completed so the squad could be renamed or reorganized
14:10:36 <sshnaidm|ruck> slagle, would you mind to do deep dive about this feature and its debug?
14:10:37 <slagle> i'll check the docs, but i thought it was policy
14:10:44 <mwhahaha> slagle: yea that
14:10:52 <mwhahaha> slagle: thought it was in docs
14:10:54 <slagle> sshnaidm|ruck: yea, i plan to
14:11:09 <EmilienM> ++ really good idea
14:11:11 <sshnaidm|ruck> thanks, would be great!
14:11:13 <mwhahaha> shardy: ok. i'm ok with keeping it if we have someone to step up and drive the containers squad
14:11:13 <slagle> #action slagle to schedule to deep-dive about config-download
14:11:16 <gfidente> slagle I am in at least for the ceph stuff
14:11:27 <fultonj> +1
14:11:38 <shardy> dprince: ^^ did you want to repurpose the containers squad for the single-node use-case or start something new?
14:11:39 <gfidente> slagle but how different is that from external_deploy_task ?
14:11:50 <gfidente> slagle or is it the same thing we're talking?
14:11:54 <slagle> gfidente: that's what it is. same thing
14:11:59 <gfidente> slagle ok cook
14:12:04 <slagle> that is all from me
14:12:41 <mwhahaha> slagle: thanks
14:12:43 <marios> slagle: i'm interested... esp. around upgrades and aligning the way config download is used (we have some discussion here for anyone interested https://review.openstack.org/#/c/526656/4/doc/source/install/developer/upgrades/fast_fw_upgrade.rst )
14:12:55 <marios> slagle: (and i'll take your beer thanks)
14:13:05 <EmilienM> :)
14:13:09 <mwhahaha> (sshnaidm) about policy of merging patches to tripleo-quickstart and tripleo-quickstart-extras - it could be done by tripleo CI cores only
14:13:19 <dprince> shardy: yes, we can prototype the single node stuff
14:13:26 <sshnaidm|ruck> mwhahaha, yeah, I'd like to propose it
14:13:27 <mwhahaha> sshnaidm|ruck: for what it is worth, I'm not sure I agree
14:13:36 <mwhahaha> if things keep breaking, I believe we lack proper coverage
14:13:36 <dprince> shardy: I would like to treat it separate from 'containerized undercloud' as I think it is a unique case
14:13:45 <EmilienM> or proper voting
14:13:46 <jtomasek> o/
14:13:50 <mwhahaha> I would push forward a +2 from CI team is sufficient
14:14:02 <sshnaidm|ruck> I have 3 reasons:
14:14:05 <sshnaidm|ruck> 1) tripleo-quickstart is used in a few CI systems, not only in upstream, tripleo-ci core ususally aware of it and can check the consequences
14:14:05 <sshnaidm|ruck> 2) tripleo-quickstart-extras has common roles which are used in all jobs, and even small functional change there can affect a lot of jobs
14:14:05 <sshnaidm|ruck> 3) we have some strategy, code conventions and good practices in quickstart, patches should be aligned with that and tripleo-ci cores can address it in reviews
14:14:12 <EmilienM> I think sshnaidm|ruck refers to the containerized undercloud patch that broke some jobs
14:14:16 <jaosorior> slagle: is it possible to use config-download on a pre-deployed overcloud? does it work with updates?
14:14:20 <sshnaidm|ruck> EmilienM, it still breaks
14:14:24 <mwhahaha> sshnaidm|ruck: 1) needs coverage
14:14:29 <mwhahaha> 2) needs coverage
14:14:40 <mwhahaha> 3) needs better communication of these conventions and not relying on just a few people
14:14:41 <slagle> jaosorior: yes
14:14:42 <EmilienM> sshnaidm|ruck: I know, sorry for that
14:14:50 <jaosorior> slagle: a colleague was trying to test it out and got something like this:  Deployment NetworkDeployment with group:os-apply-config not supported with config-download.
14:14:58 <slagle> jaosorior: please sync with me post-meeting
14:15:22 <shardy> (3) should probably be enforced via some pep style job that ensure consistent style
14:15:45 <mwhahaha> sshnaidm|ruck: i agree that the CI team should review the things. But we need to be relying on automation to prevent breakages
14:15:45 <shardy> although IMHO we have a lot of room for improvement in *quickstart due to all the j2 templated bash...
14:15:46 <sshnaidm|ruck> shardy, not really trivial
14:16:15 <EmilienM> FWIW, ovb jobs are going to be voting this week probably: https://review.openstack.org/543654
14:16:33 <sshnaidm|ruck> EmilienM, that's really great
14:16:56 <mwhahaha> sshnaidm|ruck: I would also mention that the CI team has also been responsible for breakges merging their own reviewed code. So we need something that doesn't rely on people
14:17:03 <sshnaidm|ruck> but until we have all coverage (if we are capable to have it at all) it could be a valid step
14:17:27 <mwhahaha> It would be better to spend the time to RCA the breakages and investiage automated methods of mitigation
14:17:49 <EmilienM> instead of reducing the scope of +2 in CI projects, I would rather increase education, documentation and trust.
14:18:03 <mwhahaha> restricting the projects ability to move forward based on a small group of people is not ideal
14:18:09 <shardy> EmilienM: +1, and coverage to reduce the risk of landing patches
14:18:16 <shardy> as mwhahaha has already said
14:18:17 <bogdando> and branching...
14:18:27 <holser> should we branch quickstart-extra?
14:18:34 <mwhahaha> +1 branching
14:18:41 <bogdando> that's what I meant, holser
14:18:41 <sshnaidm|ruck> I think we have active ML about branching
14:18:45 <bogdando> thanks for supporting idea
14:18:47 <mwhahaha> we are hurting outselves having to support the world in a single (or two) repositotires
14:18:53 <holser> +1 for branching
14:18:56 <shardy> I think the quickstart review velocity has improved a lot in recent months, I personally would be sorry to see it go backwards in that regard
14:19:23 <sshnaidm|ruck> branching is not ideal and has its own disadvantages, it's doesn't solve all problems
14:19:24 <holser> shardy - What's your opinion about branching quickstart ?
14:19:24 <shardy> at one time landing patches was very difficult and quite a demotivator for contributors
14:19:50 <openstackgerrit> Dougal Matthews proposed openstack/instack-undercloud master: Catch APIException exceptions raised by Mistral  https://review.openstack.org/543916
14:20:07 <jistr> +1 for branching (at least extras, maybe not quickstart itself?)
14:20:08 <EmilienM> shardy: correct, it's getting much better now.
14:20:09 <shardy> holser: I think it makes sense for -extras, but I'd like -quickstart to just provide a release agnostic bootstrap of the VM test environment
14:20:17 <bogdando> +1
14:20:20 <bogdando> for extras only
14:20:21 <mwhahaha> sshnaidm|ruck: I think this is an important topic but I don't agree in the proposed solution. Perhaps we can move it to the ML and discuss other possible solutions. I think there are several possible solutions
14:20:26 <openstackgerrit> Alan Bishop proposed openstack/puppet-tripleo master: Avoid hard-coded settings in Cinder HA containers  https://review.openstack.org/542424
14:20:27 <jistr> we could do changes affecting master much more easily, not having to worry what we're breaking in stable jobs
14:20:33 <sshnaidm|ruck> mwhahaha, ok, let's move on
14:21:00 <mwhahaha> #action sshnaidm to raise ML post about reducing risk with quickstart and quickstart-extras patches
14:21:00 <chem> jistr: holser bogdando +1 for branching
14:21:06 <mwhahaha> (sshnaidm) I'd prefer to revert: https://review.openstack.org/#/c/517444/ we still can't fix all issues and nobody knows how many of them and how many techdebts we created by this patch
14:21:33 <sshnaidm|ruck> btw, nobody in CI team except weshay_PTO knows what happens there
14:21:45 <holser> +1 for revert
14:21:47 <sshnaidm|ruck> including me
14:21:58 <mwhahaha> I would say that patch has been around for a long time, so it's not like it's been done in secret
14:22:11 <mwhahaha> that being said revert if it's breaking
14:22:16 <EmilienM> yeah we started it in November
14:22:30 <EmilienM> what job is still broken now?
14:22:39 <sshnaidm|ruck> mwhahaha, people could be added as reviewers at least..
14:23:03 <EmilienM> because so far I see green jobs this morning
14:23:04 <sshnaidm|ruck> EmilienM, undercloud containers run in ALL jobs, which cause timeouts
14:23:04 <mwhahaha> sshnaidm|ruck: and the CI team could pay attention to the open reviews
14:23:13 <EmilienM> sshnaidm|ruck: come on, we have been discussing on this work on IRC, ML, Gerrit
14:23:16 <mwhahaha> sshnaidm|ruck: the onus is not just on the people proposing the patch
14:23:16 <sshnaidm|ruck> mwhahaha, we have priorities
14:23:32 <mwhahaha> sshnaidm|ruck: which should include paying attention to reviews for the projects you want to own
14:23:51 <EmilienM> undercloud containers causing timeouts?
14:24:00 <sshnaidm|ruck> mwhahaha, it sounds like blaming team for merging this patch
14:24:12 <sshnaidm|ruck> EmilienM, yeah, it takes time
14:24:18 <mwhahaha> sshnaidm|ruck: no i'm not, but you're claiming ignorance on something that wasn't done in secret
14:24:27 <EmilienM> show me the patches where the job timeouted
14:24:43 <sshnaidm|ruck> mwhahaha, we have really a lot of ways to increase visibility of patches, so please..
14:24:45 <mwhahaha> sshnaidm|ruck: i said revert it if it's breaking things, that's fine. just don't claim you didn't know. you are equally responsible for reviewing
14:25:09 <sshnaidm|ruck> mwhahaha, I have my priority list and this patch wasn't there
14:25:22 <sshnaidm|ruck> neither in priority list of a team
14:25:50 <mwhahaha> sshnaidm|ruck: that seems to be an issue with priorities of the team them. You can't require only CI team merge thigns if CI team doesn't properly prioritize reviews
14:25:59 <mwhahaha> sshnaidm|ruck: so please review your priorities
14:26:05 <bogdando> note, it'd require reverting 445 as well. All of the related patches may be found here https://trello.com/c/3HxQkb0t/4-move-tripleo-ci-centos-7-undercloud-containers-to-gate
14:26:06 <mwhahaha> and let's revert that patch if it's still causing problems
14:26:21 <sshnaidm|ruck> mwhahaha, join the tripleo ci squad meeting and let's discuss our priorities
14:26:41 <bogdando> btw, looking into https://review.openstack.org/#/c/543861/ I can see only minor/major jobs red
14:26:48 <sshnaidm|ruck> mwhahaha, we are always open to feedbacks
14:26:49 <bogdando> and shown red in jenkins for quite a long
14:26:51 <mwhahaha> sshnaidm|ruck: I'd be happy to have a seperate meeting, unfortunately that one conflicts with my ability to be a parent
14:27:06 <mwhahaha> anyway let's move on
14:27:07 <bogdando> if we talk about unknown bugs, we can't be sure, unless we have coverage for them...
14:27:35 <sshnaidm|ruck> did we agree revert it?
14:27:36 <mwhahaha> #action sshnaidm, bogdando to figure out how to handle the fallout of  https://review.openstack.org/#/c/517444/
14:27:45 <EmilienM> show me jobs that timeouts but so far I see some green today in our ci
14:28:08 <sshnaidm|ruck> EmilienM, we had timeouts in gates
14:28:09 <bogdando> EmilienM: yes, please. As I noted, https://review.openstack.org/#/c/543861/ is almost all green
14:28:21 <EmilienM> sshnaidm|ruck: the containerized undercloud job doesn't run in gate
14:28:24 <EmilienM> so totally unrelated
14:28:35 <sshnaidm|ruck> EmilienM, I'm not talking about this job
14:28:43 <sshnaidm|ruck> EmilienM, I'm talking about ALL jobs
14:28:54 <EmilienM> so our work causes timeouts now?
14:28:58 <EmilienM> show me the logs
14:29:07 <mwhahaha> please report bug and figure it out after the meeting
14:29:07 <mwhahaha> thanks
14:29:15 <sshnaidm|ruck> EmilienM, this patch enabled containerized undercloud for all jobs
14:29:24 <sshnaidm|ruck> EmilienM, let's take offline
14:29:27 <mwhahaha> (chem) Need help testing P->M and FFU, as check rdo experimental seems to not working for https://review.openstack.org/525686 and https://review.openstack.org/543440
14:29:35 <mwhahaha> chem: p->m? or p->q
14:29:50 <chem> it's for p->m with tripleo-upgrade role and ffu
14:30:01 <beagles> m as in master?
14:30:08 <chem> beagles: yeap
14:30:12 <mwhahaha> oh not clear
14:30:14 <beagles> ah okay
14:30:17 <mwhahaha> so p->q :D
14:30:25 <chem> mwhahaha: ack
14:30:46 <chem> so basically need help from ci folk to help me run those jobs on public server somehow
14:31:03 <chem> check rdo experimental failed on me
14:31:12 <holser> chem - What about P-M and O-P upgrade jobs?
14:31:24 <holser> We need to let them vote :D
14:31:49 <chem> holser: O->P can be run easily
14:31:51 <marios> holser: i don't think p-m is ready for voting :)
14:32:26 <chem> but we need to gate tripleo-upgrade role and so we need green jobs
14:32:43 <chem> but hard to test rigth now
14:33:05 <chem> so who could help
14:33:06 <chem> help
14:33:28 <marios> chem: so lets land this in the meantime https://review.openstack.org/526006 so we can at least run it with the rdo experimental (until the role based upgrade lands)
14:34:02 <marios> chem: wdyt? i know it will be replaced but i don't see the harm in having _something_ in the meantime
14:34:44 <chem> marios: ack, np :) sshnaidm|ruck could you have a look at https://review.openstack.org/#/c/526006/ :)
14:34:46 <jistr> i can help when we're in better shape with updates job, but honestly i'd prefer to focus on P->M (or even Q->M when we branch)
14:35:04 <jistr> i think we should focus on the latest first always
14:35:07 <EmilienM> we won't branch before  2 weeks I think
14:35:16 <EmilienM> (rough estimate)
14:35:50 <jistr> stable jobs don't bring as much value (fewer patches landing there), and focusing on "history" makes us always trail behind the present
14:36:37 <chem> jistr: oki, P->M and FFU are the future :)
14:37:31 <mwhahaha> anything else?
14:37:32 <chem> oki, I just wanted to bring that up.  Currently stuck, if anybody can help, that cool, and anyway I 'll faind a way
14:37:39 <mwhahaha> thanks chem
14:37:53 <mwhahaha> (beagles) stopping neutron agent containers breaks dataplane functionality (email just sent subject: [tripleo] [neutron] Current containerized neutron agents introduce a significant regression in the dataplane)While there are related bugs on namespaces etc., I'll file a new one that is specific to this
14:38:42 <beagles> so, this came up late last week - the neutron agent containers probably need some reworking
14:39:00 <beagles> myself and some neutron devs are going to need some assistance in sorting this out the "right way"
14:39:26 <beagles> unless I'm missing some obvious container black magic, I don't think we can resolve this for queens
14:39:51 <EmilienM> can you link the bug report please?
14:39:53 <shardy> won't that be a blocker for queens upgrades where all neutron things will run in containers?
14:40:39 <beagles> EmilienM, there are some bug reports like https://launchpad.net/bugs/1748658 but they sort of confuse the issue by talking about network namespaces and this is bigger than that
14:40:40 <openstack> Launchpad bug 1748658 in tripleo "Restarting Neutron containers which make use of network namespaces doesn't work" [High,In progress] - Assigned to Brent Eagles (beagles)
14:41:02 <openstackgerrit> Sagi Shnaidman proposed openstack-infra/tripleo-ci master: [WIP] Add multinode p->m jobs in experimental.  https://review.openstack.org/543440
14:41:07 <beagles> so I think I need to file a new one
14:41:22 <beagles> yeah shardy this is actually pretty bad in that respect
14:41:43 <shardy> beagles: ack, Ok +1 on raising a bug so we can discuss options
14:42:56 <beagles> I'll work on arrange a meeting for that too..  one of the complicating factors is neutron manages processes but it is not container aware at the moment so it's going to probably be a neutron+tripleo effort
14:43:32 <EmilienM> have we looked how did Kolla solved the issue ?
14:43:43 <bogdando> Dan linked an example
14:43:45 <EmilienM> (we're probably not alone)
14:43:49 <bogdando> they mount run:shared
14:44:14 <mwhahaha> but that doesn't necessarily solve what beagles's is talking about I think
14:44:16 <beagles> EmilienM,  you're falling into the trap of the current bug reports ;)
14:44:25 <mwhahaha> the issue is the agents launching processes
14:44:30 <bogdando> http://git.openstack.org/cgit/openstack/kolla-ansible/tree/ansible/roles/neutron/defaults/main.yml#n92
14:44:32 <mwhahaha> Kolla might not even be solving this
14:44:45 <beagles> the real issue is that the processes go away when the containers do and that breaks expected behavior
14:44:48 <bogdando> taken from https://review.openstack.org/#/c/542858/
14:45:26 <openstackgerrit> Marios Andreou proposed openstack/tripleo-quickstart-extras master: Wire up pike .. queens upgrade workflow (controller only for now)  https://review.openstack.org/526006
14:45:28 <mwhahaha> #action beagles to raise bug around neutron issues with containers
14:45:36 * mwhahaha plays pin the action item on beagles
14:45:37 <beagles> ack thanks mwhahaha
14:45:48 <beagles> :)
14:45:55 <mwhahaha> alright anything else?
14:46:17 <shardy> I was wondering are we planning to formally deprecate baremetal e.g puppet/services/* support for queens?
14:46:42 <shardy> I didn't spot a relase note, I guess it's somewhat dependent on the outcome of the issues beagles just raised tho
14:47:29 <EmilienM> I think deprecating things at that time of the cycle might be too late
14:47:32 <mwhahaha> shardy: good question as I don't think we have a docker by default anywhere
14:47:41 <shardy> At some point if we can remove those and flatten the docker/services/* templates to reduce nesting, I think we'll see a signficant imrovement in performance
14:47:51 <shardy> and also we can reduce the CI test matrix
14:48:06 <shardy> mwhahaha: yeah I think it's been discussed but I wasn't sure if I missed a final decision
14:48:20 <mwhahaha> I sent an ML note back on 9/18
14:48:22 <mwhahaha> no one objected
14:48:33 <shardy> decision made then ;)
14:48:43 <mwhahaha> [tripleo] Making containerized service deployment the default
14:48:51 <EmilienM> (works for me, AFIK all our CI jobs are containerized)
14:48:55 <mwhahaha> I don't know if we ever officially made it the default from a code perspective
14:49:17 <slagle> we should include docker and docker-ha by default
14:49:18 <mwhahaha> I'll at least create a release note in THT
14:49:27 <EmilienM> the only thing I remember was Tengu who wasn't deploying on containers yet
14:49:36 <slagle> not include...the mappings should just be the default
14:49:38 <marios> mwhahaha: well testing wise upgrades squad focused on upgrading to containerized Pike
14:49:41 <shardy> Yeah I was thinking we should flip the default and add a relase note before we branch, then we can look at when we ultimately remove the puppet/services/* and rework the remaining templates
14:49:55 <mwhahaha> we can't remove teh puppet services cause I think we use them
14:50:01 <mwhahaha> in the docker bits
14:50:06 <mwhahaha> in some places
14:50:10 <marios> mwhahaha: so if you wanted to upgrade to baremetal, there would be at least some things needed in terms of puppet/services/ upgrade_tasks (just as a reminder/data point to this discussion)
14:50:13 <mwhahaha> so that would be an effort for Rocky
14:50:26 <shardy> mwhahaha: yeah that's what I'm saying, the way we do that is a performance problem, heat creates like 300 stacks intead of ~50
14:50:27 <openstackgerrit> Yurii Prokulevych proposed openstack/tripleo-upgrade stable/pike: [UPDATES] Validated oc containers/images.  https://review.openstack.org/543957
14:50:42 <shardy> that's why the ResourceChain takes 5mins to create on a deploy
14:50:43 <EmilienM> +1 to communicate the deprecation in Queens + make it default and +1 to change the templates to have one YAML / service in Rocky
14:50:57 <marios> mwhahaha: i expect the same will be the case for P..Queens (even though we will have to deal with environments starting as baremetal as well as starting from containerized P)
14:50:58 <mwhahaha> shardy: sounds like we should get a blueprint to realign the puppet/services docker/services for Rocky
14:51:26 <EmilienM> I can take care of that one
14:51:39 <shardy> mwhahaha: ack I can raise one if we're agreed that puppet/services will be removed - we can probably script "flattening" the templates and do a one-time conversion
14:51:50 <EmilienM> ++
14:52:18 <shardy> the other option I was considering is a heat feature to internally flatten the templates, but that looks much more difficult
14:52:27 <EmilienM> it's YAML after all :)
14:52:39 <mwhahaha> good ol' yaml
14:52:49 <mwhahaha> ok we need to move on we only have 8 mins
14:52:57 <shardy> ack thanks
14:53:09 <mwhahaha> #action EmilienM to open a blueprint for realign puppet/services and docker/services for Rocky
14:53:19 <mwhahaha> #topic Squad status
14:53:20 <mwhahaha> ci
14:53:20 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:53:20 <mwhahaha> upgrade
14:53:20 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:53:20 <mwhahaha> containers
14:53:20 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:53:21 <mwhahaha> config-download
14:53:21 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:53:22 <mwhahaha> integration
14:53:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:53:23 <mwhahaha> ui/cli
14:53:23 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:53:24 <mwhahaha> validations
14:53:24 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:53:25 <mwhahaha> networking
14:53:25 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:53:26 <mwhahaha> workflows
14:53:26 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:53:40 <EmilienM> an action to deprecate in Queens as well? (and another one to make docker the default in queens?)
14:54:13 <mwhahaha> EmilienM: ok
14:54:17 <shardy> I think it's one action, a patch to change the default and add a deprecation release note
14:54:20 <shardy> I can do it
14:54:25 <EmilienM> shardy: ok
14:54:43 <mwhahaha> #action shardy to change the default deploy to include docker and add deprecation notice
14:54:49 <mwhahaha> any other status stuff?
14:55:14 <shardy> I wanted to mention the networking squad have made good progress on https://review.openstack.org/#/c/523638/
14:55:28 <shardy> it's a huge change but we need to decide if we're willing to land it for queens
14:55:34 <shardy> dsneddon: ^^
14:55:48 <mwhahaha> I don't really want to land it for queens
14:55:57 <mwhahaha> reminds me of the composable networks we landed late in Pike
14:56:17 <mwhahaha> unless we're really sure it's not going to break anything
14:56:53 <shardy> mwhahaha: ack - one observation is we have zero coverage of any except one nic configs in CI, so whenever we land this it's hard to be sure of the risk
14:56:53 <EmilienM> it's not passing gate-tripleo-ci-centos-7-ovb-3ctlr_1comp-featureset035-master (ipv6)
14:57:26 <shardy> maybe we can look at ways to improve that but I'm not sure how feasable that is
14:57:46 <mwhahaha> sure
14:58:01 <mwhahaha> we only have 3 mins left
14:58:05 <mwhahaha> so moving on real quick
14:58:10 <mwhahaha> #topic bugs & blueprints
14:58:10 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/queens-rc1
14:58:10 <mwhahaha> For Queens we currently have 33 (+0) blueprints and about 606 (-15) open bugs. 571 queens-rc1, 33 rocky-1, 1 rocky-2, 1 rocky-3.
14:58:24 <mwhahaha> as a reminder, rc1 is coming up next week
14:58:28 <EmilienM> I would rather have the feature in queens, even if the risk is high - but we have folks around to fix it and we can always backport
14:58:35 <slagle> breaking that nic-config patch up would be a significant improvement
14:58:45 <mwhahaha> so please pay attention to the critical bugs
14:58:49 <openstackgerrit> Athlan-Guyot sofer proposed openstack/tripleo-quickstart master: [WIP] Use tripleo-upgrade role for p->m job.  https://review.openstack.org/540072
14:59:20 <mwhahaha> #topic projects releases or stable backports
14:59:32 <mwhahaha> EmilienM: do we have any stable releases coming up?
14:59:38 <EmilienM> I did ocata/pike yesterday, it's done
14:59:43 <mwhahaha> k thanks
14:59:47 <mwhahaha> #topic specs
14:59:47 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:59:50 <EmilienM> jschlueter: ^
14:59:58 <mwhahaha> rocky is coming up, don't forget to propose specs prior to the PTG
15:00:11 <mwhahaha> #topic open discussion
15:00:11 <mwhahaha> Reminder to propose topics for the PTG
15:00:11 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ptg-rocky
15:00:19 <mwhahaha> and we're out of time
15:00:26 <mwhahaha> thanks everyone
15:00:29 <mwhahaha> #endmeeting