14:00:35 <mwhahaha> #startmeeting tripleo
14:00:35 <mwhahaha> #topic agenda
14:00:35 <mwhahaha> * Review past action items
14:00:35 <mwhahaha> * One off agenda items
14:00:36 <mwhahaha> * Squad status
14:00:36 <mwhahaha> * Bugs & Blueprints
14:00:36 <mwhahaha> * Projects releases or stable backports
14:00:37 <mwhahaha> * Specs
14:00:37 <openstack> Meeting started Tue Feb  6 14:00:35 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <mwhahaha> * open discussion
14:00:38 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:38 <mwhahaha> Hi everyone! who is around today?
14:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:40 <openstack> The meeting name has been set to 'tripleo'
14:00:45 <dpeacock> o/
14:00:47 <jpich> o/
14:00:47 <EmilienM> o/
14:01:11 <openstackgerrit> Jose Luis Franco proposed openstack-infra/tripleo-ci master: WIP: Upgrade UC and OC using tripleo-upgrade role  https://review.openstack.org/515643
14:01:27 <chem> o/
14:01:30 <marios> o/
14:01:34 <florianf> o/
14:02:00 <mwhahaha> record attendance
14:02:00 <tbarron> o/
14:02:07 <trown> o/
14:02:15 <sshnaidm|rover> o/
14:02:20 <adarazs> o/
14:02:21 <owalsh> o/
14:02:26 <jfrancoa> o/
14:02:42 <rfolco|ruck> o/
14:03:05 <mwhahaha> alright lets get going
14:03:09 <mwhahaha> #topic review past action items
14:03:10 <mwhahaha> team to review https://review.openstack.org/#/q/status:open+topic:bp/undercloud-backup-restore
14:03:21 <beagles> o/
14:03:37 <mwhahaha> looks like the items are still open, core reviewers please take a look
14:04:15 <weshay> o/
14:04:15 <mwhahaha> ccamacho: looks like the restore command is not in a good spot either
14:04:36 <mwhahaha> That's it on past action items
14:04:42 <mwhahaha> #topic one off agenda items
14:04:43 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:52 <mwhahaha> (tbarron) python3 coming?  how to test?
14:04:56 <jaosorior> o/
14:05:22 <mwhahaha> <wes> will DF support fedora to prep for centos/rhel8? fedora in rdo-cloud and sf.  tripleo-ci team needs to engage infra  <- unlikely but we can talk about it
14:05:24 <tbarron> i was curious what the plan is for tripleo
14:05:32 <EmilienM> so we had a blueprint
14:05:36 <EmilienM> and we added unit tests jobs
14:05:36 <jtomasek> o/
14:05:38 <EmilienM> let me find it
14:05:58 <tbarron> since fixing devstack and so on is one thing, seems we need to have confidence in real deployments
14:06:27 <EmilienM> ok I can't find it now
14:06:30 <mwhahaha> since we're leaveraging the openstack services, it's more of a chicken/egg problem
14:06:33 <weshay> bah.. needs someone from rdo, but it has been discussed to run fedora/tripleo jobs to prep for python3 rhel8/centos8
14:06:39 <openstackgerrit> mathieu bultel proposed openstack/python-tripleoclient master: Inherit UpdateCommand class from overcloud DeployCommand class  https://review.openstack.org/540798
14:06:50 <mwhahaha> in theory if the openstack services work in py3, tripleo should work in py3
14:06:58 <EmilienM> https://blueprints.launchpad.net/tripleo/+spec/support-python-35
14:07:11 <mwhahaha> the question is do we have confidence in the py3 unit jobs coverage to say we won't run into any issues with the client/tripleo-common
14:07:23 <EmilienM> in Pike we added python 3 jobs to all python projects with unit tests
14:07:42 <gfidente> o/
14:07:54 <EmilienM> now in term of functional jobs, I agree we would need an experimental job
14:08:57 <EmilienM> maybe we can just restore a thread on openstack-dev
14:09:02 <EmilienM> and continue the discussion there
14:09:14 <mwhahaha> would probably be a good idea
14:09:26 <tbarron> also there will be a cross-project discussion of py3 goal at PTG I think
14:09:43 <fultonj> o/
14:09:52 <jrist_> o/
14:09:57 <mwhahaha> #action tbarron or EmilienM to send a note to ML to start discussion on python3 testing
14:10:16 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1744954
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1746734
14:10:17 <openstack> Launchpad bug 1744954 in tripleo "(race condition) oci runtime error when spawning containers" [Critical,Triaged]
14:10:18 <openstack> Launchpad bug 1746734 in tripleo "Periodic Jobs failing at tempest config while creating image(with swift backend)" [Critical,Triaged] - Assigned to Christian Schwede (cschwede)
14:10:38 <mwhahaha> i don't know how much work is needed for fedora support but it's likely to be a bunch
14:10:53 <mwhahaha> so let's get the ball rolling on the ML
14:10:56 <mwhahaha> moving on
14:10:58 <mwhahaha> (jpich) https://bugs.launchpad.net/tripleo/+bug/1741066 - No more _member_role and way forward for Queen
14:10:59 <openstack> Launchpad bug 1741066 in tripleo "Horizon project management and lack of _member_ role" [High,Triaged]
14:11:03 <jpich> Hi! I'd like to ask for help regarding https://bugs.launchpad.net/tripleo/+bug/1741066 (Keystone v3 and lack of _member_ role, which Horizon needs). I mentioned it on the list a few weeks ago but it turns out my solution doesn't work. From the original review I thought TripleO created a 'Member' role (instead of the old _member_) but it looks like there's no member-like role created at all on the overcloud now ( http://paste.openstack.org/show
14:11:03 <jpich> /663193/ )
14:11:18 <jpich> Managing projects in Horizon is broken without this. Looking for some advice on the way forward, maybe how to go/where to look for creating a role, and where would it make the most sense to do it?
14:11:39 <jpich> Doesn't need to be resolved during the meeting but if someone could reach out after to give me a hand I would deeply appreciate it :)
14:12:16 <mwhahaha> so it seems that we need to create the Member role somewhere
14:12:17 <EmilienM> we just need _member_ ?
14:12:25 <mwhahaha> if that's what we're moving to
14:12:25 <jpich> I think _member_ would be best yeah
14:12:35 <jpich> that's the default puppet-horizon expect
14:12:37 <EmilienM> we can create a stupid class in puppet-tripleo that does it
14:12:45 <EmilienM> and import the class in THT/puppet/services/horizon.yaml
14:12:56 <EmilienM> with a service_config_settings
14:13:08 <EmilienM> so it created it on where keystone runs, but only when horizon is deployed
14:13:08 <jpich> and similar for the docker service yaml?
14:13:14 <EmilienM> no need
14:13:22 <EmilienM> jpich: I can help that, let's do it today
14:13:33 <jpich> EmilienM: Sounds awesome, thanks!
14:13:39 <EmilienM> I'm just worried about the "why" horizon needs that..
14:13:58 <mwhahaha> #action EmilienM to help jpich with member role for horizon
14:14:10 <jpich> I think as long as roles still exist as a concept in keystone it's probably fine... but yeah something else to investigate
14:14:22 <jpich> rdopiera said he'd bring it up with david-lyle, not sure if he had a chance yet
14:14:46 <jpich> Thanks, that was it for me
14:14:56 <mwhahaha> thanks
14:15:01 <mwhahaha> any other one off items?
14:15:32 <mwhahaha> sounds like no
14:15:49 <mwhahaha> #topic Squad status
14:15:49 <mwhahaha> ci
14:15:49 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:15:49 <mwhahaha> upgrade
14:15:49 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:15:50 <mwhahaha> containers
14:15:50 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:15:51 <mwhahaha> integration
14:15:51 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:15:52 <mwhahaha> ui/cli
14:15:52 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:15:53 <mwhahaha> validations
14:15:53 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:15:54 <mwhahaha> networking
14:15:54 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:15:55 <mwhahaha> workflows
14:15:55 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:16:43 <mwhahaha> so we'll need to rethink the containers squad or figure out who will be responsible for status updates
14:17:15 <mwhahaha> everyone else, thanks for updating their status items.
14:17:22 <mwhahaha> any other status related things?
14:18:13 <mwhahaha> sounds like nope
14:18:19 <mwhahaha> #topic bugs & blueprints
14:18:19 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/queens-rc1
14:18:19 <mwhahaha> For Queens we currently have 33 (-1) blueprints and about 621 (+97) open bugs. 587 queens-rc1, 32 rocky-1, 1 rocky-2, 1 rocky-3.
14:18:26 <EmilienM> mwhahaha: yeah sounds like mandre was doing it but not anymore
14:18:33 <mwhahaha> as a reminder, the rc is due soon
14:18:52 <mwhahaha> so we need to make sure we've landed the FFE features and don't have any critical open issues
14:19:15 <EmilienM> AFIK, FFU and ipsec remain
14:19:28 <ccamacho> hey mwhahaha thansk for raising it, for now just https://review.openstack.org/#/q/topic:bp/undercloud-backup-restore+(status:open+OR+status:merged) the two patches for the backup are finished
14:19:34 <EmilienM> I asked jaosorior an update on ipsec, and where we are for the ipsec testing
14:19:41 <jaosorior> EmilienM: IPSec functionality is there. It's being tested by featureset042
14:19:47 <EmilienM> I haven't seen an new job in RDO CI
14:19:57 <EmilienM> where does this featureset run?
14:20:06 <jaosorior> RDO CI
14:20:14 <jaosorior> running it right now https://review.rdoproject.org/jenkins/job/gate-tripleo-ci-centos-7-ovb-3ctlr_1comp-featureset042-master/18/console
14:20:30 <jaosorior> EmilienM: adding more coverage here https://review.openstack.org/#/c/541262/
14:20:40 <EmilienM> ah cool
14:20:50 <jaosorior> big props to sshnaidm|rover for all the help in getting that featureset
14:21:02 <EmilienM> jaosorior: so we can close the blueprint?
14:21:08 <jaosorior> yep!
14:21:20 <EmilienM> jaosorior: ok, please next time go ahead and do it
14:21:33 <EmilienM> done now
14:21:37 <jaosorior> EmilienM: ack
14:22:12 <mwhahaha> ok i'm still catching up, i'll take a look at the open blueprints and poke some folks this week
14:22:21 <mwhahaha> we need to be finishing
14:22:31 <mwhahaha> moving on
14:22:35 <mwhahaha> #topic specs
14:22:35 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:22:52 <EmilienM> mwhahaha: I sent an individual email 3 weeks to specs owner
14:22:53 <mwhahaha> Rocky PTG is around the corner so don't forget to update your specs and propose any new ones you want to talk about
14:22:56 <EmilienM> asking them to move to Rocky
14:23:06 <EmilienM> otherwise we would abandon them
14:23:10 <mwhahaha> k
14:23:14 <EmilienM> I sent 2 reminders (so 3 emails total)
14:23:21 <EmilienM> so far, 1 reply and 1 update :(
14:23:57 <EmilienM> what do we do?
14:24:49 <mwhahaha> I know dnseddon was talking about updating the specs yesterday in the network meeting so we'll give it a bit longer
14:24:53 <EmilienM> anyway we can see that later
14:25:15 <mwhahaha> so we'll figure it out
14:25:18 <mwhahaha> moving on
14:25:21 <mwhahaha> #topic open discussion
14:25:21 <mwhahaha> Reminder to propose topics for the PTG
14:25:21 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ptg-rocky
14:25:28 <mwhahaha> anyone else have something to talk about?
14:26:02 <weshay> wanted to reach out to anyone who is interested in trying to put together a fast, minimal overcloud deployment
14:26:20 <openstackgerrit> James E. Blair proposed openstack/instack-undercloud stable/pike: Zuul: Remove project name  https://review.openstack.org/541286
14:26:29 <jaosorior> weshay: ??
14:26:29 <weshay> looking for insight into how to speed things up.. we have a keystone only scenario defined and it still takes a long time to deploy
14:26:45 <weshay> https://review.openstack.org/#/c/540107/
14:26:57 <openstackgerrit> Merged openstack/tripleo-quickstart master: Generate HostnameMap with quickstart interface  https://review.openstack.org/540084
14:27:05 <mwhahaha> I don't think the deployment is the long pole in CI
14:27:10 <mwhahaha> it's all the prep stuff we expect
14:27:10 <weshay> that will be renamed to scenario000
14:27:32 <mwhahaha> so I don't think trying to strip out services is really goign to achieve much
14:27:33 <trown> weshay: the keystone only job does still seem to shave 30 minutes
14:27:35 <jaosorior> weshay: do we have any way to get metrics? would be good to start measuring the steps we do inside the overcloud deploy and finally start working on reducing the deployment time.
14:27:38 <weshay> mwhahaha, ya.. btw.. we're ready to start sending detailed stats of the overcloud deployment to influx
14:27:43 <trown> weshay: and I would bet the upgrade is faster too
14:27:46 <jaosorior> bnemec: tried it for a while. Would be good to re-take those efforts.
14:27:59 <EmilienM> weshay: cool
14:27:59 <trown> weshay: so might still be able to get upgrade in multinode that way
14:28:02 <weshay> fyi.. https://review.rdoproject.org/grafana/dashboard/db/tripleo-ci?orgId=1
14:28:17 <mwhahaha> yay metrics
14:29:21 <weshay> one other note.. for anyone struggling to recreate ci, docs have been pushed http://tripleo.org/contributor/reproduce-ci.html
14:29:39 <EmilienM> weshay: did you send an email to openstack-dev about this feature?
14:29:45 <jpich> Nice
14:29:51 <EmilienM> I'm sure it would help
14:30:20 <weshay> aye, and I'll eat my vegetables too I promise
14:30:23 <mwhahaha> does reproducer work w/o rdo cloud?
14:30:44 <weshay> mwhahaha, it works w/ "a" cloud only atm, doesn't have to be rdo-cloud
14:30:52 <mwhahaha> k
14:31:14 <mwhahaha> i know there was push back about the rdo cloud requirement, any thoughts on libvirt support
14:31:32 <weshay> mwhahaha, it's in our sights
14:31:38 <mwhahaha> sounds good
14:32:33 <mwhahaha> anything else?
14:32:39 <weshay> pike is promoting atm
14:33:23 <jaosorior> To propose or ask about jobs in the promotion pipeline. the best place would be the CI meeting, right?
14:33:33 <EmilienM> or email
14:33:52 <jaosorior> right
14:34:20 <EmilienM> note: video conf meetings are not required to be involved and notes have to be taken and sent on openstack-dev
14:34:27 <EmilienM> (at least that's what we agreed to do)
14:34:45 <EmilienM> email remains the best tool to collaborate, just a reminder
14:35:09 <mwhahaha> sounds good
14:35:14 <jpich> Unrelated, but if anyone else was looking for local libvirt deployments that persist across reboots, having good luck so far with https://review.openstack.org/#/c/540350/
14:35:26 <jrist> !!!
14:35:27 <openstack> jrist: Error: "!!" is not a valid command.
14:35:32 <jrist> jpich: that's awesome thanks
14:35:53 <jpich> I am but the happy messenger
14:36:22 <mwhahaha> cool
14:36:35 <mwhahaha> if nothing else, i'll close the meeting in 1 minute and we can get back to fixing things
14:36:38 <openstackgerrit> Ryan Brady proposed openstack/python-tripleoclient master: Changes Delete Plan to Call Workflow  https://review.openstack.org/539045
14:37:10 <rdopiera> jpich: I didn't sorry, I will try on the team meeting tomorrow
14:37:21 <jpich> Cool, thank you!
14:37:36 * EmilienM will prepare the Weekly Owl
14:37:42 <mwhahaha> thanks everyone
14:37:44 <mwhahaha> #endmeeting