14:00:20 <mwhahaha> #startmeeting tripleo
14:00:20 <mwhahaha> #topic agenda
14:00:21 <mwhahaha> * Review past action items
14:00:21 <mwhahaha> * One off agenda items
14:00:21 <mwhahaha> * Squad status
14:00:21 <mwhahaha> * Bugs & Blueprints
14:00:21 <mwhahaha> * Projects releases or stable backports
14:00:21 <mwhahaha> * Specs
14:00:21 <openstack> Meeting started Tue Dec 12 14:00:20 2017 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <mwhahaha> * open discussion
14:00:22 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:23 <mwhahaha> Hi everyone! who is around today?
14:00:25 <openstack> The meeting name has been set to 'tripleo'
14:00:27 <ansiwen> arxcruz: I _had_ an deployed env and checked it there. "openstack service list" returned ec2
14:00:29 <jrist> o/
14:00:29 <dpeacock> Good morning! o/
14:00:36 <ccamacho> hey o/
14:00:53 <marios> o/
14:00:56 <dtantsur> o/
14:00:57 <arxcruz> o/
14:01:09 <b3nt_pin> o/
14:01:10 <EmilienM> o/
14:01:11 <ansiwen> o/
14:01:23 <jpich> o/
14:01:30 <fultonj> o/
14:01:41 <slagle> hi
14:02:36 <jfrancoa> o/
14:02:37 <weshay> 0/
14:02:46 <myoung|rover> o/
14:03:49 <mwhahaha> #topic review past action items
14:03:49 <mwhahaha> EmilienM to talk with slagle about switching default deployments to use config-download
14:03:55 <matbu> o/
14:03:59 <mwhahaha> so i think we confirmed that we wouldn't do that last week
14:04:09 <mwhahaha> due to various reasons we weren't going to make it the default
14:04:17 <EmilienM> right
14:04:20 <slagle> mwhahaha: correct.
14:04:37 <slagle> i'm still working through getting ovb-ha to use it, so we really shouldn't make it the default atm
14:04:39 <gfidente> o/
14:04:53 <slagle> let's plan for rocky asap
14:04:57 <d0ugal> p/
14:05:20 <mwhahaha> cool
14:05:27 <mwhahaha> moving on
14:05:28 <mwhahaha> gfidente and shardy look at ceph-ansible and config-download
14:05:52 <gfidente> mwhahaha no updates, my fault, I'd include jistr in that list too cause he worked on that for k8s
14:06:10 <EmilienM> (I guess if we disable by default, we'll accept backports of bugfixes wrt config-download *after* Queens GA)
14:06:32 <jistr> gfidente: yup :)
14:07:50 <mwhahaha> ok maybe we'll pick that one up next year
14:08:09 <mwhahaha> #action jistr, gfidente and shardy look at ceph-ansible and config-download (postponed till next year)
14:08:30 <mwhahaha> team to review open validation patches
14:08:54 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-validations+status:open
14:09:03 <mwhahaha> please take a look when you get the chance
14:09:13 <mwhahaha> EmilienM, akrivoka, gchamoul to check where validations are tested in tripleo ci
14:09:26 <EmilienM> a bunch has been merged last week
14:09:39 <EmilienM> ah, gchamoul made some progess on that
14:09:42 <EmilienM> let me find the link
14:09:49 <mwhahaha> so where are validations tested in CI?
14:09:55 <EmilienM> #link https://review.openstack.org/#/c/525637/
14:10:06 <EmilienM> please see the comments in Gerrit though
14:10:14 <EmilienM> validations aren't fatal if failing :-/
14:10:15 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:15 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1737716
14:10:16 <openstack> Launchpad bug 1737716 in tripleo "TripleO CI jobs fail: can't connect to nodepool hosts" [Critical,Triaged]
14:11:05 <mwhahaha> EmilienM: sounds like a tech-debt bug
14:11:18 <jrist> thanks mwhahaha
14:11:27 <jrist> (for the validations link)
14:11:34 <EmilienM> mwhahaha: true. I'll make sure we have a launchpad bug for this one
14:11:39 <mwhahaha> EmilienM: thanks
14:11:51 <mwhahaha> last action item
14:11:56 <weshay> they are tested outside of upstream because of timing
14:11:57 <mwhahaha> EmilienM starts to send a weekly newsletter about tripleo - DONE
14:11:57 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2017-December/125214.html
14:12:05 <mwhahaha> thanks EmilienM for putting together the weekly owl
14:12:15 <mwhahaha> i expect high quality owl facts from now on
14:12:24 <EmilienM> lol
14:12:26 <EmilienM> cool!
14:14:14 <mwhahaha> that's it on the action items
14:14:22 <mwhahaha> #topic one off agenda items
14:14:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:14:31 <mwhahaha> the agenda is empty
14:14:37 <mwhahaha> anyone have anything pressing?
14:15:20 <mwhahaha> sounds like nope
14:15:22 <mwhahaha> status time
14:15:26 <mwhahaha> #topic Squad status
14:15:27 <mwhahaha> ci
14:15:27 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:15:27 <mwhahaha> upgrade
14:15:27 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:15:27 <mwhahaha> containers
14:15:28 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:15:28 <mwhahaha> integration
14:15:29 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:15:29 <mwhahaha> ui/cli
14:15:30 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:15:30 <mwhahaha> validations
14:15:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:15:31 <mwhahaha> networking
14:15:32 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:15:32 <mwhahaha> workflows
14:15:33 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:15:57 <mwhahaha> weshay, sshnaidm|ruck, myoung|rover: ci status is not updated
14:16:09 <weshay> arxcruz, ^
14:16:16 <mwhahaha> gfidente, integration is missing status update
14:16:21 <jrist> we (ui) are still waiting on some workflows patches for roles management
14:16:30 <arxcruz> mwhahaha: we will have the meeting tomorrow, and we'll update it
14:16:40 <mwhahaha> arxcruz: it's missing last weeks update too
14:17:46 <gfidente> mwhahaha done, thanks
14:17:51 <mwhahaha> d0ugal: workflows is also missing update but they have their mieeting on weds as well
14:18:10 <mwhahaha> thanks everyone, these all feed the weekly owl :D
14:18:17 <jrist> :D
14:18:25 <arxcruz> weshay: mwhahaha I'll update the etherpad
14:18:31 <mwhahaha> don't need starving owls
14:18:37 <d0ugal> mwhahaha: yeah, it is a little unfortunate that we do the update the day after this meeting, but nevermind.
14:19:08 <mwhahaha> d0ugal: it's ok, maybe as long as we have at least last weeks update next time
14:19:21 <mwhahaha> same for CI since they do on weds as well
14:19:29 <mwhahaha> we'll play with it
14:19:36 <mwhahaha> moving on to bugs and blueprints
14:19:42 <mwhahaha> #topic bugs & blueprints
14:19:42 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/queens-3
14:19:42 <mwhahaha> For Queens we currently have 30 (-41) blueprints and about 553 (+13) open bugs. 553 queens-3.
14:19:52 <mwhahaha> I created the Rocky milestones and moved a bunch of the blueprints out. Please see the note to the ML about this effort.
14:19:52 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2017-December/125339.html
14:19:52 <mwhahaha> Additionally I have yet to move the medium bugs out to rocky-1. For now they are grouped together in queens-3 but please take a look at the Critical/High issues.
14:20:47 <mwhahaha> also about bugs, please read EmilienM's note about bug priorities
14:20:49 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2017-December/125378.html
14:21:03 <mwhahaha> any specific bug/blueprint issues?
14:21:05 <EmilienM> I think it's more a discussion now, and we might want to document
14:21:23 <EmilienM> sshnaidm|ruck's reply is good, we need to clarify what do we expect
14:21:36 <mwhahaha> perhaps we should throw it into a tripleo policy doc
14:21:48 <EmilienM> sounds good
14:21:58 <EmilienM> I'll kick off something
14:22:16 <mwhahaha> #action EmilienM to start a policy doc around bug priority
14:22:37 <mwhahaha> moving on
14:22:38 <mwhahaha> #topic projects releases or stable backports
14:22:47 <mwhahaha> any stable backport items?
14:22:55 <EmilienM> stable newton/ocata/pike tagged on Friday, RDO updated
14:23:02 <mwhahaha> as a reminder we'll be looking to EOL newton in January
14:23:23 <EmilienM> before EOL I suggest a newton review day
14:23:32 <mwhahaha> ok
14:23:39 <EmilienM> to clear things up and properly say good bye
14:24:03 <EmilienM> otherwise, backports to newton become rare nowadays, so I think it's becoming a good time
14:24:10 <mwhahaha> ok
14:24:29 <mwhahaha> #action mwhahaha/EmilienM to schedule a Newton day in January before EOL
14:24:33 <mwhahaha> as a reminder
14:25:26 <mwhahaha> moving on
14:25:31 <mwhahaha> #topic specs
14:25:31 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:25:31 <mwhahaha> As mentioned last week, we are allowing a small extra period of time for specs. Please review the open specs as we'll be freezing the repo for Queens at the end of this week.
14:25:58 <chem`> mwhahaha: EmilienM sorry about the newton day, what about ffu ?
14:26:14 <mwhahaha> chem: that's why we're waiting until January
14:26:22 <mwhahaha> chem: so if you need more time you need to tell people now
14:26:37 <mwhahaha> EOL was techincally in october so we've been keeping it open because of ffu
14:26:44 <mwhahaha> so get your FFU stuff posted now
14:27:14 <chem> mwhahaha: right, january, we will discuss this on ffu meeting and tell you next week
14:27:17 <EmilienM> chem: for FFU, do you need patches in stable/newton branch?
14:27:46 <chem> EmilienM: not that I'm aware off currently
14:27:48 <mwhahaha> chem: at this point we're keeping it open for you guys so if it needs to be fab/end of jan that's fine just let us know
14:27:49 <EmilienM> because of not, then EOLing newton isn't a problem for you, you can still deploy newton in RDO CI (like you're working now) FFU'ing
14:27:59 <EmilienM> is FFU'ing a verb? It should be.
14:28:17 <chem> EmilienM: yeah rdo is the main thing for ci testing
14:28:23 <mwhahaha> it's the sound you make when being asked to upgrade 3 versions at once
14:28:40 <chem> EmilienM: mwhahaha will make sure we have a point next meeting about this timetable and where ffu stands
14:28:49 <chem> thanks
14:28:50 <EmilienM> cool
14:29:01 <EmilienM> the only thing we need to know is, if you need patches in stable/newton
14:29:09 <chem> EmilienM: ack
14:29:14 <EmilienM> worst case: even after EOL, we'll still be able to carry patches, in RDO I guess
14:29:40 <chem> EmilienM: oki, we need to talk with rdo people anyway :)
14:30:06 <chem> (I'm done with ffu topic ... thanks )
14:30:12 <mwhahaha> sounds like there wasn't any spec related stuff
14:30:16 <mwhahaha> moving on
14:30:17 <mwhahaha> #topic open discussion
14:30:23 <dpeacock> Super trivial, but I'd like to chase a second +2 so https://review.openstack.org/#/c/526497/ can be merged please.
14:30:25 <mwhahaha> now into free time, anyone have anything?
14:31:06 <mwhahaha> dpeacock: done
14:31:13 <dpeacock> Thank you
14:31:14 <weshay> rdo-cloud is down for upgrades still FYI
14:31:20 <weshay> status on lists
14:31:25 <EmilienM> does it affect our CI so far?
14:31:48 <EmilienM> (check, check-tripleo, gate, RDO 3rd Party CI, promotions, etc) ?
14:32:50 <weshay> yes.. promotions and ovb,upgrade jobs in rdo-cloud
14:33:11 <weshay> which we still have jobs running in rh1 at this point for ovb, upgrades
14:33:15 <weshay> but promotions are blocked
14:33:23 <EmilienM> ok
14:33:58 <weshay> the upgrades team is in touch w/ rdo-cloud admins
14:35:00 <mwhahaha> ok anything else?
14:35:00 <sshnaidm|ruck> mwhahaha, EmilienM what is the policy to add tripleo admins?
14:35:20 <EmilienM> tripleo CI admins you mean?
14:35:48 <sshnaidm|ruck> yep
14:35:57 <sshnaidm|ruck> this file in tripleo-ci repo
14:36:23 <mwhahaha> so bnemec pointed to the previous documentation https://github.com/openstack/tripleo-incubator/blob/15f0afe41b009184c9f329efe9c997d3f30d6fcf/tripleo-cloud/README.md
14:36:37 <mwhahaha> it sounds like the policy should be updated/moved to the tripleo-specs repo
14:37:01 <mwhahaha> without an official change, i would assume the previous policy should continue to apply
14:37:27 <sshnaidm|ruck> ok
14:37:32 <mwhahaha> so you'd need to propose the new users individually and get a consensus amung the existing admins
14:37:47 <mwhahaha> so not the normal 2+2
14:38:16 <mwhahaha> it also sounds like we need a review of the existing admins as well
14:38:40 <sshnaidm|ruck> mwhahaha, I have other solution too, just for tripleo-ci-team
14:39:00 <sshnaidm|ruck> https://review.openstack.org/526187
14:39:09 <openstackgerrit> Daniel Alvarez proposed openstack/tripleo-heat-templates master: Add support for containerized OVN Metadata Agent  https://review.openstack.org/525164
14:40:01 <mwhahaha> sshnaidm|ruck: so it was raised to me that by doing this it actually can cause problems security wise because you could game the system and use depends-on to inject yourself into the clouds. I'm honestly not sure we should be doing this at all
14:40:38 <sshnaidm|ruck> mwhahaha, it's only for rdo cloud and rh1, I anyway can "inject" myself there
14:41:06 <mwhahaha> sshnaidm|ruck: right i don't think we should be doing that at all and you still haven't explained what you need specifically from local access
14:41:06 <sshnaidm|ruck> mwhahaha, we actually maintain rdo cloud
14:41:45 <sshnaidm|ruck> mwhahaha, in some cases it's possible only and sometimes it's faster to catch issues in running job
14:42:21 <mwhahaha> sshnaidm|ruck: without specific examples, it's hard to just agree
14:42:24 <sshnaidm|ruck> mwhahaha, I think it's helpful for anybody who work on CI on daily basis
14:42:35 <EmilienM> it's a security hole, imho
14:42:37 <mwhahaha> sshnaidm|ruck: i don't have access to any of these boxes and i'm not having any of these problems
14:42:50 <mwhahaha> nor am i looking to get ssh access
14:42:57 <EmilienM> a ci system is ephemeral, we shouldn't have access to it unless under specific circonstances
14:43:02 <sshnaidm|ruck> mwhahaha, I'm talking about people working on CI on daily basis
14:43:21 <EmilienM> in fact, the ci jobs should be reproducable, which is afik WIP
14:43:32 <sshnaidm|ruck> EmilienM, mwhahaha maybe let's continue this in ML?
14:43:45 <EmilienM> yeah ++ I want to see pabelanger's thoughts on this one
14:43:51 <sshnaidm|ruck> ok
14:43:52 <mwhahaha> sshnaidm|ruck: pretty sure i end up working on CI on a daily basis, but yes move this to the ML
14:44:03 <mwhahaha> anything else
14:44:10 <EmilienM> we're done I guess
14:44:30 <dtantsur> folks, do you still aim for containerized undercloud for Queens?
14:44:44 <EmilienM> to be the default, no
14:44:47 <mwhahaha> dtantsur: we should still work on it, but i don't think it'll be the new default
14:44:59 <dtantsur> got it
14:45:08 <EmilienM> it doesn't work in CI yet
14:45:12 <mwhahaha> if it's in a good state at teh end of queens then it makes the switch early rocky-1 easier
14:45:38 <dtantsur> good, then I don't have to urgently test all hardware provisioning features with it :)
14:45:40 <mwhahaha> so we should continue to work on the feature pairity
14:46:20 <mwhahaha> ok one last time
14:46:23 <mwhahaha> anything else?
14:46:23 <mwhahaha> :D
14:46:58 <mwhahaha> sounds like nope
14:47:01 <mwhahaha> thanks everyone
14:47:03 <mwhahaha> #endmeeting