14:00:40 <EmilienM> #startmeeting tripleo
14:00:41 <openstack> Meeting started Tue Jun 27 14:00:40 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:44 <EmilienM> #topic agenda
14:00:45 <openstack> The meeting name has been set to 'tripleo'
14:00:51 <EmilienM> * review past action items
14:00:53 <EmilienM> * one off agenda items
14:00:55 <EmilienM> * bugs
14:00:57 <EmilienM> * Projects releases or stable backports
14:00:59 <EmilienM> * CI
14:01:01 <EmilienM> * Specs
14:01:03 <EmilienM> * open discussion
14:01:05 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:07 <EmilienM> Hi everyone! who is around today?
14:01:09 <ccamacho> /o/
14:01:12 <atoth> o/
14:01:13 <adarazs> o/
14:01:14 <michapma> o/
14:01:38 <sshnaidm|afk> o/
14:02:13 <matbu_> o/
14:02:20 <EmilienM> #topic review past action items
14:02:22 <EmilienM> #link http://eavesdrop.openstack.org/meetings/tripleo/2017/tripleo.2017-06-20-14.00.html
14:02:30 <EmilienM> EmilienM to send email about how to use RSS to monitor Tempest results in TripleO CI
14:02:33 <EmilienM> EmilienM to start looking how to convert 3-nodes jobs in oooq
14:02:35 <EmilienM> EmilienM to postpone open specs to Queens, unless code has already been started during Pike and made good progress
14:02:44 <d0ugal> o/
14:02:55 <mhenkel> Hi
14:02:55 <shardy> o/
14:02:55 <EmilienM> I'll postpone the first one again
14:02:55 <cdearborn> \o
14:03:03 <skramaja> o/
14:03:08 <EmilienM> the second one is on the roadmap, after some discussion with weshay and trown
14:03:10 <jrist> /o
14:03:14 <marios> \o
14:03:24 <EmilienM> and the third is still WIP
14:03:37 <EmilienM> #topic one off agenda items
14:03:40 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:45 <EmilienM> mhenkel: hi, please go ahead
14:04:26 <weshay> 0/
14:04:39 <mhenkel> I worked on https://review.openstack.org/#/c/475048/5 and removed the big firstboot script
14:05:13 <mhenkel> I replaced it by 2 pre_network templates (one for dpdk and one for kernel module based installations)
14:05:17 <EmilienM> mhenkel: ok, I'll review it again - also anyone who has time to review, feel free to help
14:05:39 <mhenkel> thanks
14:06:03 <EmilienM> mhenkel: is there anything specific to discuss or you just need reviews?
14:06:34 <mhenkel> EmilienM: no, I think I cleaned everything up as much as I could
14:06:47 <EmilienM> ok
14:06:56 <mhenkel> there is still the need to bring up the vhost0 interface before os-net-config takes over
14:07:14 <mhenkel> therefore I unfortunately need some lines of bash
14:07:19 <EmilienM> #action review contrail patches https://review.openstack.org/#/c/475045/ https://review.openstack.org/#/c/475048
14:07:34 <EmilienM> moving on
14:07:37 <EmilienM> #topic bugs
14:07:40 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-3
14:07:55 <EmilienM> do we have any outstanding bug to discuss this week?
14:08:57 <EmilienM> great let's move on
14:09:00 <EmilienM> #topic projects releases or stable backports
14:09:09 <EmilienM> no updates on my side regarding release & backports
14:10:10 <EmilienM> moving on then
14:10:16 <EmilienM> #topic CI
14:10:37 <EmilienM> the only info I have regarding CI is that we're working on moving container scenario jobs into the gate (voting) as soon as they work
14:10:44 <EmilienM> so far we have scenario002 and scenario004 AFIK
14:11:02 <EmilienM> do we have anything to discuss about CI?
14:11:03 <shardy> The undercloud deploy has been broken, locally and in CI
14:11:06 <EmilienM> any review is needed?
14:11:16 <EmilienM> shardy: which job?
14:11:41 <EmilienM> gate-tripleo-ci-centos-7-undercloud-oooq ?
14:12:11 <shardy> EmilienM: no the undercloud-containers job
14:12:13 <EmilienM> I know the undercloud upgrade has been broken from newton to ocata, but ccamacho / me are on it
14:12:18 <shardy> https://github.com/openstack/python-tripleoclient/commit/4b1daab4eb7e29dafabc68ed82a3022399cbe013 just landed which aims to fix it
14:12:32 <EmilienM> shardy: yeah this one doesn't get much love
14:12:43 <sshnaidm> shardy, it's voting job, how was it broken?
14:12:49 <EmilienM> iirc this job / feature wasn't officially supported, that's why we didnd't have in gate right?
14:12:57 <shardy> https://bugs.launchpad.net/tripleo/+bug/1700417 has some details
14:12:59 <openstack> Launchpad bug 1700417 in tripleo "CI: Undercloud containers job timing out" [Critical,Fix released] - Assigned to Steve Baker (steve-stevebaker)
14:13:00 <ccamacho> yeah, im still checking logs to get the root cause
14:13:20 <EmilienM> sshnaidm: it's not
14:13:23 <EmilienM> gate-tripleo-ci-centos-7-undercloud-containers-nv
14:13:30 <EmilienM> let's make it voting then?
14:13:58 <shardy> https://review.openstack.org/#/c/475750/ broke it because it was merged with red CI
14:14:05 <shardy> more details in the bug of how
14:14:17 <EmilienM> shardy: should we make the job voting?
14:14:29 <shardy> EmilienM: yes I think so, as soon as it's stable again
14:14:53 <EmilienM> #action EmilienM to make gate-tripleo-ci-centos-7-undercloud-containers job voting in tripleo gate and make sure we run it where useful
14:15:08 <EmilienM> anything else CI related for this week?
14:15:15 <sshnaidm> we didn't promote today because one of periodic jobs started 5 mins later than others and caught different DLRN hash.. not sure what can we do in such case
14:15:23 <weshay> we should try to get that oooq version of that job voting, but what ever get's the job done now is ok
14:15:46 <EmilienM> weshay: yeah but I'm afraid this is not in the high prio backlog
14:15:53 <EmilienM> so it will break again if we don't make it voting
14:15:58 <weshay> aye
14:16:05 <adarazs> sshnaidm: hm, yeah, we should probably get a better way to do these periodic jobs in a more coordinated way.
14:16:09 <EmilienM> imho, upgrade jobs should be high prio to be in oooq
14:16:20 <EmilienM> we want to see upgrade jobs in oooq before anything else imho
14:16:33 <adarazs> sshnaidm: long term we could have a main job trigger all the promotion jobs with a single hash.
14:17:00 <EmilienM> sshnaidm: I don't understand why it didn't catch a more recent DLRN hash
14:17:05 <sshnaidm> adarazs, I think it's possible in rdo cloud only
14:17:08 <EmilienM> sshnaidm: it takes hashes from consistent, right?
14:17:14 <sshnaidm> EmilienM, because it changed in these 5 mins
14:17:19 <EmilienM> ahh
14:17:28 <EmilienM> can't we write it somewhere?
14:17:33 <panda> I love race conditions
14:17:42 <jrist> too me!
14:17:52 <adarazs> sshnaidm: maybe not, pabelanger was saying something about these pipeline jobs where jobs can trigger other jobs. maybe only in zuul v3?
14:18:04 <sshnaidm> EmilienM, not sure..
14:18:25 <sshnaidm> adarazs, yeah, the life will be happy with zuul v3 :)
14:18:29 <EmilienM> sshnaidm: please file a bug in Launchpad, so we can track this one
14:18:40 <panda> adarazs: there's the concept of a child job in zuul right now
14:18:42 <sshnaidm> EmilienM, ok
14:18:48 <adarazs> panda: so we could probably use that.
14:18:50 <panda> we could use that
14:19:01 <EmilienM> with zuul 2.5 ?
14:19:41 <EmilienM> tbh, I'm a bit confused (by lack of knowledge probably) why we have this race
14:19:48 <EmilienM> oh I see
14:19:50 <EmilienM> nevermind
14:19:56 <EmilienM> scenario001 picked another repo than 002 for ex
14:20:20 <EmilienM> mhh, yeah, hard to write it somewhere
14:20:40 <sshnaidm> EmilienM, I think we can live with this until we move periodics to 3party
14:20:42 <EmilienM> sshnaidm: let's think about it offline
14:20:45 <EmilienM> sshnaidm: ++
14:20:50 <EmilienM> anything about CI this week?
14:21:30 <EmilienM> moving on...
14:21:32 <EmilienM> #topic specs
14:21:35 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:21:43 <EmilienM> #action EmilienM to continue the postponing to Queens
14:21:48 <EmilienM> anything to discuss about specs this week?
14:22:35 <EmilienM> #topic open discussion
14:22:48 <EmilienM> I forgot to mention it in the off items but there is a cross project effort about documentation
14:22:57 <EmilienM> https://review.openstack.org/#/c/472275/13/specs/pike/os-manuals-migration.rst
14:23:10 <jpich> I'll send an email about it as well but I'd like to do a short i18n-themed deep dive in next week's slot (July 6th) if that works. Basically follow the Life and Journey of a String through tripleo-ui + infra + Zanata and back, what can go wrong/debugging tips, how we interact & work with the I18n team, things like that
14:23:10 <EmilienM> I'm working on it for TripleO but I'll probably ask for some help around
14:23:24 <EmilienM> jpich: that would be aweosme
14:23:40 <EmilienM> jpich: feel free to send email on openstack-dev and do it at your convenience
14:23:54 <jpich> Cool! Will do. Probably all of this is already documented but in 20 different places
14:24:10 <EmilienM> jpich: it would be fun to share screen and see real examples in code
14:24:16 <EmilienM> but I'm sure that's what you wanted to do :P
14:24:34 <jpich> Yep, though I can focus on different things if there's interest :)
14:24:43 <EmilienM> really cool
14:24:50 <jpich> I'll send the email
14:24:51 <EmilienM> anything else for this week folks?
14:25:06 <sshnaidm> I'd like to have another deep-dive about containers
14:25:18 <sshnaidm> with more deep stuff this time..
14:25:20 <EmilienM> sshnaidm: which specific area would you like?
14:25:28 <EmilienM> how deep? :)
14:25:38 <sshnaidm> EmilienM, of course everything we meet in CI :)
14:26:24 <sshnaidm> we can prepare more specific topics in next etherpad
14:26:27 <EmilienM> sshnaidm: feel free to share this feedback with folks who did previous deep dive (aka jistr) maybe we can schedule another one
14:26:40 <sshnaidm> EmilienM, ok
14:26:59 <EmilienM> allright! anything before we close the meeting?
14:27:24 <EmilienM> thanks everyone have fun and see you online
14:27:27 <EmilienM> #endmeeting