14:00:33 <EmilienM> #startmeeting tripleo
14:00:34 <openstack> Meeting started Tue Apr 18 14:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:38 <openstack> The meeting name has been set to 'tripleo'
14:00:40 <EmilienM> #topic agenda
14:00:48 <EmilienM> * review past action items
14:00:51 <EmilienM> * one off agenda items
14:00:53 <EmilienM> * bugs
14:00:55 <EmilienM> * Projects releases or stable backports
14:00:57 <EmilienM> * CI
14:00:59 <EmilienM> * Specs
14:01:01 <EmilienM> * open discussion
14:01:03 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:05 <EmilienM> Hi everyone! who is around today?
14:01:08 <shardy> o/
14:01:09 <jpich> o/
14:01:10 <trown> o/
14:01:13 <fultonj> o/
14:01:15 <mwhahaha> o/
14:01:17 <d0ugal> Hello!
14:01:25 <marios> o/
14:01:45 <akrivoka> o/
14:01:59 <dprince> hi
14:02:03 <jrist> o/
14:02:20 <florianf> o/
14:02:20 <jaosorior> o/
14:03:00 <EmilienM> I hope you didn't miss me too much last week /joke
14:03:05 <EmilienM> #topic review past action items
14:03:15 <EmilienM> dprince follow up re switch of OVB jobs to provide container coverage after mirrors are in place
14:03:24 <EmilienM> jistr/matbu/panda/weshay/shardy/Emilien work together to move multinode w/containers CI forward
14:03:29 <EmilienM> all to review http://lists.openstack.org/pipermail/openstack-dev/2017-April/115182.html and respond
14:03:54 <EmilienM> dprince: what is the progress on switching ovb jobs to have container coverage again?
14:04:02 <dprince> EmilienM: some, progress
14:04:06 <dprince> EmilienM: but not much
14:04:08 <EmilienM> bogdando: did you get enough feedback on the thread?
14:04:09 * dprince has been slow
14:04:18 <EmilienM> dprince: is there any blocker? is there any task the team can help?
14:04:32 <dprince> EmilienM: I need to enable the experimental again for tripleo-ci https://review.openstack.org/#/c/457615/
14:04:53 <shardy> There are a few different patches in flight for the various CI container efforts, would either an etherpad or gerrit topic be helpful?
14:04:56 <dprince> EmilienM: that isn't helping. One question for you. Why aren't we running all the 'template' tripleo-experiemental jobs?
14:05:00 <dprince> for tripleo-ci
14:05:08 <EmilienM> dprince: +1
14:05:44 <dprince> shardy: either would help
14:05:47 <EmilienM> dprince: all the 'template'? what does it mean?
14:05:52 <EmilienM> shardy: yes, +1 for etherpad
14:05:55 <dprince> EmilienM: in zuul
14:06:22 <EmilienM> ah, you mean "why aren't we running tripleo-experiemental everywhere in tripleo projects?" ?
14:06:30 <dprince> EmilienM: just a question why we aren't runnin all the tripleo-expimental jobs. right
14:06:40 <EmilienM> we should, probably
14:06:41 <dprince> EmilienM: with my patch it is just 1 extra job
14:06:46 <EmilienM> it's just nobody did it I guess
14:06:48 <dprince> EmilienM: ack, this cost me some time
14:06:57 <EmilienM> I'm not aware of a particular reason
14:07:01 <dprince> EmilienM: I will follow up on it then
14:07:03 <EmilienM> dprince: ok, just enable it and problem solved
14:07:05 <EmilienM> ack
14:07:12 <shardy> IIRC we wanted to run e.g only upgrades jobs on tripleo-ci for a while, as we were developing a bunch of things specific to that repo
14:07:24 <shardy> but yeah, now that all landed we can probably align things again
14:08:06 <EmilienM> dprince: could you dress an etherpad with all the WIP regarding tripleo CI & container, maybe work on that with other folks
14:08:24 <EmilienM> and then share it to the ML, so the team can help at reviewing/testing it
14:08:31 <dprince> EmilienM: yes
14:08:38 <EmilienM> thanks
14:08:40 <dprince> EmilienM: give me a few hours and I can have it
14:08:51 <EmilienM> no rush, it can be later this week. Really when you can.
14:09:17 <EmilienM> #action dprince to prepare an etherpad with all TripleO container CI work related and send it to ML
14:09:42 <EmilienM> let's move on
14:09:45 <EmilienM> #topic one off agenda items
14:09:52 <EmilienM> akrivoka: o/ I think you need some review
14:10:02 <akrivoka> EmilienM: yes please :)
14:10:11 <EmilienM> do you need to discuss about something in specific? or just need review?
14:10:15 <akrivoka> so the CLI command for plan export is ready to merge, I think
14:10:22 <akrivoka> it's missing final +2/A
14:10:39 <EmilienM> #action Folks familiar with CLI to review https://review.openstack.org/#/c/425858/
14:10:49 <EmilienM> akrivoka: thanks. Is there anything else you wanted to talk?
14:10:50 <akrivoka> I'd like to see it merged before I leave for vacation, I'm leaving tomorrow for more than a month
14:11:02 <akrivoka> no, just to draw attention to that
14:11:05 <akrivoka> thanks!
14:11:05 <jpich> Happy vacation :)
14:11:14 <EmilienM> a month? wait wait wait, no !
14:11:20 <EmilienM> joking :-) enjoy it
14:11:32 <akrivoka> thank you!
14:11:38 <EmilienM> I wanted to talk about the tripleo deployment guide that we started but is empty now
14:12:19 <EmilienM> I saw some folks interested to contribute on the ML but no concrete patches yet. I was wondering if people agrees to move some bits from current doc into this guide
14:12:30 <EmilienM> it would be moves inside the same repo (tripleo-docs)
14:12:49 <EmilienM> I'm just afraid about google search. We might need some redirections
14:13:25 <EmilienM> the last status of this work is here: http://lists.openstack.org/pipermail/openstack-dev/2017-March/114503.html
14:13:39 <EmilienM> err, sorry: http://lists.openstack.org/pipermail/openstack-dev/2017-March/114582.html
14:13:59 <EmilienM> if anyone is interested by tripleo-docs and deployment bits, please let me know and we can work on it together
14:14:32 <EmilienM> i'll also post (again) on this thread to ask for more feedback before we move bits
14:15:19 <EmilienM> any feedback or question before we move on?
14:15:39 <EmilienM> #topic bugs
14:15:47 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-2
14:16:16 <EmilienM> so last week I moved the bugs / blueprints from pike-1 to pike-2
14:16:25 <EmilienM> which means that pike-2 has now 61 blueprints and 345 bugs targeted
14:16:58 <EmilienM> I would like to remind people to self triage the bug, por favor
14:17:14 <EmilienM> I updated Launchpad to send a nice message when someone posts a new bug with some guidelines
14:17:18 <EmilienM> at how make self triage
14:17:43 <EmilienM> other than that, do we have outstanding bugs to discuss this week?
14:18:18 <EmilienM> I guess that's a no
14:18:30 <EmilienM> moving on
14:18:31 <EmilienM> #topic projects releases or stable backports
14:19:08 <EmilienM> on my list to do (and thanks jrist  for the reminder)
14:19:18 <EmilienM> #action EmilienM to document how we release TripleO so anyone can do it
14:19:42 <EmilienM> warning: you need to understand YAML :)
14:20:01 <EmilienM> is there any question or feedback about releases / backports?
14:20:18 * jrist hat tip
14:20:19 <bogdando> reno docs look self explaining
14:20:32 <bogdando> you can trust me as a newcomer :)
14:20:34 <jrist> bogdando: that's part of it
14:21:00 <EmilienM> bogdando: I think i'll contribute to an higher level document for all OpenStack projects and write tripleo specific bits in tripleo-docs
14:21:16 <EmilienM> #topic CI
14:21:25 <EmilienM> I have some quick FYIs:
14:21:44 <EmilienM> 1) we've got a promotion this morning, all blockers should be resolved now. Let us know if you see something strange.
14:22:37 <EmilienM> 2) now pike-1 is out and most of projects have a pike tag, we can actually test upgrades from ocata to pike. I started to look at it and will post updates in launchpad if I see some blockers. Once the job are passing, i'll propose to make them voting and add them to the promotion pipeline
14:23:07 <shardy> EmilienM: +1 sounds good
14:23:10 <bogdando> wrt CI, I wonder is it possible to include tripleo into elastic recheck? What was the latest attempt results for that (I'm sure there had been an attempt in the past)?
14:23:22 <EmilienM> regarding CI work, I've discussed with jistr and the folks working on containers - it seems they we need some review on the work that is being done, (quickstart, extras, and tht mostly)
14:23:24 <shardy> even while we work on CI coverage for upgrading to containers, keeping the baremetal upgrades working is important IMO
14:23:43 <EmilienM> jistr: please update dprince's etherpad once it's created with all the work you need reviews
14:23:58 <jistr> ack
14:24:11 <EmilienM> bogdando: I think console is already there but some work would have to be done for other files, specially since the move to quickstart
14:24:19 <EmilienM> trown, weshay ^ can we take action on this?
14:24:30 <weshay> ya
14:24:36 <EmilienM> shardy: I agree with you
14:24:44 <EmilienM> weshay: what would you do?
14:25:22 <shardy> bogdando: it's a good idea, but I don't recall anyone doing the work to either automate or manually propose queries for specific bugs
14:25:24 <bogdando> and once we have cotnainerized undercloud patch in, would that make sense to shortcut some of the containers jobs to side step overcloud and test things at undercloud?
14:25:25 <weshay> I'm adding a card to the tripleo-ci squads next column to look into it
14:25:30 <dprince> jistr, shardy: lets organize the CI stuff here https://etherpad.openstack.org/p/tripleo-containers-ci
14:25:53 * weshay wonders if we can move all ci planning to the tripleo ci board
14:26:02 <EmilienM> shardy: we have done some queries sometimes
14:26:14 <EmilienM> shardy: for the No host found thing when pulling rpms from trunk.rdo
14:27:26 <EmilienM> weshay: in https://trello.com/b/U1ITy0cu/tripleo-ci-squad ?
14:27:31 <weshay> aye
14:27:41 <EmilienM> just do it :)
14:27:59 <EmilienM> is there anything else to discuss about CI this week? Any question or feedback so far?
14:28:04 <shardy> bogdando: that is a good idea, but ideally I'd like us to optimize until the overcloud deploy time is (much) closer to the non-container architecture
14:28:32 <shardy> I agree testing more on the undercloud deploy may be useful, but for operators slower deployments aren't great news
14:29:44 <EmilienM> ok i'll move to the next topic
14:29:47 <EmilienM> #topic specs
14:29:49 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:30:27 <bogdando> shardy: deployment times may be covered by periodic profiling jobs
14:30:30 <EmilienM> I haven't seen much progress on the tripleo specs, as usual. I'll skip the topic unless someone has something to ask/say here about it
14:30:41 <fultonj> Is there a cutoff date for pike specs to be merged?
14:30:49 <EmilienM> it was supposed to be pike-1
14:30:58 <bogdando> shardy: while having a shortcut for a patch-based jobs looks doable to me
14:31:03 <EmilienM> fultonj: but you can't force people to review specs
14:31:30 * bogdando was late
14:32:00 <EmilienM> #topic open discussion
14:32:00 <fultonj> EmilienM: ack. sounds like state of specs to be merged is uncertain
14:32:24 <EmilienM> fultonj: for your spec, it seems like a lot of comments have been made recently, even if shardy +2'ed it
14:33:00 <EmilienM> on open discussion here, I just wanted to share http://my1.fr/blog/my-journey-as-an-openstack-ptl/ which is a blog post where I explain why I won't be PTL during the next cycle
14:33:20 <EmilienM> I truly believe we need to redefine the role together and also bring up more leaders in general
14:33:37 <EmilienM> it has been an ongoing topic in OpenStack in general, and I would like us to make progress on tripleo
14:34:36 <EmilienM> if you are interested by learning what TripleO PTLs did or what they would do in the future, please feel free to come into the disucssion
14:34:50 * EmilienM drops the mic
14:35:12 <marios> EmilienM: echo what  shardy already said in the mail thread, thanks for all your work this cycle it looked tiring!
14:35:48 <EmilienM> marios: it would be less tiring if we would redefine the role and maybe distribute some tasks on the team even more
14:36:01 <EmilienM> but I'm pretty sure we'll get there :)
14:36:19 <EmilienM> anyway, thanks for your time today
14:36:28 <EmilienM> and I'll close the meeting so folks can go back to work/fun
14:36:32 <EmilienM> #endmeeting