14:00:08 <EmilienM> #startmeeting tripleo
14:00:12 <openstack> Meeting started Tue Mar 14 14:00:08 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'tripleo'
14:00:15 <EmilienM> #topic agenda
14:00:23 <EmilienM> * one off agenda items
14:00:26 <EmilienM> * bugs
14:00:28 <EmilienM> * Projects releases or stable backports
14:00:30 <EmilienM> * CI
14:00:32 <EmilienM> * Specs
14:00:34 <EmilienM> * Week roadmap
14:00:36 <EmilienM> * open discussion
14:00:38 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:40 <EmilienM> Hi everyone! who is around today?
14:00:44 <[1]cdearborn> o/
14:00:44 <fultonj> o/
14:00:50 <jpich> o/
14:00:50 <weshay> o/
14:00:55 <akrivoka> o/
14:00:57 <adarazs> o/
14:01:01 <panda> o_|
14:01:03 <EmilienM> adarazs: coffee is ready now
14:01:03 <tzumainn> \o
14:01:04 <sshnaidm> o/
14:01:09 <ccamacho> hi! o/
14:01:09 <adarazs> \o/
14:01:14 <rbrady> o/
14:01:15 <jaosorior> o/
14:01:17 <beagles> hi
14:01:23 <matbu> o/
14:01:30 <EmilienM> what a nice crowd
14:01:33 * adarazs C|_|
14:01:42 <shardy> o/
14:01:46 <EmilienM> #topic one off agenda items
14:01:52 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:01:56 <EmilienM> there is no topic yet
14:02:04 <EmilienM> if you have one, feel free to go ahead now or wait for open discussion
14:02:14 <mandre> o/
14:02:21 <mwhahaha> o/
14:02:40 <sshnaidm> EmilienM, just added
14:02:52 <EmilienM> sshnaidm: go ahead now
14:03:13 <EmilienM> #link https://review.openstack.org/#/c/443964
14:03:29 <EmilienM> sshnaidm: what needs to be discussed ?
14:03:36 <bogdando> o/
14:03:42 <sshnaidm> weshay brought up idea about running periodic jobs more frequently
14:04:02 <weshay> it was a spec for pike
14:04:08 <sshnaidm> I did a patch that implements a new pipeline in infra, running every 4 (or more) hours
14:04:34 <sshnaidm> so if you can look at the patch and comment my mail in ML it would be nice
14:04:37 <d0ugal> i/
14:04:56 <weshay> https://blueprints.launchpad.net/tripleo/+spec/increase-cadence-of-tripleo-promotions
14:05:05 <sshnaidm> because I think we reached a point that requires a discussion about pabelanger comments
14:05:24 <EmilienM> #action team to review https://review.openstack.org/#/c/443964 and comment ML thread about it (contact: sshnaidm)
14:05:34 <sshnaidm> that's it
14:05:45 <marios> o/
14:05:46 <EmilienM> sshnaidm: ok, thanks for bringing this up. Let's figure out this week
14:05:56 <beagles> sshnaidm: should the blueprint be linked to the patch in the commit message
14:06:00 <EmilienM> akrivoka: o/
14:06:04 * beagles could just comment on the review
14:06:06 <akrivoka> I'd like to call attention to the plan import/export patches that have been up for review for quite some time
14:06:11 <EmilienM> beagles: yes, it would be great
14:06:15 <akrivoka> links in the etherpad lines 7-9
14:06:20 <akrivoka> that is all :)
14:06:45 <EmilienM> akrivoka: when there is a lack a review, sometimes people send a post on ML about the feature and how to review it
14:06:59 <EmilienM> akrivoka: it gives more visibility in the work that is done and people know about it
14:07:22 <EmilienM> akrivoka: I suggest to do that if you don't get more review by the group
14:07:27 <akrivoka> EmilienM: oh, I thought it was bad form to ask for reviews on the mailing list...
14:07:41 <akrivoka> EmilienM: thanks for the tip, I'll do that!
14:07:42 <EmilienM> imho, there is no bad form to use ML in any time
14:07:47 <EmilienM> but that's my opinion
14:08:09 <beagles> akrivoka: I think that is less so for this group than maybe others
14:08:11 <EmilienM> ML is a good way to discuss in the open and async (without IRC, so TZ independent)
14:08:25 <beagles> and context helps with reviews sometimes
14:08:44 <EmilienM> #action team to review plan import/export patches (contact: akrivoka)
14:08:53 <EmilienM> any other items for this week before we move on?
14:08:59 <akrivoka> beagles: EmilienM: thanks, noted, I'll send an email with context and instructions for review
14:09:11 <EmilienM> akrivoka: thank you :)
14:09:26 <EmilienM> #topic bugs
14:09:30 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-1
14:10:11 <EmilienM> let's do a bit of triage, we have some critical bugs reported
14:10:14 <beagles> yowzers
14:10:25 <EmilienM> beagles: https://bugs.launchpad.net/tripleo/+bug/1663217
14:10:25 <openstack> Launchpad bug 1663217 in tripleo "Newton->Ocata upgrade fails during neutron-db-manage upgrade head (caused by python-networking-bigswitch)" [Critical,In progress] - Assigned to Brent Eagles (beagles)
14:10:35 <jrist> o/
14:10:58 <EmilienM> beagles: any progress on this one?
14:11:00 <beagles> EmilienM: yes.. bigswitch has had some issues with some patches that've merged.
14:11:13 <EmilienM> beagles: ok, please update it then
14:11:28 <EmilienM> shardy, marios: can we close this one? I'm not sure we hit it anymore https://bugs.launchpad.net/tripleo/+bug/1668294
14:11:28 <openstack> Launchpad bug 1668294 in tripleo "puppet is not run at step 3 after upgrade from newton to ocata" [Critical,Triaged]
14:11:34 <beagles> EmilienM: in short their code is a bit of a mess with respect to alembic... will do
14:12:18 <shardy> EmilienM: yes I think so, although I can't provide an exact commit that fixed it atm
14:12:26 <marios> EmilienM: yes i think we cn i haven't seen that one
14:12:42 <EmilienM> shardy: ack, I'll close it. Thansk
14:13:15 <EmilienM> beagles: https://bugs.launchpad.net/tripleo/+bug/1669452
14:13:15 <openstack> Launchpad bug 1669452 in tripleo "Glance and Neutron worker defaults not working" [Critical,In progress] - Assigned to Brent Eagles (beagles)
14:13:21 <EmilienM> it seems like the fix is https://review.openstack.org/#/c/425423/ and it's ready for review
14:13:27 <beagles> EmilienM: yes
14:13:31 <shardy> 53 blueprints!
14:13:32 <beagles> have at it
14:14:04 <EmilienM> dprince: https://bugs.launchpad.net/tripleo/+bug/1669461 - anything else we can review or do?
14:14:04 <openstack> Launchpad bug 1669461 in tripleo "nova placement api container fails to start due to multiple http conf files" [Critical,In progress] - Assigned to Dan Prince (dan-prince)
14:14:09 <EmilienM> shardy: as usual...
14:14:21 <EmilienM> and as usual we'll close 5 :)
14:14:30 <mwhahaha> thought that bug was addressed via puppet-nova
14:14:48 <shardy> Heh, well I think it was 15 in ocata but yeah I'd be surprised if half land
14:14:49 <dprince> EmilienM: I think that might be resolved now
14:15:18 <marios> EmilienM: this one https://bugs.launchpad.net/tripleo/+bug/1669714 we can untarget i think ... it was fixed for Ocata (only remaining thing there is newton backport at https://review.openstack.org/#/c/441192/ )
14:15:18 <openstack> Launchpad bug 1669714 in tripleo "Newton to Ocata - upgrade to ovs 2.5->2.6 with current workaround and lose connectivity" [High,Fix released] - Assigned to Marios Andreou (marios-b)
14:15:19 <EmilienM> dprince: please update it
14:15:35 <EmilienM> marios: please do
14:15:39 <EmilienM> there is also: https://bugs.launchpad.net/tripleo/+bug/1661347
14:15:39 <openstack> Launchpad bug 1661347 in tripleo "During Newton->Ocata upgrade pattern is ignored in the 'Stop Ceph Mon' task in ceph-mon upgrade" [Critical,Triaged]
14:16:03 <EmilienM> I'm not sure but I think we fixed it
14:16:06 <marios> EmilienM:  https://bugs.launchpad.net/tripleo/+bug/1666604 same fixed in O
14:16:06 <openstack> Launchpad bug 1666604 in tripleo "Composable upgrade ansible-pacemaker default service start timeout is too short" [Low,Fix released] - Assigned to Marios Andreou (marios-b)
14:16:33 <jtomasek> o/
14:17:03 <EmilienM> shardy, marios: can we close https://bugs.launchpad.net/tripleo/+bug/1661347 also? I think ceph upgrades are fine now. Though I could check with Marius
14:17:03 <openstack> Launchpad bug 1661347 in tripleo "During Newton->Ocata upgrade pattern is ignored in the 'Stop Ceph Mon' task in ceph-mon upgrade" [Critical,Triaged]
14:17:40 <marios> EmilienM: not checked this one yet
14:17:53 <marios> EmilienM: yeah ceph upgrades are working i mean
14:17:59 <marios> EmilienM: i wasn't sure if there was still some issue
14:18:00 <EmilienM> can you check with Marius?
14:18:18 <marios> sure
14:18:21 <EmilienM> #action marios check with marius if https://bugs.launchpad.net/tripleo/+bug/1661347 is still valid or has been fixed
14:18:21 <openstack> Launchpad bug 1661347 in tripleo "During Newton->Ocata upgrade pattern is ignored in the 'Stop Ceph Mon' task in ceph-mon upgrade" [Critical,Triaged]
14:18:31 <EmilienM> ok, that's it for the critical bugs
14:18:37 <EmilienM> do we have any other bug to discuss this week?
14:19:20 <EmilienM> it sounds like no
14:19:33 <EmilienM> #topic projects releases or stable backports
14:19:33 <shardy> EmilienM: I think it was fixed by https://review.openstack.org/#/q/I0a0e60d277240130c6bd76a74ccc13354b87a30a
14:19:38 <shardy> will update the bug
14:19:45 <EmilienM> shardy: ah! you got it, thanks
14:19:47 <marios> thanks shardy
14:19:58 <EmilienM> it sounds like the right patch, indeed
14:20:21 <EmilienM> anything to discuss about release management & backports this week?
14:20:44 <EmilienM> for folks who still work on upgrades: gentle reminder to backport fixes from master into stable/ocata
14:20:58 <marios> thanks EmilienM
14:21:12 <EmilienM> shardy: do we want to talk about the tagging issue on projects for master?
14:21:31 <shardy> EmilienM: we can, but I don't have anything to add beyond the ML discussion really
14:21:32 <EmilienM> it sounds like upstream rejected having a new tag between post-release & m1
14:21:38 <EmilienM> yeah, same here
14:21:50 <EmilienM> AFIK apevec is now investigating how to trick it in delorean tooling
14:21:50 <shardy> EmilienM: I'm surprised there's so little interest in fixing this upstream
14:21:59 <trown> ya it was kind of unclear what the path forward is from the ML discussion
14:22:00 <EmilienM> shardy: you really surprised? :)
14:22:01 <shardy> but yeah, seems we'll need a delorean level workaround
14:22:09 <shardy> "it works in devstack" (tm)
14:22:11 <shardy> :(
14:22:12 <EmilienM> it works in devstack folks
14:22:23 <EmilienM> they use pip and can pick what they want
14:22:32 <EmilienM> anyway. Don't get me started here
14:22:39 <shardy> hehe
14:23:01 <EmilienM> I'll catchup with Alan and see how it goes in RDO tooling, so we can start testing upgrades from Ocata to Pike ASAP
14:23:17 <EmilienM> and also find a longterm solution
14:23:31 <EmilienM> anything else about release management & stable branches?
14:23:53 <EmilienM> #topic CI
14:24:12 <EmilienM> ok, I think we can get a quick update on quickstart jobs and the move to the check pipeline
14:24:17 <EmilienM> trown: can you go ahead please?
14:24:22 <trown> sure
14:24:23 <adarazs> I would like to give an update about the Quickstart CI transition.
14:24:29 <trown> sweet
14:24:30 <EmilienM> go ahead!
14:24:32 <trown> go for it adarazs
14:24:40 <adarazs> Once this https://review.openstack.org/441186 change merges we transitioned the first set of TripleO gate jobs to Quickstart (multinode scenario jobs + undercloud only). I will send an announcement email with links to the Quickstart documentation shortly.
14:24:54 <adarazs> Big kudos to the TripleO CI Squad, especially bkero, panda, sshnaidm, trown and weshay (in alphabetical order) who all worked a lot in the past months to make this happen.
14:25:08 <adarazs> We hope the transition will be smooth, but if you notice problems with the new jobs (they have -oooq suffix) ping either of them or me for help on #tripleo or #oooq.
14:25:11 <EmilienM> wouhouu
14:25:17 <EmilienM> let's celebrate when it's voting :P
14:25:17 <adarazs> We'll continue with more jobs (the OVB ones) next week. :)
14:25:48 <adarazs> That's it, unless you have any question about it. :)
14:25:53 <EmilienM> adarazs: do you want this patch to land today?
14:25:58 <EmilienM> adarazs: are we ready ready ready?
14:26:05 <adarazs> EmilienM: yes, go ahead!
14:26:10 <adarazs> we're ready :)
14:26:13 <weshay> +1 guys, well done
14:26:14 <EmilienM> ok I'll poke infra folks
14:26:15 <trown> EmilienM: ideally so we have the whole week to fix any issues
14:26:28 <trown> EmilienM: ie lets not merge it Thurs/Fri
14:26:54 <EmilienM> trown: yes +1
14:26:59 <EmilienM> trown: wait, i'll call you this weekend
14:27:03 <EmilienM> I think I still have your number
14:27:07 <trown> lol
14:27:09 <weshay> in other news.. FYI.. rdo-cloud is in beta atm and may be moving to production shortly
14:27:42 <EmilienM> do we have any other oustanding info about CI work in TripleO this week?
14:28:05 <weshay> we are testing rdo-cloud atm
14:28:18 <EmilienM> that's where OVB jobs will run, right?
14:28:22 <weshay> aye
14:28:22 <trown> I think that is it, all focus has been on transitioning jobs
14:28:24 <sshnaidm> everything is green beside of mitaka
14:28:41 <EmilienM> what happens with Mitaka? I haven't looked yet
14:28:53 <EmilienM> (btw, Mitaka is EOL next month)
14:29:11 <sshnaidm> EmilienM, undercloud installation fails, docker registry issue, didn't look deeper too..
14:29:21 <mwhahaha> probably need to backport that docker fix
14:29:22 <EmilienM> we have docker registry on mitaka?
14:29:28 <weshay> oh.. did that patch not get backported?
14:29:35 <mwhahaha> probably not upstream mitaka
14:29:38 <EmilienM> which patch?
14:29:43 * weshay looks
14:29:52 <mwhahaha> jfyi instack-undercloud pep8 is broken Bug 1672730
14:29:52 <openstack> bug 1672730 in tripleo "instack-undercloud pep8 failures due to broken dib-lint" [Critical,Confirmed] https://launchpad.net/bugs/1672730
14:30:03 <mwhahaha> the switch to docker profile
14:30:04 <EmilienM> oh that's a new one
14:30:18 <EmilienM> mwhahaha: why did we backport this thing in Mitaka?
14:30:24 <mwhahaha> i think we did downstream
14:30:27 * mwhahaha would have to look
14:30:40 <EmilienM> dprince, mandre ^ thoughts?
14:31:00 <mwhahaha> https://review.openstack.org/#/q/I89e14cc2a27299ce4c191d2a823deb0424693831,n,z
14:31:05 <mwhahaha> it only went back to newton
14:31:37 <EmilienM> mwhahaha: I'm confused
14:31:40 <dprince> EmilienM: backporting is fine w/ me
14:31:49 <EmilienM> dprince: not for me
14:31:56 <mwhahaha> docker packaging changed
14:31:56 <EmilienM> why would we backport that thing into mitakaA?
14:32:06 <EmilienM> ah, so it's a bugfix, not a feature
14:32:10 <weshay> aye
14:32:18 <mwhahaha> yea not a feature
14:32:19 <EmilienM> can someone take care of the backports?
14:32:48 <dprince> EmilienM: sorry, backporting the bugfix was what I thought you were proposing. Definately not keen on backporting the feature
14:33:05 <EmilienM> dprince: can you backport it? it sounds good to me in fact
14:33:22 <mwhahaha> we backported the profile switch because it handled the package change correctly
14:33:24 <EmilienM> so we can bring back the Mitaka jobs asap
14:33:35 <EmilienM> mwhahaha: sounds good
14:34:14 <mandre> EmilienM: I can take care of the backports
14:34:18 <EmilienM> mandre: ah. thanks.
14:34:20 <EmilienM> moving now
14:34:32 <EmilienM> anything else about CI before we go to next topic?
14:34:40 <yolanda> i wanted to comment about diskimage-builder
14:34:52 <EmilienM> yolanda: is it CI related?
14:34:52 <yolanda> so things were broken with the v2 merge, and tests were not catching it
14:34:55 <yolanda> yes
14:34:58 <EmilienM> ok then
14:35:09 <EmilienM> (I thought it would be related to the move of the project)
14:35:09 <yolanda> i think we shall improve coverage on dib-tripleo integration
14:35:35 <yolanda> maye creating some new job that tests that properly? seems that the instack-dib integration was not covered
14:35:37 <EmilienM> yolanda: yes it sounds like a good idea. Do you know folks who could work on it?
14:35:45 <yolanda> myself i guess? :)
14:36:05 <EmilienM> we could have a non-voting job for starting, that runs the instack-dib
14:36:07 <yolanda> i need to raise with dib cores, but i think they will suppor tthe idea
14:36:12 <EmilienM> and if it works, we can move it to voting
14:36:40 <yolanda> ++
14:36:41 <EmilienM> yolanda: I like the idea of having more tests for this project
14:36:58 <EmilienM> yolanda: let us know how we can help though
14:37:29 <EmilienM> anything else about CI this week?
14:37:30 <yolanda> EmilienM, i'll need reviews for sure
14:37:43 <EmilienM> yolanda: sure, feel free to use ML to give updates
14:37:59 <EmilienM> #topic specs
14:38:04 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:38:25 <EmilienM> we didn't merge any spec in Pike yet, it would be great to merge them before pike-1
14:38:36 <EmilienM> some of them have been well reviewed and things are moving
14:38:44 <EmilienM> I would ask our reviewers to look again and vote
14:39:00 <EmilienM> I asked Container Squad to look at this one: https://review.openstack.org/#/c/387631/ and bless it before we move forward
14:39:16 <fultonj> thanks
14:39:42 <EmilienM> fultonj: I didn't +2 because I want container folks to look before
14:39:49 <EmilienM> fultonj: but you addressed my comments quite well
14:39:57 <fultonj> makes sense. cool
14:41:03 <EmilienM> so again, it would be great to 1. people who own specs to address comments asap and 2. reviewers to give feedback on specs and vote
14:41:29 <EmilienM> some of them like https://review.openstack.org/#/c/420878/ are without activity for a week (ping arxcruz)
14:41:54 <EmilienM> any question or comment about specs?
14:42:00 <arxcruz> EmilienM: we are re-thinking it
14:42:09 <arxcruz> I need to update, I'll until the end of the day
14:42:22 <EmilienM> Pike-1 is Apr 10 - Apr 14 week so we have ~1 month to merge our specs for Pike
14:42:28 <EmilienM> any feedback about ^ ?
14:42:29 <arxcruz> EmilienM: got it
14:43:00 <arxcruz> EmilienM: I'll update today, and ensure that will be merged asap
14:43:09 <EmilienM> cool, same for other specs
14:43:11 <EmilienM> #topic open discussion
14:43:20 <EmilienM> I wanted to chat a bit about DIB
14:43:23 <EmilienM> yolanda ^
14:43:32 <yolanda> sure
14:43:42 <EmilienM> the thread about moving the project out of TripleO
14:44:04 <EmilienM> http://lists.openstack.org/pipermail/openstack-dev/2017-January/110033.html
14:44:14 <EmilienM> pabelanger: ^
14:44:55 <EmilienM> Except slagle and bnemec, we haven't got much feedback from TripleO team
14:45:03 <EmilienM> I guess it's a good sign for us to move this project out
14:45:13 <yolanda> from my side, either being under the scope of infra, or being an independent project, is good
14:45:15 <bnemec> I think I said that the last time we talked about this. :-)
14:45:21 <shardy> Yeah I think it makes sense, and there was a previous thread which reached the same conclusion IIRC
14:45:23 <yolanda> if that moves under the infra umbrella, it will gane some more cores
14:45:28 <EmilienM> if there is no complain here, I'll move forward and engage the next steps with DIB cores
14:45:37 <bnemec> +1
14:45:52 <EmilienM> yolanda: if fungi and his group are OK with it, it's cool
14:46:15 <EmilienM> i'll follow-up on the thread then
14:46:33 <EmilienM> #action EmilienM to follow-up on DIB thread and propose the change in Governance
14:46:58 <EmilienM> do we have anything else to discuss this week? Any feedback or question?
14:47:47 <EmilienM> thanks everyone!
14:47:57 <EmilienM> let's go back to work and have fun!
14:47:59 <EmilienM> #endmeeting