14:00:10 <EmilienM> #startmeeting tripleo
14:00:11 <openstack> Meeting started Tue Feb 28 14:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'tripleo'
14:00:16 <EmilienM> #topic agenda
14:00:22 <EmilienM> * review past action items
14:00:24 <EmilienM> * one off agenda items
14:00:26 <EmilienM> * bugs
14:00:28 <EmilienM> * Projects releases or stable backports
14:00:30 <EmilienM> * CI
14:00:32 <EmilienM> * Specs
14:00:34 <EmilienM> * Week roadmap
14:00:36 <EmilienM> * open discussion
14:00:38 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:40 <EmilienM> Hi everyone! who is around today?
14:00:42 <mwhahaha> o/
14:01:04 <sshnaidm> o/
14:01:06 <shardy> o/
14:01:07 <jtomasek> ~o~
14:01:29 <ccamacho> hi!
14:01:31 <jpich> o/
14:02:04 <EmilienM> ok let's start
14:02:08 <matbu> o/
14:02:10 <EmilienM> #topic review past action items
14:02:16 <EmilienM> upgrade squad to move remaining work in bugs instead of blueprint: done
14:02:19 <EmilienM> EmilienM to propose RC1 by end of this week (postponed): done & released
14:02:25 <trown> o/
14:02:26 <EmilienM> EmilienM to propose a Python3 session & invite RDO folks: done (at PTG)
14:02:27 <gfidente> o/
14:02:30 <EmilienM> High - team to work on last Critical / High bugs for ocata-rc1: done. focus is now on ocata-rc2
14:02:35 <EmilienM> Medium - Pike planning - prepare specs, prepare PTG: done.
14:02:39 <EmilienM> and
14:02:41 <EmilienM> EmilienM to reply to Heidi and ask Design team to re-propose a new logo that would be a variation on the current logo that moves closer to the foundation themes: done. We're waiting for OpenStack foundation now.
14:02:50 <EmilienM> #topic one off agenda items
14:02:53 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:06 <EmilienM> no one off items this week?
14:03:17 <gfidente> we had so many last week at the ptg
14:03:26 <gfidente> :)
14:03:27 <EmilienM> true, let's move on
14:03:32 <EmilienM> #topic bugs
14:03:35 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-rc2
14:03:49 <EmilienM> is there any particular bug we need to discuss this week?
14:03:57 <adarazs> o/
14:04:18 <weshay> o/
14:04:38 <EmilienM> seems like no
14:04:41 <bandini> o/
14:04:51 <EmilienM> we still have 28 Triaged, 33 In Progress for ocata-2
14:04:55 <EmilienM> err, ocata-rc2
14:05:16 <beagles> o/
14:05:33 <EmilienM> it seems like a lot, but I guess most of them will move to pike-1 soon
14:05:53 <jrist> o/
14:06:03 <EmilienM> moving on
14:06:04 <EmilienM> #topic projects releases or stable backports
14:06:13 <EmilienM> #info Essential release blocker: composable upgrades
14:06:20 <EmilienM> #action EmilienM to propose RC2 by end of next week
14:06:47 <EmilienM> quick reminder: since we haven't released final ocata, don't miss backports to stable/ocata
14:07:01 <fultonj> o/
14:07:49 <EmilienM> can someone give an update on remaining blockers for upgrades from newton to ocata?
14:08:18 * EmilienM will give an update about CI jobs for upgrades in the CI topic
14:08:54 <ccamacho> EmilienM I think there are no blockers, just submissions to check, from your last week email add the pending tasks
14:09:08 <EmilienM> ccamacho: ok thanks
14:09:11 <ccamacho> for the pending services upgrades
14:09:16 <shardy> chem or marios can probably help identify blockers, but we landed the nova fixes so I think we're pretty close now
14:09:20 <bandini> not sure about the complete picture (chem would know I guess), I filed https://bugs.launchpad.net/tripleo/+bug/1668600 and https://bugs.launchpad.net/tripleo/+bug/1668372 which I think are pretty serious
14:09:20 <openstack> Launchpad bug 1668600 in tripleo "N-O upgrades rabbitmq has the wrong ha policy" [High,Triaged]
14:09:21 <openstack> Launchpad bug 1668372 in tripleo "N-O upgrades do not wait for galera to be fully up" [Critical,In progress] - Assigned to Michele Baldessari (michele)
14:09:36 <bandini> am working no both atm
14:09:40 <bandini> *on both*
14:09:43 <shardy> EmilienM: I think at this point we'll have to go ahead with rc2 and deal with any remaining issues as bugfix backports
14:09:53 <bandini> shardy: ack
14:10:04 <EmilienM> shardy: trailing release allows us to release in ~10 days
14:10:28 <EmilienM> bandini: can you update 1668600 to be assigned to you and change it from high to critical please
14:10:42 <bandini> sure
14:10:57 <marios> EmilienM: sry am late was distracted in another chan shardy ack yes
14:11:01 <EmilienM> shardy: but indeed, I'll probably propose a release early next week and we'll deal with backports
14:11:05 <marios> shardy: i mean to being close
14:11:31 <EmilienM> anything else about release management?
14:11:33 <marios> shardy: we (mcornea me and others) got clean local runs through the nova services on pacemaker env and ansible tasks + puppet config cleanly applied
14:11:46 <user`> bandini: upgrade task for pacemaker are non existant that may be the problem.  I'm investigating it.
14:11:49 <EmilienM> marios: it would be great to also validate things in upstream CI
14:11:56 <user`> bandini: upgrade task for pacemaker *services* are non existant that may be the problem.  I'm investigating it.
14:12:00 <shardy> marios: ack thanks for the update, that's good news :)
14:12:44 <marios> EmilienM: also may be relevant to point out some docs we landed too wrt the upgrades at https://docs.openstack.org/developer/tripleo-docs/post_deployment/upgrade.html#upgrading-the-overcloud-to-ocata-and-beyond
14:12:54 <EmilienM> chem: also, ccamacho and I discussed before the meeting about https://review.openstack.org/#/c/438090/ - we think httpd should be stopped at step 1
14:12:55 <marios> EmilienM: may help if someone wants to jump in for any remaining tasks/services
14:12:56 <bandini> chem: yeah one issue is that we do not wait for galera to be settled down (pathces are up) and the other one I need to test a fix for
14:13:03 <bandini> marios: nice!
14:13:11 <EmilienM> marios: sure. thanks
14:13:39 <EmilienM> chem: please follow-up in the review when you can, so we can move forward with this one.
14:13:56 <chem> EmilienM: doing
14:14:05 <EmilienM> anything else about releases? before we go to next topic
14:14:23 <EmilienM> #topic CI
14:14:41 <EmilienM> sshank: can you please give an update on oooq transition (blockers, etc)
14:14:46 <EmilienM> sshnaidm: ^
14:15:03 <weshay> adarazs, ^
14:15:07 <sshnaidm> EmilienM, I think adarazs can do it
14:15:18 <sshnaidm> he's our liason :)
14:15:18 <adarazs> okay :)
14:15:32 <adarazs> so, there are no real blockers, but there are quite a few items we are working on.
14:15:48 <adarazs> you can see it on the RDO Infra board (we will transition to the CI Squad board after the transition)
14:16:06 <adarazs> I sent an email with the links about the outstanding work items this morning to the openstack-dev list.
14:16:19 <weshay> https://trello.com/b/HhXlqdiu/rdo?menu=filter&filter=label:oooq%20phase%201%20transition
14:16:26 <adarazs> thanks for the link.
14:16:28 <EmilienM> quick update on upgrade jobs CI (cc marios, matbu, chem, shardy, ccamacho) : 1) we enabled pacemaker on all scenarios to increase testing coverage. 2) scenario have now in check-nv pipeline the upgrade jobs (not passing yet)
14:16:39 <adarazs> but I think it looks promising and we will be able to transition at the end of the cycle.
14:16:58 <EmilienM> quick question for oooq transition, I just realized that we need to make sure to have multinode upgrade jobs support. Is it in the list?
14:16:58 <matbu> EmilienM: cool
14:17:03 <adarazs> so yeah, announcement here: we're planning to transition at or close to 10th of March!
14:17:39 <adarazs> EmilienM: yes, there are 2 outstanding changes for quickstart that are supporting it, rlandy and matbu are working on it and I'm reviewing them.
14:17:46 <EmilienM> adarazs: excellent
14:18:00 <adarazs> EmilienM: hopefully when these are submitted we have a clear path for working upgrade jobs with quickstart.
14:18:12 <EmilienM> so I'm working on upgrade CI jobs this week, helping the upgrade squad to move forward. Any help is really welcome.
14:18:30 <weshay> EmilienM, we have to test upgrades w/ multinode so we'll also be pulling in bkero to help there
14:18:59 <EmilienM> weshay: in oooq multinode upgrades you mean?
14:19:03 <weshay> aye
14:19:15 <matbu> EmilienM: which help do you need exactly ?
14:19:19 <adarazs> yeah, that's a missing piece, even if upgrades will start working in general.
14:19:19 <EmilienM> yes but before that we need to make upgrades working and that's why I'm asking for help
14:19:29 <weshay> k
14:19:40 <EmilienM> matbu: make upgrades actually working. They are failing now (I think I tracked all bugs but not sure what's next)
14:19:57 <matbu> EmilienM: the CI job is failling ?
14:20:04 <EmilienM> jobS
14:20:16 <EmilienM> we have 4 upgrade jobs now and yes, the scenarios are failing
14:20:29 <EmilienM> I think https://review.openstack.org/#/c/438657/ will solve it
14:20:40 <matbu> EmilienM: k i can help you to debug if you want
14:20:42 <EmilienM> but it depends on a revert in puppet-tripleo
14:21:10 <EmilienM> matbu: I need help in moving forward with the 3 scenarios. I'll let you know today how jobs work after the revert lands
14:21:35 <matbu> EmilienM: k
14:21:53 <EmilienM> we really need to invest more in these upstream CI jobs
14:22:17 <EmilienM> not sure we can set them voting once they pass green though
14:22:20 <matbu> EmilienM: +1 that's really helpful
14:22:36 <matbu> EmilienM: i think it would be nice to hva it voting
14:22:38 <EmilienM> if we make them voting, I think we'll really need to add them to the promotion pipeline
14:22:42 <weshay> +1 to voting
14:22:50 <EmilienM> matbu, weshay: that's not that easy tbh
14:23:02 <matbu> EmilienM: the previous one (before my ptos) was really stable and catched real issues
14:23:26 <EmilienM> the only way to not break CI every morning is to add them to promotion pipeline
14:23:51 <EmilienM> we can take it offline
14:23:56 <EmilienM> anything else about CI this week?
14:24:18 <EmilienM> #topic specs
14:24:21 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:24:51 <EmilienM> #action team to make progress on reviewing Pike specs
14:25:36 <EmilienM> anyone wants to discuss about a spec?
14:25:50 <EmilienM> it would be great to review all specs before pike-1
14:25:54 <jrist> honza: ^ ?
14:25:58 <jrist> +1
14:26:19 <EmilienM> #topic week roadmap
14:26:41 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-rc2
14:26:51 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:27:05 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-1
14:27:38 <EmilienM> also, some of you presented some work at PTG, please create blueprints as soon as you can
14:28:09 <EmilienM> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112995.html
14:28:12 <EmilienM> summary of PTG ^
14:28:36 <EmilienM> anything else we should pay attention this week?
14:29:03 <EmilienM> #topic open discussion
14:29:15 <EmilienM> if you have any question or feedback, it's time :)
14:29:42 <shardy> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112960.html
14:29:56 <shardy> I started a thread as a follow-up to the cross project discussions at the PTG last week
14:30:17 <shardy> any feedback welcome, the idea is we try to keep the cross team discussion going between the f2f events
14:30:23 <shardy> and hopefully over time collaborate more
14:30:36 <EmilienM> excellent
14:31:08 <EmilienM> on short term, bnemec and I want to write a spec in oslo.config
14:31:32 <EmilienM> any other topic before I close the meeting?
14:31:47 <EmilienM> thanks everyone!
14:31:49 <EmilienM> #endmeeting