14:00:05 <EmilienM> #startmeeting tripleo
14:00:10 <openstack> Meeting started Tue Feb  7 14:00:05 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'tripleo'
14:00:15 <EmilienM> #topic agenda
14:00:16 <EmilienM> * review past action items
14:00:18 <EmilienM> * one off agenda items
14:00:20 <EmilienM> * bugs
14:00:22 <EmilienM> * Projects releases or stable backports
14:00:24 <EmilienM> * CI
14:00:26 <EmilienM> * Specs
14:00:28 <EmilienM> * Week roadmap
14:00:30 <EmilienM> * open discussion
14:00:32 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:34 <EmilienM> Hi everyone! who is around today?
14:00:39 <beagles> o/
14:00:39 <michapma_alt> o/
14:00:40 <fultonj> o/
14:00:41 <jpich> o/
14:00:41 <mwhahaha> o/
14:00:43 <trown> o/
14:00:44 <radez> o/
14:00:45 <marios> o/
14:00:47 <karthiks> o/
14:00:48 <jtomasek> o/
14:00:50 <matbu_> o/
14:00:56 <ccamacho> \o
14:01:13 <EmilienM> we have a long agenda today, let's get started
14:01:25 <EmilienM> #topic review past action items
14:01:29 <EmilienM> Team to move Low/Medium/Wishlist from ocata-rc1 to pike-1: done
14:01:32 <EmilienM> EmilienM to add 'week roadmap' to next meeting agenda: done
14:01:36 <EmilienM> TripleO core reviewers to block new features in TripleO unless FFE has been granted.: done
14:01:39 <EmilienM> EmilienM to work on TripleO RC1 schedule and propose it on openstack-dev: done
14:01:43 <EmilienM> EmilienM to move remaining blueprints to pike-1 when needed: done
14:01:46 <EmilienM> EmilienM sends a reminder about FFE / RC1 policy on openstack-dev: done
14:01:50 <EmilienM> panda to email openstack-dev about quickstart & tripleo-ci changes: done
14:02:04 <slagle> is there a list/etherpad of the granted ffe's?
14:02:20 <slagle> i lost track of what had been granted last week
14:02:24 <EmilienM> slagle: no, and I'll create it right after the meeting
14:02:37 <EmilienM> #action EmilienM to create etherpad with list of granted FFE for ocata
14:02:59 <EmilienM> slagle: though I prepare some discussion for the FFE later in the meeting, and list all of them
14:03:06 <EmilienM> prepared*
14:03:11 <EmilienM> #topic one off agenda items
14:03:13 <slagle> thanks!
14:03:14 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:16 <EmilienM> gfidente: o/
14:03:44 <gfidente> o/
14:03:45 <EmilienM> gfidente: you wanted to chat about ceph/hci
14:03:58 <dprince> hi
14:04:03 <sshnaidm> o/
14:04:07 <gfidente> yep, we have that implemented in the code from a while, trying to bring it into CI though we need to provision the storagemgmt network on the compute nodes
14:04:39 <EmilienM> gfidente: at that point, not sure we can have it for ocata cycle
14:04:42 <adarazs> o/
14:05:02 <gfidente> yeah that was the point of the item in the pad, it's not really stopped on code changes, but on infra changes
14:05:51 <EmilienM> gfidente: what do you need to discuss exactly?
14:06:18 <gfidente> if we're of the idea of blocking it and skip hci testing in newton
14:06:37 <EmilienM> I don't think we should add HCI for newton testing
14:06:50 <EmilienM> Newton CI jobs are considered stable, let's keep them stable
14:07:07 <EmilienM> I would rather move forward to make it work in Pike
14:07:17 <EmilienM> and stabilize it during the next cycle
14:07:26 <gfidente> again, it's not hci we are working on, it's infra
14:07:37 <gfidente> so we don't need to make it stable, we need to setup infra appropriately
14:07:38 <EmilienM> yes, I understand
14:07:54 <EmilienM> I'm just worried about changing how infra works for stable jobs
14:08:20 <EmilienM> any thoughts?
14:09:10 <EmilienM> gfidente: sounds like very few feedback here. Do you mind following-up later on #tripleo?
14:09:19 <gfidente> nope, good idea, thanks
14:09:26 <EmilienM> gfidente: thx
14:09:41 <EmilienM> any other item for this week?
14:09:51 <weshay> o/
14:10:13 <EmilienM> ok next topic
14:10:19 <EmilienM> #topic bugs
14:10:22 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-rc1
14:10:39 <EmilienM> before we jump into Ocata release blockers & CI. Do we have other outstanding bug we need to discuss?
14:11:34 <EmilienM> ok I'll go to the next topic, we have plenty of things to discuss
14:11:39 <EmilienM> #topic projects releases or stable backports
14:11:45 <EmilienM> #info Essential release blocker: composable upgrades
14:11:55 <EmilienM> matbu_, marios: can you summarize progress & blockers please?
14:12:26 <matbu_> EmilienM: yep
14:12:33 <EmilienM> matbu_: please go ahead
14:12:43 <matbu_> EmilienM: so marios feel free to correct if i'm wrong
14:12:58 <marios> EmilienM: sure, matbu ack
14:13:09 <matbu_> EmilienM: so currently most of the work has been done, we are at the stage where we are trying to figure out every reviews
14:13:29 <marios> matbu: EmilienM: https://review.openstack.org/#/q/topic:bp/overcloud-upgrades-per-service and https://review.openstack.org/#/q/topic:bp/overcloud-updates-per-service_fixup are the relevant topic branches
14:13:29 <matbu_> a bunch of them needs to be reviewed and probably landed
14:13:42 <EmilienM> marios: I was about asking for it, thx
14:14:10 <marios> matbu_: EmilienM: as matbu says these are for the basic workflow .. these should be landed this week (matbu mcornea and me are testingt his today, ccamacho is also starting to help)
14:14:39 <EmilienM> is there any blocker you need to inform us?
14:15:01 <EmilienM> #action team to review https://review.openstack.org/#/q/topic:bp/overcloud-upgrades-per-service and https://review.openstack.org/#/q/topic:bp/overcloud-updates-per-service_fixup
14:15:09 <matbu_> so i think except the little nits and probable bugs hidden, the most tricky part was the nova upgrade review
14:15:21 <EmilienM> ok
14:15:25 <marios> EmilienM: i know we are still having to do all sorts of workarounds for the nova upgrade like the cells stuff... see https://review.openstack.org/#/c/405241/30/puppet/services/nova-api.yaml
14:15:36 <EmilienM> (on my side, I made little progress on scenarios/upgrade CI job, FYI)
14:15:38 <marios> EmilienM: but they are actively being worked on owalsh i know is helping lots there
14:15:48 <EmilienM> marios: excellent.
14:16:03 <EmilienM> #info major blocker for upgrades are need for review & nova cells
14:16:07 <EmilienM> is that correct? ^
14:16:17 <matbu_> EmilienM: ack, btw i tried to update de CI in regards of the coming merged review (pacemaker and nova)
14:16:34 <marios> EmilienM: sounds right sure i miss some more :) but yeah that would be a great start!
14:16:49 <EmilienM> marios: ok thx
14:17:11 <EmilienM> marios, matbu_: thanks. Anything else we need to know?
14:17:29 <ccamacho> hey marios FYI Im hitting also "ERROR: The specified reference "ControllerUpgradeBatch_Step2" (in ControllerUpgradeConfig_Step0) is incorrect. Im debugging it right now
14:17:41 <marios> ccamacho: cool lets continue in chan
14:18:00 <EmilienM> ok, sounds like we can move forward
14:18:09 <EmilienM> #info Critical release blocker: nova cells v2 https://bugs.launchpad.net/tripleo/+bug/1662344
14:18:09 <openstack> Launchpad bug 1662344 in tripleo "(HA) mysql bind_address param is not compatible with nova cell_v2" [Critical,In progress] - Assigned to Oliver Walsh (owalsh)
14:18:09 <EmilienM> #info Critical release blocker: nova is pin to ocata-3 in RDO. Trunk is still not working
14:18:10 <matbu_> ccamacho: im debuging it also
14:18:11 <EmilienM> #info Critical release blocker: nova/wsgi needs to be disabled, fix: https://review.openstack.org/#/c/428778/ (waiting for CI and dependency to merge)
14:18:17 <matbu_> ccamacho: i think i know what happen
14:18:55 <EmilienM> owalsh: I don't think we need much discussion, damien & bandini are not connected here. let's catchup after this meeting
14:19:08 <matbu_> ccamacho: im just taking forever to redeploy my current env :(((
14:19:18 <owalsh> EmilienM: ack
14:19:21 <EmilienM> matbu_: please keep debug for #tripleo ;)
14:19:28 <ccamacho> matbu_ cool Ill ping you on #tripleo
14:19:30 <ccamacho> ack
14:19:32 <EmilienM> thx folks
14:19:55 <EmilienM> #action owalsh / EmilienM to work together on short term solutions for nova blockers
14:19:57 <matbu_> EmilienM: yep sorry
14:20:03 <EmilienM> #info High release blocker: FFE Contrail is waiting for patchset from Juniper on https://review.openstack.org/425717
14:20:19 <EmilienM> I talked with the author and he's going to push on it today if not done already
14:20:24 <EmilienM> #info Medium release blocker: FFE: Dell is waiting for CI to pass https://review.openstack.org/#/c/425861/
14:20:41 <EmilienM> this one should land today if CI is passing correctly
14:20:49 <EmilienM> #info Medium release blocker: FFE: Scale-IO https://review.openstack.org/#/c/422238/ - need more work
14:21:04 <EmilienM> I see a risk on this one, it might slip to Pike.
14:21:15 <gfidente> EmilienM me too on that one
14:21:30 <EmilienM> gfidente: I emailed Dell, I'll double check later with them on this one :-/
14:21:36 <EmilienM> #info Medium release blocker: FFE: Collectd: need CI to pass + review on https://review.openstack.org/#/c/411048/ and https://review.openstack.org/#/c/427802/
14:21:41 <gfidente> eventually I can pickup the puppet-tripleo part
14:21:53 * jrist late
14:21:54 <jrist> o/
14:22:00 <EmilienM> lars has been doing excellent work on it, let's help him by reviewing the patches
14:22:14 <EmilienM> gfidente: ok, thx, let's sync on it later today
14:22:39 <EmilienM> #action gfidente / EmilienM to help Dell to get Scale-IO on time for ocata https://review.openstack.org/#/c/422238/
14:22:51 <EmilienM> #info Medium release blocker: FFE: Congress
14:22:57 <EmilienM> radez: o/
14:23:08 <radez> yup
14:23:14 <radez> Congress package spec has been merged and currently waiting on the under-review flag to be dropped so the package can be built and promoted.
14:23:26 <radez> Puppet module and THT patch are written and waiting for the package to be promoted to complete the CI testing.
14:23:27 <EmilienM> what patches in THT need to be reviewed?
14:23:39 <radez> https://review.openstack.org/#/c/330050/
14:23:53 <radez> but currrent status is that it fails on installing the package
14:23:54 <EmilienM> we got promotion last night
14:23:59 <EmilienM> please do recheck now
14:24:08 <radez> congress still has the under-review flag on it
14:24:14 <EmilienM> ah right sorry
14:24:16 <radez> so as soon as that's dropped...
14:24:22 <EmilienM> yeah
14:24:24 <radez> so it's moving along :)
14:24:25 <EmilienM> radez: any ETA?
14:24:43 <radez> still lots of variables... hope would be by eotw?
14:24:49 <EmilienM> I hope so
14:24:58 <EmilienM> radez: let's target Thursday max
14:25:00 <radez> if things keep moving along and don't hit snags I think that's doable
14:25:13 <radez> ack, it's top prio with tacker for me right now
14:25:14 <EmilienM> I'm in a room with RDO folks, i'll lock them :P
14:25:20 <beagles> lol
14:25:22 <radez> +2
14:25:30 <EmilienM> #info Medium release blocker: FFE: Tacker
14:25:36 <EmilienM> radez: ^ same question. Where are we?
14:25:38 <radez> Tacker has packaging and puppet module with acceptance test completed
14:25:42 <radez> There were updates that needed to be made to the packaging that were corrected and promoted as of late yesterday.
14:25:47 <radez> THT patch with tacker in ci scenario001 is currently running in CI.
14:25:52 <radez> My hope is to complete the tacker THT stuff today.
14:26:03 <radez> https://review.openstack.org/#/c/424135/
14:26:03 <EmilienM> radez: link?
14:26:22 <EmilienM> ok
14:26:28 <radez> just waiting on scenario001 to complete to see where we are
14:26:39 <EmilienM> radez: let's sync later today or tomorrow to see how things evolve
14:26:51 <radez> since the puppet acceptance test pasts I would hope we're close
14:26:56 <EmilienM> yeah
14:26:57 <radez> EmilienM: sure will, I'll keep you updated
14:26:59 <EmilienM> radez: thx for updates & details
14:27:12 <EmilienM> #info Medium release blocker: FFE: Octavia
14:27:14 <EmilienM> beagles: o/
14:27:17 <beagles> hi
14:27:44 <beagles> so the patches that are up there need to be rechecked, but I don't expect to have more mods on those except to review feedback
14:28:02 <EmilienM> do you have a gerrit topic or links handy?
14:28:15 <beagles> there is one patch remaining that should be up tonight or early tomorrow that is more of a user helper kind of thing for post deployment
14:28:16 <EmilienM> beagles: no blocker except reviews?
14:28:28 <beagles> https://review.openstack.org/#/q/topic:bp/octavia-service-integration
14:28:47 <EmilienM> beagles: otherwise we can do post deployment in Pike. I don't think it's critical. Worst case, we document it for Ocata and automate it for Pike.
14:28:57 <EmilienM> #action team to review https://review.openstack.org/#/q/topic:bp/octavia-service-integration
14:29:05 <beagles> EmilienM: for this cycle's objectives mainly yeah
14:29:24 <beagles> EmilienM: exactly (re: worse case scenario)
14:29:27 <EmilienM> beagles: anything else?
14:29:33 <beagles> EmilienM: nope that's it
14:29:56 <EmilienM> I skipped the novajoin blueprint because Juan is not online, I'll double check with him but I think we're moving it to Pike at this point.
14:29:57 <EmilienM> #action EmilienM to propose RC1 by end of this week if possible or next week.
14:29:59 <EmilienM> #link Ocata release patch https://review.openstack.org/#/c/428416/
14:30:11 <EmilienM> any feedback, question about release management?
14:30:55 <EmilienM> #action EmilienM to double check about novajoin blueprint & ffe status
14:31:01 <EmilienM> #topic CI
14:31:28 <EmilienM> sshnaidm, bnemec: any useful infos this week?
14:31:40 <EmilienM> https://bugs.launchpad.net/tripleo/+bug/1662521
14:31:40 <openstack> Launchpad bug 1662521 in tripleo "CI: not enough space on mirror-server" [High,Triaged]
14:31:46 <sshnaidm> we had problem with space on mirror-server
14:32:03 <EmilienM> yeah we need a script/cron that cleanup for us
14:32:09 <EmilienM> is it an option to get more storage?
14:32:25 <sshnaidm> right now it's solved, and patch is proposed: https://review.openstack.org/#/c/430257/
14:32:37 <sshnaidm> EmilienM, I think yes, need to talk to bnemec
14:32:58 <sshnaidm> EmilienM, it's just a vm, we can assign it much more
14:33:01 <EmilienM> sshnaidm: lgtm except my little comment
14:33:22 <EmilienM> sshnaidm: +1 for more space
14:33:24 <sshnaidm> another question is - do we need to save stable branch images and use them (we save now, but don't use)
14:33:53 <sshnaidm> we build images in each stable branch job
14:34:14 <sshnaidm> so.. if we use the saved ones, it'll reduce time of stable branch job
14:34:16 <EmilienM> if we build at each runtime, let's cleanup old images
14:34:37 <EmilienM> but yes, it would save job runtime if we used the saved ones
14:35:09 <EmilienM> on short term, let's cleanup old images (even stable) and keep only one per release
14:35:14 <sshnaidm> EmilienM, ok, then I have some patch for it too, starting: https://review.openstack.org/#/c/429782/
14:35:29 <EmilienM> and probably on long term switch our stable Ci jobs to use saved images
14:35:34 <EmilienM> sshnaidm: excellent
14:35:37 <sshnaidm> EmilienM, ok
14:35:55 <EmilienM> sshnaidm: let's make sure we include bnemec & other folks in the discussion
14:35:55 <sshnaidm> I think that's it
14:35:59 <EmilienM> sshnaidm: thx
14:36:12 <EmilienM> sshnaidm, bkero, adarazs: anything about quickstart we need to discuss this week?
14:36:25 <EmilienM> weshay: ^
14:37:22 <sshnaidm> EmilienM, ooooq ha job failing, I'm working on this right now
14:37:29 <EmilienM> ok sounds like folks got distracted (/me watching them in the room)
14:37:38 <EmilienM> sshnaidm: ack, let us know if we can review something
14:37:44 <sshnaidm> sure
14:37:56 <EmilienM> anything else about CI this week?
14:38:18 <adarazs> EmilienM: I don't think there's much to discuss. we have a quite a few outstanding cards that we should implement to replace the upstream jobs completely :)
14:38:36 <EmilienM> adarazs: cool, and reports on openstack-dev are very useful, thx
14:38:43 <adarazs> EmilienM: np!
14:38:50 <EmilienM> #topic specs
14:38:53 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:39:26 <EmilienM> if you're working on a spec for Pike and you're attending PTG, feel free to propose a session on https://etherpad.openstack.org/p/tripleo-ptg-pike
14:39:51 <karthiks> We (Myself and skramaja) have raised 2 blueprints for pike.
14:39:54 <karthiks> 1. https://blueprints.launchpad.net/tripleo/+spec/ovs-2.6-dpdk -> To handle the DPDK related changes in TripleO for OVS 2.6 migration
14:40:01 <karthiks> 2. https://blueprints.launchpad.net/tripleo/+spec/ovs-2.6-features-dpdk -> To support Jumbo frames and Multiqueue support in TripleO
14:40:09 <karthiks> We think the changes look small, but please review them and let us know if spec is required for the same.
14:40:18 <EmilienM> karthiks: do you plan to write a spec or just keep blueprints ?
14:40:27 <EmilienM> karthiks: ok you answered to my question
14:40:40 <EmilienM> #action team to look at ovs-2.6 blueprints and give feedback
14:40:42 <karthiks> skramaja will attend the PTG
14:40:58 <EmilienM> karthiks: I would announce it on openstack-dev [tripleo] so we can discuss about it on the ML
14:41:06 <EmilienM> karthiks: and figure if spec is required or not
14:41:14 <karthiks> EmilienM,  Thanks
14:41:34 <EmilienM> #action karthiks post on ML about ovs-2.6 blueprints and ask for feedback
14:41:59 <EmilienM> anything else about specs this week?
14:42:00 <karthiks> EmilienM, ack
14:42:19 <beagles> The final bits of octavia integration will need a spec I believe - the patch (or docs) I mentioned earlier will basically be pseudo code for the stuff
14:42:26 <beagles> that needs to be covered by the spec
14:42:48 <beagles> I'll follow the same steps as karthiks (mailing  list to start discussion, etc)
14:43:03 <EmilienM> beagles: make sure you mention what has been done in the spec, and what is remaining, etc
14:43:14 <beagles> EmilienM: right, will do
14:43:20 <EmilienM> beagles: it's important to use the spec if we need to discuss about design and a direction to take
14:43:22 <EmilienM> thanks
14:43:31 <EmilienM> #topic week roadmap
14:43:37 <EmilienM> #action High - team to work on Critical / High bugs for ocata-rc1
14:43:54 <EmilienM> link reminder (already posted before) https://launchpad.net/tripleo/+milestone/ocata-rc1
14:44:09 <EmilienM> #action Medium - team to finish features with granted FFE and help in review
14:44:16 <EmilienM> #action Low - Pike planning - prepare specs, prepare PTG
14:44:38 <EmilienM> is there any question about our short term roadmap?
14:44:43 <EmilienM> is there any doubt or concern?
14:45:09 <EmilienM> I'll open discussion
14:45:10 <EmilienM> #topic open discussion
14:45:31 <EmilienM> if you have any question / feedback and topic to bring, feel free now
14:46:26 * EmilienM will end the meeting in 30s
14:46:51 <EmilienM> thanks everyone, let's get back to work!
14:46:57 <EmilienM> #endmeeting