14:00:03 <EmilienM> #startmeeting tripleo
14:00:04 <openstack> Meeting started Tue Aug 16 14:00:03 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <beagles> bandini, hold on, he hasn't called roll yet :0
14:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'tripleo'
14:00:09 <EmilienM> #topic rollcall
14:00:11 <beagles> o/
14:00:13 <derekh> o/
14:00:14 <EmilienM> o/
14:00:15 <shadower> hey
14:00:16 <weshay> o/
14:00:17 <marios> o/
14:00:18 <skramaja> hello
14:00:18 <slagle> hi
14:00:19 <hrybacki> o/
14:00:20 <cdearborn> o/
14:00:29 <adarazs> o/
14:00:29 <bandini> o/
14:00:34 <bandini> beagles: :) ops
14:00:38 <ccamacho> hello again :P  o/
14:00:54 <EmilienM> #topic agenda
14:00:58 <sshnaidm> o/
14:01:03 <EmilienM> * one off agenda items
14:01:18 <EmilienM> * bugs
14:01:20 <EmilienM> * Projects releases or stable backports
14:01:22 <EmilienM> * CI
14:01:24 <EmilienM> * Specs
14:01:26 <EmilienM> * open discussion
14:01:29 <pabelanger> o/
14:01:39 <EmilienM> #topic one off agenda items
14:01:44 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:01:44 <d0ugal> o/
14:01:49 <EmilienM> d0ugal: hey, go ahead!
14:01:51 <karthiks> Hi
14:01:57 <d0ugal> EmilienM: Hey, thanks
14:01:58 <dprince> hi
14:02:14 <d0ugal> So I just wanted to give everyone a bit of an update on the status of the transition to Mistral for deployment.
14:02:30 <d0ugal> With the CLI patch here: https://review.openstack.org/#/c/342261/
14:02:44 <d0ugal> and the tripleo common series here: https://review.openstack.org/#/c/298732/
14:02:44 <radeks> o/
14:02:47 <d0ugal> We have it working!
14:02:56 <dprince> d0ugal: nice
14:03:00 <d0ugal> So, really looking for feedback on the approach, testing and reviewers.
14:03:00 <shadower> woo
14:03:02 <hrybacki> super cool
14:03:13 <beagles> nice
14:03:20 <EmilienM> d0ugal: that's a great news! thanks for all this work
14:03:26 <d0ugal> The tripleo-common patches are fairly low risk - nothing will use them until the CLI changes lands. So I'd like to see that happen soon
14:03:35 <d0ugal> (Then the CLI patch can actually test against CI properly)
14:03:52 <d0ugal> If anyone wants more info to test or try things out, please ping me
14:03:56 <EmilienM> great, so the patch in depends-on can be reviewed with low risk of breaking something
14:03:58 <d0ugal> ... and that is all I've got. thanks :)
14:04:06 <d0ugal> EmilienM: Yup, exactly.
14:04:07 <jtomasek> o/
14:04:19 <myoung> o/
14:04:27 <EmilienM> #action tripleo team to review https://review.openstack.org/#/c/298732/ and https://review.openstack.org/#/c/342261/
14:04:46 <marios> thanks d0ugal added to review queue fwiw
14:04:48 <EmilienM> d0ugal: thx for the update! don't hesitate to use ML if you need more reviews or have more updates!
14:05:02 <d0ugal> marios: thanks!
14:05:07 <d0ugal> EmilienM: will do :)
14:05:22 <EmilienM> #topic bugs
14:05:25 <EmilienM> #link https://bugs.launchpad.net/tripleo/?orderby=-id&start=0
14:05:43 <EmilienM> #link https://bugs.launchpad.net/tripleo/+milestone/newton-3
14:05:57 <Jokke_> o/
14:06:13 <florianf> o/
14:06:32 <EmilienM> if you're working on a bug listed for newton-3, please make sure it's up to date
14:07:24 <EmilienM> so, outstanding bugs :)
14:07:34 <saneax> o/
14:07:45 <EmilienM> the one I can see is https://bugs.launchpad.net/tripleo/+bug/1613088
14:07:45 <openstack> Launchpad bug 1613088 in tripleo "tripleo-ci: periodic nonha job failing to promote due to SSL" [Critical,In progress] - Assigned to Emilien Macchi (emilienm)
14:07:56 <EmilienM> but it's under control afict
14:08:08 <EmilienM> do we have other bugs to mention this week?
14:09:11 <EmilienM> https://bugs.launchpad.net/tripleo/+bug/1613630 will be solved when our CI will be pin
14:09:11 <openstack> Launchpad bug 1613630 in tripleo "CI: current-tripleo repo contains broken cinder and volume creation fails" [Critical,In progress] - Assigned to Sagi (Sergey) Shnaidman (sshnaidm)
14:09:28 <slagle> here's the pin: https://review.openstack.org/#/c/354481/
14:09:37 <sshnaidm> EmilienM, it's in progress, working with jpena from #rdo on this
14:09:51 <slagle> sshnaidm: is there update on getting the repo switched back?
14:10:06 <sshnaidm> slagle, not yet, jpena is checking right now
14:10:41 <sshnaidm> might be a problem related to manual change of link yesterday
14:10:46 <EmilienM> the patch is in gate now, hopefully it will merge in the next hour
14:11:06 <EmilienM> do we have anything else about bugs this week?
14:11:19 <EmilienM> please raise anything outstanding
14:12:09 <EmilienM> ok,  next topic
14:12:12 <EmilienM> #topic Projects releases or stable backports
14:13:03 <EmilienM> I haven't checked if shardy actually propose stable branch releases last week
14:13:20 <EmilienM> #action EmilienM to check & release stable branch this week if needed
14:13:27 <EmilienM> any question about releases?
14:13:44 <ansiwen> o/
14:13:57 <EmilienM> ansiwen: what's up?
14:14:18 <ansiwen> oh, I thought that's the way to say hello, sorry :-)
14:14:26 <EmilienM> ok next topic
14:14:28 <EmilienM> #topic CI
14:14:32 * ansiwen was late
14:14:59 <EmilienM> derekh: I noticed you're around, do you have any update this week?
14:17:03 <EmilienM> regarding upgrade/update jobs, I have no update, still working with matbu but really slow progress with all recent outages...
14:17:57 <sshnaidm> maybe you'll find it useful: https://etherpad.openstack.org/p/tripleo-ci-status
14:18:11 <slagle> even when jobs are passing, are ha jobs are running close to the check timeout, and some are getting killed
14:18:31 * EmilienM bookmarks it
14:18:32 <slagle> that will need to be investigated once the current issues are sorted
14:18:38 <weshay> nice
14:18:59 <EmilienM> slagle: we might reduce the number of services
14:19:15 <EmilienM> slagle: ie: sahara, etc (even if I remember gfidente's concern about upgrades)
14:19:18 <gfidente> EmilienM, slagle ack, see dtantsur thread on subject on openstack-dev
14:19:26 <slagle> EmilienM: yes i plan to do that in the multinode  job at least
14:19:37 <slagle> i think we can get it consistently under 60 minutes
14:19:40 <gfidente> EmilienM, yeah I was thinking about an experimental job deploying full overcloud as an alternative?
14:19:56 <gfidente> and trim down the gate job to a minimum instead
14:19:59 <EmilienM> what do you mean by full?
14:19:59 <sshnaidm> slagle, for periodic jobs we added undercloud idempotent and pingtest deletion which take time
14:20:06 <EmilienM> one with all services and that will timeout?
14:20:14 <slagle> sshnaidm: this isn't for periodic though
14:20:15 <gfidente> EmilienM, yeah pretty much
14:20:20 <EmilienM> gfidente: -1
14:20:35 <gfidente> EmilienM, eheh how do we test the optional services then?
14:20:36 <EmilienM> experimental jobs are usually incubator jobs, I would rather see a new non voting job for now
14:20:39 <slagle> sshnaidm: check-tripleo ha jobs are routinely taking 2h40m, or getting timed out
14:20:55 <EmilienM> gfidente: by creating scenarios, like we did in puppet CI
14:21:03 <EmilienM> they add more (not all) services
14:21:08 <derekh> EmilienM: sorry, missed your ping, nothing to bring up at the moment, just back today and catching up
14:21:17 <gfidente> EmilienM, right but to do that we'd need a lot more resources
14:21:24 <EmilienM> I know I pasted the link 1000 times but here's again https://github.com/openstack/puppet-openstack-integration#description
14:21:28 <gfidente> EmilienM, any permutation will run an entire undercloud/overcloud
14:21:33 <EmilienM> gfidente: I kow
14:21:39 <EmilienM> but the idea of experimental job won't help
14:21:54 <gfidente> well experimental can be triggered on request
14:22:00 <EmilienM> 1) it won't prevent breakages as it requires people to run "check experimental"
14:22:16 <EmilienM> 2) they'll timeout if you add all optional services
14:22:38 <EmilienM> the idea of scenarios is to have multiple scenarios (1 with all telemetry for ex)
14:22:43 <gfidente> right so let's put it this way, with unlimited CI capacity, I agree permutations work better
14:23:02 <EmilienM> derekh: ack
14:23:42 <EmilienM> gfidente: one option is periodic job
14:23:51 <EmilienM> scenarios in periodic
14:24:04 <sshnaidm> slagle, image build takes almost 45 mins, pretty long
14:24:14 <EmilienM> so we cover everything, we don't timeout because we have multiple scenarios and we use periodic pipeline so don't consume too much resources
14:24:31 <slagle> sshnaidm: yea, it takes half that time for me locally
14:24:34 <EmilienM> maybe I can come up with an idea on the ML
14:24:53 <gfidente> EmilienM, yep that'd be nice
14:24:56 <EmilienM> ok
14:24:59 <gfidente> we need similar support for ipv6 too
14:25:12 <gfidente> or for 'competing' services, as like ceph/rgw vs swift
14:25:13 <beagles> how much effort is it to maintain the various scenarios?
14:25:17 <EmilienM> #action EmilienM to propose periodic scenarios CI jobs testing on ML
14:25:41 <EmilienM> beagles: unknown at this time, we don't have it, but shouldn't be that hard with our composable services
14:25:42 <beagles> not that it's a reason not to do do it.. just thinking about delegation to devs, etc
14:25:48 <beagles> good point
14:25:49 <EmilienM> gfidente: exactly
14:26:04 <EmilienM> anything else about CI this week?
14:26:53 <EmilienM> #topic Specs
14:27:01 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:27:54 <EmilienM> if you have a spec and need a review, please go ahead
14:28:05 <EmilienM> it sounds like some of them have positive agreement
14:29:39 <EmilienM> but some of them are still under discussion
14:29:48 <EmilienM> please update / rebase your spec if you have one
14:30:22 <EmilienM> any question about specs?
14:30:59 <EmilienM> #topic open discussion
14:31:54 <EmilienM> we're heading to end of newton-3, and final approach is in few days, please continue to review as you can
14:32:15 <EmilienM> please let us know blockers and what can't be done for n3
14:32:21 <dtantsur> hmm, when is the deadline for tripleo? the same as other projects?
14:32:25 <dtantsur> * feature deadline ofc
14:32:31 <gfidente> marios, EmilienM is it fair to say that upgrade process from mitaka is still hackable after freeze?
14:32:42 <EmilienM> Aug 29-02 -> N3
14:32:49 <EmilienM> gfidente: yes
14:32:56 <gfidente> marios, EmilienM I think we consider upgrade a feature so it's fair game to improve it until release
14:32:59 <dtantsur> so, 2 more weeks essentially...
14:33:05 <EmilienM> we might want RC1 during Sep 12-16
14:33:22 <EmilienM> yes, we have 2 more weeks than other projects
14:33:35 <EmilienM> but in my experience, I like keeping short deadlines, for impediments :-)
14:33:49 <EmilienM> I'm sure we'll have plenty of things to do during those 2 weeks
14:33:53 <marios> gfidente: EmilienM yeah i think we have always lagged on the upgrade after the release
14:34:00 <EmilienM> our ultimate deadline is Oct 17-21
14:34:08 <marios> gfidente: EmilienM we have backport exception for upgrades related bugs right
14:34:16 <EmilienM> marios: right
14:34:33 <EmilienM> any help to bring upgrade / update CI jobs upstream would be great
14:34:56 <EmilienM> ping me or matbu - we're looking at it recently, but 0 progress since outages
14:34:58 <jrist> EmilienM: I can't stress enough the need for the mistral transition stuff to get eyes
14:35:03 <jrist> and reviews
14:35:18 <jrist> we need it to land for n-3 for the UI or we're in deep water
14:35:29 <EmilienM> jrist: right
14:35:40 <jrist> thanks
14:35:43 <EmilienM> jrist: please dress a list and share it with our team
14:36:00 <EmilienM> maybe a gerrit topic or LP #
14:36:03 <jrist> EmilienM: my understanding is that asking for reviews on the ML is frowned upon?
14:36:18 <dtantsur> I think listing project priorities is ok
14:36:19 <EmilienM> jrist: what?
14:36:25 <jrist> dtantsur: ok thanks
14:36:25 <dtantsur> just appearing out of blue with your patches is not
14:36:28 <jrist> dtantsur: got it
14:36:33 <EmilienM> jrist: using ML for anything is IMHO good
14:36:37 <jrist> ha
14:36:37 <EmilienM> it keeps things open and async
14:36:38 <jrist> ok
14:36:58 <dtantsur> EmilienM, there were bit objects for using for 2 things: asking for reviewing and 3rd party CI status updates
14:37:00 <shadower> same goes for the validations patches -- /me will email the ML
14:37:01 <dtantsur> don't ask me why please :)
14:37:08 <jrist> related, tripleo-ui launchpad would like to migrate to tripleO launchpad
14:37:10 <dtantsur> * big objections
14:37:15 * dtantsur has no clue what he's typing
14:37:20 <jrist> do I need special access for adding stuff?
14:37:25 <EmilienM> anything else for this week ?
14:37:28 <jrist> some sort of admin rights on tripleo launchpad?
14:37:41 <EmilienM> jrist: for what?
14:37:47 <EmilienM> I don't think so
14:37:53 * beagles imagines all of the frowning upon that he's been provoking lately
14:37:56 <jrist> adding/changing/deleting launchpad items for tripleo-ui in the tripleo launchpad
14:37:56 <EmilienM> let me know if something blocks you
14:37:59 <jrist> beagles: heh
14:38:02 <jrist> EmilienM: ok thanks
14:38:17 <EmilienM> I'm closing the meeting in 30s, go ahead now if you have anything
14:38:33 * EmilienM preparing his notes for puppet meeting in 20 min
14:38:58 <EmilienM> thanks everyone and keep rocking folks!
14:39:00 <EmilienM> #endmeeting