14:01:15 <EmilienM> #startmeeting tripleo
14:01:15 <openstack> Meeting started Tue Jun 21 14:01:15 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:19 <openstack> The meeting name has been set to 'tripleo'
14:01:20 <gfidente> thanks EmilienM
14:01:21 <dprince> EmilienM: you run it
14:01:29 <saneax> o/
14:01:35 <EmilienM> hey folks!
14:01:37 <karthiks> o/
14:01:38 <d0ugal> \o
14:01:38 <rhallisey> hey
14:01:39 <marios> \o thanks EmilienM
14:01:41 <skramaja> hi
14:01:43 <coolsvap> o/
14:01:44 <oneswig> hi
14:01:48 <tzumainn> hi!
14:01:54 <EmilienM> #topic agenda
14:01:57 <ccamacho> thanks EmilienM!
14:02:00 <beagles> o/
14:02:03 <EmilienM> * bugs
14:02:05 <EmilienM> * Projects releases or stable backports
14:02:07 <EmilienM> * CI
14:02:09 <EmilienM> * Specs
14:02:11 <EmilienM> * open discussion
14:02:22 <EmilienM> do we have other items for this week?
14:02:40 <EmilienM> if no one-off items, let's move to bugs
14:03:13 <EmilienM> #topic bugs
14:03:17 <EmilienM> #link https://bugs.launchpad.net/tripleo/
14:03:39 <trown> o/
14:03:57 <EmilienM> Does anyone have any bugs to mention this week in particular?
14:04:17 <marios> EmilienM: hey man, fyi/fwiw/as i mentinoed earlier, i am hitting a bunch of bugs for undercloud upgrade, like https://bugs.launchpad.net/tripleo/+bug/1593736
14:04:17 <openstack> Launchpad bug 1593736 in tripleo "stable/mitaka to newton undercloud upgrade fails with 'Could not find class ::tripleo::selinux'" [Medium,Triaged] - Assigned to Marios Andreou (marios-b)
14:04:55 <EmilienM> it sounds like a packaging issue in OPM
14:04:59 <marios> EmilienM: i think they are all package issues possible, though i see the fixes landed in master quite a while ago (different for each one, some few weeks old)
14:05:02 <EmilienM> but I might be wrong
14:05:06 <marios> s/possible/possibly
14:05:23 <EmilienM> marios: can you ping jayg (not here) and check if OPM/Mitaka is up to date?
14:05:29 <EmilienM> I guess puppet-tripleo needs to be updated
14:05:45 <marios> EmilienM: ok i think i will file a tracking bug for each one i find (similar to that bug i pointed to, probably i have like 5 in total so far)
14:05:47 <EmilienM> well
14:05:49 <EmilienM> no
14:05:51 <EmilienM> https://github.com/openstack/puppet-tripleo/tree/stable/mitaka/manifests
14:05:53 <EmilienM> I don't see selinux.pp
14:05:58 <EmilienM> so I guess something was not backported
14:06:21 <EmilienM> https://github.com/openstack/puppet-tripleo/commit/8e533aaf447022c62865130f2ffc88690f06aef1
14:06:24 <marios> EmilienM: right so for some cases it may be backports and i should check mitaka
14:06:26 <EmilienM> sounds like it was not backported ^
14:06:35 <EmilienM> also check with slagle, he did that patch
14:06:36 <marios> EmilienM: ack, just fyi cos is bugs /me end :)
14:06:40 <EmilienM> to make sure we can backport it
14:07:04 <EmilienM> dprince: do we have CI related bug?
14:07:14 <EmilienM> everything is still super red on http://tripleo.org/cistatus.html
14:07:56 <EmilienM> any other outstanding bug this week?
14:08:28 <EmilienM> #action marios to investigate selinux backport to mitaka https://bugs.launchpad.net/tripleo/+bug/1593736
14:08:28 <openstack> Launchpad bug 1593736 in tripleo "stable/mitaka to newton undercloud upgrade fails with 'Could not find class ::tripleo::selinux'" [Medium,Triaged] - Assigned to Marios Andreou (marios-b)
14:08:46 <sshnaidm_> EmilienM, https://bugs.launchpad.net/tripleo/+bug/1594732
14:08:46 <openstack> Launchpad bug 1594732 in tripleo "CI: No connected gearman servers" [Undecided,New]
14:09:12 <marios> EmilienM: ack thanks, i'll also file the rest of the issues individually for tracking after this like https://bugs.launchpad.net/tripleo/+bug/1593182 for example and a few more
14:09:12 <openstack> Launchpad bug 1593182 in tripleo "failed openstack-nova-scheduler after updating undercloud from mitaka to newton packages" [Medium,Triaged] - Assigned to Marios Andreou (marios-b)
14:09:13 <EmilienM> sshnaidm_: right, this one. Do we have any action on this one?
14:09:21 <sshnaidm_> EmilienM, geard is restarted and running, also submitted a patch to renew it: https://review.openstack.org/#/c/332123/
14:09:39 <sshnaidm_> EmilienM, if it's installed from pip, it may to resolve the problem
14:09:47 <EmilienM> #action team to review CI patch to deploy gear from pip https://review.openstack.org/#/c/332123/
14:09:54 <sshnaidm_> EmilienM, if not, will do something to restart it gracefully if possible
14:10:05 <EmilienM> cool thx
14:10:09 <EmilienM> can you assign the bug to you please?
14:10:14 <sshnaidm_> EmilienM, yep
14:10:15 <EmilienM> and tag it critical/confirmed
14:10:17 <EmilienM> thx
14:10:22 <EmilienM> auto triage FTW
14:10:27 <EmilienM> anything else for bugs?
14:10:43 <EmilienM> #topic Projects releases or stable backports
14:10:48 <EmilienM> #link http://releases.openstack.org/newton/schedule.html
14:10:54 <EmilienM> #link https://launchpad.net/tripleo/+milestone/newton-2
14:11:02 <EmilienM> 3 weeks until n-2
14:11:02 <sshnaidm_> (I can't set its importance, only cores I think)
14:11:31 <EmilienM> sshnaidm_: done.
14:11:33 <coolsvap> sshnaidm_, done!
14:12:33 <EmilienM> so 3 weeks before n-2, release is coming fast... Please take some time to do reviews on ongoing work for n2
14:13:01 <EmilienM> If you think you'll miss the n-2 deadline, please move it to n3.
14:13:23 <EmilienM> any question /blocker about release management?
14:14:19 <EmilienM> great let's move to CI
14:14:21 <coolsvap> EmilienM, nothing blocker as such but i had some queries related to releases of some components
14:14:21 <EmilienM> #topic CI
14:14:35 <coolsvap> maybe later
14:14:54 <EmilienM> coolsvap: go ahead?
14:14:57 <EmilienM> #undo
14:14:57 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7fc2af159610>
14:15:18 <EmilienM> #topic Projects releases or stable backports
14:15:25 <EmilienM> coolsvap: what's up?
14:15:31 <coolsvap> I was talking with shardy when he trigrgerred ther release
14:15:35 <coolsvap> for instack-undercloud
14:15:48 <coolsvap> and asked me to look for some other projects which also need
14:16:17 <coolsvap> i didn't get how to do it for say diskimage-builder
14:16:21 <coolsvap> or instack
14:16:28 <coolsvap> which are independant
14:16:33 <coolsvap> independent*
14:16:47 <marios> coolsvap: https://wiki.openstack.org/wiki/TripleO/ReleaseManagement not sure how up to date that info is, haven't dont it in quite a while
14:17:01 <EmilienM> coolsvap: https://github.com/openstack/releases/commit/85bfe0c0488a1dfdd046e14b4d27cdd1d2e4c929
14:17:02 <marios> coolsvap: i hink it is missing instack-*
14:17:07 <EmilienM> look what I did for our first Newton release
14:17:29 <EmilienM> you can check in https://github.com/openstack/releases/tree/master/deliverables/newton
14:17:37 <EmilienM> https://github.com/openstack/releases/blob/master/deliverables/newton/instack.yaml
14:17:58 <EmilienM> coolsvap: did you have a particular question?
14:18:03 <gfidente> coolsvap this was independent
14:18:03 <gfidente> https://review.openstack.org/#/c/303986/
14:18:06 <gfidente> EmilienM ^^
14:18:08 <coolsvap> EmilienM, but instack doesnt have release in mitaka
14:18:23 <coolsvap> how to handle that
14:18:29 <gfidente> coolsvap marios EmilienM we link to that from the ReleaseManagement wiki
14:18:37 <gfidente> coolsvap https://review.openstack.org/#/c/303986/
14:18:49 <EmilienM> https://github.com/openstack/releases/blob/master/deliverables/_independent/instack.yaml
14:18:52 <coolsvap> gfidente, alright
14:19:10 <EmilienM> you can add it in independent
14:19:12 <coolsvap> that was my question whether it will remain in independent i have some doubts
14:19:18 <EmilienM> yes it will
14:19:19 <coolsvap> but i will ask on #tripleo
14:19:23 <EmilienM> cool
14:19:31 <EmilienM> anything else about releases?
14:19:45 <EmilienM> #topic CI
14:20:07 <EmilienM> regarding liberty CI, upgrade job is still failing
14:20:20 <EmilienM> I investigated a bit and I found out it was related to ipv6 on upgrade job
14:20:37 <EmilienM> I tried to run ipv4 on upgrade job for liberty: https://review.openstack.org/329664 but it still fails
14:20:40 <EmilienM> I have no progress since then ^
14:20:50 <EmilienM> if anyone volunteers to help, let me know
14:21:15 <EmilienM> dprince: can you give an update about CI (derek is offline)
14:21:34 <EmilienM> slagle: also your status on multi nodes please
14:22:40 <slagle> hi
14:22:56 <slagle> i'm still working on it (and other things)
14:23:10 <slagle> it's been slow going, due to the networking setup (vxlan tunnels)
14:23:28 <slagle> maybe i'll have something up this week
14:23:39 <EmilienM> slagle: do you have blocker that you need solved from our side ? (composable roles, etc)
14:23:42 <slagle> i'll at least push some updated patches
14:23:49 <slagle> EmilienM: not that i know of
14:24:06 <dprince> we had a CI outage this weekend
14:24:20 <EmilienM> slagle: ok last week you mentionned "<slagle> which may be possible when composable nova-compute lands"
14:24:25 <EmilienM> slagle: so I was wondering
14:24:38 <slagle> yes, an aio overcloud may be possible
14:24:49 <EmilienM> dprince: it's the same as we had this morning/night right?
14:24:55 <slagle> i'll give it a try, but want to make sure i get the networking correct first
14:25:00 <dprince> The compute host running our "mirror" server died. After rebooting it and cleaning up a bit things are moving again. Although I forgot to run os-collect-config on the compute host after reboot so we need to fix that eventually too
14:25:02 <EmilienM> slagle: right
14:25:13 <dprince> EmilienM: no, different issue. Today was the te-broker server which runs gearman
14:25:22 <EmilienM> ok
14:25:44 <dprince> anyway, I think things should be running fine now
14:26:05 <EmilienM> dprince: yeah, will see if using pip to install gear can help
14:26:06 <dprince> I will watch the gearman until sshnaidm_ bumps the version as discussed earlier
14:26:26 <EmilienM> and if yes, I would suggest to reach maintainer and try  to update it in centos7
14:26:50 <EmilienM> anything else about CI? questions? info?
14:27:21 <EmilienM> #topic specs
14:27:49 <karthiks> https://blueprints.launchpad.net/tripleo/+spec/tripleo-sriov
14:28:07 <karthiks> just wanted to confirm if the above spec is accepted for newton ?
14:28:22 <EmilienM> karthiks: it sounds like you addressed most of comments
14:29:08 <karthiks> yes ... we have uploaded  the changes .
14:29:25 <karthiks> We are working on the patches.
14:29:41 <EmilienM> karthiks: I have serious doubt about making it on time for Newton
14:29:44 <EmilienM> but I might be wrong
14:29:57 <karthiks> :)
14:30:11 <karthiks> we are hopefull :)
14:30:43 <EmilienM> freeze is ~ August 30th
14:30:48 <dprince> I think sriov could land in newton just fine
14:30:52 <EmilienM> so you have ~ 2 months
14:31:01 <EmilienM> if dprince is confident, cool then :-)
14:31:05 <dprince> EmilienM: the idea with composable services is actually that we can land things faster hopefully
14:31:11 <EmilienM> right
14:31:14 <karthiks> :)
14:31:15 <dprince> EmilienM: it is only CI which holds up up
14:31:19 <dprince> us up
14:31:30 <EmilienM> do we need to talk about other blueprints?
14:31:34 <skramaja> i have uploaded a spec for iorc changes for kernel boot parameters #https://review.openstack.org/#/c/331564
14:31:37 <EmilienM> last week we mentionned composable upgrades
14:31:39 <skramaja> *ironic
14:32:07 <EmilienM> dprince: well, if they have some other specs in ironic, etc... we might not do it on time...
14:32:16 <skramaja> it is also related to SR-IOV and DPDK changes..
14:33:09 <EmilienM> no more spec to discuss?
14:33:35 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:33:59 <EmilienM> marios, jistr: any update on https://review.openstack.org/#/c/319264/ ?
14:34:03 <EmilienM> Composable Upgrades
14:34:29 <EmilienM> this one is essential: https://blueprints.launchpad.net/tripleo/+spec/overcloud-upgrades
14:34:36 <jistr> no update, other than the PoCs are being debated in terms of tool selection
14:34:54 <EmilienM> debated in Gerrit?
14:34:55 <rhallisey> I guess this would be a good place to bring it up, when do we want to meet again?
14:35:04 <EmilienM> I don't see much discussion on https://review.openstack.org/#/c/319264/
14:35:05 <marios> EmilienM: yeah, i think that will likely be updated after we finish the discussion about the overall direction
14:35:25 <EmilienM> where is happenning the discussion? sorry for dumb question
14:35:35 <marios> EmilienM: we had a bluejeans call last week (I believe rhallisey extended the invitation to all during last week irc meeting)
14:35:40 <jistr> #link https://etherpad.openstack.org/p/tripleo-composable-upgrades-discussion
14:35:54 <EmilienM> ok excellent ^
14:35:55 <jistr> EmilienM: ^
14:36:08 <marios> EmilienM: there will likely be another call this week, tbd afaik, possibly tomorrow shardy around?
14:36:16 <EmilienM> are we going to reach a concensus by n-3 ?
14:36:24 <marios> EmilienM: hope so :)
14:36:27 <EmilienM> shardy is travelling
14:36:29 <rhallisey> EmilienM, ya I think so
14:36:34 <marios> EmilienM: so actually
14:36:35 <EmilienM> great
14:36:38 <marios> EmilienM: i believe the conclusion was
14:36:52 <marios> EmilienM: yes it would be great to (and given we are talking about direction, not full working implementation)
14:36:59 <marios> EmilienM: but if mitaka..newton
14:37:13 <marios> EmilienM: sorry, but for mitaka... newton upgrades, we will use the existing workflow
14:37:27 <EmilienM> bash scripts, right?
14:37:33 <marios> EmilienM: for which there is WIP
14:37:36 <marios> EmilienM: not quite
14:37:37 <jistr> yea, and non-composable ones
14:37:41 <EmilienM> ok
14:37:44 <marios> EmilienM: 3 heat stack updates
14:37:50 <marios> EmilienM: and some bash scripts :)
14:37:56 <EmilienM> it makes sense,
14:38:03 <marios> EmilienM: what could possibly go wrong
14:38:04 <EmilienM> so you're targetting this work for n..o
14:38:17 <marios> docs wip at https://review.openstack.org/#/c/308985/
14:38:28 <marios> EmilienM: yes that was my understanding at least
14:38:43 <EmilienM> cool
14:38:49 <marios> EmilienM: but anyway, at least the overall direction shouldb be decided in 2/3 weeks !!
14:39:05 <EmilienM> "pray for upgrades"
14:39:05 <rhallisey> marios, well depending on what we setting with and when, we could apply some of the work back for this
14:39:21 <rhallisey> just a thought
14:39:33 <rhallisey> may not be within the timeframe though
14:39:58 <marios> rhallisey: ack, just not concrete yet what we will do ... this is the blocker atm
14:40:13 <EmilienM> do we have other spec to discuss today? I'll let 30 more sec and go to next topic
14:40:49 <EmilienM> #topic Open Discussion
14:41:16 <chem> I was wondering where the use of the new pacemaker module in tht could fit in regarding specs ?(maybe Add initial next generation HA architecture spec)
14:41:48 <EmilienM> chem: that's a question for bandini (not here)
14:42:01 <chem> oki
14:42:27 <EmilienM> chem: honestly, I think you can consider the spec good for most of bits
14:42:37 <EmilienM> chem: ie: most of openstack services won't be managed by pacemaker
14:42:48 <EmilienM> chem: and take it in consideration in your work
14:43:15 <EmilienM> chem: but needs to be confirmed with ha folks
14:43:27 <bnemec> Would like some more thoughts on dlrn-repo: http://lists.openstack.org/pipermail/openstack-dev/2016-June/097221.html
14:43:29 <chem> EmilienM: I know, I just had a meeting with bandini, I just wondered under which umbrella this effort is
14:43:43 <EmilienM> chem: ha-lite
14:45:36 <EmilienM> bnemec: that's a good proposal, did you have feedback from trown and rdo folks?
14:45:58 <bnemec> EmilienM: The only feedback I have so far is from derek on that thread.
14:46:12 <bnemec> Which is why I'm bringing it up here. :-)
14:46:18 <EmilienM> great
14:46:37 <EmilienM> I would get in touch with trown & other rdo folks for this one
14:46:51 <trown> ya I am less sure that is something needed in RDO
14:47:06 <trown> the convoluted repo setup is specific to tripleo-ci
14:47:40 <EmilienM> I'll let this meeting open 30 more seconds unless something comes up
14:47:52 <trown> now, whether that mini python app is better than what is in tripleo.sh is up for debate, and I dont really have any opinion on it
14:49:40 <EmilienM> ok thanks folks
14:49:43 <jokke_> thanks
14:49:45 <EmilienM> have a great week
14:49:51 <EmilienM> #endmeeting