14:00:37 <EmilienM> #startmeeting tripleo
14:00:38 <openstack> Meeting started Tue May 31 14:00:37 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <openstack> The meeting name has been set to 'tripleo'
14:00:47 <EmilienM> #topic rollcall
14:00:51 <EmilienM> hey folks
14:00:51 <coolsvap> Hello
14:00:52 <derekh> \o
14:00:56 <sshnaidm> hi
14:00:58 <marios> o/
14:01:02 <gfidente> hello
14:01:11 <d0ugal> Hi all!
14:01:20 <EmilienM> #topic agenda
14:01:21 <beagles> o/
14:01:27 <EmilienM> #link https://wiki.openstack.org/wiki/Meetings/TripleO
14:01:42 <EmilienM> * two off agenda items
14:01:46 <EmilienM> * bugs
14:01:51 <EmilienM> * Projects releases or stable backports
14:01:56 <EmilienM> * CI
14:01:57 <EmilienM> * specs
14:01:59 <EmilienM> * open discussion
14:02:19 <EmilienM> (I just realized I created an item that is part of a topic)
14:02:27 <EmilienM> so we have one off agenda item
14:02:34 <EmilienM> beagles: o/
14:02:42 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-bug-cleanup-2016
14:02:46 <EmilienM> you wanted to chat about it?
14:02:49 <rbrady> o/
14:02:55 <woodster_> o/
14:02:58 <rhallisey> hi
14:03:16 <sshnaidm> EmilienM, unfortunately I can't edit wiki and add there issues, because of security policy of wiki, maybe it's better to use a etherpad for this?
14:03:22 <beagles> more of a status really
14:03:40 <EmilienM> beagles: sure, go ahead
14:04:01 <EmilienM> sshnaidm: that's unfortunate :(
14:04:02 <beagles> I've been digging through the bugs  starting at the oldest first and working my way forward
14:04:37 <beagles> some of them are probably having more learned eyes go over, but aren't a high priority afaict
14:04:39 <jtomasek> o/
14:05:40 <beagles> I just wanted to bring it up in this meeting along with the link in the agenda that if anyone is curious, go have a look and offer thoughts, guidance, correction etc
14:05:42 <beagles> that is all really
14:05:45 <trown> o/
14:05:49 <EmilienM> beagles: ok cool
14:06:02 <EmilienM> #topic bugs
14:06:10 <EmilienM> #link https://bugs.launchpad.net/tripleo/
14:06:26 <dprince> hi everyone
14:06:28 * dprince is late
14:06:51 <EmilienM> do we have outstanding bugs this week?
14:07:18 <sshnaidm> I filed yesterday: https://bugs.launchpad.net/tripleo/+bug/1586906
14:07:18 <openstack> Launchpad bug 1586906 in tripleo "CI: periodic jobs fail becasue "no stack found"" [Undecided,New]
14:07:32 <slagle> just wanted to mention https://bugs.launchpad.net/tripleo/+bug/1585641, which is still causing many CI jobs to fail
14:07:32 <openstack> Launchpad bug 1585641 in tripleo "CI: jobs failing with Message: No valid host was found. There are not enough hosts available., Code: 500"" [High,Triaged] - Assigned to James Slagle (james-slagle)
14:07:45 <EmilienM> slagle: right, we still have this one
14:07:45 <slagle> we are still waiting on the fix in nova to land
14:07:52 <dprince> yeah, still seeing lots of those myself too
14:07:53 <EmilienM> :( sigh
14:08:54 <EmilienM> we need https://review.openstack.org/#/c/316031/
14:08:58 <EmilienM> iirc
14:09:31 <EmilienM> someone is looking at https://bugs.launchpad.net/tripleo/+bug/1586906 already?
14:09:31 <openstack> Launchpad bug 1586906 in tripleo "CI: periodic jobs fail becasue "no stack found"" [Undecided,New]
14:09:32 <dprince> if there is a patch we know fixes it (or think it does) we could cherry pick it
14:09:54 <dprince> that would mean building a custom Nova patch for each CI run... but we've done it before
14:10:02 <EmilienM> dprince: yes we could, as long as we catch-up from master once the patch is merged upstream
14:10:25 <slagle> dprince: i wasn't sure that still worked or not
14:10:31 <EmilienM> dprince: +1 for this proposal
14:10:42 <slagle> i couldn't see how in our scripts it would know to build the nova package
14:10:47 <slagle> so we might need to add some plumbing
14:10:50 <dprince> slagle: well... it used to. And it is a useful thing to have
14:11:05 <dprince> slagle: so if we need to re-add this capability I'd think it generally useful
14:11:11 <slagle> yes
14:11:16 <dprince> think of it as an upstream defense mechanism
14:11:35 <EmilienM> (as long as it's temporary)
14:11:42 <EmilienM> dprince: do we take action on this?
14:11:52 <slagle> i can have a look at it
14:12:04 <derekh> slagle: it stopped working a while ago, but if you add nova to ZUUL_CHANGES as part of the cherry-pivk function then that should be all thats needed http://git.openstack.org/cgit/openstack-infra/tripleo-ci/tree/scripts/common_functions.sh#n43
14:12:27 <slagle> derekh: yea, that's what i had tried, but i think i got the syntax wrong for ZUUL_CHANGES
14:12:59 <EmilienM> #action slagle to cherry-pick nova/316031 into tripleo CI
14:13:11 <derekh> slagle: ok, iirc depending on where you do it, it may need to be space delimited or "^"
14:13:43 <EmilienM> anything else about bugs?
14:14:45 <EmilienM> #topic Projects releases or stable backports
14:15:06 <EmilienM> shardy asked us if we could produce a newton-alpha this week
14:15:25 <EmilienM> slagle: do you still have time this week to work on it with me?
14:15:40 <EmilienM> I never did it for tripleo (only puppet modules), but want to learn
14:15:44 <derekh> slagle: also there might be something useful in here (or maybe not) https://review.openstack.org/#/c/227563/6
14:16:12 <slagle> EmilienM: yea, it should be relatively straightforward, get the hashes from the last successful promote, and release those
14:16:17 * beagles lost network connectivity for a couple of minutes
14:16:19 <EmilienM> #link http://releases.openstack.org/newton/schedule.html
14:16:41 <slagle> EmilienM: hopefully we can get a promote this week, if not, we can use what was promoted last week
14:16:43 <EmilienM> slagle: cool, let's do it this afternoon or tomorrow, depending if your agenda (mine is flexible)
14:17:16 <EmilienM> #action EmilienM & slagle to promote CI & release newton-alpha
14:17:30 <EmilienM> any question/feedback about release management?
14:17:44 <EmilienM> do we have outstanding backports this week?
14:18:14 <EmilienM> ok, let's move then
14:18:30 <EmilienM> #topic CI
14:19:05 <EmilienM> so we have some bugs already mentionned earlier that affect CI, but otherwise, do we have outstanding work regarding CI?
14:19:40 <sshnaidm> I'm asking for advise who can review and approve tripleo testing jobs: https://review.openstack.org/#/c/320957/  because talking "to all" doesn't work, I'd prefer to ask specific people. If somebody knows how it could be pushed, please advise me
14:20:34 <EmilienM> sshnaidm: you need to ping infra prople about this patch, pabelanger for example
14:20:47 <EmilienM> people*
14:21:11 <EmilienM> sshnaidm: /join #openstack-infra and ask for review
14:21:16 <sshnaidm> EmilienM, ok, will ask pabelanger
14:21:19 <EmilienM> cool
14:21:21 <derekh> I have nothing on the current ci
14:21:23 <derekh> rh2 deployment is making progress, I now have a publically available working rh2 overcloud
14:21:27 <sshnaidm> EmilienM, I do it every day
14:21:30 <derekh> today started testing OVB on it
14:21:34 <EmilienM> sshnaidm: sad story
14:21:41 <derekh> will be redeploying several times over the next week or so, so still a WIP (but no blockers yet)
14:21:59 <EmilienM> derekh: excellent progress :)
14:22:13 <EmilienM> derekh: do you need help for something?
14:23:07 <derekh> not at the moment, when I get it all up, I'll send on my scripts and take suggestions etc.. on how things could better be configured
14:23:16 <EmilienM> cool
14:23:19 <EmilienM> thx for this work
14:23:27 <EmilienM> let's move to next topic then
14:23:27 <derekh> EmilienM: and if I hit any blockers I can't figure out I'll ping #tripleo
14:23:32 <EmilienM> ++
14:23:36 <EmilienM> #topic Specs
14:23:43 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:24:26 <EmilienM> if you have a spec you want to discuss, please go ahead
14:25:44 <EmilienM> most of specs already had nice insights in gerrit
14:25:59 <EmilienM> if there is anything outstanding to discuss go ahead or we move to open discussion
14:26:52 <EmilienM> #topic Open Discussion
14:27:22 <EmilienM> (quite meeting today)
14:27:30 <dprince> So I've got one
14:27:40 <dprince> many of the developers have their own blogs
14:27:57 <dprince> but would it be useful to setup a "team" blog and tie it in as well?
14:28:25 <EmilienM> for tripleo posts?
14:28:33 <dprince> I was thinking of setting up a github pages blog (simple one) and we could host it under the github.com/tripleo account
14:28:56 <marios> hey o/ am testing M..N upgrades using the current upgrades process... some rework needed in the 'start/stop all the things' logic we use tracked at https://blueprints.launchpad.net/tripleo/+spec/overcloud-upgrades-workflow-mitaka-to-newton currently testing. reviews welcome. would be nice to land sthing in N1 for the parent upgrades BP at https://blueprints.launchpad.net/tripleo/+spec/overclo
14:29:02 <marios> ud-upgrades
14:29:05 <dprince> yeah, for team posts, that we perhaps collaborate on. Or for individuals who are part of the team and want to blog but don't have their own.
14:29:41 <marios> dprince: +1 to reminder about writing _sthing_ (thinking about the recent experience doing the upgrades process 'for real')
14:30:06 <EmilienM> marios: it's all on https://review.openstack.org/#/q/topic:fixup_upgrades_scripts,n,z ?
14:30:27 <marios> EmilienM: for now... i also fixed the nova pinning etc today... see what else we find
14:30:38 <marios> EmilienM: that is the purpose of the blueprint... track work needed to adapt the current workflow
14:30:45 <coolsvap> or we could just aggregate the tripleo related blogs (like we do for most planet)
14:30:46 <ccamacho> dprince "but don't have their own" +1
14:31:20 <marios> EmilienM: see the whiteboard at https://blueprints.launchpad.net/tripleo/+spec/overcloud-upgrades-workflow-mitaka-to-newton
14:31:25 <coolsvap> i mean ghpages would need additional reviewing
14:31:33 <dprince> coolsvap: we would still aggregate them w/ planet. And also this would go into planet.openstack.org too
14:31:47 <dprince> coolsvap: it would just be a team blog in addition to any individual blogs
14:31:53 <EmilienM> marios: do we have plans to have a CI that test it?
14:32:15 <marios> EmilienM: good questino. matbu is looking at that i believe
14:32:27 <marios> EmilienM: and yes that is totally missing atm
14:32:32 <EmilienM> because, yeah, we can review it, but without manual testing it's blind review
14:33:04 <coolsvap> dprince, I am +1 on it just thinking about options
14:33:43 <dprince> marios: sorry, what were you reminding me for again? The 'overcloud execute' stuff?
14:33:45 <coolsvap> because any additional information on tripleo is useful
14:33:46 <marios> EmilienM: ack, let's take it up on the review. fwiw am testing it locally, which is how we landed these scripts originally (for liberty upgrades), because, we didn't have ci, same reason
14:34:10 <EmilienM> right, I don't say we should block your patches because we have no CI for it
14:34:14 <EmilienM> I just ask if we have plans for it
14:34:16 <marios> dprince: ha, nothing, you reminded me about saying i'd write sthing about tripleo when you said you asked ppl to
14:35:02 <EmilienM> matbu: please let us know your plans, mailing-list for example
14:35:17 <marios> EmilienM: i think he just started looking
14:35:22 <marios> EmilienM: we have a tracking bug
14:35:22 <marios> sec
14:35:39 <marios> https://bugs.launchpad.net/tripleo/+bug/1583125
14:35:39 <openstack> Launchpad bug 1583125 in tripleo "There is no 'major version' upgrades job for ci " [High,Triaged] - Assigned to mbu (mat-bultel)
14:35:46 <EmilienM> (we had a CI topic and it was not raised :-P)
14:35:54 <marios> sry :(
14:36:29 <EmilienM> cool work
14:36:46 <EmilienM> #link Major upgrade work https://bugs.launchpad.net/tripleo/+bug/1583125
14:36:46 <openstack> Launchpad bug 1583125 in tripleo "There is no 'major version' upgrades job for ci " [High,Triaged] - Assigned to mbu (mat-bultel)
14:36:55 <matbu> EmilienM: yep i'll try to figure out this part asap
14:36:59 <EmilienM> cool
14:37:18 <matbu> EmilienM: i just discover the ci tripleo.sh script yesterday
14:37:33 <EmilienM> dprince: maybe we could use mailing-list to poll people who would be interested by blogging in a common place
14:37:47 <matbu> EmilienM: but afaik there is not much work there ... just hoping the upgrade will work
14:37:59 <dprince> EmilienM: yep, I'll ask there too
14:38:14 <EmilienM> do we have other thoughts for today?
14:39:32 <EmilienM> dprince, gfidente: do you guys have something to mention about composable roles?
14:39:33 <dprince> not from me. Thanks EmilienM
14:39:46 <EmilienM> no blocker? progress is good?
14:40:00 <gfidente> EmilienM, we got swift proxy
14:40:13 <gfidente> I think we got to wire chains in cephstorage and compute nodes
14:40:20 <gfidente> so I'm getting back at the ceph roles
14:40:23 <EmilienM> good
14:40:34 <gfidente> slow progress
14:40:36 <dprince> EmilienM: oh, so we need to prototype a solution that works better to enable/disable things with Heat environments
14:40:37 <gfidente> but progress
14:40:47 <dprince> slow progress, largely due to CI I think
14:41:01 <EmilienM> dprince: let's fix nova, it should be better
14:41:07 <dprince> yep
14:41:27 <EmilienM> I'll keep meeting open 30 more seconds, if anything go ahead now
14:42:24 <EmilienM> ok folks, have fun! /peace
14:42:26 <marios> EmilienM: ++ thanks
14:42:26 <EmilienM> #endmeeting