08:05:03 <SpamapS> #startmeeting tripleo
08:05:04 <openstack> Meeting started Wed Jan 21 08:05:03 2015 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:05:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:05:05 <lsmola2> hello
08:05:07 <openstack> The meeting name has been set to 'tripleo'
08:05:28 <shardy> o/
08:05:39 <SpamapS> #topic agenda
08:05:39 <SpamapS> * bugs
08:05:39 <SpamapS> * reviews
08:05:39 <SpamapS> * Projects needing releases
08:05:39 <SpamapS> * CD Cloud status
08:05:41 <SpamapS> * CI
08:05:44 <SpamapS> * Specs
08:05:46 <SpamapS> * open discussion
08:05:52 <StevenK> o/
08:05:54 <marios> o/
08:05:57 <SpamapS> Remember that anyone can use the link and info commands, not just the moderator - if you have something worth noting in the meeting minutes feel free to tag it
08:06:00 <tchaypo> \o
08:06:08 <SpamapS> #topic bugs
08:06:13 <lsmola2> o/
08:06:22 <SpamapS> #link https://bugs.launchpad.net/tripleo/
08:06:22 <SpamapS> #link https://bugs.launchpad.net/diskimage-builder/
08:06:22 <SpamapS> #link https://bugs.launchpad.net/os-refresh-config
08:06:22 <SpamapS> #link https://bugs.launchpad.net/os-apply-config
08:06:22 <SpamapS> #link https://bugs.launchpad.net/os-collect-config
08:06:24 <SpamapS> #link https://bugs.launchpad.net/os-cloud-config
08:06:26 <SpamapS> #link https://bugs.launchpad.net/os-net-config
08:06:29 <SpamapS> #link https://bugs.launchpad.net/tuskar
08:06:32 <SpamapS> #link https://bugs.launchpad.net/python-tuskarclient
08:06:34 <tchaypo> this is the part ofthe meeting where i suddenly remember to see if anything is assigned to me
08:06:57 <SpamapS> Yeah me too
08:07:25 <SpamapS> Mine are stalled out while I work on adding L3 segmentation support to the holey trinity of Ironic+Nova+Neutron
08:08:04 <SpamapS> anybody want to bring up specific bugs that need attention?
08:08:32 <greghaynes> I am currently filing one that is a big deal IMO - seeing f20 failures and there ends up being no logs for the seed to debug
08:08:42 <tchaypo> yeah, I've seen that a fair bit
08:09:05 <tchaypo> looking at the g_s_f_h logs it looks like it's having trouble parsing the .xz file that should have the logs
08:09:08 <greghaynes> https://bugs.launchpad.net/tripleo/+bug/1413106
08:09:24 <SpamapS> Unfortunately Soren seems MIA and uvirtbot isn't here to chime in with bug titles.
08:10:02 <greghaynes> There is also something causing our f20 jobs to fail >50%, which is a separate issue
08:10:06 <greghaynes> but this is hard to debug without logs
08:10:17 <SpamapS> agree
08:10:23 <greghaynes> and thats all I got :)
08:10:35 <SpamapS> yeah I think that's where we're at
08:10:53 <SpamapS> #topic reviews
08:11:14 <SpamapS> #info There's a dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
08:11:17 <SpamapS> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
08:11:20 <SpamapS> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
08:11:23 <SpamapS> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
08:12:16 <SpamapS> tons of old reviews that may benefit from fresh eyes
08:12:27 <tchaypo> So this is the bit where we said at paris we'd ask for cores to adopt a review and see if we can move it, right?
08:12:44 <SpamapS> still a bit skewed from holidays on the 30 and 90 day numbers
08:12:57 <SpamapS> tchaypo: right, have seen it a bit.
08:14:14 <SpamapS> I don't want to wade too deep into these waters. I think things are working o-k, but we should make sure to clear out the cruft of old reviews so we don't miss the gems.
08:14:55 <marios> fwiw, just mentioning this made me go check one of those old ones that i was waiting on green tests for
08:14:59 <marios> (and landed it)
08:15:07 <greghaynes> +1 to just pointing out check the old reviews queue
08:15:16 <greghaynes> ive been forgetting to do this :)
08:15:27 <StevenK> Same :-(
08:15:44 <tchaypo> I'm digging through the list of ones I'm already involved in but not seeing any  that I could move along
08:15:55 <tchaypo> except maybe 114360
08:16:04 <SpamapS> the thing is to get involved with old ones you haven't touched yet
08:16:12 <SpamapS> they may need fresh energy.
08:16:42 <tchaypo> indeed.
08:16:51 <tchaypo> I thought I might have some that just need some +2s to land
08:16:53 <tchaypo> but I don't.
08:17:19 <tchaypo> looking at Longest waiting reviews (based on oldest rev without -1 or -2):
08:17:27 <tchaypo> https://review.openstack.org/137031
08:18:18 <tchaypo> actually that's one - all the things people have asked for have been addressed, it passes tests, it looks like it just needs people to look over it again to see if it's ready to land
08:19:02 <SpamapS> oh also, congrats tchaypo on joining the core team. :)
08:19:18 <greghaynes> yaya \O/ congrats
08:19:44 <lsmola2> congrats :-)
08:19:49 <SpamapS> #topic Projects needing releases
08:20:15 <greghaynes> I failed and did not release
08:20:25 <greghaynes> I would kind of like to tomorrow though - I want to try out my new yubikey
08:20:30 <SpamapS> sounds like you're volunteering again. :)
08:20:48 <greghaynes> yep /me makes reminder
08:20:49 <SpamapS> #action greghaynes to try out new yubikey and release all the things
08:21:07 <SpamapS> #topic Live clouds status
08:21:16 <SpamapS> We talked about this last week in the other time slot
08:21:42 <SpamapS> I wanted to make this more of a time for those running actualy clouds on TripleO to socialize anything specific to operations.
08:22:05 <tchaypo> the bot seems to not have understood the topic
08:22:21 <tchaypo> no wait, it did, it's my coffee-deprived brain that doesn't understand
08:22:29 <tchaypo> but i approve of this idea.
08:22:48 <SpamapS> helllewwwww bot?
08:23:17 <SpamapS> ok but nobody has anything to socialize
08:23:24 <SpamapS> so, bring us your stories, your status, and your questions, next time
08:24:10 <shardy> Heh, we had a similar item to this on the heat agenda for a year, and we didn't get a single item, not one! ;)
08:24:30 <SpamapS> :(
08:24:33 <shardy> Maybe more folks actually running TripleO attend these meetings tho ;)
08:24:45 <SpamapS> well we _do_ dogfood it for CI
08:24:51 * tchaypo grumbles
08:25:02 <tchaypo> on which note
08:25:08 <SpamapS> #topic CI
08:25:29 <tchaypo> StevenK: i'm going for breakfast after this, I assume you'll be gone by the time I get back, so how about I send you an email overnight?
08:25:52 <tchaypo> I didn't send an update email last week :(
08:26:04 <greghaynes> I have been hearing that the only think preventing hp1 from running jobs is a -infra patch?
08:26:16 <tchaypo> I'll do that later today
08:26:22 <SpamapS> yeah whats up with that infra patch?
08:26:23 <greghaynes> which I assume is us needing someone competent around incase it explodes
08:26:33 <greghaynes> as per infra policy
08:26:40 <tchaypo> do you know what the patch is?
08:26:43 <SpamapS> we've been pretty responsive in the past
08:26:59 <greghaynes> yea, they still like a volunteer to be on point though
08:27:08 <SpamapS> I don't know
08:27:18 <SpamapS> but if somebody could #link it that would be great
08:27:18 <greghaynes> https://review.openstack.org/#/c/126513/
08:27:23 <greghaynes> #link https://review.openstack.org/#/c/126513/
08:27:26 <SpamapS> ty
08:27:53 <SpamapS> all tripleo-cd-admins should be able to respond so let's make sure we do stay on top of it.
08:28:29 <SpamapS> anything else new about CI?
08:28:44 <greghaynes> our pass rate is abismal. its been that way for a while
08:28:56 <SpamapS> seems like we've been debugging and addressing mostly-external issues and barely keeping it stable
08:28:58 <greghaynes> im not sure if we want to do something process wise to help that
08:29:15 <SpamapS> IIRC we had more ubuntu mirror problems
08:29:57 <SpamapS> Ok well.. we should continue to be vigilant and debug CI failures.
08:30:07 <SpamapS> #topic Specs
08:30:39 <SpamapS> Honestly, I"m running out of cognitive ability and the coffee is running out, so... talk amongst yourselves
08:31:03 <tchaypo> I just took a look and realised there are specs I haven't looked at
08:31:12 <SpamapS> yes everybody go read specs. :)
08:32:01 <SpamapS> In the interest of me not passing out on my keyboard in this channel.. I think I'll move on.
08:32:04 <SpamapS> #topic open discussion
08:32:05 <SpamapS> anyone?
08:32:18 <greghaynes> Summit topics!
08:32:20 <greghaynes> er
08:32:23 <greghaynes> mid cycle
08:32:26 <greghaynes> (its late here too)
08:32:36 <SpamapS> yes please review the agenda even if you're not going to be there. :)
08:33:11 <SpamapS> #link https://etherpad.openstack.org/p/kilo-tripleo-midcycle-meetup
08:33:50 <SpamapS> anyone else?
08:33:53 <marios> (unrelated) can we get some eyes on dan's template consolidation reviews @ https://review.openstack.org/#/c/147287/3
08:34:54 <SpamapS> indeed that's an interesting problem
08:37:29 <SpamapS> Ok that's 4 minutes of silence by my count.
08:37:50 <SpamapS> Thank you all for coming, and keep Triple-O'ing everybody.
08:37:57 <greghaynes> gn!
08:38:04 <SpamapS> any further discussions can continue in #tripleo
08:38:10 <SpamapS> #endmeeting