19:05:19 <slagle> #startmeeting tripleo
19:05:20 <openstack> Meeting started Tue Apr 15 19:05:19 2014 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:05:22 <tchaypo> You're all so witty. Clearly you've had time to pre-caffeinate.
19:05:24 <openstack> The meeting name has been set to 'tripleo'
19:05:26 <slagle> Hi everyone!
19:05:34 <Ng> o./
19:05:35 <jdob> o/
19:05:35 <bnemec> o/
19:05:39 <dprince> hello
19:05:50 <jomara> ahoy
19:05:54 <GheRivero> o/
19:06:04 <slagle> #topic agenda
19:06:10 <SpamapS> half here
19:06:13 <slagle> *  bugs
19:06:15 <slagle> * reviews
19:06:21 <slagle> *  Projects needing releases
19:06:25 <SpamapS> on vacation.. but vacation w/ excellent wifi.. :-P
19:06:29 <slagle> *  CD Cloud status
19:06:32 <slagle> *  CI
19:06:40 <slagle> *   Insert one-off agenda items here
19:06:46 <jcoufal> o/
19:06:47 <slagle> good grief
19:06:50 <marios> o/ sorry a bit late
19:06:55 <slagle> i am incapable of copy/pasting the agenda apparently
19:07:03 <greghaynes> O\
19:07:04 <bnemec> :-)
19:07:12 <slagle> #topic bugs
19:07:20 <slagle> #link https://bugs.launchpad.net/tripleo/
19:07:20 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:07:20 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:07:20 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:07:20 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:07:22 <slagle> #link https://bugs.launchpad.net/tuskar
19:07:25 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:08:13 <slagle> we have some untriaged bugs...
19:08:42 <slagle> 4 in tripleo
19:09:40 <tchaypo> I see 4 incomplete, but only one new
19:09:41 <slagle> can someone pick those up and triage?
19:09:52 <slagle> none appear critical to me
19:10:00 <tchaypo> I thought the incomplete ones are considered triaged?
19:10:46 <slagle> not sure what the stance on that is
19:10:48 <lsmola2> hello
19:10:52 <slagle> i like to see an Importance on there
19:11:02 <slagle> although, if incomplete, that can be hard to determine
19:12:22 <slagle> i don't see any other untriaged in the other projects
19:12:27 <tchaypo> That seems reasonable - we should at least be able to figure out what the priority would be if we get the data to support the reported bug
19:13:08 <slagle> tchaypo: indeed, i'm just thinking...if it's not something that reproduces, thus we need more info, etc, it's not likely critical
19:13:56 <slagle> i don't see any unassigned critical bugs
19:14:09 <slagle> anyone have anything to discuss about those?
19:14:15 <slagle> or other bug business for that matter?
19:14:48 <slagle> excellent! everyone agrees to fix all open bugs
19:14:49 <slagle> moving on
19:14:54 <slagle> #topic reviews
19:15:28 <slagle> #link http://www.russellbryant.net/openstack-stats/tripleo-openreviews.txt
19:15:37 <slagle> this was a big topic last week
19:15:47 <slagle> around the backlog of reviews related to exposing configuration
19:15:59 <slagle> i did not see the proposed patches for a configuration pass through?
19:16:03 <slagle> did i miss it?
19:16:15 <dprince> slagle: I volunteered to help but was told Steve K was working on it
19:16:33 <dprince> lifeless: can you confirm someone is working on a pass through option?
19:16:51 <slagle> could be worth following up on the ML about the status on that
19:16:56 <dprince> lifeless: not trying to point any fingers... but would like to not duplicate effort as well
19:17:01 <bnemec> lifeless is out for the beginning of the meeting.  Maybe ask him when he gets here.
19:17:12 <slagle> since he's gone, i'll action him
19:17:28 <slagle> #action lifeless provide status update on config pass though
19:17:32 <dprince> slagle: that was the last I heard anyways, we (someone) needs to implement a pass through option
19:17:51 <slagle> right, i thought it was coming "today or tomorrow" last tuesday
19:17:54 <tchaypo> I've been poking at the problem; it's interesting as a learning exercise
19:18:12 <slagle> i did see the patch for the os-apply-config override templates
19:18:23 <slagle> maybe that was it? dunno for sure
19:18:36 * bnemec thinks we should wait for lifeless and revisit this
19:18:37 <tchaypo> But I have no objection to someone who already understands the space jumping in
19:18:56 <slagle> bnemec: indeed
19:19:06 <tchaypo> I'm fairly sure stevenk hasn't had time to look at it
19:19:20 <slagle> so, we continue to slip on reviews, but i think this is directly related to everyone agreeing not really to review the outstanding config changes last week
19:19:26 <slagle> --> Stats since the last revision without -1 or -2 :
19:19:27 <slagle> ----> Average wait time: 6 days, 8 hours, 19 minutes
19:19:29 <marios> worth noting that the tht reviews are blocked waiting for the software config worke
19:19:46 <bnemec> Yeah, it's hard to tell.  At least half of the longest waiting reviews are config options.
19:19:58 <slagle> marios: yes, and SpamapS is on vacation
19:20:12 <slagle> i do think the software-config support is really high priority for the templates
19:20:27 <slagle> any volunteers to help tests SpamapS's patches that are out there?
19:20:33 <shadower> here
19:20:34 <jprovazn> yes
19:20:41 <jprovazn> I was trying them today
19:20:41 <shadower> been loo,king into it anyway
19:20:44 <slagle> cool, i saw you guys were looking at it :)
19:20:53 <jprovazn> seemed to work fine for me
19:20:55 <slagle> the more folks that jump in and test, the faster that will go
19:21:15 <greghaynes> Yep, are all the os-c-c patches needed for it now merged?
19:21:19 <shadower> the occ patches blocking this just landed
19:21:22 <shadower> we need a release
19:21:22 <greghaynes> w00t
19:21:34 <jprovazn> but I still didn't finish reading through them to the end and understand it completely :)
19:21:36 <lsmola2> I will test it too
19:21:43 <slagle> lsmola2: thanks!
19:21:53 <slagle> any other review business?
19:22:08 <jprovazn> just a nit
19:22:10 <slagle> if you're waiting on reviews...don't be shy about pinging cores in #tripleo
19:22:25 <shadower> yeah
19:22:33 <slagle> don't want to see folks blocked given the backlog
19:22:33 <jprovazn> review stats might be also worse because bunch of reviews are still waiting on success gating tests
19:22:59 <shadower> jprovazn: shouldn't that just affect approvals?
19:23:07 <jprovazn> shadower, yes
19:23:12 <slagle> jprovazn: true, but that doesn't affect all the stats about feedback
19:23:19 <jprovazn> ah, right
19:23:42 <slagle> any other review business?
19:24:04 <slagle> #topic releases
19:24:23 <slagle> i don't mind releasing again this week
19:24:41 <rpodolyaka1> slagle feel free to give this to me, if you are busy :)
19:24:46 <slagle> on a related topic, we are still waiting on some acl overrides in gerrit for commit access to the stable branches
19:24:47 <lifeless> o/ am here now :). not taking over but just able to participate :)
19:25:28 <slagle> rpodolyaka1: i can handle for now :). thx though!
19:26:05 <slagle> #topic CD Cloud Status
19:26:07 <shadower> slagle: so the software config t-h-t patch depends on os-*-config changes that just landed. Would you let me know once the release is out?
19:26:20 <slagle> shadower: yes, will do
19:26:24 <shadower> thanks
19:26:27 <slagle> shadower: will aim to do that one this afternoon
19:26:41 <shadower> cool, I'll pikc it up in EU morning then
19:26:49 <slagle> i'm not actually sure what the status of the CD cloud is. i suspect unchanged from last week
19:27:18 <slagle> #topic CI
19:27:57 <slagle> i think stuff is passing now
19:28:10 <slagle> after the nova fixes from yesterday
19:28:19 <slagle> i'm not sure of the details on that
19:28:25 <slagle> i don't think derekh is here
19:28:44 <lifeless> he's not
19:28:56 <lifeless> I think we should be able to remove his bandaid too
19:29:05 <slagle> i've seen successful runs from this afternoon
19:29:15 <slagle> if you have patches that need to be rechecked, plz do so
19:29:24 <lifeless> dansmith landed a patch that broke bare use of the metadata server without nova-network; its been reverted
19:30:42 <slagle> lifeless: i already see a revert for the bandaid https://review.openstack.org/#/c/87354/
19:31:02 <slagle> although...it failed CI :/
19:31:07 <slagle> likely unrelated
19:31:23 <slagle> anywho, that is in flight
19:31:34 <dprince> slagle: I plan on looking at it..
19:31:39 <slagle> dprince: thx!
19:31:45 <slagle> other CI business?
19:32:00 <slagle> dprince: how goes the reliability of the f20 job?
19:32:22 <dprince> slagle: seems like it is doing better to me. although still slowish on resources
19:32:27 <slagle> i know derek was looking into an issue with nodepool not spinning up fedora nodes
19:32:34 <dprince> slagle: yes
19:33:05 <slagle> k
19:33:09 <slagle> #topic open discussion
19:33:29 <slagle> lifeless: do you have an update on the config pass through proposal from last week?
19:33:36 <lifeless> somewhat
19:33:41 <lifeless> tchaypo has been poking at it
19:33:52 <lifeless> and I've now cleared my plate - I'll be doing that and only that today
19:34:25 <slagle> k, cool
19:34:31 <lifeless> http://lists.openstack.org/pipermail/openstack-dev/2014-April/032768.html <- would like thoughts on this
19:35:27 <greghaynes> Is the plan to then pick some subset of the config change reviews as things we want to expose? Curious if therse some criteria for what we want to do as passthrough and what we dont
19:35:39 <greghaynes> makes it hard to give any review on those otherwise
19:35:54 <lifeless> greghaynes: indeed, so I think we need a layer cake doc
19:36:05 <lifeless> we describe in the overall design the different tools etc
19:36:18 <lifeless> but we don't talk about what not to expose, because there has until now never been a choice
19:37:09 <greghaynes> doc sounds good. Do we err on the side of accepting those reviews as well (if they are fine otherwise)?
19:37:26 <tchaypo> lifeless: I'll talk to you after the meeting about where I'm at.
19:37:36 <lifeless> tchaypo: cool, thanks!
19:37:59 <lifeless> greghaynes: I think not. Like spamaps big patchset, this is going to be hugely hard if lots of little dribs and drabs are landing
19:38:40 <greghaynes> ah, right.. and theres more of that incoming
19:39:04 <SpamapS> I think the things to expose are the things that would be hard to do with the manual injection.
19:39:23 <lifeless> or anything that involves a derivation process
19:39:24 <slagle> lifeless: so the gist of the nova spec proposal is: you submit a review with a spec/design doc. people review the commit as usual, provide feedback etc. then spec gets committed ?
19:39:26 <lifeless> but there are two layers
19:39:34 <lifeless> at the TIE layer, we'll be making things more generic
19:39:54 <lifeless> at the THT layer we'll be modelling the conf files and then exposing is choosing to make it a parameter vs part of the passthrough json
19:40:11 <lifeless> slagle: yes, and blueprints are created at the end of that process
19:40:32 <slagle> ok, i think it could work and like the idea
19:40:47 <lifeless> so for instance, for the passthrough stuff; we'd write a doc in incubator/doc/source/designs/passthough_config.rst
19:41:00 <bnemec> I'm +1 on spec reviews, but last I heard they were still iterating on the nova process and wanted to finish that before applying it to other projects.
19:41:40 <lifeless> there's no reason we can't start ourselves
19:41:41 <bnemec> Although if we put our spec reviews directly in incubator that might help.  Part of it was they didn't want a bunch of infra churn if things changed.
19:41:55 <slagle> yea, let's be trendsetters
19:42:01 <lifeless> they aren't in a position to say 'this is what everyone should do' yet is all
19:42:07 <lifeless> which really, thats a TC call
19:42:41 <ccrouch> do they have some sort of folder/naming convention so we dont end up with a sea of notstarted/completed/inprogress/abandoned designs ?
19:42:57 <ccrouch> maybe we just want a folder per cycle?
19:43:15 <lifeless> Good question; perhaps wait and see?
19:43:33 <slagle> yea, and more real time status will be tracked in the blueprint i suspect
19:43:56 <ccrouch> true
19:44:02 <slagle> oh, before i forget, everyone please submit your design session proposals for Atlanta before Friday
19:44:09 <slagle> #link http://summit.openstack.org/
19:45:01 <slagle> any other business or shall we end early?
19:45:52 <slagle> guess not! bye folks! c ya in #tripleo
19:45:54 <slagle> #endmeeting