19:02:33 <lifeless> #startmeeting tripleo
19:02:34 <openstack> Meeting started Tue Dec  3 19:02:33 2013 UTC and is due to finish in 60 minutes.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:36 * markmc ~10% here
19:02:37 <openstack> The meeting name has been set to 'tripleo'
19:02:45 <lifeless> #topic agenda
19:02:51 <jomara> hello there
19:02:57 <lifeless> bugs
19:02:58 <lifeless> reviews
19:02:58 <lifeless> Projects needing releases
19:02:58 <lifeless> CD Cloud status
19:02:58 <lifeless> CI virtualized testing progress
19:03:00 <lifeless> Insert one-off agenda items here
19:03:02 <lifeless> open discussion
19:03:14 <lifeless> (I forgot to remove summit wrap-up from the agenda list - oops)
19:03:17 <lifeless> #topic bugs
19:03:24 <lifeless> #link https://bugs.launchpad.net/tripleo/
19:03:24 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
19:03:24 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
19:03:24 <lifeless> #link https://bugs.launchpad.net/os-apply-config
19:03:24 <lifeless> #link https://bugs.launchpad.net/os-collect-config
19:03:26 <lifeless> #link https://bugs.launchpad.net/tuskar
19:03:29 <lifeless> #link https://bugs.launchpad.net/tuskar-ui
19:03:31 <lifeless> #link https://bugs.launchpad.net/python-tuskarclient
19:03:46 <marios_> evening all, apologies baby a bit poorly tonight so not paying too much attention to irc
19:03:52 * coolsvap is away: Away!!!
19:04:12 <lifeless> marios_: :( hope baby feels better soon
19:05:31 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1254246
19:05:36 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1254555
19:05:44 <SpamapS> lifeless: those are making progress upstream from what I see.
19:05:47 <lifeless> https://bugs.launchpad.net/diskimage-builder/+bug/1252975
19:05:51 <lifeless> SpamapS: is there a bug for dnsmasq?
19:05:52 <SpamapS> lifeless: we have regressed _a lot_ from where we were when we found those
19:06:07 <SpamapS> lifeless: no I just made a trello card a bit ago, probably deserves a bug now though.
19:06:23 <lifeless> SpamapS: ok, please do
19:06:28 <SpamapS> lifeless: starting to feel like we're getting deep in the entropy...
19:06:40 <lifeless> so the third critical is fix committed and roman has volunteered to cut releases this week
19:06:58 <lifeless> Untriaged bugs - we have one : https://bugs.launchpad.net/diskimage-builder/+bug/1256982
19:07:11 <lifeless> which is massively better than before we started paying attention
19:07:41 <lifeless> and only 12 hours old or something, so I think we can accept that ;) - but please do keep up the triage work!
19:08:02 <lifeless> any other bugs discussion ?
19:08:36 <lifeless> nope, moving on
19:08:38 <lifeless> #topic reviews
19:09:01 <lifeless> I was going to send out my monthly core review yesterday but the day exploded
19:09:04 <lifeless> I will get that done today
19:09:12 <lifeless> http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:09:17 <lifeless> 
19:09:18 <lifeless> Stats since the last revision without -1 or -2 :
19:09:23 <lifeless> Median wait time: 0 days, 7 hours, 45 minutes
19:09:23 <lifeless> 3rd quartile wait time: 1 days, 3 hours, 39 minutes
19:09:52 <lifeless> That 3rd quartile means there is at least one patch that doesn't have a -1 or -2 thats been there more than a day
19:10:10 <SpamapS> I've been basically absent from reviews save for the ones I'm already involved in for the last week or so.
19:10:18 <tzumainn> lifeless, the thanksgiving holiday might have affected that
19:10:38 <lifeless> tzumainn: it's over since Monday no?
19:10:50 <tzumainn> oh, sorry, I thought that was since last tuesday
19:10:52 <tzumainn> my bad!
19:11:12 <slagle> https://review.openstack.org/#/c/59299/
19:11:14 <slagle> must be that one
19:11:17 <lifeless> tzumainn: I may be wrong, I don't know US holidays.
19:11:23 <lifeless> SpamapS: when did Thanksgiving finish ?
19:11:29 <slagle> which, i think folks are just waiting on, given the discussion on the topic in the other review
19:11:52 <tzumainn> sorry, I thought you meant that patch reviews were a little slow over the past week
19:12:27 <lifeless> slagle: yeah, I think thats the cause, which will happen from time to time; it would be nice to have the stats take that into account
19:12:49 <lifeless> slagle: I'll chat with russellb and see if thats doable
19:12:56 <slagle> yea, or switch that to WIP
19:12:59 <SpamapS> lifeless: yesterday
19:13:12 <lifeless> slagle: also your patch which is +1'd but not +2'd
19:13:23 <lifeless> SpamapS: as in mon was holiday tuesday work day?
19:13:27 <SpamapS> no
19:13:42 <SpamapS> as in last Thursday/Friday were a holiday
19:13:49 <SpamapS> followed by weekend
19:13:57 <dprince> lifeless: I think what is happening here is your -2 is warding people off of reviewing my series
19:13:59 <slagle> lifeless: which one is that? the dib element?
19:13:59 <SpamapS> yesterday was the first day back for people
19:14:16 <SpamapS> and a lot of people (myself included) took days before Thursday off as part of it.
19:14:35 <lifeless> slagle: yes
19:15:12 <lifeless> dprince: it does block the series yes; the bottom patch should be reviewable, but I do see the discussion about is-it-needed which takes the rest of the series into account
19:15:59 <lifeless> ok, so it seems that we're pretty healthy review wise; any other review business to attend to ?
19:16:06 <lifeless> #action lifeless to do core review email asap
19:16:11 <dprince> lifeless: I don't mind the debate. In my experience a -2 on a patch/branch in many cases gets you less comments
19:16:11 <tzumainn> lifeless, it might be also worth mentioning that a lot of the developers working on tuskar-ui have been working and reviewing in the horizon arena
19:16:25 <lifeless> tzumainn: good stuff!
19:16:38 <lifeless> #note 08:16 < tzumainn> lifeless, it might be also worth mentioning that a lot of the developers working on tuskar-ui have been working and reviewing in the horizon arena
19:18:30 <lifeless> ok, moving on
19:18:40 <lifeless> #topic Projects needing releases
19:19:00 <lifeless> Many of our projects do, and roman (who isn't here) has volunteered.
19:19:10 <lifeless> So, unless someone wants to debate doing that; we can move on...
19:19:26 <SpamapS> seconded.. move on. :)
19:20:08 <lifeless> #topic CI virtualized testing progress
19:20:18 <lifeless> pleia2: your fav time, conflicts with -infra meeting :)
19:20:37 <pleia2> I don't have any updates right now, holiday put a crimp in things
19:21:18 <pleia2> saw some changes from derekh come in, dprince any updates?
19:25:10 <pleia2> 11:24:53 < dprince> pleia2: last week was mostly a holiday, so not much CI stuff yet, Derek has made progress on the gearman eleements though. Soon I plan on tackling making TOCI use the devtest scripts...
19:25:14 <pleia2> lifeless: I think we can move on :)
19:25:24 <lifeless> okydoky
19:25:41 <lifeless> We should add a section on the TripleOCloud status!
19:25:51 <lifeless> #topic TripleOCloud status
19:25:57 <lifeless> SpamapS: I believe you're most up to date :0
19:26:36 <SpamapS> Right
19:26:57 <SpamapS> So somewhere between a reboot and other things I don't have all the information on, basically everything broke.
19:27:22 <lifeless> The reboot was because ml4xcore wedged on rmmod
19:27:37 <SpamapS> I'm currently tracking down timeouts for things booting to tftp not working after DHCP. Also dnsmasq was segfaulting, but I think that may have been a bug in dnsmasq+neutron which is fixed in both in newer versions.
19:27:38 <lifeless> left it for hours
19:28:03 <lifeless> how would neutron make dnsmasq segfault?
19:28:14 <SpamapS> lifeless: by putting an invalid format in the configuration
19:28:34 <SpamapS> Dec  3 19:28:17 undercloud-notcompute-jws3awlsb2kh dnsmasq[14821]: bad IP address at line 11 of /var/run/neutron/dhcp/e85b44c7-1136-4217-954e-cdf0acdddfe1/opts
19:28:47 <lifeless> oh, nasty.
19:28:48 <SpamapS> lifeless: that is what is being printed now, instead of segfault
19:28:57 <SpamapS> I think
19:28:58 <lifeless> so we need to upgrade Neutron on the undercloud now?
19:28:59 <SpamapS> 90% sure
19:29:18 <dkehn> bad IP address and you a segfault, ouch
19:29:19 <SpamapS> lifeless: well I upgraded dnsmasq, and that has stopped the segfaults, but it still crashed for some unknown reason last night while tripleo-cd was running
19:29:29 <lifeless> wow
19:29:30 <lifeless> tag:ece4c8aa-15c9-4f6b-8c42-7d4e285734bf,option:server-ip-address,
19:29:34 <lifeless> thats the line in question
19:29:46 <dkehn> so no IP address
19:29:47 <SpamapS> lifeless: I think it is actually the line that has no newline on it
19:29:49 <lifeless> its missing an ip after the tag
19:29:56 <SpamapS> but I could be wrong
19:30:00 <SpamapS> I haven't done deep analysis
19:30:01 <lifeless> SpamapS: both are bugged
19:30:04 <SpamapS> just bisecting things right now
19:30:35 <lifeless> SpamapS: you're right on it, this is a bug in the neutron tag code; for some reason we have a dhcpopt where the value is invalid, and neutron is still writing it out
19:30:49 <lifeless> SpamapS: this suggests that we need validation there
19:30:54 <SpamapS> that may have been something that was broken mid-reboot
19:30:59 <lifeless> nah
19:31:23 <lifeless> neutron port-show ece4c8aa-15c9-4f6b-8c42-7d4e285734bf
19:31:32 <dkehn> Hrm, the db is setup for NON NULL so thats interesting
19:31:32 <lifeless> you can see the options are blank
19:31:41 <lifeless> dkehn: I think they are empty strings
19:31:52 <dkehn> yah
19:31:57 <SpamapS> lifeless: could this also be why I can't reach 10.10.16.172 ?
19:32:01 <lifeless> SpamapS: no
19:32:06 <SpamapS> could be that causes issues with l3 agent too?
19:32:14 <SpamapS> wait no we don't do that on undercloud
19:32:22 <lifeless> SpamapS: oh, possibly; lets -> #tripleo for that
19:32:25 <SpamapS> yeah
19:32:25 <lifeless> we're in the weeds
19:32:35 <SpamapS> So anyway, firedrill under way..
19:32:36 <lifeless> short story, CD cloud broke, bad booboo; bugs being uncovered.
19:32:39 <SpamapS> once that is solved..
19:32:40 <lifeless> ok
19:32:52 <lifeless> #topic open discussion
19:33:02 <jtomasek> jcoufal asked me to mention the new wireframes for Deployment and Resource Management.
19:33:12 <jtomasek> So here are the askbot links:
19:33:19 <jtomasek> http://ask-openstackux.rhcloud.com/question/95/tripleo-ui-resource-management/
19:33:25 <jtomasek> http://ask-openstackux.rhcloud.com/question/96/tripleo-ui-deployment-management/
19:33:33 <SpamapS> How come those are discussed on askbot and not the mailing list?
19:33:51 <lifeless> SpamapS: oh no you didn't
19:34:14 <jtomasek> SpamapS: He also sent an email to mailing list, but UX stuff is prefered to discuss on askbot
19:34:27 <lifeless> SpamapS: thats a long running debate about needed facilities
19:35:22 <tzumainn> so I sent a reply asking for a list of requirements driving the wireframes - I feel like that would help me best understand/evaluate what's going on - am I the only one that feels that way?
19:35:54 <lifeless> tzumainn: I think thats a good thing to have yes; we have that thread where we started to get into such things
19:36:03 <matty_dubs> tzumainn: I don't think you're the only one.
19:36:51 <jomara> +1 to that
19:38:03 <matty_dubs> (That's not to say I take issue with anything in them, just that I could use some more context/background.)
19:38:14 <matty_dubs> (so as to fully appreciate them)
19:41:27 <dkehn> SpamapS: will get with you later on the empty string, may be a bug and I think I can fix it in neutron
19:41:46 <SpamapS> dkehn: we should probably just try pulling the latest neutron
19:42:17 <dkehn> SpamapS: true, but I'm want to verufy that it can happen, which I think it can
19:42:25 <SpamapS> dkehn: ok I won't touch it
19:43:23 <lifeless> dkehn: is it alright if we update that port so we can resume deploying ?
19:43:41 <lifeless> dkehn: SpamapS: I suggest spamaps file a bug for this
19:43:42 <dkehn> lifeless: please do I've got all I need to reproduce
19:43:43 <SpamapS> I think this is all weedy stuff for #tripleo
19:43:52 <SpamapS> but yes, bug I will file
19:43:53 <lifeless> ok, so
19:43:55 <SpamapS> and I'll dump the database
19:43:55 <lifeless> #endmeeting