19:00:25 <lifeless> #startmeeting tripleo
19:00:26 <openstack> Meeting started Tue Oct  1 19:00:25 2013 UTC and is due to finish in 60 minutes.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:29 <openstack> The meeting name has been set to 'tripleo'
19:00:32 <lifeless> #topic agenda
19:00:34 <lsmola> o/
19:00:42 <lifeless> bugs
19:00:42 <lifeless> Projects needing releases
19:00:42 <lifeless> Grizzly test rack status
19:00:42 <lifeless> CI virtualized testing progress
19:00:42 <lifeless> Insert one-off agenda items here
19:00:45 <lifeless> Tuskar UI design update discussion
19:00:47 <lifeless> CD proposal
19:00:50 <lifeless> open discussion
19:00:52 <lifeless> #topic bugs
19:01:06 <lifeless> #link https://bugs.launchpad.net/tripleo/
19:01:06 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
19:01:06 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
19:01:06 <lifeless> #link https://bugs.launchpad.net/os-apply-config
19:01:08 <lifeless> #link https://bugs.launchpad.net/os-collect-config
19:01:11 <lifeless> #link https://bugs.launchpad.net/tuskar
19:01:13 <lifeless> #link https://bugs.launchpad.net/tuskar-ui
19:01:16 <lifeless> #link https://bugs.launchpad.net/python-tuskarclient
19:01:34 <lifeless> Hey everyone, welcome to the first unified meeting
19:02:52 <lifeless> so, in dib we have one critical
19:03:32 <lifeless> which should be fix-released
19:04:22 <lifeless> https://bugs.launchpad.net/os-collect-config/+bug/1233656 looks like it will be a fun bug
19:04:44 <lifeless> I'm going to bet it's global requirements time...
19:05:03 <lifeless> I see https://bugs.launchpad.net/tuskar has lots of undecided bugs
19:05:12 <lifeless> shadower: hey
19:05:32 <lifeless> shadower: we haven't updated the tuskar bug teams I think; I can't triage on tuskar
19:05:54 <lifeless> shadower: should we do the same thing we did for review teams? just merge, and update the projects to use the combined team?
19:05:55 <lsmola> lifeless, I think he is not here
19:06:11 <lsmola> lifeless, most of the brno team is on cloud party
19:06:18 <SpamapS> DOH
19:06:22 <matty_dubs> And they didn't invite us?
19:06:33 <lsmola> well it's in Brno :-)
19:07:08 <matty_dubs> Speaking as a not-in-charge Tuskar person, though, merging teams in LP makes sense to me
19:07:32 <lifeless> ok
19:07:59 <lsmola> make sense for me too
19:08:08 <rpodolyaka1> +1
19:08:09 <lifeless> #action shadower to reconfigure tuskar,tuskar-ui,python-tuskarclient in LP to use the tripleo team for driver/bug triage etc.
19:08:11 <tzumainn> +1
19:08:21 <lifeless> #action lifeless to pull into the tripleo team the existing tuskar team members
19:08:35 <lifeless> those two things combined should DTRT
19:08:53 <lifeless> so there's a bunch of triage needed in tuskar
19:09:05 <lifeless> and tuskar-ui
19:09:15 <lifeless> python-tuskarclient is in better shape
19:09:32 <lifeless> Reminder: everyone should triage; it doesn't need to be closely held :)
19:09:48 <lifeless> Once the teams are sorted, I'm sure that will be easier
19:11:27 <lifeless> we have bug 1233596
19:11:36 <lifeless> hmm, no urlifier, pok
19:11:50 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1233596
19:11:54 <lifeless> lets ensure thats fixed asap
19:12:18 <rpodolyaka1> should be an easy pie, AFAIK
19:12:19 <lifeless> the existing POC bugs can be closed I think
19:13:29 <lifeless> I think we're going to have to close https://bugs.launchpad.net/tripleo/+bug/1189385 as cannot-reproduce
19:13:32 <lifeless> as it hasn't happened again
19:13:40 <lifeless> any thoughts
19:13:41 <lifeless> ?
19:13:43 <marios> lifeless: seems like tuskar saw that "six < 1.4" issue too (https://bugs.launchpad.net/os-collect-config/+bug/1233656) @ https://review.openstack.org/#/c/44689/
19:14:39 <SpamapS> lifeless: agreed on POC bugs, they are too far away from any future-focused work to be useful and they don't have data points.
19:16:37 <SpamapS> lifeless: re neutron/quantum wonkiness.. I think it is a data point and perhaps just deserves demotion to Medium until we see it again.
19:17:04 <rpodolyaka1> anyone but me and derekh seeing this https://bugs.launchpad.net/tripleo/+bug/1231930 ?
19:18:04 <lifeless> rpodolyaka1: I haven't heard of it no
19:18:10 <lifeless> rpodolyaka1: you see derekh's theory on gre?
19:18:24 <lifeless> marios: interesting
19:18:55 <rpodolyaka1> lifeless: I applied the fix, he proposed in the bug description and it works. not sure, how correct this is
19:19:06 <lifeless> SpamapS: where does the <1.4.0 come from for six?
19:19:18 <SpamapS> lifeless: global reqs
19:19:23 <lifeless> SpamapS: not anymore
19:19:26 <SpamapS> I believe there is a patch in queue to address
19:19:39 <SpamapS> https://review.openstack.org/#/c/49194/1/requirements.txt
19:19:45 <lifeless> SpamapS: six
19:19:46 <rpodolyaka1> lifeless: though derekh fixed this in Fedora by adding of an iptables rule (this doesn't fix the problem for Ubuntu 13.04/OVS 1.9)
19:19:51 <lifeless> SpamapS: is whats in global-requirements.
19:19:56 <lifeless> rpodolyaka1: oh, you're seeing it in Ubuntu ?
19:20:04 <rpodolyaka1> lifeless: yep
19:20:15 <SpamapS> lifeless: approve that and I'll tag a release
19:20:41 <rpodolyaka1> looks like an OVS bug to me, though I can be wrong
19:20:57 <rpodolyaka1> we'd better ping Neutron guys to take a look at this one
19:21:05 <lifeless> SpamapS: done
19:21:12 <derekh> rpodolyaka1: if the iptable rule doesn't help for your situation then look like a different problem
19:21:15 <lifeless> rpodolyaka1: so, clearly something wrong
19:21:34 <lifeless> rpodolyaka1: I don't think the hard timeot is appropriate; the timeout is to prevent cruft building up over time
19:21:50 <derekh> rpodolyaka1: I definatly had a VM I couldn't contact, and then could after allowing gre
19:22:00 <derekh> rpodolyaka1: tested several times
19:22:39 <rpodolyaka1> derekh: Fedora has kernel 3.11 and ovs 1.11
19:22:39 <SpamapS> lifeless: sweet ty
19:23:20 * rpodolyaka1 is tired of fighting with ovs/neutron and blames versions of software...
19:23:20 <derekh> rpodolyaka1: yup
19:23:34 <lifeless> is there anyone setup with an overcloud that *doesn't* show this problem ?
19:23:36 <shadower> lifeless: sorry, yeah let's merge the LP teams
19:24:11 <lifeless> shadower: if you change the owner of the tuskar teams, I can do the merging for you
19:24:15 <lifeless> shadower: (to me that is)(
19:26:07 <shadower> lifeless: done for tuskar and tuskar-ui. I can't change the pythonclient, will ask the cli guys to do that tomorrow
19:26:22 <derekh> rpodolyaka1: before ovs was updated on fedora, (and we had ovs 1.10, this command was returing a -1
19:26:24 <derekh> ovs-vsctl get Interface gre-1 ofport
19:26:28 <lifeless> shadower: ack, thanks
19:27:29 <rpodolyaka1> derekh: I checked neutron logs on compute/notcompute - all OVS calls exit codes  equal 0
19:28:08 <lifeless> rpodolyaka1: derekh: lets take this offline from the meeting.
19:28:16 <rpodolyaka1> sure
19:28:23 <lifeless> rpodolyaka1: derekh: I suggest expanding the eyeballs that look at it e.g. via the -dev list.
19:28:33 <lifeless> ther's nothing obviously tripleo specific about the fail
19:28:55 <derekh> okie dokie
19:29:12 <lifeless> #topic Projects needing releases
19:29:30 <lifeless> I've added this section because I want to ensure we don't leave useful things locked up in git HEAT
19:29:33 <lifeless> bah
19:29:35 <lifeless> HEAD
19:30:40 <SpamapS> etoomany names
19:31:12 <lifeless> so
19:31:15 <SpamapS> lifeless: is there a quick git command to say "show me everything since the last tag" ?
19:31:25 <lifeless> git log 0.0.4..HEAD
19:31:30 <lifeless> oh, last tag
19:31:31 <lifeless> possibly
19:31:40 <SpamapS> well getting the last tag isn't _that_ difficult
19:31:42 <lifeless> so dib needs a release.
19:32:02 <lifeless> occ needs a release
19:33:09 <lifeless> oac needs one
19:33:49 <lifeless> orc needs one
19:34:09 <SpamapS> orc?
19:34:15 <lifeless> Update stackforge references to openstack
19:34:18 <lifeless> affects metadata
19:34:28 <SpamapS> Yeah surprised that we have any changes. ;)
19:34:42 <SpamapS> #action SpamapS release all the things
19:35:05 <lifeless> shadower: / anyone with tuskar history :) - has python-tuskarclient done a release?
19:35:06 <SpamapS> lets try and land anything in the patch queue first
19:35:14 <lifeless> likewise the tuskar api and ui ?
19:35:30 <marios> lifeless: don't believe so
19:35:33 <marios> (no)
19:35:40 <lifeless> so, unreleased code is unusable code :>
19:35:45 <marios> for any of them
19:36:05 <shadower> yea
19:36:15 <lifeless> I think we should put this out to the list for discussion, but I'd like to get the tuskar bits on the release train sooner rather than later
19:36:24 <lifeless> python-tuskarclient isn't contentious
19:36:39 <lifeless> however ttx may have opinions about incremental delivery of web services.
19:36:47 <shadower> yea, it'd be great to point people to something we know works
19:36:59 <shadower> first step: get it work :)
19:37:00 <lifeless> if there are no objections, I'll raise the subject on the dev list
19:37:05 <shadower> +1
19:37:12 <ccrouch> lifeless: speaking of releases
19:37:28 <ccrouch> what about another t-i-e release?
19:37:35 <lifeless> oh, I did not check it
19:37:44 <lsmola> +1
19:37:49 <lifeless> and tht too probably.
19:37:53 <lifeless> SpamapS: ^ ALL the things
19:38:02 <SpamapS> tht needs one too
19:38:04 <SpamapS> :)
19:38:06 <marios> speaking of which, would be awesome if we could land https://review.openstack.org/#/c/47589/ in there too
19:38:09 <ccrouch> more things....
19:38:10 <lifeless> SpamapS: btw I think 'land everything first' is an antipattern.
19:38:11 <marios> (tie)
19:38:16 <ccrouch> t-h-t
19:38:19 <SpamapS> lifeless: fair enough
19:38:21 <lifeless> SpamapS: we have inventory, ship it.
19:38:44 <ccrouch> https://git.openstack.org/cgit/openstack/tripleo-heat-templates/refs/ no releases so far
19:38:45 <lifeless> SpamapS: review shouldn't be rushed; and putting release after review pressures review.
19:38:45 <SpamapS> lifeless: but its like, an entire command, _each_ repo.. to do a release.
19:38:49 <SpamapS> _a whole command_
19:38:54 <rpodolyaka1> marios: seems to be working now... going to try once again tomorrow and remove WIP status
19:38:55 <lifeless> SpamapS: I know, right.
19:39:14 <marios> rpodolyaka1: awesome, was going to ping you about that tomorrow
19:39:48 <rpodolyaka1> marios: depends on https://review.openstack.org/#/c/47826/ be merged into tuskar-api though
19:40:17 <lifeless> ok, anything else on releases  ?
19:40:20 <ccrouch> SpamapS: thoughts on a t-h-t release ?
19:40:40 <marios> rpodolyaka1: noted, lets talk tomorrow
19:41:35 <SpamapS> ccrouch: its been a grab bag of fail for a while now... but I've been pondering adding tox support so it runs its tests in the gate... releases naturally would follow that.
19:42:47 * ccrouch grabs his bag of fail and runs
19:42:48 <lifeless> I agree; though I don't think we /have/ to have CI to do 0.y.z releases
19:42:51 <lifeless> per semver.
19:43:05 <lifeless> #topic Grizzly test rack status
19:43:08 * ccrouch would be pretty stoked with just a tag :-)
19:44:18 <SpamapS> ccrouch: I'd love to have the first release have a merge.py that isn't god awful.
19:44:29 <SpamapS> but that wouldn't be a first release would it?
19:44:31 <lifeless> SpamapS: release early, release often :>
19:44:41 <SpamapS> "if your first release isn't embarassing..."
19:44:48 <lifeless> then it's not an MVP
19:44:54 <lifeless> so the grizzly test rack is going to die
19:45:03 <lifeless> I hope we'll agree to replace it with a trunk POC rack
19:45:15 <lifeless> Please a) see my email to the list
19:45:31 <lifeless> and b) give feedback! So far it's been an overwhelming silence...
19:45:44 <lifeless> with a few direct IRC comments saying 'hell yeah'[6~
19:46:15 * shadower should be able to find some code review & email time tomorrow
19:47:02 <lifeless> #topic CI virtualized testing progress
19:47:18 <lifeless> pleia2: , clarkb:, mordred: and I spoke in person in Seattle about this
19:47:24 <lifeless> there is a new plan
19:47:37 <mordred> you have to say new plan in a loud deep voice
19:47:53 <lifeless> New Plan
19:48:00 <mordred> there you go
19:48:04 <lsmola> hehe
19:48:08 <lifeless> https://etherpad.openstack.org/tripleo-test-cluster
19:48:13 <lifeless> #link https://etherpad.openstack.org/tripleo-test-cluster
19:48:40 <lifeless> I propose that the tooling for this can be brought up in parallel with the cloud we'll need to run it on
19:48:58 <lifeless> we may have one machine already that it can run on
19:49:09 <lifeless> and we have a (non-state-preserving) overcloud we can run it on already
19:49:17 <lifeless> kindof
19:49:56 <lifeless> pleia2: does that make sense to you? Are you able to push the infra glue forward if the tripleo folk push the cloud it'll run in forward?
19:50:17 <lifeless> I'll make sure that we have a set of action items in the spec, and probably fairly specific kards for it in kanban
19:50:21 <pleia2> lifeless: yeah, working closely with clarkb on this so between the two of us we can get whatever you need done
19:50:35 <lifeless> pleia2: ok cool; I will drill in in detail with you post meeting then ?
19:50:47 <pleia2> lifeless: sounds good
19:50:47 <lifeless> #action lifeless and pleia2 to talk turkey on ci story
19:51:04 <lifeless> #topic Tuskar UI design update discussion
19:52:16 <lifeless> so there are some tuskar ui updates based on the list discussion
19:52:20 <lifeless> the designers would love feedback
19:52:31 <lifeless> "
19:52:32 <lifeless> Updated processes in Tuskar-UI in order to be more flexible.
19:52:32 <lifeless> Change is reflected in wireframes + there is a link for youtube stream (posted in openstack-dev list, with [Tuskar] prefix in subject).
19:52:35 <lifeless> Change is demonstrated in UI but it affects API a lot. API needs to be as flexible as possible to support multiple architectures and concepts which were presented in the UI.
19:52:39 <lifeless> "
19:52:49 <lifeless> Please have a look at this and discuss on the list
19:53:02 <lifeless> It's a high leverage chance to influence things for quite some time
19:53:17 <lifeless> #topic CD proposal
19:53:34 <lifeless> (Sorry for pushing through, we have a lot of content today)
19:53:43 <lifeless> This is about running a reference TripleO cloud
19:53:58 <lifeless> Which we'd all be collaboratively responsible for
19:54:17 * SpamapS loves the idea
19:54:30 <lifeless> I sent a mail to the list
19:54:43 <lifeless> has anyone had a chance to see it and think through/got questions ?
19:56:02 <lifeless> ok, deferring to the list then
19:56:14 <lifeless> #topic open discussion
19:56:55 * matty_dubs reading that mail now
19:58:54 <matty_dubs> As far as open discussion goes, and hearing a lot of silence, I should say that I'm excited that tuskar and tripleo are united!
19:59:08 <lsmola> yaaay
19:59:22 <lsmola> :-)
19:59:55 <lifeless> matty_dubs: cool :)
20:00:00 <lifeless> ok, out of time
20:00:02 <lifeless> #endmeeting