20:01:55 <lifeless> #startmeeting tripleo
20:01:56 <openstack> Meeting started Mon Jul  8 20:01:55 2013 UTC.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:59 <openstack> The meeting name has been set to 'tripleo'
20:02:02 <lifeless> #topic agenda
20:02:06 <NobodyCam> morning lifeless :)
20:02:08 <lifeless> bugs
20:02:09 <lifeless> Grizzly test rack status
20:02:09 <lifeless> CI virtualized testing progress
20:02:14 <lifeless> open discussion
20:02:40 <lifeless> #topic bugs
20:02:42 <lifeless> #link https://bugs.launchpad.net/tripleo/
20:03:25 <lifeless> #link https://bugs.launchpad.net/os-config-applier
20:03:31 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
20:03:38 <SpamapS> bug 1182249 and bug 1183223 are still kind of in limbo due to ordering things.. once I finish integrating orc and oac with occ I can address them
20:03:40 <uvirtbot> Launchpad bug 1182249 in tripleo "quantum configuration is overly hardcoded" [Critical,In progress] https://launchpad.net/bugs/1182249
20:03:41 <uvirtbot> Launchpad bug 1183223 in tripleo "nova-compute.yaml missing parameters" [Critical,In progress] https://launchpad.net/bugs/1183223
20:03:51 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
20:04:02 <lifeless> cool
20:04:12 <SpamapS> occ "works" now
20:04:15 <lifeless> bug 1182241 I have in hand
20:04:16 <uvirtbot> Launchpad bug 1182241 in tripleo "first-boot.d rules are running on every boot" [Critical,Triaged] https://launchpad.net/bugs/1182241
20:04:24 <lifeless> With my stack of patches landing
20:04:46 <lifeless> all the boot-stack first-boot rules are now orc rules
20:05:06 <SpamapS> swweeeeeeetttt
20:05:18 <lifeless> except one fedora one which I've mentioned to lucasgnomes/derekh
20:05:26 <lifeless> Ng: https://review.openstack.org/#/c/35943/ doesn't look like you actually clicked on it
20:06:45 <lifeless> Ng: I may have misunderstood your IRC feedback
20:07:28 <lifeless> bug 1189385 and bug 1184484 seem stalled neutron side
20:07:30 <uvirtbot> Launchpad bug 1189385 in tripleo "quantum-server hung up it's listening port" [Critical,Triaged] https://launchpad.net/bugs/1189385
20:07:32 <uvirtbot> Launchpad bug 1184484 in tripleo "Quantum default settings will cause deadlocks due to overflow of sqlalchemy_pool" [Critical,Triaged] https://launchpad.net/bugs/1184484
20:07:38 <lifeless> #action lifeless follow up on those bugs
20:09:02 <lifeless> and thats all our criticals.
20:09:21 <lifeless> I haven't actually rearranged highs yet, OTOH I started closing some myself.
20:09:34 <lifeless> Perhaps we don't need to rearrange, just have folk start cherrypicking highs ?
20:10:37 <SpamapS> +1 for cherry pick
20:10:46 <SpamapS> a bug a week will keep us from getting burried
20:11:21 <lifeless> ok
20:11:56 <lifeless> anymore bugs discussion ?
20:12:12 <SpamapS> do we need a bug tracker for orc and occ?
20:12:26 <lifeless> we have one for orc
20:12:32 <lifeless> didn't I link it?
20:12:40 <Ng> lifeless: fixed. I thought I had clicked that one
20:12:42 <lifeless> I did : https://bugs.launchpad.net/os-refresh-config
20:12:43 <SpamapS> ah yes later
20:12:49 <SpamapS> lifeless: ok so occ will need one too
20:13:13 <lifeless> lets us the same lp teams as tripleo does
20:13:25 <lifeless> I don't think we need per-project granularity - or do we?
20:13:34 <SpamapS> no definitely not
20:13:41 <lifeless> Ng: thanks!
20:13:56 <SpamapS> 1 team should handle tripleo-* and os-* for now
20:14:04 <lifeless> and dib :)
20:14:11 <lifeless> okies
20:14:13 <SpamapS> yeah KISS :)
20:14:20 <lifeless> #topic Grizzly test rack status
20:14:25 <lifeless> Still working.
20:14:42 <lifeless> We had some reports of instance startup glitchiness, but haven't actually confirmed.
20:14:48 <Ng> lifeless: I've not seen any more mails about dying quantum/etc bits - are they still throwing load at it?
20:14:55 <lifeless> SpamapS: you were going to file bugs for the things we need to do to make it long lived.
20:15:00 <Ng> (or am I just terrible at email ;)
20:15:10 <lifeless> Ng: there are instances running, I too have not heard any more.
20:15:36 <SpamapS> lifeless: indeed I was. action me?
20:15:43 <lifeless> #action SpamapS to do what SpamapS does
20:15:56 <lifeless> Any other POC rack business?
20:16:36 <lifeless> #topic CI virtualized testing progress
20:16:53 <lifeless> pleia2: oh hai
20:18:10 <lifeless> ok, I'm going to time out that ping :)
20:18:20 <lifeless> I haven't heard anything more from pleia2 - has anyone else?
20:18:52 <SpamapS> no
20:18:59 <SpamapS> guessing the US holiday interfered
20:19:02 <lifeless> ah
20:19:04 <lifeless> likely
20:19:12 <lifeless> It's kind of related
20:19:19 <lifeless> so I'll take a second to talk about devtest
20:19:31 <lifeless> devtest now covers all the way up to heat spawning an overcloud
20:19:47 <lifeless> of course, we don't have a scalable heat template for an overcloud
20:20:00 <lifeless> so its a bit of a lie
20:20:02 <SpamapS> hm
20:20:21 <SpamapS> I have been distracted elsewhere, but the main reason we didn't use nova-compute-group.yaml was the hostname issue, right?
20:20:22 <lifeless> SpamapS: as I recall we kindof do
20:20:27 <lifeless> SpamapS: yes I think so
20:20:34 <SpamapS> ok, that is solved
20:20:45 <SpamapS> - is used instead of ., and i believe there is a random component now too
20:20:46 <lifeless> SpamapS: I may need a little hand holding today, if you can
20:21:40 <SpamapS> lifeless: sure, I'll be out of pocket for 2 hours after the meeting but then should be around to help
20:21:44 <pleia2> lifeless: no updates from me, holiday plus other things (needed to refresh my dev environment to flush out some network gremlins)
20:21:53 <lifeless> SpamapS: awesome
20:21:57 <lifeless> pleia2: ack!
20:22:05 <lifeless> toci is catching stuff too which is good
20:22:06 <lifeless> ok
20:22:09 <lifeless> #topic open discussion
20:22:23 <pleia2> toci is failing at the moment, probably needs some eyeballs on that
20:22:45 <SpamapS> last I saw was some 404 on pypi
20:22:52 <pleia2> ah, good
20:22:59 <pleia2> (well, not good, but you know)
20:23:18 <SpamapS> its the kind of not good we know how to handle I think
20:23:23 <pleia2> right
20:24:44 <lifeless> so
20:24:56 <lifeless> I guess we need to figure out how to get toci reliable enough to make it a gate
20:25:20 <lifeless> that is separate out 'infra failed' vs 'actually broken by $other'
20:25:20 <SpamapS> some of the issues are just general di-b issues
20:25:50 <SpamapS> like how to get already checked out repos into it and how to use a static mirror for certain things
20:26:36 <lifeless> yup
20:26:43 <lifeless> derekh has a stack of patches I'm going to review today
20:26:58 <lifeless> which will give us the basis for git caching
20:27:04 <SpamapS> is there any reason we manually have people run all the steps in devtest.md versus just "run toci" ?
20:27:24 <lifeless> I think there are three concerns
20:27:36 <lifeless> one is 'get developers to understand the process'
20:27:45 <lifeless> there is 'automated in a specific context'
20:27:51 <lifeless> and there is 'deploy somewhere'
20:28:02 <lifeless> toci is a version of 'automated in...'
20:28:38 <lifeless> to me, devtest is the former; we should get considerably more automation in it, but not to the extent of reducing clarity.
20:29:07 <mordred> this has come up before
20:29:16 <lifeless> and for deploy somewhere, that should be clearly broken up into what runs on the seed host, hardware enrollment etc.
20:29:17 <pleia2> has toci been kept up to date with what is specifically in devtest.md?
20:29:42 <mordred> people want to start doing something with tripleo, but the steps in 19 seem to be a stumbling block
20:29:44 <lifeless> pleia2: largely yes, and one potential benefit of saying 'its all toci' would be to remove conceptual duplication
20:30:26 <lifeless> mordred: the recent report of failure looks like something toci would totally fail on too
20:30:54 <mordred> probably so
20:30:57 <lifeless> my big concern about telling folk to run toci is that toci, like devstack, assumes it owns the local machine.
20:31:05 <mordred> just being clear to what the desire is
20:31:16 <lifeless> ack
20:31:58 <lifeless> SpamapS: so for instance - the 'ssh in and copy this seed rc out' - thats something we should have a utility for IMO.
20:32:22 <lifeless> SpamapS: -or- we should populate the rc file from outside, for boot-stack init (Which I do for undercloudrc now)
20:32:45 <SpamapS> yeah there are a few other steps that I don't think devs need help understanding
20:32:48 <SpamapS> like all the git clones
20:33:00 <lifeless> yup
20:33:12 <lifeless> we should just have an mr // config-manager definition for that
20:33:22 <SpamapS> alright so in general.. make steps simpler, but keep the progression obvious
20:33:37 <lifeless> yes
20:34:02 <lifeless> IMO treat devtest as a manual for onboarding new tripleo devs.
20:34:53 <lifeless> needs to be robust and reliable; needs to be safe to run on a laptop's normal environment.
20:35:19 <lifeless> needs to show -just enough- working folk get a handle on the overall process and where they can/should poke things.
20:35:25 <mordred> what about new tripleo users who arent' necessarily devs
20:35:31 <lifeless> mordred: they are deployers
20:35:45 <mordred> they might be _potential_ devs or deployers
20:35:53 <mordred> try-before-you-buy kindda thing
20:36:15 <mordred> or am I just too impatient
20:36:18 <mordred> ?
20:36:45 <lifeless> The archetype in my head of a deployer
20:36:48 <lifeless> vs a dev
20:37:06 <lifeless> a dev is someone tasked with making tripleo better, in terms of *first contact*.
20:37:16 <lifeless> a deployer can obviously segue into doing dev.
20:37:57 <lifeless> a deployer usually wants to know enough about the plumbing to be confident driving it, but not to know all the gory details.
20:38:31 <lifeless> so - in my head there are a small number commands you run to just deploy.
20:38:42 <lifeless> you raise an interesting question of 'deploy to virt'
20:39:17 <lifeless> but frankly, we can't yet deploy a full overcloud from scratch without manual tweaking; let alone upgrade the software on it.
20:39:44 <lifeless> I think we need to close the loop and get the whole thing intact-but-improvable before we polish the entry
20:39:58 <lifeless> any deployer right now will be disappointed because not being able to upgrade is kindof a big deal
20:40:24 <lifeless> [or they will be doing upgrades via a CM-that-does-packages, and thus the whole design makes a lot less sense for them]
20:40:36 <lifeless> mordred: perhaps a better way to address this:
20:40:49 <lifeless> - we have enough people to either work on functionality, or polish.
20:40:54 <lifeless> - which should we pick :)
20:42:02 <pleia2> more polish makes testing easier and easier to get more folks involved
20:42:09 <pleia2> but I think it may be a harder sell
20:42:40 <lifeless> pleia2: I certainly agree; OTOH folk getting involved who don't know all the big picture structure can work on polish with good results
20:43:02 <SpamapS> the bridge still has a hole in it
20:43:07 <lifeless> pleia2: as a way to get involved : thats no reason to have it unpolished, but it mitigates the 'can't get involved' aspect.
20:43:31 <SpamapS> lets fill the hole, (updates) and then we can choose to improve the rest or add more.
20:43:58 <lifeless> SpamapS: yah. so here is what I think we should drive at
20:44:16 <lifeless> we should drive at end to end CI tests of deploy, and of upgrade-under-load.
20:44:29 <lifeless> and we should be implementing and automating precisely whats needed to deliver that
20:45:13 <lifeless> there is a tonne more to do once thats done, but at that point we no longer need to say 'and there is science fiction in this presentation'
20:47:41 <lifeless> so, mordred is distracted by a pep8 thing.
20:47:48 <mordred> sorry
20:47:48 <lifeless> Any other business?
20:48:16 <mordred> mission statement
20:48:18 <lifeless> mordred: np; just don't think we have enough here to make a useful decision other than 'we have work to do and we want to automate all the things'
20:48:24 <lifeless> mordred: thank you! I shall draft today
20:48:27 <mordred> please do
20:48:33 <lifeless> #action lifeless to draft missing statement.
20:48:40 <mordred> tripleo needs to apply for program status in a mail to the dev list
20:48:47 <mordred> and it needs to happen 4 days before a tc meeting
20:48:54 <mordred> for it to be an eligible vote item
20:49:21 <mordred> that needs to happen before the infra team is really going to be available in mindspace to help think about ci integration
20:49:32 <lifeless> gotchya.
20:49:35 <lifeless> Ok, anything else?
20:50:01 <lifeless> Folk should put in paper submissions for HK.
20:50:21 <lifeless> Any other other things?
20:51:33 <SpamapS> be well, Robert Collins
20:51:39 <lifeless> #endmeeting