20:01:15 <lifeless> #startmeeting tripleo
20:01:16 <openstack> Meeting started Mon Jul  1 20:01:15 2013 UTC.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:19 <openstack> The meeting name has been set to 'tripleo'
20:01:29 <NobodyCam> o/
20:02:14 <dkehn> hi
20:02:20 <lifeless> #topic agenda
20:02:26 <lifeless> bugs
20:02:27 <lifeless> Grizzly test rack status
20:02:27 <lifeless> CI virtualized testing progress
20:02:27 <lifeless> Periods at the end of git commit messages. https://review.openstack.org/#/c/33262 (SpamapS, markmc)
20:02:29 <lifeless> open discussion
20:02:43 <lifeless> Any last minute agenda items?
20:03:18 * SpamapS draws a blank
20:03:55 <lifeless> #topic  bugs
20:04:16 <lifeless> #link https://bugs.launchpad.net/tripleo/
20:04:41 <lifeless> We're down to 4 on tripleo itself
20:04:51 <lifeless> we probably need a better way to view cross code base
20:05:22 <lifeless> the two quantum ones are still limboing
20:05:29 <lifeless> SpamapS: has the two others
20:05:53 <SpamapS> I think the other two need to be revisited, they may not still apply.
20:09:12 <lifeless> ok
20:09:18 <lifeless> so lets look at some highs
20:09:39 <SpamapS> https://bugs.launchpad.net/tripleo/+bug/1174151
20:09:53 <lifeless> right, good choice
20:09:54 <SpamapS> IIRC, we have to do that work in Ironic, correct?
20:10:03 <lifeless> nope
20:10:22 <lifeless> we kindof need two answers to all of these
20:10:53 <lifeless> we need a workaround answer: vendor raid tools in the deploy ramdisk and some hack to tunnel settings through (e.g. via flavor attributes)
20:11:02 <lifeless> and we need a clean answer in Ironic
20:11:48 <lifeless> where clean for this one probably means a cinder Ironic driver, to communicate raid levels
20:12:16 <lifeless> or perhaps flavors for ephemeral config (e.g. same as nova bare-metal) and cinder for volume raid levels
20:12:45 <lifeless> I think https://bugs.launchpad.net/tripleo/+bug/1178088 is fixed, no ?
20:13:08 <SpamapS> Yeah long time ago
20:13:14 <SpamapS> I think the gerrit plumbing wasn't working then
20:13:32 <SpamapS> no thats incubator
20:14:00 <lifeless> hmmm patch might not be landed
20:14:03 <lifeless> I will check for that
20:14:35 <lifeless> I will do a scan of the high bugs for things that aren't high, later today.
20:15:00 <lifeless> we have a couple of F19 related from kashyap on d-i-b
20:15:03 <SpamapS> Or it might be in diskimage-builder actually
20:15:21 <lifeless> load-image is in incubator
20:15:43 <SpamapS> Date:   Mon Jun 10 22:09:29 2013 +0000
20:15:43 <SpamapS> Merge "Add RedHat support for disk-image-get-kernel."
20:15:51 <SpamapS> lifeless: yes but it calls disk-image-get-kernel :)
20:16:09 <lifeless> oh
20:16:12 <lifeless> so yeah, fixed?
20:16:25 <SpamapS> yes, already closed
20:16:33 <lifeless> thanks
20:17:02 <lifeless> ok so
20:17:11 <rwsu> lifeless: fwiw load-image has worked for me on fedora, I can take a look at that bug if it is still and issue
20:17:21 <SpamapS> rwsu: nah it is closed now
20:17:26 <lifeless> rwsu: thanks, we're pretty sure its good
20:17:32 <rwsu> cool
20:17:37 <lifeless> rwsu: more of a worry is kashyap's bugs on f19
20:17:50 <lifeless> rwsu: one looks like a process getting killed ('Bad Address' from losetup)
20:18:04 <lifeless> rwsu: and the other one udevd seems to have changed it's firmware handling
20:18:33 <rwsu> I haven't looked at f19 yet, pblaho has been working on that, I can take a look though
20:18:45 <lifeless> let me grab te bug numbers for you
20:19:54 <lifeless> rwsu: https://bugs.launchpad.net/diskimage-builder/+bug/1195264
20:20:34 <lifeless> rwsu: https://bugs.launchpad.net/tripleo/+bug/1196409
20:20:43 <lifeless> ok, any other bug stuff ?
20:21:47 <rwsu> lifeless: I will take a look at those two
20:21:51 <lifeless> tanks!
20:21:56 <lifeless> erm, *thanks*
20:22:14 <lifeless> #topic Grizzly test rack status
20:22:20 <lifeless> ok, so good news everybody.
20:22:43 <lifeless> The user we're doing the rack for w/in HP wants to keep using it for another 3 months or so
20:23:15 <lifeless> When we brought it up, we cut corners because it was a short term thing.
20:23:34 <lifeless> Do we need to revisit those things? Like 'should it run newer builds of everything' ?
20:23:48 <SpamapS> if by cut corners you mean we made a square into a triangle, then agreed. ;)
20:24:08 <lifeless> Specifically it's not running random creds for everything
20:24:18 <lifeless> and its not l4 firewalled etc
20:24:29 <SpamapS> Right it is just not production hardened at all.
20:24:29 <lifeless> someone malicious could be rather malicious if they wanted to.
20:24:42 <lifeless> And we have no update facility for the code on it.
20:25:07 <lifeless> We can update the horizontally scaled bits fairly easily
20:25:11 <SpamapS> nothing clean
20:25:35 <SpamapS> we can update all of it .. just not cleanly/efficiently/without entropy bombs.
20:25:51 <lifeless> So : what do we need to do; what could we do; what impact on tripleo will it have to do it (is it things we need to do anyway, or new work...)
20:27:34 <SpamapS> I think random credentials, and perhaps getting Heat Metadata updates working (which would help facilitate the random creds), would help a lot.
20:28:05 <SpamapS> lifeless: really though, what would help the most would be to have a second (even much smaller..) rack that we can use for CD
20:29:08 <lifeless> SpamapS: ok, so we ahve a have dozen machines in that rack in principle
20:29:15 <lifeless> SpamapS: that we can recover if someone wants to spend the time
20:29:25 <lifeless> SpamapS: they are available immediately.
20:30:10 <lifeless> SpamapS: I will ask for a dedicated test rack soon, but I want the story through to the POC level actually scripted (it's not yet) so that we're actually able to /use/ a rack vs just being able to boot a VM
20:30:46 <lifeless> SpamapS: which is what https://review.openstack.org/35090 is all about
20:31:15 <SpamapS> lifeless: ahh lovely
20:32:09 <lifeless> SpamapS: if you want to join me on pushing automation for up to the POC level, we might get there sooner
20:32:19 <lifeless> SpamapS: I am going to have to context switch this week for pyconau anyhow
20:32:28 <lifeless> (or someone else might want to?) :)
20:32:31 <SpamapS> lifeless: yeah I am nearly done with a first-cut of os-collect-config then I should be able to push on that
20:34:52 <lifeless> ok so - SpamapS can I ask you to create bugs on tripleo for the work items we need to do asap, to get the POC 'safe' for a 3 month running period ?
20:35:04 <lifeless> SpamapS: critical importance, I think.
20:35:14 <SpamapS> lifeless: most are already there, just not critical
20:35:35 <lifeless> SpamapS: rephrasing: we need to do the changes in trunk, and we need to deploy them into the POC.
20:35:43 <lifeless> SpamapS: so for any one thing there are two items.
20:35:50 <SpamapS> Right. :)
20:36:19 <lifeless> SpamapS: the 'get it in the rack' is higher priority I think, and whomever is doing it can choose whether to achieve that by doing the trunk work first or second.
20:36:26 <lifeless> SpamapS: what do you think?
20:38:18 <SpamapS> lifeless: +1 I was thinking the same thing.
20:38:44 <SpamapS> As some things will need to be a little duct-tape-ish on the POC rack but will need to be clean in trunk.
20:39:30 <lifeless> yup
20:39:53 <lifeless> #action Spamaps to create POC specific bugs in tripleo for a 3 month lifespan
20:40:06 <lifeless> #topic CI virtual testing status
20:40:08 <lifeless> pleia2: ^
20:40:26 <pleia2> I was out of town most of last week so no real updates from me
20:40:41 <pleia2> diving back into it this week though, spent some time this morning getting back up to speed with the most recent changes
20:45:55 <lifeless> ok
20:46:08 <lifeless> #topic periods redux
20:46:17 <lifeless> This was all on the list and in various reviews but...
20:46:31 <lifeless> periods on the end of commit messages are now not a subject for review debate
20:46:39 <lifeless> present or not, up to the author.
20:46:55 <lifeless> s/commit messages/first line of commit messages/
20:47:10 <lifeless> Good grammar is still needed :)
20:47:18 <lifeless> #topic open discussion
20:47:31 * lifeless opens the floor
20:48:56 <SpamapS> crap I had something and then forgot
20:49:03 <SpamapS> Oh, right
20:49:36 <SpamapS> I was wondering if anybody would be interested in a mid-cycle sprint to tie some of the themes from havana summit together into reality somewhere around "2 weeks before h3" ?
20:50:16 <lifeless> SpamapS: can you put actual dates on that ?
20:50:17 <SpamapS> I'm sure lifeless will vote that it be held in .nz .. and I'd be open to that if everybody's corporate overlords were on board with that.
20:51:10 <SpamapS> H3 is 9/5
20:51:32 <SpamapS> https://wiki.openstack.org/wiki/Havana_Release_Schedule
20:51:33 <SpamapS> btw
20:52:39 <lifeless> is that 20130905 ?
20:52:43 <SpamapS> yes
20:53:07 <lifeless> ok
20:53:18 <lifeless> I suggest you send a mail out to -dev proposing this
20:53:26 <lifeless> just gauge interest
20:53:28 <lifeless> sec
20:53:34 <SpamapS> so week of 20130812 - 20130816 or 20130819 - 20130823 would probably be ideal
20:53:53 <SpamapS> lifeless: yeah good idea. Its a thought that just came to me this morning.
20:54:27 <lifeless> so if there is interest we can sort out venues and exact dates then
20:54:42 <lifeless> like, I need to check vs pyconnz etc
20:54:54 <lifeless> and perhaps OSDC
20:55:25 <SpamapS> right it may not work out just because we're late in proposing it. :P
20:56:02 <lifeless> any other business?
20:58:24 <lbragstad> dhellmann: Couple questions on your response to https://review.openstack.org/#/c/34834/3/openstack/common/local.py. Your main concern is the test coverage given there are two implementations?
20:58:43 <lifeless> Thanks everyone
20:58:49 <lifeless> #endmeeting