13:00:37 <joehuang> #startmeeting tricircle
13:00:44 <openstack> Meeting started Wed Jan  6 13:00:37 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:48 <openstack> The meeting name has been set to 'tricircle'
13:01:15 <joehuang> #topic rollcall
13:01:28 <joehuang> #info joehuang
13:01:32 <zhiyuan_> #info zhiyuan
13:01:55 <joehuang> hi zhipeng
13:02:25 <joehuang> hi Khayam
13:02:40 <joehuang> is it clear for fk/pk/uk
13:02:41 <zhipeng> hi joehuang
13:03:41 <joehuang> #topic design and progress
13:03:57 <joehuang> hi, Zhiyuan, how things going
13:04:56 <zhiyuan_> i'm working on the l3 functionality. I am going to divide it into two patches
13:04:58 <joehuang> let's look at the todo list first
13:05:17 <joehuang> how to divide the patches
13:05:37 <joehuang> how to divide the patches, zhiyuan
13:05:46 <zhiyuan_> typing
13:05:59 <joehuang> your network seems to be not stable
13:06:45 <zhiyuan_> in the first patch, our tricircle neutron plugin will create bridge vlan network, bottom pod router and attach interfaces to router
13:07:23 <zhiyuan_> in the second patch, xjob will configure extra route to connect the bottom routers in two pods
13:08:00 <joehuang> is the network with VM attached also included in the first patch
13:08:33 <joehuang> except the bridge network
13:09:41 <zhiyuan_> since we introduce network az, subnet can be attached to router without hosting a vm, in my implementation, plugin will create the related bottom network, subnet if they doesn't exist
13:10:54 <joehuang> good, that means the first patch will at least make it testable and workable
13:11:51 <joehuang> the L3 networking is relative a bit complex
13:12:14 <joehuang> it's necessary to ensure each patch is workable and testable
13:12:33 <zhiyuan_> sorry I was offline just now
13:12:52 <zhiyuan_> and lose the message history
13:12:53 <joehuang> yes, I can see your network connection was lost
13:13:08 <joehuang> that means the first patch will at least make it testable and workable
13:13:35 <joehuang> it's important for each patch is testable and workable
13:14:36 <joehuang> when will your patch be ready for review
13:15:31 <zhiyuan_> yes, I have written the unit tests. in the first patch, after DevStack starts, use can attach a subnet to a router and then the bottom network, subnet, port ,etc will be ready
13:15:47 <zhiyuan_> i think i can submit the patch this Friday
13:15:57 <joehuang> great
13:16:10 <joehuang> let's look at the TODO list
13:16:21 <joehuang> #link https://etherpad.openstack.org/p/TricircleToDo
13:17:32 <joehuang> The phase 1 is almost finished if we look at the TODO list
13:19:10 <joehuang> hi, Khayam,  are you still online?
13:20:02 <zhiyuan_> i mark no7 as done, joe has done that for me
13:20:12 <joehuang> ok
13:20:35 <joehuang> but not update all, some more description is needed
13:20:57 <zhiyuan_> ok
13:22:25 <joehuang> for cinder part, I would have finished that if I did not delete the source code.
13:22:56 <joehuang> I have to rewrite the code, hopefully will be ready for review this friday
13:23:29 <joehuang> and the site mode has been moved to pod model
13:23:41 <joehuang> so that tricircle can support big AZ
13:24:32 <joehuang> thanks for zhiyuan's patch for accelaration for the migration
13:24:38 <zhiyuan_> cool, will you include DevStack script to deploy top and bottom cinder API in your working patch?
13:24:58 <joehuang> will do
13:25:22 <joehuang> Cinder API and cinder-apigw is there, only need to make them work
13:25:57 <zhiyuan_> yes, need some scripts to make them running on one host
13:27:00 <joehuang> It's the first time for Khayam to join the meeting, but his connection is lost.
13:27:12 <joehuang> He
13:29:04 <joehuang> #info The phase 1 is almost finished if we look at the TODO list
13:29:56 <joehuang> #info it's necessary to make sue each patch is workable and testable
13:30:14 <zhipeng> i have a question about the current devstack setup
13:30:26 <joehuang> please
13:30:30 <zhipeng> the current script will provide two regions
13:30:54 <zhipeng> on how many nodes?
13:30:55 <joehuang> yes
13:31:00 <joehuang> one node
13:31:25 <zhipeng> it should be possible to have for example two node devstack
13:31:34 <zhipeng> with the top running tricircle, right?
13:31:37 <joehuang> #info current devstack only needs one node
13:31:52 <joehuang> of course
13:32:25 <joehuang> but you have to manually register the second region to the keystone of the first node
13:32:34 <zhipeng> cool,i'm looking into a way of vagrant spawning multinode to demo tricircle
13:32:44 <joehuang> so that all endpoints are visible in one keystone
13:32:52 <zhipeng> okey got it
13:33:36 <joehuang> could you please add the script to Tricircle if you tried two nodes setup successfully
13:33:43 <zhiyuan_> i am going to write some scripts to help to deploy DevStack in two hosts in my second patch of l3 functionality
13:33:59 <zhiyuan_> so we can test cross-pod vm connectivity
13:34:09 <joehuang> yes
13:34:14 <zhipeng> sure
13:34:51 <joehuang> #action add scripts for two nodes devstack deployment for mutli-pod support
13:35:32 <joehuang> more topic?
13:35:49 <zhiyuan_> no for me
13:36:43 <zhipeng> none from my side
13:36:56 <joehuang> ok, let's conclude the meeting
13:37:03 <joehuang> thanks for attending the meeting
13:37:07 <joehuang> see you
13:37:10 <joehuang> good night
13:37:14 <zhiyuan_> good night
13:37:19 <joehuang> #endmeeting